or Connect
AVS › AVS Forum › HDTV › HDTV Recorders › Recording to PC from a SA 8300HD via Firewire
New Posts  All Forums:Forum Nav:

Recording to PC from a SA 8300HD via Firewire - Page 16

post #451 of 474
I tried both TSReader and VLC with my SARA 8300hd box (client is XP laptop). I am able to record but the video glitches every few seconds. Tried several tests with the same video source. Does not appear to be a pattern as to where in the video it glitches.

The only DV cable I have is about 15 feet long (6pin to 4pin). Could this be a problem ?

post #452 of 474
Originally Posted by bunnysuicide View Post

has one been able to get this to work on Vista 64?

The drivers are for 32bit versions of windows.

After many tests with different programs on both windows and linux I've come to the conclusion that test-mpeg2 in ubuntu seems to be the most reliable and has the least amount of lost frames.
post #453 of 474
Thanks for the clarifications from dochartung and JAdamz.

I think I am ready to give this a whirl. I am a little reluctant to shell out $100 for TSreader before I know for sure how much of my dvr content will be copy protected. My cable provider is Atlantic Broadband, Miami Beach, Fl.

Can I test this somehow with either WMC or TSreader Lite to see if it will work prior to purchasing the full TSReader version?
post #454 of 474
First I want to thank everyone here for the great information.

I've been trying to get this to work on and off for several months. Here's what I have so far:

I'm on Brighthouse in the Tampa Bay Area with an SA8300/HDC.

I've got the firewire STB drivers loaded successfully and the PC recognizes the STB and the data stream. I can stream via VLC but the picture and audio is choppy and the video is pixilated. The only thing I've been able to record via CapDVHS is a playback of an SD broadcast on SpeedTV, everything else bombs CapDVHS (I'm assuming because of the poor stream quality) although the SpeedTV playback recorded perfectly. Pretty much everything I've tried will stream on VLC, albeit poor quality.

My questions are this:

#1 Would you think the poor quality is due to the firewire driver speed restriction problem I’ve read about?

#2 The firewire driver patch only works with service pack 2, I'm at service pack 3. One would think that MS would have fixed this with service pack 3 but in my experience with MS that's a mighty big assumption. I read an article on how to manually roll back the drivers to SR1 level but I've searched and searched and can't find it again, anyone got a link?
[Edit: found this and did roll back the drivers. Will test it later]

#3 I'm running XP MCE 2005 but I haven't been able to get tray.exe to recognize the tuner so MCE doesn't see it. Not a big deal but it would be a nice feature to have. Is there some registry hack I have to perform to make this work or something else?

#4 Are my assumptions about CapDVHS bombing out because of the poor stream correct?

#5 Also I'm assuming if I can get it to stream via VLC then I can record it as well i.e. no 5c restriction, is this correct?

#6 Yes I've searched for all of these issues but haven't found a definitive answer on any of them. So please don't tell me to search for an answer I've been searching for 3 days

Thanks in advance for any and all input.

[Update: Well I rolled back the firewire drivers and did the registry hack to get the port up to speed, I saw a lot of improvement. I guess it would be watchable, but it ain't gonna impress my friends and family for sure. I have a firewire pc card thinking maybe that would show some improvment with pretty much the same results. Also tried TSReader for the capture, it's showing a lot of data loss so it's looking a lot like the Windows XP firewire just plain sucks. Going to try pluging in another hard drive and giving it a shot with linux, unless someone has some suggestions?]
post #455 of 474
Thanks to all the info here I was able to copy programs from my Comcast 8300HD (SARA v1.89.22.2) to Vista laptop no problem. I followed the instructions here and loaded the STB drivers, paid $99 for the TSReader program (the free version only records for 60 seconds), connected the firewire cable between my box and the PC, started playing a program saved on the DVR, saw the PID, and recorded the program. The quality is perfect, no pixelation.

Fyi, when I went into the system settings for my 8300HD I noticed it said Firewire "disabled", but sure enough it still worked. I am in Orlando, by the way.

I was able to copy very nice HD programs like Science Channel HD, as well as regular programs. Have not tried HBO.

One thing I had to figure out is what type of file the TSReader is saving my program as. By default it was creating .bin files. Turns out that regardless of what file extension you give it, it's creating a "ts" or "transport stream" file type. Some programs like Mplayer can play this by default. I was able to get Windows Media Player to play it after renaming the extension to .mpg, but again this was on Vista and may have to do with having the latest version of everything. If you have the right codecs you can probably play anything, but most cannot, so you may need to convert it.

If you are a technical person, as I am, then use free FFMPEG to convert the ts video to something like AVI. Then you can convert the AVI to Flash (FLV) if you want, also using FFMPEG. You might also try "WM Converter 2.0", which is GUI-based and freeware.

Now what I am going to do with all this video? Well, mostly it is for editing fun a la YouTube. But theoretically I can burn it to DVD and save for future. I don't usually watch programs over and over, not even movies, so I don't know. What do others do with their programs they've saved to PC?

post #456 of 474
EDIT:Using TSReaderLite version 2.8.46e, recordings suffer from continuity errors in HD when using Vista or XP. Vista and XP recordings appear to be the same. I also tested both IEEE ports on the back of the SA8300HD. I'm using ExDeus' STB Firewire Drivers.

This is the latest lite version, but the standard version may be more updated. I'm hoping that the latest TSReader Standard version fixes the continuity errors. However, I'm not willing to spend $99 on something that may or may not work, so if anyone has the a later version, could someone upload the TSReader_Firewire.dll file? The default location is in C:\\Program Files\\COOL.STF\\TSReader\\Sources\\TSReader_Firewire.dll. That way I could test the areas where continuity errors are fixed in the latest version and if the reason is the firewire.dll.
post #457 of 474
Was wondering if anybody has successfully transferred files with TS Reader using a Windows 7 computer?
post #458 of 474
Originally Posted by Eyedoctor2 View Post

Was wondering if anybody has successfully transferred files with TS Reader using a Windows 7 computer?

I have tried it with Windows 7 and it works. Of course to the extent of pixelation and jumps while recording HD. I've tried every tweak in this thread.
I've tried it first on my 64-bit machine, but there are no drivers that I could find.

My system:
Lenovo laptop C3000 N100 E7U-0768.
Windows 7 Ultimate, 32-bit edition.
Located in Manhattan, working with TWC, have their SA 8300HDC.

I wish that someone would solve the jumps while recording HD and post it here.
post #459 of 474
Anybody got this working on Win7 x64? I have tried to use the drivers listed and they don't work. I am probably hosed because I have x64 Win 7 but hopeful someone may have an answer......
When Windows saw the FW connection it loaded some drivers that say SA 8300 HD tuner and panel but CAP does not see a input device..
post #460 of 474
So how did you get it to work with no drivers? Just trying to figure out what drivers to use for WIN7 X64
post #461 of 474
It doesn't work on x64. He used Windows 7 Ultimate 32-bit edition.

johnb003 is currently working on 64-bit drivers: http://www.avsforum.com/avs-vb/showthread.php?t=1145429
post #462 of 474
Any updates to this for folks using Win 7 64 ??
post #463 of 474
Hi all,

I tried to connect the firewire port from 8300HD to a dvr that accepts firewire inputs. No video or audio were detected on the dvr. So I tried the s-video and regular rca audio inputs and the dvr showed both the video and audio coming from the 8300HD.

I was able to make a cbs hd recording that i streamed from the 8300hd.

What was really weird was the video feed that came from the 8300HD was elongated into letterbox format on the dvr.

Has anyone tried this and had the same result as me?

I tried to correct the screen format but the image remained the same.
post #464 of 474
Hello! I've been following this topic for years and finally last week I decided to give it a whirl after about two years ago the drivers I installed toasted my VAIO. My wife works with special needs children and records a lot of educational and informative programs. In the past we've recorded to tape so she could take to the office but transferring to laptop is now a better solution. So now I'm on a Lenovo T400 with DeusEx's drivers and streaming recordings from my 8300HD to the laptop via firewire with TSReader full version (latest). It took a couple tries but I was finally able to transfer part of the Joy Behar interview of Temple Brandin with spectacular results. I did Record Program and got an mpg format file which played flawlessly.
The problem is, every time I've tried since then, I get great video but no audio. Any help would be greatly appreciated.
post #465 of 474
I have been using Cap DVHS for a couple of years without any issues. I recently switched ISP's and had to switch DVR's. I used to have a motorola which worked flawlessly. I now have SA 3800 HD which is giving me many problems. Cap DVHS seems to be out of the question because it will only record DVR'd material, then it crashes after a couple of seconds. I then read about irecord on the mac and tried that. It seems to work but I have a hell of a time playing back the recording. So far, I have only found 1 player that will play back the material. When I finally get the recording to play it stops after bout 6 seconds.

So, the port is definitely open on the SA 3800. It is communicating, the channels I am trying are copy freely. I just cannot get this thing to work. I am thinking of trying TSreader, I just don't want to pay $100 to see if it will work. I need a little bit more info before I make that plunge. Anyone have any suggestions on what could be happening?
post #466 of 474
Originally Posted by mit3gt View Post

Cap DVHS seems to be out of the question because it will only record DVR'd material, then it crashes after a couple of seconds. I then read about irecord on the mac and tried that. It seems to work but I have a hell of a time playing back the recording. So far, I have only found 1 player that will play back the material. When I finally get the recording to play it stops after bout 6 seconds.

It sounds like there could be a lot of errors in the stream. Try downloading VideoReDo TVSuite V4 (It has a free trail) and use its "QuickStream Fix" option. It'll show you if your files are filled with errors. In many cases it can fix them, but if the output from your cable box is too messed up, you'll have dropped frames, etc.
post #467 of 474
Thanks for the suggestion. I really appreciate it. Unfortunately, Videoredo did not help. I still get the first 6 seconds of the video. I don't seem to be getting any errors as far as I can tell. Is their a more in depth way to find out if the file has errors? Whats strange is I always get the first six seconds of the video. I wonder if the video is starting out as a copy freely stream then goes to protected, ie, my new service provider is being a pain in the ass.. I read about someone having a similar issue in the AVC noodle thread. I'll see if I can dig it up.
post #468 of 474
This was taken from the AVCnoodle thread. Someone had similar issues and sent the recorded stream to the developer who had this to say:

"Hey Steve-

Any leads with the file I sent?


The file is bad news.

In summary, it starts well with a perfectly good looking video packet on pid 0x85 with a valid PES header, 00 00 01 e0 indicating the start of the video elementary stream. No encryption flags in the header, etc.

47 40 85 12 00 00 01 e0 0000 pid=0x85 (133) Not scrambled PES header with payload
47 40 85 12 00 00 01 e0 00 00 84 80 13 27 51 ad G@...........'Q.
0b 33 ff ff ff ff ff ff ff ff ff ff ff ff ff ff .3..............
00 00 01 00 00 df ff fb b8 00 00 01 b5 83 33 3b ..............3;
5d 80 00 00 01 b2 47 41 39 34 03 4a ff fc 80 80 ].....GA94.J....
fa 00 00 fa 00 00 fa 00 00 fa 00 00 fa 00 00 fa ................
00 00 fa 00 00 fa 00 00 fa 00 00 ff 00 00 00 00 ................
00 00 00 00 00 00 01 01 32 58 59 fa b7 1a 4b 0e ........2XY...K.
c5 b2 82 bd 0c ec ea 9e 9a 3a c1 35 91 9e 26 eb .........:.5..&.
32 4c 7a a5 d2 c9 23 2e 4a c3 33 bb d4 4e 58 d1 2Lz...#.J.3..NX.
d6 5c 95 93 a8 9d 92 b4 8c 33 f9 cd 17 96 cf c6 .\\.......3......
a7 cd 47 00 fa 87 e2 0d 09 03 3a 66 f5 f3 1f 09 ..G.......:f....
a7 cd 46 ce f5 33 68 ef 89 0f 4e 81

This continues for a while, including good quality unscrambed audio until BAM!....

47 40 85 94 d6 22 e8 0c 49ae pid=0x85 (133) Scrambled PES header with payload
47 40 85 94 d6 22 e8 0c 49 ae 8f 24 65 cd aa 8c G@..."..I..$e...
f0 fb 2b 76 0a 15 1f 02 1b 0f 1c 7b a0 05 9f 3f ..+v.......{...?
e5 48 b2 2f 50 d6 34 d8 3b 3c f9 55 44 c4 70 23 .H./P.4.;<.UD.p#
13 21 fe c0 a7 bc 84 2c da c0 e5 90 5d b1 f9 be .!.....,....]...
60 50 7a 90 4a d0 51 0e 9a 5a 83 43 4e a0 f1 a5 `Pz.J.Q..Z.CN...
c5 a1 c9 13 a1 54 61 40 2f ad cd 5e 17 10 4b 2c .....Ta@/..^..K,
80 b1 6e d6 3d ae 52 bd 0b 43 13 98 91 41 1e 69 ..n.=.R..C...A.i
f6 30 b0 48 03 ca ef 6f 6f 1d 6d 86 fa 74 d0 d7 .0.H...oo.m..t..
08 e5 b6 c1 74 95 51 50 50 ed bc 2b 78 e1 05 f0 ....t.QPP..+x...
cb 40 4a 04 57 d0 78 dd 13 43 ab 6a c4 b1 5d 4c .@J.W.x..C.j..]L
b6 9b e6 34 e9 b3 07 54 31 0e ef ae 90 51 0b ae ...4...T1....Q..
d2 ec 7c 57 8d 5e 17 a3 45 63 40 d9

The packets are now scrambled, the PES header is flagged, which means we should see 00 00 01 e0 in a clear stream. However the scramble bit is set, meaning the STB has not decrypted the content.

The stream is also missing PAT and PMT packets, they're being filtered by the STB which DTCP debugging difficult. This would also confuse VLC and other media players, who use them for service information on codec types and stream positioning, explaining your earlier findings. This is not a total loss, these can be re-created on the fly if the entire stream had been Copy Freely.

Based on the clip you sent, which my debugging tools turned into 7.2million lines of debugging, the scrambled data started at line 513423, so most of the clip was scrambled. It's hard to say time wise what this represents without running more numbers based on bitrate and throughput etc.

The fact AVCNoodle is reporting 'DTCP Protection' (as you indicated earlier), sounds like the stream starts out clear then turns scrambled. Perhaps you switched to this channel from another channel and the STB briefly unscrambles the content until the next DTCP marker appears on the networks (missing) PMT table (causing scrambling to re-occur). Speculation at this point but the fact remains that the stream went quickly from Copy Freely to a higher security level, meaning the recording contains encrypted content. AVCNoodle is unable to do anything about this.

Other than that the stream is recorded perfectly, no errors, no junk from the STB, no missing packets (continuity counter wise). The firewire stack appears to be doing what it was designed to do, no obvious buffer alignment issue or dropped buffer.

Just a plain old case of your network provider being a pain in the ass.


I wonder if this is what is happening to me. Is their any way I can find out? Trying to make sense of this. Unfortunately, it's a little over my head.
post #469 of 474
After reading through this entire thread, I have found the best to capture video from my 8300HD after much trial and error.

I used a Dell E5410 with Windows 7 Enterprise 32bit with the following results:

I tried VLC. It worked, but choppy video and sound.
I tried TSReader Lite. Same issues with choppy video and sound
I got a demo of Adobe Premier Elements. I couldn't even get it to capture without crashing.

I then thought about Linux since I have Ubuntu 11.04 dual booting on this machine. I am no means an linux expert, but was able to capture flawless 1080i video with test-mpeg2.

Ubuntu 11.04 should come with the necessary components to make this work. Being a linux novice, it took me several days to realize my problems when trying to use test-mpeg2.

You should have a folder named libiec61883-1.2.0. If you don't download it's tar from the web and extract it wherever.

Once extracted open terminal and go to the extracted libiec61883-1.2.0 folder. Then do a ./configure and make. Then go to examples folder in libiec61883-1.2.0. This is where test-mpeg2 resides.

Connect your 8300hd and type plugreport in the terminal window under libiec61883-1.0.0/example.

You should see the firewire nodes. My device was under node 1.

I then issued the following command ./test-mpeg2 -r 1 > test.m2ts .
Then I saw starting to receive below. To stop capturing hit ctrl+c .

At that point I viewed the file with VLC in linux. I got concerned because it was choppy with image tearing. I then copied that test.m2ts to my windows C:\\ drive . Then booted into Windows 7 and it played 100% flawlessly.

test-mpeg2 is rather crude with its command line operation, but it is the best method I have found for the 8300HD.
post #470 of 474
First off, thanks to everyone who contributed in getting this working. I'm so happy to be able to clear out my dvr.

Thanks to dochartung for the link to the drivers and the instructions.

I have a Scientific Atlanta 8300HDC. I tried this on 3 operating systems,two computers and in vmware. The first computer had xp pro installed on it. While trying to install the drivers it said I needed xp media center edition.

So, I installed that on the first comp, which has a 2.5ghz processor, 1gb ram and onboard video. With this setup, it recorded just as well as on a much more powerful comp. I then installed the Vista RC1 firestb.msi drivers and tsreader 2.8.46b. The firestb.msi drivers would crash on windows startup every time.

If you're using xp mce don't forget to look through the readme and pay attention to these steps:
1)Open the MyTray dialog and enable "Recording over firewire"
2)Make sure "Do nothing with MCE recording" is selected
3)When you plug in the STB via firewire, 3 devices will be detected: Unknown, AV/C Tuner and AV/C Panel.
Cancel the New Hardware wizard for the Unknown device.
Next you should see AV/C Panel Device or AV/C Tuner Device as the hardware that was found. Choose Install the software automatically (Recommended) and click Next.
The driver should then be installed, click on Finish when prompted.

Then, I just followed dochartung's intructions:
Originally Posted by dochartung View Post
You have to click on the PID and then the Record Program should be selectable. If you have a trial version it will not work. Also I found VLC to be very laggy so I had to use my remote and jump back and forth. Exactly how I did it was to run the dvr with the program I wanted to record, jump back to pc (only using 1 monitor to do this) then select the pid, go back to DVR rewind to beginning, pause it then back to PC, record then unpause DVR program, lol, sounds like a waste of time but it works flawless. PM me if you need any more help and I will do my best.
Originally Posted by dochartung View Post
Someone asked me for a tutorial for TSREADER so here it goes.
First off you need the $99 version of TSreader as the trial will not work.

I run a Vista HTPC and I found the drivers for the SA 8300HD here:

OK after the drivers and TSreader are installed reboot the machine.

Now open TSreader and choose the firewire.dll as the source interface from the dropdown list.

Ok now you are ready to capture from the DVR, I have not tried live TV but I am sure it will work.

Start the playback of your DVR and then go back to HTPC (best to do this with pip or 2 monitors) click on the PID (which is the stream of the TV recording) so it is highlighted.

Now go to the top menu of tsreader and choose record, and if you chose the pid correctly another windows will pop up and ask you to name the recording and then all you have to do from there is choose the destination.

I hope this helps and for sure this is a crude tutorial but it should get you through with some trial and error.
On the second computer I used win 7 32bit. This computer is much more powerful, but the end result of the recording was the same. I get 50-400 continuity errors per hour of recording a HD programming. To me, this is still very watchable for personal use. Also, keep in mind it will take up to 7gb of hard drive space per hour of HD recording.

Lastly, I tried to get this working on a virtual machine. I couldn't find any virtual environment which supported firewire in this application.
post #471 of 474
Hi all, I recently started capturing recordings from my 8300HD onto a Mac, and was wondering if there's a way to force a specific resolution to be output over the STB's firewire connection? I can force the resolution over HDMI using the advanced setup/picture settings options, but this setting doesn't carry over to the firewire stream. It will still just output whatever the recording's native resolution is. Any help is greatly appreciated...thanks!
post #472 of 474
Newbie here so please excuse my ignorance on the topic. A friend of mine just had her cable shut off and she has to give her SA 8300hd box back. She had a bunch of shows/movies on the DVR that she wishes to save. Does anyone know if recording via firewire will work once the box has been disabled? She tells me that since the cable has been turned off, the box doesn't turn on anymore. I don't want to go through the trouble of bringing my desktop PC to her house if it's not going to work anyway.

I have been searching for this but I haven't found anything specific about it. If it exists already on this forum, can someone point me in the right direction, please?
post #473 of 474
I dont think recording over firewire works with SA boxes anyways, so I think it would be a waste of yours and her time to try.
post #474 of 474
You have to use the driver, but it is for 32-bit OS only. You also have to play it through the box in order to record from firewire. So if you can't play any of the shows through the box, you can't use firewire to record it.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: HDTV Recorders
AVS › AVS Forum › HDTV › HDTV Recorders › Recording to PC from a SA 8300HD via Firewire