or Connect
AVS › AVS Forum › Video Components › Home Theater Computers › boot up to full MyHD, with MyIRC
New Posts  All Forums:Forum Nav:

boot up to full MyHD, with MyIRC  

post #1 of 17
Thread Starter 
...I seem to lack some very basic PC skill...I can drag MyIRC into startup, and all's well, but when I also drag MyHD (program) into startup as well, MyIRC is in-operative. Any tricks for one-step auto boot to MyHD with MyIRC control?

I'm using MDP-120 with an old P3 500, BX440 motherboard, 512 MB ram

...I just want to turn on my computer and end up in MyHD, with full MyIRC control....one step
If I close MyHD and reload it, MyIRC is fine
post #2 of 17
Try putting MyHD below MyIRC (drag and drop works)
post #3 of 17
Thread Starter 
"Try putting MyHD below MyIRC (drag and drop works) "

tried that ....both ways
post #4 of 17
hmm. Up until recently I had MyHD startup that way. Since I added the playlist manager I don't do it anymore since PLM needs to run first. There is a way to run all the stuff in sequence but for the life of me I don't remember. If it bugged me a bit more I would look into it. Pretty sure it is not complicated. For now I just hit the power button on the remote to start myhd. If not one offers a solution I will look into it further and mention it here. I did like when it all started up.
post #5 of 17
I'm not sure that you can force the execution order in the Startup folder. This may not work either if MyIRC needs a specific head start time and I can't test it right now, but did you try putting them both in a batch file with MyIRC.exe first and executing that from Startup? Such as:

@echo off
REM batch file (MyHD_onestep.bat) to be run from Startup group
START /B "C:\\Program files\\MyHD\\MyIRC.exe"
START "C:\\Program files\\MyHD\\MyHD.exe"
EXIT
post #6 of 17
I kept trying CALL in my batch files but PLM never had time to finish. I will try START and see if my problem is solved. Hope it helps artworkvideo
post #7 of 17
Tell rbatch file to wait/pause between executions.
post #8 of 17
OK, how? (Remember that the goal was NO keypresses required, so PAUSE is off the table)

I think that a fixed-interval pause will require a non Windows utility to be used, but I don't remember for sure if I have ever used such a utility or what it was called. I expect a google or two would turn it up. If it were my problem that would be my next step.
post #9 of 17
Thread Starter 
Quote:
Originally Posted by TPeterson
I'm not sure that you can force the execution order in the Startup folder. This may not work either if MyIRC needs a specific head start time and I can't test it right now, but did you try putting them both in a batch file with MyIRC.exe first and executing that from Startup? Such as:

@echo off
REM batch file (MyHD_onestep.bat) to be run from Startup group
START /B "C:\\Program files\\MyHD\\MyIRC.exe"
START "C:\\Program files\\MyHD\\MyHD.exe"
EXIT

...tried your .bat file (above) and dragged it into Startup...neither MyIRC or MyHD started, and CMD window did not close...thanks for trying

...still looking (sigh...on my Amiga, I would start each program from the startup-sequence, with wait commands...easy text fix)
post #10 of 17
Quote:
Originally Posted by artworkvideo
...tried your .bat file (above) and dragged it into Startup...neither MyIRC or MyHD started, and CMD window did not close...thanks for trying

...still looking (sigh...on my Amiga, I would start each program from the startup-sequence, with wait commands...easy text fix)
So you've described what didn't happen...what did happen? Any error messages?
post #11 of 17
Ah! The penny dropped. I forgot (again) that the window title is not optional in a START command. The batch file should read:

@echo off
REM batch file (MyHD_onestep.bat) to be run from Startup group
START "" /B "C:\\Program files\\MyHD\\MyIRC.exe"
START "" "C:\\Program files\\MyHD\\MyHD.exe"
EXIT
post #12 of 17
Thread Starter 
Quote:
Originally Posted by TPeterson
Ah! The penny dropped. I forgot (again) that the window title is not optional in a START command. The batch file should read:

@echo off
REM batch file (MyHD_onestep.bat) to be run from Startup group
START "" /B "C:\\Program files\\MyHD\\MyIRC.exe"
START "" "C:\\Program files\\MyHD\\MyHD.exe"
EXIT

..SUCCESS...both programs work as they should, without any help other than your script...CMD window closes as well!

Thanks,
Art
post #13 of 17
I will try this when I am home since I had the same problem (batch worked fine but window remained open). Of course now I need to also run "Cliff" and populate my epg.
post #14 of 17
Thread Starter 
...this is really bizzare. The script worked fine yesterday, but today, the MyIRC program does NOT work until I shut down MyHD and restart, as before???

...is there any way to count to 1 million between the IRC and the MyHD commands?
post #15 of 17
Thread Starter 
Update 1: ...retrofitted back to V1.65.2...now it seems to work again, go figure?

Maybe it's the Serial IRC and the MPD-120 being a little older?

Update 2: ...removed script and replaced with the MyIRC and MyHD links...all works just fine. There must be something different with V1.66e, which was the version I was using when I started down this road.

Art
post #16 of 17
Quote:
Originally Posted by artworkvideo
...this is really bizzare. The script worked fine yesterday, but today, the MyIRC program does NOT work until I shut down MyHD and restart, as before???

...is there any way to count to 1 million between the IRC and the MyHD commands?
If you want to go back to 1.66 and explore this, you can see if it's the timing by inserting a PAUSE command between the two START lines. That won't be a good solution for you, since you don't want to enter any keystrokes, but it will confirm that the problem is lack of a delay between the two.

If it turns out that that is the problem, Google for some delay batch file utilities--I'm sure that there are bunches of them. There's a kluged method shown here, for example.
post #17 of 17
Thread Starter 
..it's possible that this thread is moot...seems that I only have the problem when my virus program (AVS) updates on bootup..first time...I'm back to 1.66e and the two icons only, and things are fine on subsequent re-boots after AVG virus updates.

But Iv'e been fooled before..stay tuned.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Home Theater Computers
This thread is locked  
AVS › AVS Forum › Video Components › Home Theater Computers › boot up to full MyHD, with MyIRC