post #1 of 1
Thread Starter 
I'm wondering how many of the existing Pioneer Plasma owners have had terrible service/support.

I'm wondering if this is normal service and I'm just expecting to much.

It has been about 11 months since I had purchased a PDP-4350 43" pioneer plasma display. After doing comparisons among various plasma displays, I had gone with the pioneer brand.

About on the 10th month of owning my plasma (May 27), I noticed the picture became terrible, the red and green colors would be out of sync, and the picture looked like something I'd need 3D glasses for. I did verify it was happening on multiple sources TV signal, as well as DVD. Knowing I had time, I opted to call the company I bought the display from. To my surprise, the extended service company I planned to buy my plan through, required 6 months left on my original warranty. Informed the company I bought it from, that if they would of called me, I would of purchased it. I had planned on purchasing it about the time, the problem started.

Stuck with not much warranty left, I called Pioneer; they pointed me to the website for local repair companies. I had called the one recommended, talked to the people, explaining the issue, and that it was intermittent. They sent a service tech onsite with a video board. Of course the problem wasn't happening, when the tech was here. I was explaining to him what I was seeing when the problem was happening. He called someone to get an authorization to replace the video board, even though he didn't see the issue described. The person on the other side wouldn't authorize it. Informed that the problem described was rare on generation five plasma, and also has never been intermittent. I had felt a little disappointed, that the tech had to drive 2.5 hours to my site, and wasn't able to replace any parts. The tech suggested the next time I see the problem, to use my digital camera and take pictures. He had given me is business card, with email address. He also was trying to tell me that, the problem could have been because I don't subscribe to HD programming for my TV. I told him, that the issue was happening on both DVD as well as TV SD signal.

On June 14, 2006, the problem was really prevalent and was able to capture photos as requested with my camera. I then posted them on my website and had emailed the tech the link to look at the photos. After wasting a few days emailing back and forth, he suggested that I call back to the dispatch. The earliest they were able to set up for the tech to come back on site is July 3rd. Well, July 3rd came, and the tech didn't. He called, made a comment that he may of had the wrong part and would callback later after verifying it. About 4pm that day, I get a voice message saying he would call and reschedule. Another week later (today) I get a call to schedule a site visit for July 13th (happens to be last day of warranty). I have since upgraded my viewing package to include HD channels so the tech couldn't use that excuse again. Currently I’m disappointed that this has been dragged out nearly a month without resolution. (Longer, since the problem started/noticed Memorial weekend.)

Looking back at the initial visit, I'm disappointed that the "pioneer technician" didn't do any diagnostics other than a "Sponge Bob" DVD he played. He never slid out and examined the media receiver, when into diagnostics to see how many hours the display has logged, or anything troubleshooting related.

It's wonderful that Pioneer has such a nice product, when it works. The customer service on the other hand, is going to keep me from purchasing or recommending Pioneer to any of my friends, relatives or colleagues that seek my opinion on regular basis.

Sorry for the long rant, I appreciate any comments/suggestions.