or Connect
AVS › AVS Forum › Audio › Home Theater In A Box › Sony "dream" DAV-C770 problems
New Posts  All Forums:Forum Nav:

Sony "dream" DAV-C770 problems

post #1 of 5
Thread Starter 
I'm having a ton of problems with my Sony dream system DAC-C770. It is about 4 years old now. It has always had problems with the 5-disc transport system - discs get caught up inside and I have to take the whole thing apart.

Today while watching one episode of the Simpsons, it went haywire after the episode. I couldn't get back to the main menu. Then it wouldn't play anything or eject. I powered it down then back up, but it still acted wierd. After a few minutes it finally brought up the disc, but the main menu was all corrupted. I tried another DVD, and it was screwed up too. The only thing that displays right is the FBI warning. That helps a lot.

Thanks in advance for the help,
Adam
post #2 of 5
Getting to be time to put her out to pasture, I think. Integrated DVD players/receivers are generally considered throwaway items. You can try unplugging it overnight and trying it again in the morning, but it's probably not repairable.
post #3 of 5
Mine is a few years old & recent;y has started acting up on me ... Normally it's on all the time, yesterday I powered it down & now all I get is a blinking standby light & nothing else when I turn it on ..

Anyone know what's wrong & how to fix it?
post #4 of 5
Hi,
I've also had the unit for around 4 years. It's now began to play up; when left on standby the power cuts off and the light fades out. You cannot turn the device back on until you take the plug out for around 5minutes. Even then there is a change the unit does not power up. I can get the unit working sometimes still and is fully operational. This problem developed, after i was searching around finding multi-regional unlock codes and trying them.

I don't know if anyone has this problem but when you supply the device with SPDIF line in and turn the volume up to 21 or higher there is a loud interference sound in the background. To overcome this problem you have to reset the device to factory settings (resets sound balance, equalizer etc).

Does anyone else have the power down? Or does anyone know the cause?

(UK Device being used in the UK).
post #5 of 5
Quote:
Originally Posted by Fatboy03 View Post

Mine is a few years old & recent;y has started acting up on me ... Normally it's on all the time, yesterday I powered it down & now all I get is a blinking standby light & nothing else when I turn it on ..

Anyone know what's wrong & how to fix it?

Mine recently has started to do the same. I basically never turned it off. I bought a new TV last week and unplugged it. After plugging it back in, all I get is the flashing standby light.

I hope someone can shed some light, but the few mentions of this I've seen on the Internet have no resolutions...
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Home Theater In A Box
AVS › AVS Forum › Audio › Home Theater In A Box › Sony "dream" DAV-C770 problems