or Connect
AVS › AVS Forum › Audio › Home Theater In A Box › Problems with Refurb Onkyo HT-S790
New Posts  All Forums:Forum Nav:

Problems with Refurb Onkyo HT-S790

post #1 of 10
Thread Starter 
I got a refurbished HT-S790 from Shoponkyo.com

Everything works great but the sub doesn't seem to power on. Rest of the speakers are great and the receiver seems to be working fine. I tried turning up the sub volume as well as the sub level on the receiver.

Normally, I wouldn't be worried but I had to destroy the BIG box that it came in to get the system in my car (had it shipped to work).

Has anyone ever dealt with Onkyo after you bought a refurbished unit? I want to get the sub replaced only (receiver too if its on that end). I spent a lot of time with the wiring and I'd rather not try to repack all the pieces in another box and send it back.

I'm calling Onkyo tomorrow but I just wanted to know anyone else had been in a similar situation.
post #2 of 10
Where did you get refurbed S790? I have been checking Onkyo.com for weeks. Where on the website should I have looked. Just for the hell of it what did you give for it?

I have been looking for one for some time and finally nailed a new one for $329.00 at CC this week. Did I do ok?
post #3 of 10
$329 for a new system is very good. Yeah, you did OK.
post #4 of 10
Thread Starter 
Got it off the onkyo website. I just had to check everyday. I called them and asked about how often the refurbs go on sale....and all they could tell me was to keep checking. I ordered as soon as I saw it online right before thanksgiving.

As for the price you got for a new set....thats slightly less than what I paid for my refurb so I say you did quite well. I just figured it'd be better for me to order from Onkyo direct.....

I got in touch with the customer service at Onkyo...and after some bitching and arguing (only with the service dept., sales/tech were extremely nice and helpful), I got them to just send me a box for the broken subwoofer.

Overall I was satisfied with their support....
post #5 of 10
I bought a refurbed HT-S790 from accessories4less, about two months ago, for about $330.

My problem is with the sub too, and in my case, it seems the sub doesn't output any signal. I have everything hooked up, and when the system is active, the sub's status light is green, meaning it is receiving the signal. The 'volume' dial at the back just turns and turns, it doesn't stop when you reach the minimum or maximum bass levels. There's no output. Using the test tone, there's nothing but silence on the sub's channel.

Anyone know any good Onkyo licensed repair shops in Queens?
post #6 of 10
I have had two Onkyo ht-s790 refurbed units. The first one had a bad sub exactly like you describe. The second had a bad amp in the receiver that would not output any sound through the 'A' speaker out puts (B worked fine). The first went back in return for the second one, and the second is on its way back now. I should have just complained to get the sub returned the first time since everything worked.

The service department is okay, and pretty quick now. It was impossible to get through right after Christmas (it was a gift) but since it has been fine. They pay the shipping there and back every time, and sent out the labels quickly and turn around once they got it was only a day. The worst part is that they have sent me busted units and while yes I am pissed about it, they should be even more pissed. They must have spent well over $200 on freight for it so far and that does not include sending it back. The only people happy with the whole deal must be Fed-Ex.
post #7 of 10
You get what you pay for. There is a good reason why refurbs are sold at a lower price.
post #8 of 10
Quote:
Originally Posted by Flushy View Post

I bought a refurbed HT-S790 from accessories4less, about two months ago, for about $330.

My problem is with the sub too, and in my case, it seems the sub doesn't output any signal. I have everything hooked up, and when the system is active, the sub's status light is green, meaning it is receiving the signal. The 'volume' dial at the back just turns and turns, it doesn't stop when you reach the minimum or maximum bass levels. There's no output. Using the test tone, there's nothing but silence on the sub's channel.

Anyone know any good Onkyo licensed repair shops in Queens?

From your description it sounds to me like the knob is just turning freely on the shaft of the "volume" control (often called a potentiometer, or "pot"). If the factory setting is to minimal output and the knob is not rotating the shaft, that might explain the phenomenon you describe.

How about checking to see if the knob has a set screw? If it does, try tightening the screw so it firmly grips the shaft of the potentiometer. That might fix it.

If not, does it come off when you pull it? Most control shafts have a flat section, meant to have a set screw tightened against it, but the corresponding knobs often have a female fitting that matches the "male" profile of the control shaft. It might just be that the spring steel insert in the knob that grips the flat on the shaft has been lost. If that's the case, try stuffing some aluminum foil into one side of the area into which the shaft inserts (or, alternatively, perhaps a trip to your nearest RS will yield a workable replacement knob). I think from your description that all you need is something to help the knob get a better grip on the shaft of the pot.

Good luck--if I'm right this might just help you avoid a trip to a repair station.

Doug
post #9 of 10
Quote:
Originally Posted by flags View Post

You get what you pay for. There is a good reason why refurbs are sold at a lower price.

I own two separate Onkyo refurbed products and have had absolutely zero problems with either. One is going on 4 years and gets used every day and never turned off, while the other is very seldom used and only one year old. The most recent had a sticker on the box that said "Minor cosmetic defects". I can't find them.

Due to my good experiences, I would have confidence ordering Onkyo refurb units any time.

Doug
post #10 of 10
Yeah, I got an Onkyo DVD changer that was refurbished. Thing looks brand new and works as well as my Panasonic changer, with a better picture to boot.

I wish I knew of the refurbed 790s so I could have saved some money.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Home Theater In A Box
AVS › AVS Forum › Audio › Home Theater In A Box › Problems with Refurb Onkyo HT-S790