or Connect
New Posts  All Forums:Forum Nav:

Iamm NTD36HD by Novatron - Page 2

post #31 of 491
great work antivirus, what kind of speeds can we expect from ftp and samba
post #32 of 491
Thread Starter 
USB stick boot has been a standard feature for the excellent german satellite receiver Dreambox for some time now... I was quite impressed that they would allow booting from USB instead of the internal flash!

antivirus: I suggest you start working from scratch on the v1.1.142 which is the latest, it will be a shame to work twice since you seem to know what you're doing

I suggest you do tFTP with "root" as both username and password... don't leave the password blank...

Did you check out the background images I posted here? Would you like me to get new ones for the patched firmware?

Regards, Konsti
post #33 of 491
Thread Starter 
OK... gFTP is what? Secure FTP? Telnet FTP? I am lost
With that I can connect from any computer (Mac/Windoze) to the IAMM?

Remember: Anything you change on the code, please be very careful !!!
Thanks!
post #34 of 491
antivirus

is ip tv and ip radio possible with the iaam?
post #35 of 491
Thread Starter 
(a) don't get me wrong; I appreciate ALL that is done and said, here! Especially for antivirus...

(b) it's a shame that the new "L" generation of Sigmas don't support H.264. It's so close to the cpu power needed for WMV. I wonder if this can be a reality, one day

(c) antivirus, let us know when you've got something final final final to test!

Thanks for everything,
Konsti
post #36 of 491
I had to alter the root password in the 'shadow' file to a known crypted pw to allow me access as root under Telnet.

You can get access if you use 'default' as the login name; it throws up an error about being unable to set directory, but lets you in anyway -and it's probably safer not being root-.
post #37 of 491
Hi to you all,

I am impressed, Antivirus actually did a great job . But since I am not either actually an expert in Linux nor in Networks, I do understand the basics of what he did (thank you Konsti for re-stating Antivirus hacking tips...)
Just a few questions left (excuse me if I appear to be a neophyt...):
What are the actual benefits of replacing NDAS by TFTP ? (Higher transmit rate ? TFTP is described as a very light and simple protocol on Wikipedia therefore perhaps much easier to implement as a software solution).
One other key point for me, what is the impact of the patch on the Wireless functionality ?
and finally (same concern as others might have ...) Is the GUI modified somehow and is it still possible to roll back to a previous firmware just in case
post #38 of 491
>replacing NDAS by TFTP ?
TFTP is not a replacement for NDAS, it is just a means of transferring a newer rom image over to and installing onto the NTD36HD.

Currently the only modifications made on the FW by Antivirus are those he listed in one of his .docs:


cat /dev/null > /tmp/config/playlists/shortcut/JUKEBOX.list
cat /dev/null > /tmp/config/playlists/shortcut/MYVIDEO.list

/usr/sbin/telnetd &


Solving a problem with crashes -seemingly because one of these .list files grew large enough to disrupt the normal operation of the unit-, and opening up the possibility of using telnet to get 'into' the unit...this is of little use to the normal user however.

More interesting to the user will be the implementation of Samba and Ftp which Antivirus is trying to get running on the unit. Wheter the actual file transfer speed improves by using either of those over NDAS remains to be seen.
post #39 of 491
Thank you Phew for this quick explanation. Basically just a way to download new unofficial (but improved) firmwares by bypassing the normal novatron update scheme.
post #40 of 491
Thread Starter 
Guys, there's a hurricane going on here--I can't cope with the speed stuff is released! Antivirus, let us know as a TOTAL what your firmware now supports...

Can you please keep track of the changes/additions? That will save all some time reading this thread back...!

Thanks to all for your support and comments.
post #41 of 491
I managed to get 'pure-ftpd' working on the NTD36HD, allowing me to ftp to/from the unit but cannot get my ext3 drive to be recognized on the NTD36HD ...maybe Antivirus has had better luck.


Built a version of the FW that autoloads telnetd and installed.

Formatted a 120Gig drive to ext3 in linux and replaced the drive I have installed.

Made the folders MOVIE, PHOTO and MUSIC on the ext3 drive.

Booted the NTD36HD with new FW, new 120g HDD and a memory stick with some test files on it.
...There was no HDD1 showing on the GUI

telnet'd into the unit and checked what had been mounted

cubee:~# mount
/dev/root on / type romfs (ro)
none on /dev type devfs (rw)
proc on /proc type proc (rw)
ramfs on /tmp type ramfs (rw)
usbfs on /proc/bus/usb type usbfs (rw)
/dev/scsi/host0/bus0/target0/lun0/part1 on /tmp/usb/disc0/lun0/part1 type vfat (ro,nosuid)

...the /dev/scsi.... is my memory stick.
so, the new 120g ext3 drive did not load automatically.
I forced it to mount to the same location as the ntfs drive loaded with


/dev/ide/host0/bus0/target0/lun0/part1 on /tmp/ide/part1 type ntfs (ro,noatime,n
odiratime,nosuid,uid=0,gid=0,fmask=0177,dmask=077,nls=utf8,e rrors=continue,mft_z
one_multiplier=1)


I mounted with:
cubee:~# mount /dev/ide/host0/bus0/target0/lun0/part1 /tmp/ide/part1
...this mounted OK as an ext3 drive (rw) and I could browse the folders in /tmp/ide/part1

Unfortunatly the GUI still could not see the HDD1, I assume that the 'caracoa' executable tries to load an 'ntfs' drive at startup and if it does not find one flags it as not being there? (maybe needs a slight hex edit to the executable here)

ANYWAY:
The purpose was to test pure-ftpd (I just assumed that the ext3 drive would work as a replacement so we can deal with that later).

From my memory-stick I copied a version of 'pure-ftpd' (borrowed from the MG 35 thread) into the /tmp/ folder:
cp tmp/usb/disc0/lun0/part1/pure-ftpd /tmp/pure-ftpd

and ran the program from the /tmp/ide/part1 folder

/tmp/pure-ftpd -H -D -M -z &

I could then use a WinXP ftp program to connect as 'anonymous' and see the folders MOVIE, PHOTO and MUSIC on the ext3 drive. Copying to/from these from my desktop (not super-fast but worked)

Anyone with some linux knowledge with any thoughts?

How are you getting on Antivirus?
post #42 of 491
phew,

your right about flag for the 'ntfs' drive at startup:

"I assume that the 'caracoa' executable tries to load an 'ntfs' drive at startup and if it does not find one flags it as not being there"

I have a irrating bug with my IAAM, where my 500gb drive is not always picked up, and i have to restart the IAAM and ony then is the drive picked up.

Can this irratating BUG be fixed or will i have to live with it?

K
post #43 of 491
Thread Starter 
Phew, Antivirus, thanks for your great work!

I know you're still experimenting, maybe you can tell me if I can offer some ideas on new menus, higher in resolution, like 1280x720 or other.... Did you try the JPG's I posted? How did they display in terms of quality? Smooth or jagged edges?

Phew, why do you need to mount an ext3 drive? I am not supporting the NTFS but just asking... is it to be able to write files when you FTP from another computer?

Hmmm... I guess so
post #44 of 491
phew, good to see that antivirus is not the only one to work on the IAMM. It is a good piece of hardware but the software badly needs to be improved.

Thanks to you and antivirus for your work and effort,

Michael
post #45 of 491
Phew, glad to see that antivirus now has some support. It is a shame that the manufacturer appear to be either incapable or unwilling to support their own product. So the work you and antivirus spend on the device is all the more welcome and appreciated.

Regards,

Michael
post #46 of 491
I,m also a reasonably new owner of an IAMM. Would love to be to gain control over this thing too, if I could be of any help... unfortunately my Linux sucks..

Would love to be able to transfer files from my main PC which run XP64 on home network. NDAS doesn't support X64 .

PS the 1080i output from this thing is superb on my TECO 40 inch ..

Am an ex Kiss DP558 user.
post #47 of 491
Thread Starter 
Greetings to all !

I am happy to see that the thread I started is gathering more and more fans!
Phew, Antivirus, good to know you're working together.

I will be preparing some background images for you and will send them to you for inclusion in your new firmware.

Good luck in your experimentation with the code!
post #48 of 491
Thread Starter 
Guys... anyone... no news... what's up? Phew! Antivirus! How are you guys doing with the experiments?!?
post #49 of 491
Its gone quiet.....?
post #50 of 491
Thread Starter 
The guys are still experimenting. That's what I am told.... Let's be patient, the baby is not far from being born
post #51 of 491
I bought this media player and I'm using it with great satisfaction, I love the possibility to play files directly from my PC using the wireless connection.
I have some problems with my external HDD (it's a Packard Bell 2.5" without external power supply) : it's recognized and I'm able to browse the files stored in but if I try to play them the Iamm remains in loading status and it freezes. I contacted Novatron and they suggested to format the HDD in NTFS but I have to try yet. I hope it will work
post #52 of 491
Thread Starter 
Good luck! I don't see why FAT32 should not be working (you don't mention it but I assume it's FAT32 for what size? 80GB?) perhaps NTFS read-only that the IAMM supports has better results. What did you try to play? ISO file? VOBs and Video_TS? .avi?

Let us know...
post #53 of 491
It's a 120GB in FAT32, Novatron support wrote me that it's better using NTFS for HDDs greater than 32GB... I tried divx, xvid, dvd iso and mp3. The same files are ok using internal HDD or Network.

This is the email Novatron support sent me :

Dear Sir

Thanks for your e-mail.

Could you check the below things with your external HDD.

* If your HDD is over 32GB, we recommend NTFS file system.
Please check the HDD is formatted NTFS.

* To be used with NTD36HD, the HDD should be a primary partition.
Please check the HDD has a primary partition.

* Please check the file that can be played with NTD36HD.

After checking this, please let me know if you still have some problems.

Best regards,

NOVATRON CO., LTD.
post #54 of 491
Thread Starter 
FAT32 only supports single files up to 2GB, so the full DVD ISO is not supported--you can't write it on the HDD itself! The VIDEO_TS folder is still OK since each VOB is 1GB.

Try NTFS and let us know. I have formatted my drive (internal) with NTFS. Does your external appear as HDD2 or you select the USB icon?
post #55 of 491
Internal drive is formatted with NTFS so no problems, the external HDD appears as USB. ASAP I'll be able to move files on my external HDD I will try to format it with NTFS... cross the fingers
post #56 of 491
I have formatted my external HDD with NTFS and now it works fine Now I'm trying NDAS but it's slow, a copy function from external USB devices to internal HDD would be great in a next firmware release.
post #57 of 491
Thread Starter 
NDAS is software-based and IS SLOW by default. But for a media player, I don't think why the manufacturer would put a copy function (from volume to volume) since it's not really in the framework of a media player's operation (although handy, I agree with you).

PLUS! You're forgetting that NTFS capability seems "read-only", except for the NDAS module (which is not Novatron's software). I don't know if the internal linux-based system loads a driver for WRITE capability on NTFS...

Phew, Antivirus, you've analysed the firmware--is there a full "read-write" driver you can load in the IAMM when mounting the HDD (internal or external)?
post #58 of 491
Thread Starter 
Well done, guys. Just make sure you let us know in detailed steps what to do ;-)

Should I prepare the two menu backgrounds for you? What size do you want them? The green ones were just a test, I have this same background from my iMac (MacOS X) in a great resolution!
post #59 of 491
Has anyone used a DVD as an external device on the IAMM?

If so whats the quality, does it upgrade the image and which ext DVD player is recommended?
post #60 of 491
I read it on the forum that wi-fi can be activated on sarotech DVP-570HD by using a router like linksys. I would highly appreciate if you could guide me how to use the router fr activating hifi on 570HD.
Thanks
Meenakshi Jhamb
New Posts  All Forums:Forum Nav:
  Return Home