or Connect
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Receiver and amplifier hum?
New Posts  All Forums:Forum Nav:

Receiver and amplifier hum?  

post #1 of 4
Thread Starter 
Is it normal for my Arcam receiver and Adcom amplifier to have a hum coming out of the power supplies? For the Arcam 300 receiver you have to get real close in order to hear it, but the Adcom 7807 I can always slightly hear from my seating position. I have a dedicated room, so it's pretty quiet. I am running a dedicated 20 amps electrical outlet for the Adcom. When the Adcom amp is running and I turn on the Arcam receiver, the hum increases on the Adcom amplifier as the Arcam clicks to turn on, but then after two seconds or so the hum on the Adcom comes down to its usual level.

One more detail, everytime the microwave is used, the hum shows its ugly head even more, it doubles, only on the Adcom amplifier. The microwave being in the kitchen, get its power from a different line.

Is this normal, or do I have an electrical problem? The house is 17 years old.
post #2 of 4
Thread Starter 
Is there anybody on this forum that has any idea of what may be wrong?
post #3 of 4
Sounds like you might have a ground loop issue. The easiest way to test this out is to use a "cheater" plug. If the cheater plug gets rid of the hum, you could continue to use it, or go to more extreme means to resolve the ground issue.

* Note: there are those who believe there is no issue in using a cheater plug on a regular basis, while there are others who despise it. I'm from the camp where if it works, then use it. I haven't read of equipment being damaged by using the adapter.
post #4 of 4
Thread Starter 
[quote=wje]Sounds like you might have a ground loop issue. The easiest way to test this out is to use a "cheater" plug.

Excuse my ignorance, What is a cheater plug?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Receivers, Amps, and Processors
This thread is locked  
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Receiver and amplifier hum?