or Connect
AVS › AVS Forum › Other Areas of Interest › Car Audio, Video, and Nav › Kenwood KRCX858 faceplate is NOT hiding
New Posts  All Forums:Forum Nav:

Kenwood KRCX858 faceplate is NOT hiding

post #1 of 2
Thread Starter 
Hey guys,

I have a weird problem. My Kenwood KRCX858 decided to freak out on me. The faceplate that hides when the car is off is now remaining in the open "Cassette Tape insertion" mode. When I press the reset button, the faceplate goes into the ON position but there is no power in the display. I cant press any buttons. I took the stereo out and checked the fuse and wiring but everything looks good. What can be the problem? I cant take off the faceplate either. The lock switch seems like it is stuck or something. Help!
post #2 of 2
Quote:
Originally Posted by eug718pioneer View Post

Hey guys,

I have a weird problem. My Kenwood KRCX858 decided to freak out on me. The faceplate that hides when the car is off is now remaining in the open "Cassette Tape insertion" mode. When I press the reset button, the faceplate goes into the ON position but there is no power in the display. I cant press any buttons. I took the stereo out and checked the fuse and wiring but everything looks good. What can be the problem? I cant take off the faceplate either. The lock switch seems like it is stuck or something. Help!

Usually the ribbon cable was the cause of the MASK headunit failures reguarding the faceplate. It can be fixed, however it might be cost effective to replace it.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Car Audio, Video, and Nav
AVS › AVS Forum › Other Areas of Interest › Car Audio, Video, and Nav › Kenwood KRCX858 faceplate is NOT hiding