or Connect
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › Switch from SD to HD and lose pic ... Help.
New Posts  All Forums:Forum Nav:

Switch from SD to HD and lose pic ... Help.

post #1 of 3
Thread Starter 
I would appreciate some help/input. I just got the SHARP LC-C3742U. I have the comcast scientific atlantic 8300 hd dvr box hooked up via hdmi.

When I change channels from a non-HD channel to an HD channel, the picture goes black (I can hear the correct channel, just no picture). No matter which channel I turn to after that, the screen remains black. However, the screen comes back again if I turn the TV off and on.

Any idea what I need to do to get my HD picture to come through, without turning my TV off and on.

I am pretty sure this is a tv issue because my previuos lcd never had this happen.

I am going to try running through the tv setup again and reconnect everything but was hoping someone else may have had the issue and be able to offer a solution.

If its the tv then back to the store it goes ...

Any help is appreciated.
post #2 of 3
Quote:
Originally Posted by fixitfox View Post

I would appreciate some help/input. I just got the SHARP LC-C3742U. I have the comcast scientific atlantic 8300 hd dvr box hooked up via hdmi.

When I change channels from a non-HD channel to an HD channel, the picture goes black (I can hear the correct channel, just no picture). No matter which channel I turn to after that, the screen remains black. However, the screen comes back again if I turn the TV off and on.

Any idea what I need to do to get my HD picture to come through, without turning my TV off and on.

I am pretty sure this is a tv issue because my previuos lcd never had this happen.

I am going to try running through the tv setup again and reconnect everything but was hoping someone else may have had the issue and be able to offer a solution.

If its the tv then back to the store it goes ...

Any help is appreciated.

Short loss of signal is normal as you switch tuner signals SD - HD.

However, Power problems can result in this type event.

To resolve - the back of the TV should have a reset button indentation where you can insert a pin and it will reset to factory settings. Your manual should identify where the reset is - this can occur during power problems and give the impression the panel is not working receiving sound and no display of Picture.

Also, on the high end sets there also is a display setting to send music through the TV and turn off the display and this can be accidentally activated - doing the reset button and leaving it off a few minutes and then restarting the TV should reset to the factory standards and bring the display back if this is the issue. I've had this occur on two of mine and it appears that the TV protects from damage during unexpected error events and must go through a reset process much like a PC does often. It does give the impression the TV display is no longer working. I also had it once when I had an HDMI conflict with my HD DVD player but since I upgraded it's firmware all errors from HDMI have been resolved. All of the events have been caused by external factors not the TV and I also used a Power Cleaner in the chain but an unexpected power outage can replicate such an event unless you use an APC device with temporary battery backup much like one uses on a server rack to keep everything going during those temp events but add's to the expense.
post #3 of 3
Thread Starter 
I've looked on the back and cant see an obvious rest button ... anywhere special I should be looking?

Thanks.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: LCD Flat Panel Displays
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › Switch from SD to HD and lose pic ... Help.