or Connect
AVS › AVS Forum › Video Components › Home Theater Computers › HTPC - Linux Chat › DLP resolution question
New Posts  All Forums:Forum Nav:

DLP resolution question

post #1 of 16
Thread Starter 
I've been using a 720p modeline to output to my CRT HDTV for the last six months, but I just got a Mitsubishi HD1000 projector and I'm having trouble getting the picture coming from my Myth box to fill the new screen.

The projector has a native resolution of 1280 x 720, so I expected that when the video card was set to that resolution the picture would use every available pixel. Instead, no matter what zoom setting I choose, the picture is a small box on the screen. My XBox 360 is also set to 720p and it fills the screen. Both are connected to the projector by the same component cable through a component switcher.

Does anyone have any suggestions, like a different modeline or resolution I should try? I did a quick search of this forum, but didn't find anything.
post #2 of 16
Are you sure that your output it 720p? or is that just what you have it set to? you can use xvidtune to check the currently used settings.
post #3 of 16
Thread Starter 
Well, the projector recognizes the signal as 720p. I have an nvidia card and I've got Option "TVStandard" "HD720p" set in my xorg.conf, and I'm using (what I believe to be) a 720p modeline that I generated here...

I'm open to the possibility that it's not actually putting out as many pixels as I think it is. I'll run xvidtune when I get home. I only have one modeline, though, so it should pretty much be constrained to the one resolution I have defined.

On the bright side, the text is incredibly legible and clear, unlike when I used the same settings to display on my CRT.
post #4 of 16
If the text is incredibly clear, then you might not be putting out 720p.

Also, I hope you don't run into this, but I have a projector that absolutely cannot do a 1:1 pixel mapping of an analog signal. It always smears the image, and doesn't have alignment settings available. I miss my UP-1100...
post #5 of 16
What video card are you using?
post #6 of 16
Thread Starter 
Thanks for the tip, Len. I ran xvidtune and it turns out I was running at 800x600.

I took a closer look at my X error log and found that it was ignoring my custom modeline and defaulting to a safe-mode 800x600 this whole time and I never knew! I'm using a GeForce 6200, and (after some research) I guess it doesn't like custom modelines for TV output and only accepts standard resolutions... which is fine since I want to use a standard resolution.

I was able to specify a standard 1280x720 in xorg.conf and now it looks big and beautiful. (incidentally, the text still looks great )
post #7 of 16
underwhelm, so does that mean you are not using a custom ModeLine any more? Does the standard res work fine as long as you specified Option "TVStandard" "HD720p" ?

Thanks for the help, just bought the hd1000 and want to make sure I have my myth box all ready for its arrival.
post #8 of 16
Thread Starter 
Here is the relevant portion of my xorg.conf:

Code:
Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "TV-0"
        Option "TVStandard" "HD720p"
        Option "ConnectedMonitor" "TV"
        SubSection "Display"
                Viewport   0 0
                Depth     16
                Modes "720p" "1280x720"
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes "720p" "1280x720"
        EndSubSection
EndSection
You'll see that I have the TVStandard set, and have two modes listed. The "720p" mode makes reference to a modeline I set in the Monitor section.

Code:
Section "Monitor"
        Identifier   "TV-0"
        VendorName   "Mitsubishi"
        ModelName    "HD1000"
        HorizSync 15.73 - 68.68
        VertRefresh 50 - 75
        ModeLine     "720p" 73.78 1280 1312 1592 1624 720 735 742 757 +hsync +vsync
EndSection
It turns out the Nvidia driver does not accept custom modelines when connecting through the TV out. Instead, it only accepts specific modes as detailed in the driver documentation (see Appendix H and Appendix J--"Because these TV modes only depend on the TV encoder and the TV standard, TV modes do not go through normal mode validation. The X configuration options HorizSync and VertRefresh are not used for TV mode validation.

Additionally, the NVIDIA driver contains a hardcoded list of mode sizes that it can drive for each combination of TV encoder and TV standard. Therefore, custom modelines in your X configuration file are ignored for TVs.")

So the nvidia driver does not accept my 720p modeline, it rejects it as invalid. But it accepts my "1280x720" mode as valid, even though it is not defined. Its definition is supplied by the driver itself. Without specifying the "1280x720" mode, the driver finds no valid modes, and defaults to an 800x600 "safe mode."

Here is the relevant output of my X log with this xorg.conf:
Code:
(**) NVIDIA(0): Option "ConnectedMonitor" "TV"
(**) NVIDIA(0): Option "TVStandard" "HD720p"
(**) NVIDIA(0): Option "RenderAccel" "true"
(**) NVIDIA(0): Enabling RENDER acceleration
(**) NVIDIA(0): TV Standard string: "HD720p"
(**) NVIDIA(0): ConnectedMonitor string: "TV"
(II) NVIDIA(0): NVIDIA GPU GeForce 6200 at PCI:1:0:0
(--) NVIDIA(0): VideoRAM: 131072 kBytes
(--) NVIDIA(0): VideoBIOS: 05.44.a2.05.00
(II) NVIDIA(0): Detected AGP rate: 8X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 6200 at PCI:1:0:0:
(--) NVIDIA(0):     NVIDIA TV Encoder (TV-0)
(--) NVIDIA(0): NVIDIA TV Encoder (TV-0): 400.0 MHz maximum pixel clock
(--) NVIDIA(0): TV encoder: NVIDIA
(II) NVIDIA(0): Assigned Display Device: TV-0
(WW) NVIDIA(0): No valid modes for "720p"; removing.
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "1280x720"
(II) NVIDIA(0): Virtual screen size determined to be 1280 x 720
...
(II) NVIDIA(0): Setting mode "1280x720"
Revised to add: I've considered trying a 1080i or even 1080p resolution just to see how it would look on the HD1000 (after reading some threads that suggest that it may actually "look better"), but haven't gotten around to the effort. It looks great now so why mess with success? Plus, I use my myth box to play DDR, so by providing a native resolution image I don't have to worry about scaling or deinterlacing delay introduced by driving the projector with a non-native resolution.

If anyone tries, I'd be interested to hear about the results.
post #9 of 16
Thanks for the help, my hd1000u finally showed up today and I tried your recommendations, but Im having one issue.

xvidtune shows that I am indeed running at 1280x720, but not all of the image in X is showing up on the screen. ie: in fluxbox, I can't even see the icon bar at the bottom. I have been searching google for an answer, but wanted to check with you to see if you had this same problem.

The only difference from what it sounds like you are doing, is that Im using the VGA out into the projector instead of the tv/svideo out.

Any help would be greatly appreciated.
post #10 of 16
tyce: I just got my HD1000U last weekend and I ran into a similar issue when connecting my computer via VGA. I managed to tweak the settings and get the entire image to display, but I can't get rid of pixel smearing. Its like its not doing a 1:1 pixel map or something. Let me know if you get this figured out

Dan

Edit: I'm currently running windoze with an Asus GeForce 4 Ti 4600. This issue only appeared at 1280x720. The projector seemed to scale other resolutions without any issues.
post #11 of 16
well, right as I was trouble shooting this, construction workers in my neighborhood clipped a power line and took everything down in my house. Anyone else, had this issue that might want to lend a hand?

thanks,
post #12 of 16
Power's back on and I seem to have made some progress...

I figured the problem must be with the modeline, so I tried to find another one. I wasn't successful at finding another hd1000u, but I did find one for the hd3000u which I decided to give a whirl. Here are the two compared (first one 1000u followed by 3000u):

ModeLine "720p" 73.78 1280 1312 1592 1624 720 735 742 757 +hsync +vsync
Modeline "720p" 83.05 1280 1376 1504 1736 768 771 778 798 -hsync -vsync

The whole desktop is now showing up and myth actually plays HD again. I am not 100% sure that I want to continue using this modeline, but I am hoping that this might put someone else on the right track of a real solution.

Let me know if you figure anything else out.
post #13 of 16
Thread Starter 
Make sure the HD1000 is set to 100% overscan. The default setting crops the image like a TV would, while 100% shows every pixel.
post #14 of 16
Mine came set to 100% over scan, so I didn't have to touch it. For the most part, that 3000u modeline appears to be working. underwhelm, you generated that modeling from a site right? you haven't had any trouble with it?
post #15 of 16
I've tore all my hair out trying to figure out the proper mode line yesterday after the projector arrived. A 1280x720 mode line calculated from xtimings doesn't give good results; however, the standard ATSC video timing works great. The only problem seems to be a tad bit of shimmering on static images. It might just be my cable though. Here's the modeline:

ModeLine "ATSC-720p" 74.16 1280 1352 1392 1648 720 725 730 750

The projector detects it as "720p 60" under the menu. It sets overscan to 97% automatically, and I'm not sure if you can disable that. Setting it to 100% will reveal the clipped regions, but you have to set it every time you switch signals. It's probably not going to be an issue for normal viewing.
post #16 of 16
pthreadunixman, tried that modeline and had the same results. At this point however, it appears to be the best looking option available and until something else comes along, it'll be what I'm using. Thanks!

If any one else finds a better alternative, please share it.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: HTPC - Linux Chat
AVS › AVS Forum › Video Components › Home Theater Computers › HTPC - Linux Chat › DLP resolution question