or Connect
AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › Official Outlaw Owners thread
New Posts  All Forums:Forum Nav:

Official Outlaw Owners thread - Page 12

post #331 of 7091
Quote:
Originally Posted by laugsbach View Post

Hi weverb,

Kaizen..whoa, I don't know about that.

My Wife watches too much TV and has Lexus' commercials committed to memory. She came up with that line a couple of days ago.

I like Kaizen, I'll lay that one her the next time she complains about my endless pursuit of perfection.

Larry

My wife wants to have a vanity plate on her car that says "kaizen".
post #332 of 7091
Since I just bought some Outlaw products, I figure I ought to add myself to the thread...

I just purchased 3 M-2200's for my front 3 speakers (Klipsch RF-62's and RC-62) and am still waiting to try them out. I receive my receiver (VSX-92TXH) on Wednesday, so I'll hook it all up then... just to pack it all up a day later as the movers are coming to pack everything else up. We'll be moving into a new house another state over and I've been given the nod to finish the basement the way I want. I'll have cool pics someday! :-)
post #333 of 7091
Just bought an LFM-2! At $199 I figured it was just too good a deal to pass up, and I wanted to buy it before the sale ended.

Additionally, I doubt I'll ever be able to realistically test its limits in my apartment and future condo situation, let alone that of the LFM-1c or higher!

I'll update with my thoughts once the sub gets here.
post #334 of 7091
Hi nsdjoe,

Welcome. I am looking forward to your thoughts.

Enjoy your new sub!

Larry
post #335 of 7091
Nevermind found the spike screws in the bottom of the box
post #336 of 7091
Hi Imatk,

There should be 4 threaded inserts included with your sub. From my memory, they were located in one of the styrofoam rails and I think they were covered with tape.
I'll go look at my shipping carton.

Larry
post #337 of 7091
Hi Imatk,

Ok, I just looked at my shipping carton. The same long, thin white box that contained your spikes and discs should have the 4 threaded posts that screw into the spikes and then the spikes screw into the threaded hole in each corner of the LFM.

Larry
post #338 of 7091
Quote:
Originally Posted by laugsbach View Post

Hi Imatk,

Ok, I just looked at my shipping carton. The same long, thin white box that contained your spikes and discs should have the 4 threaded posts that screw into the spikes and then the spikes screw into the threaded hole in each corner of the LFM.

Larry

Hi Larry, thought I would post a few pics that may help. Hope you don't mind my friend.

Cheers,

Phil
post #339 of 7091
Phil, You Are The Man!

Larry
post #340 of 7091
Quote:
Originally Posted by laugsbach View Post

Phil, You Are The Man!

Larry

I wish.........LOL!!!!! When I was a little boy, my Dad would always say Conway Twitty "was the man". So, every time I hear that saying "you are the man" I can NOT help but to think about Conway Twitty. Of course, the operative word now is "was" since he has since passed. But, do appreciate your level of support Larry. Hope all is well my friend.

Cheers,

Phil
post #341 of 7091
Thanks guys, I found them... they somehow got to the bottom of the box.
post #342 of 7091
Quote:
Originally Posted by audiofreak38 View Post

Hi Larry, thought I would post a few pics that may help. Hope you don't mind my friend.

Cheers,

Phil

Nice pics Phil. Hey, I read a few posts back that LFM-1 Plus #2 should be arriving soon . Keep us updated, and congrats - that tiny room is going to be one big buttkicker!

Stephen

BTW, keep that picture-taking tradition going - I have to see that tiny room with two subs
post #343 of 7091
Well I popped in Master and Commander after setting up my EX last night.

Went through the auto setp with my Pioneer 92 Elite. It had me set the woofer on 2.5 for volume. I thought, "Man this is going way low."

Ummm... all I can say is holy crap!

I have it set on "Max Output" as I kind of wanted to have that mid-bass jolt as well. And boy does it jolt!

My wife says, "It isn't going to shake the house apart is it?"

I said no, but in retrospect... I don't know. Could it damage the house?

I'm guessing no since it's in a 19' x 15' room. But the floor and my chest sure were rumbling hehe.

I do have a question though. I didn't notice the "sound" of the subwoofer as much as I felt it. Is this the way it should be? Almost like my mains and my other speakers were taking care of much of the bass. Although maybe it's just because it's integrated well and I don't notice it above all the other speakers... don't know.

I'm running Aperion Intimus 6T towers for my mains and Aperion all the way around for the two surrounds and the center channel.
post #344 of 7091
Quote:
Originally Posted by lalakersfan34 View Post

Nice pics Phil. Hey, I read a few posts back that LFM-1 Plus #2 should be arriving soon . Keep us updated, and congrats - that tiny room is going to be one big buttkicker!

Stephen

BTW, keep that picture-taking tradition going - I have to see that tiny room with two subs

Stephan, I hope to have my second LFM-1Plus very soon. I will be more than happy to take some more pics. However, I need to put in my new tv stand and more or less re-install everything. Might as well wait till the other Plus gets here and just do it all at the same time. That way, I won't have to recalibrate again. Setting up my tri-pod over and over again can get quite boring. Hope to have it all done w/in the next (2) weeks.

Cheers,

Phil
post #345 of 7091
Quote:
Originally Posted by Imatk View Post

Well I popped in Master and Commander after setting up my EX last night.

Went through the auto setp with my Pioneer 92 Elite. It had me set the woofer on 2.5 for volume. I thought, "Man this is going way low."

Ummm... all I can say is holy crap!

I have it set on "Max Output" as I kind of wanted to have that mid-bass jolt as well. And boy does it jolt!

My wife says, "It isn't going to shake the house apart is it?"

I said no, but in retrospect... I don't know. Could it damage the house?

I'm guessing no since it's in a 19' x 15' room. But the floor and my chest sure were rumbling hehe.

I do have a question though. I didn't notice the "sound" of the subwoofer as much as I felt it. Is this the way it should be? Almost like my mains and my other speakers were taking care of much of the bass. Although maybe it's just because it's integrated well and I don't notice it above all the other speakers... don't know.

I'm running Aperion Intimus 6T towers for my mains and Aperion all the way around for the two surrounds and the center channel.

Hey, great write-up. Really enjoyed reading your initial impressions. The reason you are feeling the bass more than hearing is because real low bass is more felt than heard. If you are in MO mode, the EX is easily reaching down to the low 20's. If you put it in ME mode and plug one port it will easily go into the mid teens. Glad you are enjoying your EX. Can you snap a few pics?

Cheers,

Phil
post #346 of 7091
Quote:
Originally Posted by audiofreak38 View Post

Stephan, I hope to have my second LFM-1Plus very soon. I will be more than happy to take some more pics. However, I need to put in my new tv stand and more or less re-install everything. Might as well wait till the other Plus gets here and just do it all at the same time. That way, I won't have to recalibrate again. Setting up my tri-pod over and over again can get quite boring. Hope to have it all done w/in the next (2) weeks.

Cheers,

Phil

I feel ya, man. I just rearranged my room yesterday, completely reorienting my entire setup. What a PITA! Had to rerun wires, remount speakers, etc. Fortunately I think the change was worth the hassle. Anyway, I completely understand you wanting to get things in a more finalized state before calibrating and snapping pictures. Hope it all goes smoothly.
post #347 of 7091
Thanks man, I will definitely take some shots when I get home

Should I run it in the Bass Extension mode instead?

I figured since I don't have a mid-bass woofer other than my mains that the Max Output was the way to go.
post #348 of 7091
Quote:
Originally Posted by lalakersfan34 View Post

I feel ya, man. I just rearranged my room yesterday, completely reorienting my entire setup. What a PITA! Had to rerun wires, remount speakers, etc. Fortunately I think the change was worth the hassle. Anyway, I completely understand you wanting to get things in a more finalized state before calibrating and snapping pictures. Hope it all goes smoothly.

Too bad you don't live closer as I would let you rearrange mine. Yeah, when I get the time my plan is to do just that. Right now I have a real problem-it is called "lead in my a$$ syndrome".........LOL!!!!! Perhaps, I will get more motivated when my second Plus arrives. Thanks for the kind words. Good luck to you as well my friend.

Cheers,

Phil
post #349 of 7091
Quote:
Originally Posted by Imatk View Post

Thanks man, I will definitely take some shots when I get home

Should I run it in the Bass Extension mode instead?

I figured since I don't have a mid-bass woofer other than my mains that the Max Output was the way to go.

I run my ONLY in MO mode as my preference is on musical performance. Getting down to the low 20's is plenty low enough for me. If, you want to go into the subsonics, then by all means try the ME mode and decide for yourself. I prefer the extra midbass punch where most of the musical action is at. Once you decide what works best for YOU please let us all know. Looking forward to some pics. Have a good day.

Cheers,

Phil
post #350 of 7091
Quote:
Originally Posted by Imatk View Post

Thanks man, I will definitely take some shots when I get home

Should I run it in the Bass Extension mode instead?

I figured since I don't have a mid-bass woofer other than my mains that the Max Output was the way to go.

I kept mine in MO until I picked up a MBM-12...... Start saving now for the MBM. It will take your EX to another level. ME that is!

How much power do you have going to mains? What are they?

Go to page 7 and you will see pix of my set-up.
post #351 of 7091
Quote:
Originally Posted by Imatk View Post

Thanks man, I will definitely take some shots when I get home

Should I run it in the Bass Extension mode instead?

I figured since I don't have a mid-bass woofer other than my mains that the Max Output was the way to go.

Hi Imatk,

Welcome to the Outlaw Owners Thread.

Before I rec'd my second LFM-1+, I ran in MO mode after experimenting with ME. I watch 100% movies with an occasional concert HD-DVD / BR.

Now that I have two, I'm in ME on both with plenty of output.

That being said, plug one port and rent Cloverfield on DVD or BR and get ready for 1 hour of none stop LFE.

Looking forward to the pics,

Larry
post #352 of 7091
Two LFM-1+! You lucky man. I have debated about adding a second MBM or EX. I think my wife would kill me right now.
post #353 of 7091
Quote:
Originally Posted by weverb View Post

Two LFM-1+! You lucky man. I have debated about adding a second MBM or EX. I think my wife would kill me right now.

This is why I don't have a wife. Just can't deal with a WAF. Have things MY way and that is how they will stay. No pun intended btw.

Cheers,

Phil
post #354 of 7091
Quote:
Originally Posted by weverb View Post

Two LFM-1+! You lucky man. I have debated about adding a second MBM or EX. I think my wife would kill me right now.

weverb, Stimulus Check, man, Stimulus Check

My 1/2 spent on another LFM-1+ & she used her money to buy clothes.
Just tryin' to be good Americans.

Larry
post #355 of 7091
Quote:
Originally Posted by laugsbach View Post

weverb, Stimulus Check, man, Stimulus Check

My 1/2 spent on another LFM-1+ & she used her money to buy clothes.
Just tryin' to be good Americans.

Larry

post #356 of 7091
I just ordered an lfm-1 plus yesterday. I can't seem to find whether or not they are in stock right now. If not, how long is the wait for one? Thanks in advance.
post #357 of 7091
Quote:
Originally Posted by Twisted Dave View Post

I just ordered an lfm-1 plus yesterday. I can't seem to find whether or not they are in stock right now. If not, how long is the wait for one? Thanks in advance.

Hi Dave. It takes about 4 business days depending on where you are. Just give Outlaw a call and they will be more than happy to answer your questions. Congrats on your purchase!!!!!

Cheers,

Phil
post #358 of 7091
Thanks freak, I can't wait! So, are you saying that the plus is in stock? That's my problem. I don't know if they're in stock at the moment, and am trying to find out how long my wait will be if they are not in stock. I haven't gotten a shipping confirmation yet, due to the fact that I ordered online on Friday afternoon. So if they are in stock, I'm sure it's just a matter of Outlaw being too busy, and not being able to process my order until monday maybe. I'll call them on Monday anyway. Just seeing if anybody knew. Thanks.
post #359 of 7091
FWIW, when i ordered mine last month, I never got a shipping confimation either.

I ordered it on a Fri afternoon, and it was delivered the next Wed morning.
post #360 of 7091
Quote:
Originally Posted by Twisted Dave View Post

Thanks freak, I can't wait! So, are you saying that the plus is in stock? That's my problem. I don't know if they're in stock at the moment, and am trying to find out how long my wait will be if they are not in stock. I haven't gotten a shipping confirmation yet, due to the fact that I ordered online on Friday afternoon. So if they are in stock, I'm sure it's just a matter of Outlaw being too busy, and not being able to process my order until monday maybe. I'll call them on Monday anyway. Just seeing if anybody knew. Thanks.

No, that is not what I am saying. But, to answer your question I am sure they are in stock. No worries my friend. Just give them a call in the morning and ask. You should receive your Plus in about 4-5 business days depending on where you are located. Jennifer or Scott will be glad to answer all of your questions. Be sure to keep us posted.

Cheers,

Phil
New Posts  All Forums:Forum Nav:
  Return Home
AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › Official Outlaw Owners thread