or Connect
AVS › AVS Forum › Blu-ray & HD DVD › HD DVD Players › Toshiba HD-A2 Problems Survey
New Posts  All Forums:Forum Nav:

Toshiba HD-A2 Problems Survey

post #1 of 73
Thread Starter 
Okay, I bought the A2 two days ago and have not even taken it out of the box. I have been reading through most of the posts about problems and I must admit that I'm thinking of returning it and waiting another 6 months to see if the problems can be resolved. For whatever reason it seems that problems of any kind creates the allusion that the technology and disks are not truly ready for the average movie watcher. It almost seems like the first and second genereations of players are nothing more than live alpha and beta tests for the manufacturer. So, before I let fear totally envelop my thinking I thought I would steal an ideal another poster said we needed which is a statistical analysis of the problems instead of anecdotal. My theory is that mMore people are willing to post their problems then those that are not experiencing problems. So the poll with be specifically for the HD-A2.
post #2 of 73
I opened my new A2 last weekend and haven't upgraded the firmware yet (I think it's on v1.3). I've watched Matrix and Matrix Reloaded (non-combo discs) so far, and they both played perfectly. Loaded up fine and no issues at all during playback.
post #3 of 73
I haven't had any disks that wouldn't play, but I have had a synchronization problem with the HDMI-DVI connection. Sometimes I get high definition snow on my projector, right after turn-on. I have to push the "setup image" button, or one of the "source" buttons repeatedly to get the player and the projector to sync. On component, it works flawlessly. OEM firmware is at Rev 1.2.

I can't tell you what to do, but I can tell you I am satisfied with my A2, and wouldn't take it back.
post #4 of 73
The vast majority have few to no problems. I'd encourage you to set it up, update to firmware 1.6, and be prepared to be blown away.
post #5 of 73
I received error 408bc504 while booting-up The Fountain post-1.6
post #6 of 73
Thread Starter 
ttt
post #7 of 73
Open it and start enjoying HD films.
post #8 of 73
Serisouly, the problems that seem to be going around are severely exaggerated in comparison to the people who don't have any problems at all. I have had one that hasn't blinked at any disc thrown at it as well as a friend who's got one and the only time it ever through him an error at all was on the Matrix with really old firmware. Now with a firmware upgrade it takes everything as well as mine does. Don't let fear ruing your HD watching experience.
post #9 of 73
I had a problem with my A2 - it frequently froze when playing. I sent it back to Toshiba for repair, and so far, it is playing far better since the factory repair. I am running firmware version 1.5.
post #10 of 73
Any message board on any product is gonna give the impression of problems more widespread than they are. I bet most people do not have problems.


I myself have had only one problem, ever, and it was a disc issue. CoM, fixed right up with some hot water and soap.
post #11 of 73
No problems here. So far it's played everything I've thrown at it, including burnt media without a hitch... and it upconverts better then my HTPC.
post #12 of 73
I have had my A2 for over a week with V1.3. I have feed it every SD and HD rental DVD I can get my hands on without any problems. My wife still has not caught on the fact it is a new player. I did feel about about the firmware update, so I did burn the ISO and it updated without any issues. My A2 is screaming for a new AV receiver. Open the box and enjoy HD DVD.
post #13 of 73
I've had my A2 for a couple of months now and it's played everything I've thrown at it. Combos, no problem. Homemade discs, played without a hitch. That one SD PAL disc I mistakenly put into my A2 instead of my converting player, well , it wouldn't play that one, but it's not supposed to

100% satisfied here.
post #14 of 73
Thread Starter 
Quote:
Originally Posted by eapleitez View Post

Any message board on any product is gonna give the impression of problems more widespread than they are. I bet most people do not have problems.


I myself have had only one problem, ever, and it was a disc issue. CoM, fixed right up with some hot water and soap.

And this is exactly why I decided to put a poll up so that all could see actual performance. Amazon has 122 individual reviews and I read through all the negative and there weren't many. The player has 4.5 star rating out of 5.

My player is now in play position and I am about to watch MI3!
post #15 of 73
mine is still at 1.5 and no disc playback problems at all. The only "problem" disc I have tried, however, is Smokin' Aces. I have played other combo discs (I.e. The Departed) also with no problems.

So until I see problems, 1.5 FW is where I stay.
post #16 of 73
Thread Starter 
Okay, a small problem. I am watching MI3 and I have no LFE. I have it setup as Bitstream according to the manual. My received says it is playing in 5.1 DTS but I have no sub. I know I saw something about this in another post. Is this a setting I need to change or this is a firmwear issue?
post #17 of 73
But there are no problems with HD DVD......?
post #18 of 73
Quote:
Originally Posted by thebland View Post

But there are no problems with HD DVD......?

But there are no problems with Blu-ray......? Dude whats your point? There is not one player on either format that is perfect at the moment so WTF?
post #19 of 73
Thread Starter 
I turned up the subwoofer and got the LFE. For some reason my sub was turned way down. I found another post about this as well. I did not set up the player correctly. I am using HDMI to the TV and optical to the reciever. I have a 7 year old Kenwood so I don't have HDMI. I switched the player from HDMI Auto to PCM and the other setting is on Bitstream. Sound is much better. I don't have it up loud cause the grandkids as sleeping over. I am really impressed with the picture quality. I am watching MI3 and the scene where Tom Cruise drives up to the 7-11 there is a light mist that I saw for the very first time. I never saw it on the SD version. Do I need to upgrade to a newer receiver to take advantage of the HD sound.
post #20 of 73
you nmeed a PUBLIC poll otherwise you cannot trust the results.

also do a search i asked the same queation in a PUBLIC poll and 80% or more said their unit was perfect.
post #21 of 73
I've had my HD-A2 for 2 months now and when I first received it (box was still closed) I was nearly certain I would be taking it back. I didn't think there was anyway the player would play stunning HD THAT much better than the current upconversion of std DVD. Once I hooked it up and played the HD movies, there was no way this thing was going back! I don't care if I had to write my own firmware to keep it!!

I would rate the increase in PQ on par with moving from std def on TV to high def compressed on satellite.

Yes there are SOME issues. We want our players to operate 100% perfect which isn't happening curently but I'd say in my case it is 98% perfect.

It's your choice but the issues we currently face are not as bad as you may think. In most cases you have a 30 day return policy. What do you have to lose by opening the box and trying the unit?

HDDVD is amazing and it is worth it to setup your player and begin watching
post #22 of 73
Quote:
Originally Posted by thebland View Post

But there are no problems with HD DVD......?

their is, but its mostly with combo's not the players themselfs...

but look what i found on the first page on the blu ray player section. and only by looking at the first page!

http://www.avsforum.com/avs-vb/showthread.php?t=855380

http://www.avsforum.com/avs-vb/showthread.php?t=851314

http://www.avsforum.com/avs-vb/showthread.php?t=855435

http://www.avsforum.com/avs-vb/showthread.php?t=851295

and even the owner of avs forum had problems playing pirates on his sony bd player!
post #23 of 73
Go ahead and use your player. Mine has played everything great over the past 4 weeks that I've owned it -- mostly rental discs (thank you, Netflix!). I've also played some burned DVD-R home movies and burned audio CDs that my old regular DVD player couldn't handle. For standard DVDs, I'm really impressed with how well it upconverts to a near-HD experience.

Mine came out of the box with something like the 1.2 firmware and I updated it up to 1.5 about 2 weeks ago, and then today to 1.6. For some reason, I had to stair-step up one firmware version at a time, which takes over 30 minutes using the internet. Still, I've had no problems at any time playing anything.

The only thing to be aware of is that it turns on slow -- as if it's a computer booting up, taking maybe 20 long seconds before you can put a disc in.
post #24 of 73
Quote:
Originally Posted by betona View Post

The only thing to be aware of is that it turns on slow -- as if it's a computer booting up

Bingo! It is a computer, so it has to "boot up" every time you turn it on.
post #25 of 73
Just received the A2 from amazon.com. Planet Earth won't play on my A2. I'm waiting for the update to come in the mail from Toshiba. Will that take care of the problem? I watched Serinity on it last night without a problem.
post #26 of 73
Quote:
Originally Posted by Iggster View Post

their is, but its mostly with combo's not the players themselfs...

but look what i found on the first page on the blu ray player section. and only by looking at the first page!

http://www.avsforum.com/avs-vb/showthread.php?t=855380

http://www.avsforum.com/avs-vb/showthread.php?t=851314

http://www.avsforum.com/avs-vb/showthread.php?t=855435

http://www.avsforum.com/avs-vb/showthread.php?t=851295

and even the owner of avs forum had problems playing pirates on his sony bd player!

lol
post #27 of 73
Did have a problem and posted it here:
http://www.avsforum.com/avs-vb/showthread.php?t=855716

So far it has not re-occurred.
post #28 of 73
I have experienced one glitch so far. I have only had the player for a few days and am on fw 1.2. When I was watching a SD DVD and hit menu to get to the DVD menu, the analog audio was muted. I tried opening and closing the tray, which didn't help. Rebooting restored the audio. I will upgrade the firmware soon which I am guessing will resolve the problem. Planet Earth should be arriving in the mail today, so I'm looking forward to that.
post #29 of 73
A question. Have any of you guys downloaded firmware updates from that Canadian Toshiba site? this one
http://209.167.114.38/support/ceg/downloads/#
post #30 of 73
I purchased my HD a2 from Value Electronics during the $100 off sale and their promotion of 3 free hd dvds, hdmi cable and tee shirt.

In terms of problems, I have had my unit lock up a couple of times, both on SD DVD's forcing me to unplug the unit and then plug it back in. Another time, when I turned it on it produced a green like snow. Again I unplugged it and turned it back on and it then worked fine. I am viewing thru hdmi to dvi-d cable to my NEC HT 1000.

I have not attempted to update in that when I play sd dvd's the player indicates that it is sending the signal out at 1080i so I assume that I have the 1.6 update.

I am a little disappointed that it will not stretch 4 3 discs but the image is definitely better when playing HD DVD's. I would highly recommend this player and investing in the HD DVD format. If you are a music fan, The Eagles Farewell Tour I will blow you away. Great image and beautiful sound and very active surrounds.

I wish I could say I am as happy with Value Electronics. On the one hand they were very responsive in getting the player to me and it was double boxed and to me in perfect shape. Included in the box were all what the promised but two of the HD DVD discs. There was no explanation on the invoice or anywhere in the box as to the were abouts of the missing discs. I called and was told by, I think the owner, that he did not keep up with the dvd inventory and he was sure that my other discs would be along shortly. I did get an e-mail from them saying I was short two discs. I was assured by person I talked to that it would be along in a few days. It has been over a week now and nothing. I e-mailed them Saturday morning and as of this moment have gotten no response. Their service or lack thereof does not induce me to do business with them in the future.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: HD DVD Players
AVS › AVS Forum › Blu-ray & HD DVD › HD DVD Players › Toshiba HD-A2 Problems Survey