or Connect
AVS › AVS Forum › Blu-ray & HD DVD › Blu-ray Software › Blu-ray disc rot on a few titles!
New Posts  All Forums:Forum Nav:

Blu-ray disc rot on a few titles!  

post #1 of 397
Thread Starter 
Has anyone else been hit by blu-ray disc rot? I've just discovered it in my The Prestige blu-ray disc.

I've only watched it once, on the PS3, about 1.5 months ago. Couple of days ago, I tried it again and realised that the PS3 wasn't able to read it. The surface of the disc looks like it has lots of blotches or specks, but when you run your fingers over the surface, its smooth, which means that the problem is happending below the top surface layer. Here are some photos





post #2 of 397
I haven't seen anything like this but...

You should be able to get a replacement for that disc, I think if you go to the studios site there is a support area then you will probably need to enter the code from the inner band.

I would be suprised if they wanted you to pay anything for it. Especially given the circumstances.
post #3 of 397
Ick. I lost more than a few laser discs to rot. Those pictures don't make me happy.
post #4 of 397
Ouch, hope this is an isolated issue. I lost too may Laserdiscs to rot for my liking.

I think you should not have a problem getting the disc replaced either by the retailer or the Studio. I'm sure Disney would want the disc so their can isolate what happened here. If this a production related they definitely want to know about it.
post #5 of 397
Lol, My Prestige BD is exacly the same. The same spots and everything, but I can still watch the movie. I thought it was part of the design.
post #6 of 397
Thread Starter 
Quote:
Originally Posted by MaxDam77 View Post

Lol, My Prestige BD is exacly the same. The same spots and everything, but I can still watch the movie. I thought it was part of the design.

Huh? your BD player was able to read it? Are you using a Playstation3 or some other player? Hmm, I'll try it again.
post #7 of 397
"Its like sprinkles!"
Eddie Murphy
-Delirious
post #8 of 397
The PS3, The thing is that the movie "Froze" at 20 minutes so I took the disc out to check it and all these spots where there, the same ones like on your pictures. I cleaned it, but it didn't appear it needed to and it read fine and I could watch the whole movie just fine. I'll try to watch it again this afternoon to see if it is still readable. I'll let you know.
Last time I've watched it i had the 1.70 firmware though
post #9 of 397
Are these the final Blu ray specs?
post #10 of 397
Going to have to check my copy of the Prestige when I get home tonight. Have not watched it in like 2 months.
post #11 of 397
Oh brother, something else to look out for with these new formats. These BD and HD DVD disc problems have me more anxious than Woody Allen.
post #12 of 397
bought mine on release date. it looks perfect still. All products have some quality control issues. I doubt this will be wide spread. It should be an easy reutrn IMO.
post #13 of 397
Hey guys,

The exact same thing happened to my BD copy of the "Prestige" (I also uses PS3 as my BD player). I have never seen this before and thought it was an isolated incident...interesting to hear that others also suffer the same issue. Seems like there were some manufacturing issue with the "Prestige" BD.

Tony
post #14 of 397
Thread Starter 
I just tried it again, no go, it just spins and then nothing.....the PS3 doesn't even acknowledge that a disc is present

I've filed a technical support email at the BVHEBluray.com, hopfully they'll respond soon. Will let you guys know what they say.
post #15 of 397
hmm, how can this happen?
i was going to buy "the prestige" on germans release day, maybe i think twice about it :\\
post #16 of 397
You probably have too much mold in your house.
I'll check to see my copy of the prestige to see if it has the same thing. I've watched it 3 times total but always, always leave it in its case.
post #17 of 397
do u guys that are having problems leave the disc out of the case?? I've had mine since it was released and there's not a speck of dust on it.
post #18 of 397
Quote:
Originally Posted by dalamchops View Post

do u guys that are having problems leave the disc out of the case?? I've had mine since it was released and there's not a speck of dust on it.

There isn't any dust on that one either.
post #19 of 397
I had a couple of DVD that had ROT, my worst one was Road Trip, all player would hang at the 2nd layer and the disc was prestine clean...
post #20 of 397
My X-men 2 dvd was worse than those photos, but only on half, other side was perfect. weird stuff.

Ill check my prestige tonight.
post #21 of 397
I guess there is another benefit to living in a dry desert climate. I never saw anything like this on a DVD, HD DVD or Blu-ray disc. That's pretty bizarre.
post #22 of 397
Ok I just got home and it took me like 4 tries to finally be able to watch it but it freezes.
Here is the pic of my Prestige BD:

post #23 of 397
Just checked mine - bought in Marched, played twice and it's A'OK.
post #24 of 397
Quote:
Originally Posted by MaxDam77 View Post

Ok I just got home and it took me like 4 tries to finally be able to watch it but it freezes.
Here is the pic of my Prestige BD:



This looks like the issue with the hardcoat application as it is spread thruout the disk. Maybe the hardcoat process got contaminated with something during a particular batch.
post #25 of 397
Uh oh. I will try to remember to check mine when I get home. I've watched it twice, once at release and then again about a month ago, no problems.
post #26 of 397
That is freaky. I had about 50 LDs and 2,000 DVDs and I never saw anything like this before. Guess I've been lucky but now I want to go home and check my Prestige BD!
post #27 of 397
I had to check my copy immediately; I've had some bad experiences with rot in the past.
Gad-zooks! One half of the disc was covered with tiny dots, while the other half was pristine. I wiped the disc on my shirt real quick-like, and most of the dots disappeared. Turned out it was simply dust, gathered on that half of the disc which had protruded out of the PS3 for a day or so. Whew!
post #28 of 397
Boil it
post #29 of 397
my prestige is perfect but now i feel like checking all my bd
post #30 of 397
Quote:
Originally Posted by Jason One View Post

That really is interesting. I agree with plasmabuyer about it being a coating problem, since you can see it over the hub and everything.

Venom5 and MaxDam77, do you know if your discs were like this when you first got them, or did the spots develop later?

Also, has anyone else had this happen with a title other than The Prestige?

I bought the Prestige in April. I've watched it 2 or 3 times, then, two weeks ago I watched it again and it froze around 20 mins of the movie. I ejected the disk and i saw thoses weird spots. I cannot recall if it was there before or when I first got it.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Blu-ray Software
This thread is locked  
AVS › AVS Forum › Blu-ray & HD DVD › Blu-ray Software › Blu-ray disc rot on a few titles!