or Connect
AVS › AVS Forum › Blu-ray & HD DVD › HD DVD Players › Component outs of HD-A2 not working. Please help fix!
New Posts  All Forums:Forum Nav:

Component outs of HD-A2 not working. Please help fix!

post #1 of 4
Thread Starter 
Here's the scenario. I got my HD-A2 recently. Upgraded the firmware to 1.6. Used component video and HDMI audio to play movies. The HDMI went to my receiver, but my TV has no HDMI input, so I used component. Everything was fine. Then I tried to get a HDMI to compenent converter. I could play the movies, but the converter is a little wacky right now. So I want to go back to component video out. Problem is, I can't get a picture to come out. Even when I unplug the HDMI cable and plug the components directly into the TV I get nothing. Yet when I plug the HDMI back in, it will send the picture via HDMI over my converter. It's like it's forcing all video to go over HDMI, and unless that's hooked up I get nothing. Any suggestions on how to fix that? Thank you.
post #2 of 4
perhaps your converter has damaged the component inputs on your set. perhaps not. only way to know is connect to another television directly to hdmi, and directly to component. i wouldn't test with the converter. btw, what exactly is the converter and where did you get it?
post #3 of 4
Are you trying to play SD or HD DVDs? If SD, try unplugging the HDMI cable while playing to make your components active (SD upconvert not allowed over component; while the HDMI is plugged in, it disables the 1080i display of SD DVDs over the component outputs)
post #4 of 4
Thread Starter 
The converter is the VisionFC4 model I bought off ebay. Not sure why that would damage the component outputs. And I'm trying to play HD-DVDs. Although I can try and play a SD DVD to see it that forces anything.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: HD DVD Players
AVS › AVS Forum › Blu-ray & HD DVD › HD DVD Players › Component outs of HD-A2 not working. Please help fix!