or Connect
AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › The OFFICIAL Jamo Subwoofer Owners Thread
New Posts  All Forums:Forum Nav:

The OFFICIAL Jamo Subwoofer Owners Thread - Page 4

post #91 of 102
D6 is a great sub. For a ported sub, I find it fairly musical. It hits hard and will not leaving you wanting more from your action movies.

If it is blowing the fuse with the signal hits then there is more than a little water going on. Take a look at the board and see if you can detect any other damage.


Jamo sells parts. I think you could replace the amp for fairly cheap. Vanns also is selling these boys for 399 right now as they are closing out the inventory.

Good luck.
post #92 of 102
Hey Guys,

Anyone have any opinion on the Jamo D 4SUB 8" dual woofer 400W powered subwoofer? Seems there are some good prices on these right now? Probably clearance I would guess since this thing has been around for a while (since 2003?) I like the dark apple finish to go along with my E680s. Have not been able to find much at all in terms on reviews on this thing. Any thoughts would be appreciated.

http://www.jamo.com/na-en/products/d-4sub-description/

Maciej
post #93 of 102
So am keen to get my hands on the Jamo 650SUB like the looks in black and get get it for a reasonable price but now the guy in the shop is telling me I should get the Klipsch SW-112 instead - they are the same price?

also figured that they are made by the same company now so what's the difference really...

Any ideas
post #94 of 102
Quote:
Originally Posted by Celso View Post

So am keen to get my hands on the Jamo 650SUB like the looks in black and get get it for a reasonable price but now the guy in the shop is telling me I should get the Klipsch SW-112 instead - they are the same price?

also figured that they are made by the same company now so what's the difference really...

Any ideas


i heard from sub650.its deep and powerful.great for music and movies.
i didn't get a chance to hear from sw-112,so can't comment.
650 is a great sub.
post #95 of 102
got myself the Klipsch SW-112...

Guess it's got more punch than the Jamo - it's a hell of a step for me anyway

Shaking my appartment, no complaining neighbors yet but eyeing up a subdude or gramma just in case

saved transformers 3 for tmr just for my new sub

giving it a good workout tmr
post #96 of 102
Just got my sub 300 today. There are a few of concerns:

1. The volume turns 180º, though volume never turns all the way down. It's still overpowering my front Bose 301s at it's lowest setting. (this is true when using the LFE input or speaker level input)

2. Ground loop buzz when amp is shut off before sub.

3. Buzzing if anything is plugged into the 'speaker level' terminals.

Is any of this normal for Jamo?
post #97 of 102
I am amazed there is a thread for Jamo subs! I recently acquired a Jamo MPA-100 sub amp, which I have connected to an 8 inch Jamo sub speaker. I have been trying to get an answer on the thread for my Pioneer Elite SC-55 receiver why I can't seem to get any sound from my sub speaker. I have an RCA Y from the pre-out to a double RCA cable to the right and left sub amp inputs. I have a two conductor wire speaker cable to the speaker and the sub amp set to Bridge. I wired the Jamo speaker with the two voice coils in series. I have my receiver sub output LFE at 0 dB. I am not sure how to check it, but I don't think the sub is putting out any sound, and the receiver MCACC sound check does not seem to detect a sub.
post #98 of 102
I too didn't know a Jamo sub thread existed until this evening.
I just bought a Jamo SUB 650 and I couldn't be more pleased. It's my first sub so I can't compare it to anything but it does sound very nice in my system and I really don't know how I enjoyed anything before I got it. I'm still messing with getting it set up right but so far it's a joy to listen to.

Al
post #99 of 102
Quote:
Originally Posted by Dobes49 View Post

I am amazed there is a thread for Jamo subs! I recently acquired a Jamo MPA-100 sub amp, which I have connected to an 8 inch Jamo sub speaker. I have been trying to get an answer on the thread for my Pioneer Elite SC-55 receiver why I can't seem to get any sound from my sub speaker. I have an RCA Y from the pre-out to a double RCA cable to the right and left sub amp inputs. I have a two conductor wire speaker cable to the speaker and the sub amp set to Bridge. I wired the Jamo speaker with the two voice coils in series. I have my receiver sub output LFE at 0 dB. I am not sure how to check it, but I don't think the sub is putting out any sound, and the receiver MCACC sound check does not seem to detect a sub.

I found out that my voice coils are fried, apparently by the way I hooked it up. Does anyone know where I can get a manual for the Jamo MPA-100 sub amplifier?
post #100 of 102
Quote:
Originally Posted by Dobes49 View Post

I found out that my voice coils are fried, apparently by the way I hooked it up. Does anyone know where I can get a manual for the Jamo MPA-100 sub amplifier?

The MPA-100 looks like the previous version of the MPA-101. Go to the Jamo site and download the MPA-101 manual (because they don't list the MPA-100) and, provided it's the same amp, should help you.

Al
post #101 of 102
Hi All,

I'm from Australia , and just bought the Jamo Sub 660, which is paired with Jamo S606's.
I have to say that it is a bloody powerful sub also , at one point I thought the windows were going to shake out of their frames, the wife was absolutely outraged!!!!!
I have to say I'm not quite used to the auto on feature where the sub only comes on when bass frequencies go to it. I have a Yamaha receiver and when i set it to music mode "Hall in Venice" the sub wont come on as that feature mimics the acoustics of the real Venice Theater and thus doesn't send the required bass frequencies across.
But otherwise in all the normal music modes the sub is awesome!!!!
post #102 of 102
hahaha

I'm glad that women across the world are consistently unhappy about our toys tongue.gifbiggrin.gif
New Posts  All Forums:Forum Nav:
  Return Home
AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › The OFFICIAL Jamo Subwoofer Owners Thread