or Connect
AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › Official Epik Subwoofer Thread
New Posts  All Forums:Forum Nav:

Official Epik Subwoofer Thread - Page 612

post #18331 of 20356
Quote:
Originally Posted by duyhung View Post

I'm in the market for or either Empire or a dual Legend, my budget is around $1000, my living room is about 20 by 25 with a vault ceiling and is a open plain so the dinning room and the kitchen is open to the living room, and there's cat walk run a cross the living, which one should I buy
I'd ask yourself 2 questions:

1.) Will 2 subwoofers work in my space?
2.) Would I be willing to spend more than $1000 over time?

If 2 subwoofers will work in your space and your willing to spend more than $1000 over time, I'd get a single Empire today and upgrade to dual Empires later. If you absolutely don't want to pay more than $1000 for subwoofers, I'd get the dual Legends.

I love dual subwoofers, it really fills the room more evenly than I anticipated. I love my Dual Empires.

Gear mentioned in this thread:

post #18332 of 20356
Quote:
Originally Posted by duyhung View Post

I'm in the market for or either Empire or a dual Legend, my budget is around $1000, my living room is about 20 by 25 with a vault ceiling and is a open plain so the dinning room and the kitchen is open to the living room, and there's cat walk run a cross the living, which one should I buy

Couldn't have said it better than Dreamliner.

I faced the same dilemma as you when I first went after my "decent" sub. I'm so glad I didn't get dual Legends. I got my Empire a year and a half ago. Tomorrow, my second one shows up at my door. My room is 15.5 x 26. One sub can tear down my 2900 sq ft home, I'm going for even bass response.
post #18333 of 20356
Empire.
post #18334 of 20356
Quote:
Originally Posted by duyhung View Post

I'm in the market for or either Empire or a dual Legend, my budget is around $1000, my living room is about 20 by 25 with a vault ceiling and is a open plain so the dinning room and the kitchen is open to the living room, and there's cat walk run a cross the living, which one should I buy

I totally recommend the Empire. I have four of them and they are flat to 15Hz. With any room gain at all you will probably be flat to 12-13Hz.

Chad is a great, and knowledgeable, guy to talk to. You might give him a call before ordering.
post #18335 of 20356
Also, in my experience it is completely impossible to make the Empire make bad sounds (over drive them). I can't say this about some other subs I used to own. wink.gif
post #18336 of 20356
I'm loving my dual Empires!!

These monsters make light objects slide right off my coffee table from the vibrations. Although these are my first subs, the experience has been amazing.

My only regret is not getting 4, but that is easily remedied.

My ears = Tokyo

Empires = Godzilla
post #18337 of 20356
Wish I could have afforded Duals but. as this is my first step into real HT, I went with the single Legend.
Glad to be part of this community!
post #18338 of 20356
Hello everybody,
I have a problem with my Epik Dragon SUb. I bought it in June 2009 and it worked very well untill 3 weeks ago. The powedr light went off and there is not osund from it at all. playing with the on and of switch produced no light/results. Also, I removed and visually inspected the fuses. They seem OK. I tried to contact Epik via email but they did not respond. Also, their phone has been disconnected. Anyone has an idea on how to fix it? Thanks, Peter:mad:
post #18339 of 20356
Quote:
Originally Posted by tanev View Post

Hello everybody,
I have a problem with my Epik Dragon SUb. I bought it in June 2009 and it worked very well untill 3 weeks ago. The powedr light went off and there is not osund from it at all. playing with the on and of switch produced no light/results. Also, I removed and visually inspected the fuses. They seem OK. I tried to contact Epik via email but they did not respond. Also, their phone has been disconnected. Anyone has an idea on how to fix it? Thanks, Peter:mad:

What phone number did you call?

PS I'd think your amp has crapped out, though.
Edited by lovinthehd - 6/22/12 at 12:04pm
post #18340 of 20356
You must be calling the wrong number. The number on their site is NOT disconnected. How long ago did you email? Chad will get back to you, may take a couple of days though.
post #18341 of 20356
I called the number listed under contact on their web site: (815) 337-6067.
Also, I imailed sales a week ago and have no reply.
Has anybody had similar problem?
Thanks,
Peter
post #18342 of 20356
Not sure why you reach that number as disconnected. I just called it from my cell phone and it's fine.
post #18343 of 20356
You are correct. Just used differnt phone and got through :-)
Lets see what Chad says...
Thanks,
Peter
post #18344 of 20356
Quote:
Originally Posted by tanev View Post

Hello everybody,
I have a problem with my Epik Dragon SUb. I bought it in June 2009 and it worked very well untill 3 weeks ago. The powedr light went off and there is not osund from it at all. playing with the on and of switch produced no light/results. Also, I removed and visually inspected the fuses. They seem OK. I tried to contact Epik via email but they did not respond. Also, their phone has been disconnected. Anyone has an idea on how to fix it? Thanks, Peter:mad:
try another power cord. Mine went on the Dragon.
post #18345 of 20356
hmm, I was about to order Epic legend, but just going through last 3 pages of this thread, I am having second thoughts now.

Too many amp failures, and customer service not that good.

too bad, I really wanted to buy the legend, will probably order SVS
post #18346 of 20356
Quote:
Originally Posted by mrrame View Post

hmm, I was about to order Epic legend, but just going through last 3 pages of this thread, I am having second thoughts now.
Too many amp failures, and customer service not that good.
too bad, I really wanted to buy the legend, will probably order SVS

I had the same concerns about amp failures before finally settling on the Legend in January. So far, so good, and I couldn't be happier with it. I've had no need to test their customer service, but from my reading here, it may be a little tough contacting them at times, but once you do make contact, they are very good at resolving issues. I was more than a bit surprised that when I placed my order, that the Legend was shipped and on the road the same day.

Good luck with whatever you decide.
post #18347 of 20356
Quote:
Originally Posted by mrrame View Post

hmm, I was about to order Epic legend, but just going through last 3 pages of this thread, I am having second thoughts now.
Too many amp failures, and customer service not that good.
too bad, I really wanted to buy the legend, will probably order SVS

Legend owner here that has gone through an amp failure, and all in all my experience has been positive. Yes it's hard to get hold of Chad and it takes some patience but he totally came through and get me back up and running. We live in a world of instant gratification and when we don't get it, we get angry. I'll admit you probably get quicker customer service from some of the other ID brands but bang for the buck the Legend is hard to beat. I will be ordering my second in a few weeks, just have to fund my toy account.
post #18348 of 20356
I put a lot of thought into this as well before I bought my Legend but...
I'd rather deal with a little frustration with contacting Chad for service than buy from a lot of other companies that give you the run around.
At least, once contact is made, the problem is fixed and the new amp is shipped out that day.
Some companies (not naming any in particular) will have you on the phone for an hour just to realize the problem. Then, you have to wait while they "process" the new shipment.
This can sometimes take a week or more to rectify.
I want the problem fixed NOW and, from all the posts that I've read, Chad gets it done.
post #18349 of 20356
Quote:
Originally Posted by mrrame View Post

hmm, I was about to order Epic legend, but just going through last 3 pages of this thread, I am having second thoughts now.
Too many amp failures, and customer service not that good.
too bad, I really wanted to buy the legend, will probably order SVS

FWIW I recently ordered speakers from SVS and they were not on top of the order on the first working day, plus I had to fill out more junk for them (a la Radioshack for their marketing dept) and so far as a result their customer service score is kinda low with me. I don't expect instant gratification either. I doubt I can call SVS and talk to the head guy like I've done with Epik, though I might try. So far the speakers aren't impressive after over a week of use (break-in so to speak), and even at 50% off not worth the money so likely they're going to go back unless something amazing happens in the next week or two....sure hope their subs are better than their speakers!
post #18350 of 20356
Quote:
Originally Posted by mrrame View Post

hmm, I was about to order Epic legend, but just going through last 3 pages of this thread, I am having second thoughts now.
Too many amp failures, and customer service not that good.
too bad, I really wanted to buy the legend, will probably order SVS

True, the subs do have amp failure, my first Empire had amp failure after 3mo, replaced it and has been two years now and great. Excellent customer service as well.

Ordered my second Empire just recently, got it set up, watching first movie, amp crapped out after 20min, replaced new amp and has been working flawless for a week now and is running nice and cool. My older amp runs a tad warm.

If I were to do again, I wouldn't hesitate to order Epik subs. These subs are without a doubt, awesome to say the least. Last night, was watching Terminator Salvation, toward the end, when they blow up skynet, my gain is at 1/3 on both subs, I set them to +12 for the explosion, I thought my house was coming down around me, FREAKING AWESOME!!!!!

P1030870.jpg
post #18351 of 20356
I have five Empires. Four in my man cave and one up stairs. I have had two amp failures to date, but Chad has promptly sent replacement amps (free of charge and free shipping). The second time it took about 3 weeks to get the amp because he didn't have any in stock that weren't already in subs.

Chad told me that he has had a couple bad batches of amps, but was working on rectifying the issue with his amp vendor.

I sometimes wonder how Chad might treat his Empire customers when their subs start coming out of warranty. Most especially because I was one of the first to buy the Empire, and I am sure I was the first to buy quads (all in one order). He initially charged me one price for shipping, but it ended out being much cheaper than he anticipated so he gave me like a $150 refund... all on his own. IME he is great guy and will sell us replacement amps for at or near cost (probably plus shipping) when our Empire amps start coming out of warranty.

I have spoken to him twice on the phone, and I feel is a genuinely great person. I also get the impression that he wishes there were more than 24 hours in a day. smile.gif
post #18352 of 20356
I bought the last pair of Sentinel subs on 12/22/09, and I do believe that no 12" sub still can compare. My question is, however, why does the Epik Home Page still picture the Sentinel, and only the Sentinel?
post #18353 of 20356
Just pulled the trigger on dual Empires, they are going to replace a polk 550 pro. I am going to have a hard time waiting on my babies to get here !

Yamaha RX-A3010
Emo XPA-5
Front RTI 12 Polks
Front PL TC65I Polks
Center CSIA-4 Polk
Sides TC 60i Polks
Rears Rti 6
Sub 550 Pro Polk
Sharp LC-70LE735U 70" 3D LED
Sharp BD-HP75U
Xbox Elite

smile.gif
post #18354 of 20356
Quote:
Originally Posted by counsil View Post

I have five Empires. Four in my man cave and one up stairs. I have had two amp failures to date, but Chad has promptly sent replacement amps (free of charge and free shipping). The second time it took about 3 weeks to get the amp because he didn't have any in stock that weren't already in subs.
Chad told me that he has had a couple bad batches of amps, but was working on rectifying the issue with his amp vendor.
I sometimes wonder how Chad might treat his Empire customers when their subs start coming out of warranty. Most especially because I was one of the first to buy the Empire, and I am sure I was the first to buy quads (all in one order). He initially charged me one price for shipping, but it ended out being much cheaper than he anticipated so he gave me like a $150 refund... all on his own. IME he is great guy and will sell us replacement amps for at or near cost (probably plus shipping) when our Empire amps start coming out of warranty.
I have spoken to him twice on the phone, and I feel is a genuinely great person. I also get the impression that he wishes there were more than 24 hours in a day. smile.gif

I agree with your assessment.

My Empire was dead on arrival, which left me disheartened. However, Chad's response restored my faith in the brand and my Empire has been rocking ever since. I am quite confident that Chad will provide top notch service, always.

Justin
post #18355 of 20356
Quote:
Originally Posted by JustinHEMI05 View Post

I agree with your assessment.
My Empire was dead on arrival, which left me disheartened. However, Chad's response restored my faith in the brand and my Empire has been rocking ever since. I am quite confident that Chad will provide top notch service, always.
Justin
Glad you had you prolem fixed. Unfortunately, I can not say the same. My Dragon has beed dead for 5 -6 weeks.Called and e-mailed Epik several times. Chad responded once leaving voice mail. It has been 2 weeks since no response. BTW, my fuses are fine and I have power through power cord. Amp I think is dead. Otherwise, sub was great when it worked. I don't know when I my get it fixed.
post #18356 of 20356
Just keep calling, afternoon worked best for me. (2-4PM EST)
post #18357 of 20356
Quote:
Originally Posted by firemanast View Post

Just pulled the trigger on dual Empires, they are going to replace a polk 550 pro. I am going to have a hard time waiting on my babies to get here !
Yamaha RX-A3010
Emo XPA-5
Front RTI 12 Polks
Front PL TC65I Polks
Center CSIA-4 Polk
Sides TC 60i Polks
Rears Rti 6
Sub 550 Pro Polk
Sharp LC-70LE735U 70" 3D LED
Sharp BD-HP75U
Xbox Elite
smile.gif
Empires made it home yesterday, got everything dialed in today. I must say they are by far the best addition to my system.
They sound great just watched Cloverfield and they ROCK !
post #18358 of 20356
Wait til you add a sub eq to the Empires, you'll be really impressed!
post #18359 of 20356
I just added an Anthem MRX and my Empire is now incredibly well integrated with my mains. Before I could hear mains vs sub, now I can't really tell where one starts and the other begins. I can't really tell where the sub is located in the room anymore. Here's a screenshot of what Anthem room correction has done (ARC), red is the measured response before correction, green is after:

202

+1 to sub EQ
post #18360 of 20356
I also have a 37 month old EPIK Dragon that suddenly stopped working. After checking the power cord and fuse, which turned out to be good, I thought that the amp was dead. After some thought, I tried cycling the "ON/OFF" rocker switch and that brought it back to life. It MAY be that being left in the "ON" position for most of it's three years allowed some build-up between the contacts and cycling the switch broke through the crud.

Good Luck,

Bill C
New Posts  All Forums:Forum Nav:
  Return Home

Gear mentioned in this thread:

AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › Official Epik Subwoofer Thread