or Connect
AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › Official Epik Subwoofer Thread
New Posts  All Forums:Forum Nav:

Official Epik Subwoofer Thread - Page 614

post #18391 of 20352
Anyone who thinks that just because a product is NEW and will not fail is living under a rock! I have an Epik Knight that has performed flawlessly for 5 yrs and has been pushed hard in our HT. Now this past spring I upgraded our HT projector to get 3D, meaning I had to upgrade my AV Receiver. I purchased an Onkyo 809, in March and it failed after 5 minutes of use, HDMI board went out, Amazon sent another one to replace, hooked it up and on initial start up the amp popped with a nice flash and all, needless to say I did not go with another Onkyo. Don't take me wrong, I have an Onkyo 805 that has worked perfectly for 5 yrs. Over the years I have had many product fail on initial start up or within a week or month. As long as each company stands behind their warranty no one should have issues. Moral of the story!! DON'T sweat the small stuff, life is to short!! Regards Tony

Gear mentioned in this thread:

post #18392 of 20352
Quote:
Originally Posted by LowTech1 View Post

Let me get this straight. There are quite of few guys that have had amp failures. There shouldn't be barely any! If I got a new sub and the amp failed after 20 mins,I'd be screaming! So you guys are ok with spending $800 + shipping and then soon after the amp takes a dump. rolleyes.gif Just because someone rectify's the faulty amp doesn't make it right....


To be honest with you, if a company puts out a failing product and drags their heels on getting something done, or worse yet, does nothing at all, then you have a problem, then you can criticize the company and the product. If I was walking along, tripped and fell right into you and knocked you down and said, "A-hole, shouldn't have been in my way", then I'm the a-hole. If I help you up and apologized sincerely, I've done the right thing.


My first Empire has been with me for almost two years, second amp since the second month. It runs just warm. My second Empire is just over a month old, second amp, after 20min. It runs nice and cool. So Chad is working hard on this, as someone mentioned before, this costs the company bucks, I'm sure dudes not the richest guy in the world so yeah, he's getting things done and done right, that's evident from my new amp being as cool as it is.

Congratulations on your choice for Empires, my basement is pretty much like yours, L shaped only 26 x 15 x 15 and I use the one section of it. My subs have more than thump your chest, they knocked down a no cell phone sign from the back of the room, of course, I was experimenting with the power, that was 1/2 volume of gain btw. Have fun and be careful smile.gif
post #18393 of 20352
Quote:
Originally Posted by Geoff4RFC View Post

To be honest with you, if a company puts out a failing product and drags their heels on getting something done, or worse yet, does nothing at all, then you have a problem, then you can criticize the company and the product. If I was walking along, tripped and fell right into you and knocked you down and said, "A-hole, shouldn't have been in my way", then I'm the a-hole. If I help you up and apologized sincerely, I've done the right thing.
My first Empire has been with me for almost two years, second amp since the second month. It runs just warm. My second Empire is just over a month old, second amp, after 20min. It runs nice and cool. So Chad is working hard on this, as someone mentioned before, this costs the company bucks, I'm sure dudes not the richest guy in the world so yeah, he's getting things done and done right, that's evident from my new amp being as cool as it is.
Congratulations on your choice for Empires, my basement is pretty much like yours, L shaped only 26 x 15 x 15 and I use the one section of it. My subs have more than thump your chest, they knocked down a no cell phone sign from the back of the room, of course, I was experimenting with the power, that was 1/2 volume of gain btw. Have fun and be careful smile.gif
Amen Brother I love my Empires !
post #18394 of 20352
I purchased my Epik Legend 1 year ago and I have had zero problems with it. When I first purchased my Legend I had some questions about it and had trouble contacting the folks at Epik to answer my questions. I was vocal about it here saying that I was concerned that I had a product from a company that had some known amp issues, yet I couldn't ever get them to answer the phone or reply to my e-mails.

A year later, my Legend is still the best purchase I have ever bought for my HT system. As soon as we move into a bigger house and I get a dedicated theater room (instead of our living room right now) I'll be buying another Legend so I can run duals. I am still floored by what these subs can do.

I am still crossing my fingers in hope that I never have an amp problem. But Chad DOES take care of his customers. Just read through this thread if you don't belive it. While I had troubles contacting him in the past, I was still able to get a hold of him and he did answer my questions. It might not have been instant, but he did get back with me.

I guess what I am staying is that I would never hesitate to purchase another sub from the folks at Epik. In fact, I don't even read up on other subs anymore in this forum. I am so just happy with my Legend I just don't ever want anything other than it.
post #18395 of 20352
Just for the record,I ordered a Legend and should have it today. I talked to Chad before I bought it,not to ask him about amp or sub,because I was trying to order it online and kept getting an error message Chad is a good guy,and would take care of anyone that purchases from him. He also said the amp thing is way overblown. I can believe that,there are people that probably don't even own one that are stirring crap up because they heard it from a buddy or something.
post #18396 of 20352
Quote:
Originally Posted by LowTech1 View Post

... I can believe that,there are people that probably don't even own one that are stirring crap up because they heard it from a buddy or something.

Um, there is zero evidence to support that theory. I think every single effected poster here, and there have been a good number of them, have handled the situation very well. While Chad has eventually come through in each case, there has been plenty of mentions of initial response issues. Even in those cases where it took a week or two to finally connect, folks have later praised Chad for the eventual resolution. The point is, I have noticed nobody recklessly stirring up crap as you are trying to suggest.
post #18397 of 20352
+1

No one is stirring up crap. All of the posts thus far have been honest, helpful, and fruitful.
post #18398 of 20352
Quote:
Originally Posted by counsil View Post

+1
No one is stirring up crap. All of the posts thus far have been honest, helpful, and fruitful.

As a representative of Crap Stirrers Local #86, I would like to register a formal complaint. This situation must be remedied immediately, or we will be forced to go on strike!


...What?!..umm...Yes, there's a down side to that! How dare you! mad.gif


biggrin.gif
post #18399 of 20352
Sooooooooooo i just got my second Empire today, and im vary happy that i got my second Empire, Man i gotta tell you its much better now, there is a great amount of bass, and it has much more presence to it also. When listening to music/movies, the bass is much smother. and harder to localize.
post #18400 of 20352
I'm selling my Epik Legend for $450. It's in perfect condition and has about 50 hours of use on it. Bought it back in January 2012. I'm selling it because I can't use it to its full potential since I live with my parents. I also need some $ for school. Call or Text Mike at 716-880-0149. Original box, and everything. I'm located in Buffalo New York.
post #18401 of 20352
I don't have a failed amp but another issue with my legend, the sales process is great and yes they do provide customer service I've recived 2 replies to 12 emails 6 VM's! Then...
I was sent an amp I have no amp issue but that was the solution they felt was the answer because it is so common, no one talked to me about anything elseI just got an email stating an amp is shipped so for them to say its over blown is BS because if it was a minor issue we wouldn't be discussing it regularly on this forum! I have attempted to contact them now it's been 7 days no respond to my email.
Edited by deepat04 - 6/7/13 at 6:48am
post #18402 of 20352
Quote:
Originally Posted by deepat04 View Post

I don't have a failed amp but another issue with my legend, the sales process is great and yes they do provide customer service I've recived 2 replies to 12 emails 6 VM's! Then...
I was sent an amp I have a rattle not an amp issue but that was the solution they felt was the answer because it is so common, no one talked to me about the rattle I just got an email stating an amp is shipped so for them to say its over blown is BS because if it was a minor issue we wouldn't be discussing it regularly on this forum! I have attempted to contact them now it's been 7 days no respond to my email.

If I were Chad and I received an email written at all like that post, I don't think I'd know how to reply either.
post #18403 of 20352
Quote:
Originally Posted by deepat04 View Post

I don't have a failed amp but another issue with my legend, the sales process is great and yes they do provide customer service I've recived 2 replies to 12 emails 6 VM's! Then...
I was sent an amp I have a rattle not an amp issue but that was the solution they felt was the answer because it is so common, no one talked to me about the rattle I just got an email stating an amp is shipped so for them to say its over blown is BS because if it was a minor issue we wouldn't be discussing it regularly on this forum! I have attempted to contact them now it's been 7 days no respond to my email.

Sounds like you have problems in communication more than anything...
post #18404 of 20352
+1
post #18405 of 20352
I've had my legend and empire for a little over a week now. It's sounding better as I make crossover setting changes to my receiver.
When I first set them up I wasn't sure about the sound. Past sub velodyne and sunfire .
post #18406 of 20352
You like the Epik subs better than the velodyne and sunfire?
post #18407 of 20352
Quote:
Originally Posted by LowTech1 View Post

You like the Epik subs better than the velodyne and sunfire?

I know this was directed towards another user, but I can answer on the Sunfire question as I just upgraded from a 12'ish year old Sunfire True Subwoofer MK2 to a preowned Epik Empire. I connected up the Empire and ran Audyssey and I while it had a fuller / cleaner sound, it did not "blow me away". I remember when I purchased the Sunfire it was because it just seemed to have so much more impact then any of the other subs I listed to at the time.

After messing around for a few weeks I think I've come to the conclusion that the Empire get's down lower (and higher if wanted) and has yet to strain under pressure. The Sunfire it not nearly as clean sounding, but it does seem to have some punch that the Empire doesn't. Hard to explain, they are different but I like them both. I have since brought my Sunfire back and put it in a second corner of the room. I have lowered the volume and crossover the Sunfire so it doesn't put out as much, but I feel like I get the best of both worlds.

One funny note is because of the very high excursion drivers on the Sunfire it does shake a ton. Since it is now near my listening position I can feel the shake on my couch, almost like a transducer. I know get the sound of the bass from the Epik and the feeling of it from the close location Sunfire. I'm sure many people would frown upon my setup but personally I am loving it.
post #18408 of 20352
Its funny,I was looking into buying that exact sunfire used for $450. Is it worth it? I would think the Empire would spank that sunfire.. The legend I have is a different sound for sure being sealed. I've noticed it blends with my fronts better especially for music..
post #18409 of 20352
Quote:
Originally Posted by LowTech1 View Post

Its funny,I was looking into buying that exact sunfire used for $450. Is it worth it? I would think the Empire would spank that sunfire.. The legend I have is a different sound for sure being sealed. I've noticed it blends with my fronts better especially for music..

Well, I'm sure the experts here would say it's not worth it as there are more subwoofers that can player deeper, louder, etc at the same price. That being said, I like the sound of my Sunfire to keep it. Originally I was going to sell it to help pay for the Empire; it's amazing the value these small subwoofers hold after all of these year. I have no doubt that the Epik can put out so much more, but I don't see it being a night a day difference if using Audyssey. Perhaps I need to research Audyssey more, but it seems to want to set a volume threshold so all speakers are putting out the correct volume at and up to reference level. I did save my previous configuration so perhaps I will reload my original Sunfire Audyssey settings and use it with the Epik to see how much different it sounds with those settings...
post #18410 of 20352
Wow you explained it perfectly. the sunfire sub has a great sound but it just works too hard to get that big speaker sound . both epiks play louder than my velodyne and sunfire sub. I purchased my sunfire jr's on ebay for $400. I had them for a little over a year . 2 big movie nights later the drivers were damaged . So i sent out both drivers in Feb. waited for 5 months after 310 more dollars........1 driver was repaired but didnt sound right. the other driver was paper weight. so epik is my new sub. it plays a lot louder than my velodyne and sunfire. think thats the night & day..but the bass is not as punchy or fast..as the sunfire..but because of the reliabilty of the sunfire i think i made i good decision to buy a new proven sub,,,, cost and performance.
post #18411 of 20352
What are you guys running? Legends or Empires?
post #18412 of 20352
Quote:
Originally Posted by LowTech1 View Post

What are you guys running? Legends or Empires?

I am running an Epik Empire with my Sunfire MK2.

Here's a picture of the Sunfire sitting ontop of the Empire. This worked great for about 10 minutes until the Sunfire, which is known to "dance" on non carpeted floors, fell off mid movie putting a nice gash in the wall. It has since been moved to a different corner of the room...

Edited by theanimala - 8/2/12 at 8:25am
post #18413 of 20352
I wonder if I should have gotten and Empire. But I didn't want to spend close to 1k and its a lot bigger. But I wish I could hear one to know how big the difference is..
post #18414 of 20352
Quote:
Originally Posted by theanimala View Post

I am running an Epik Empire with my Sunfire MK2.
Here's a picture of the Sunfire sitting ontop of the Empire. This worked great for about 10 minutes until the Sunfire, which is known to "dance" on non carpeted floors, fell off mid movie putting a nice gash in the wall. It has since been moved to a different corner of the room...

Why two RCA's on the Empire? Is one of those going to the Sunfire? I'm not at home so I don't remember what that one jack is labeled below the LFE input.
post #18415 of 20352
Quote:
Originally Posted by LowTech1 View Post

I wonder if I should have gotten and Empire. But I didn't want to spend close to 1k and its a lot bigger. But I wish I could hear one to know how big the difference is..

I never heard the Legend, but I knew if I was going to upgrade from the Sunfire I wanted it to be a very noticeble upgrade and I assumed the Empire would be. I too did not want to spend close to 1K so I bought the Empire used for nearly half the price. Over the past year I have had some great luck in picking up stereo equipment used or last years model at a substantial savings.
Quote:
Originally Posted by globalgreg View Post

Why two RCA's on the Empire? Is one of those going to the Sunfire? I'm not at home so I don't remember what that one jack is labeled below the LFE input.

The Empire has a dual (stereo) LFE input. Actually the Sunfire does as well. I remember reading quite a bit about people arguing if using both inputs made any difference and the general word back was "no". But since I had the splitter from my old sunfire I decided to user it anyway.
post #18416 of 20352
Dual Empires here and I have not heard the Legends.
post #18417 of 20352
Quote:
Originally Posted by globalgreg View Post

Why two RCA's on the Empire? Is one of those going to the Sunfire? I'm not at home so I don't remember what that one jack is labeled below the LFE input.

One input is for use of the sub's internal crossover and the other (LFE) is for your source/AVR to provide crossover.
post #18418 of 20352
Quote:
Originally Posted by lovinthehd View Post

One input is for use of the sub's internal crossover and the other (LFE) is for your source/AVR to provide crossover.

Crap, then what I am doing with both of them hooked up? I wonder if I have messed up the output. If I change to just the top RCA do I need to rerun Audyssey?
post #18419 of 20352
I have no idea which one is the top one on a Legend, but usually the LFE channel is preferred generally for HT and is white, at least on my Empire and some other subs I've got. Why not just rerun Audyssey and find out and report back? Which Audyssey version do you have?
post #18420 of 20352
I'm running 1 empire and 1 legend . Correct they have 2 inputs one for (LFE) and other for internal sub crossover. Before I left the warehouse of epik I asked chad about the RCA inputs and he told me not to use a sub splitter cable it's not an left right input . He said some people use 2 different sources to 1 sub . 2.1 system that hooks to the internal crossover input. And they use the LFE input for a avr receiver.
New Posts  All Forums:Forum Nav:
  Return Home

Gear mentioned in this thread:

AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › Official Epik Subwoofer Thread