or Connect
AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › Official Epik Subwoofer Thread
New Posts  All Forums:Forum Nav:

Official Epik Subwoofer Thread - Page 661

post #19801 of 20352
Anyone looking to unload a pair of empires or legends? I'm in Wisconsin..

Gear mentioned in this thread:

post #19802 of 20352
I have a pair of Empires but I'm in Knoxville TN......can't ship
post #19803 of 20352
Quote:
Originally Posted by RocShemp View Post

A friend tested the speakers for me and they seemed fine. My only concern is that the Legends are at 3.5 ohms so I chose to run one EPX4000 in stereo mode rather than two such amps in bridge mode.

3.5 ohms ran in stereo should be fine.
post #19804 of 20352
Quote:
Originally Posted by daveds50 View Post

3.5 ohms ran in stereo should be fine.

Thanks. Although I do have one other question. What is the amp consumption is of the EPX4000? The manual only mentions that its consumption is 4500 W. But wouldn't that mean it that it needs 37.5 A? Isn't that ridiculously high? And it's really weird since the amp only comes with an IEC power cord (albeit a very thick one). Wouldn't such a connection, at most, draw 15 A?
post #19805 of 20352
Quote:
Originally Posted by RocShemp View Post

Thanks. Although I do have one other question. What is the amp consumption is of the EPX4000? The manual only mentions that its consumption is 4500 W. But wouldn't that mean it that it needs 37.5 A? Isn't that ridiculously high? And it's really weird since the amp only comes with an IEC power cord (albeit a very thick one). Wouldn't such a connection, at most, draw 15 A?

good question ! but i dont know.

it may draw 37 amps at peak... but remember, that the current draw is not constant.
only if you played a test disc and played it at clipping will you ever see that situation... i hope you are not planning on trying that... only then will the power cord, cooling, etc, etc become an issue.
but playing a movie or music, your average current draw wont be anywhere near that.
post #19806 of 20352
Quote:
Originally Posted by daveds50 View Post

good question ! but i dont know.

it may draw 37 amps at peak... but remember, that the current draw is not constant.
only if you played a test disc and played it at clipping will you ever see that situation... i hope you are not planning on trying that... only then will the power cord, cooling, etc, etc become an issue.
but playing a movie or music, your average current draw wont be anywhere near that.

No, I would never go that loud. Heck, I don't even listen to movies at reference. I usually listen at -20dBFS and very rarely have to crank it passed -10dBFS (only with a movie that's recorded excessively low). But, to be safe, should set up two 40 A connections (one for each EPX4000 that I own) plus a separate 15 A connection for my receiver (it draws 12.5 A)? Or am I safe with three separate 20 A connections?

Thank you for your responses so far.
post #19807 of 20352
I just got three 10 inch Kicker CVR's and I put them on an 800 watt Lanzar amp and they fried it. I believe that they are 400 watts rms. What size amp should I get?
post #19808 of 20352
Quote:
Originally Posted by leorich94 View Post

I just got three 10 inch Kicker CVR's and I put them on an 800 watt Lanzar amp and they fried it. I believe that they are 400 watts rms. What size amp should I get?

You posted this in the Epik subwoofer forum.
post #19809 of 20352
Quote:
Originally Posted by leorich94 View Post

I just got three 10 inch Kicker CVR's and I put them on an 800 watt Lanzar amp and they fried it. I believe that they are 400 watts rms. What size amp should I get?
Try a car audio forum. When you do ask about correct impedance loads.
post #19810 of 20352
Just replaced the amp this morning in my Conquest. Based on the experiences so well documented in this thread, I guess is was only a matter of time for me. Suppose I could muster a small golf clap for Epik, since the BASH 500W amp so widely available is compatible to the point of even having identical screw placements with the original amp. Just broke in the new amp by playing WOTW. Can't stop grinning.
post #19811 of 20352
chad, is that 18" ready yet.rolleyes.gif
post #19812 of 20352
Quote:
Originally Posted by airgas1998 View Post

chad, is that 18" ready yet.rolleyes.gif

My Phoenix is for sale!! PM for details!
post #19813 of 20352
Quote:
Originally Posted by CFOPRO View Post

Just replaced the amp this morning in my Conquest. Based on the experiences so well documented in this thread, I guess is was only a matter of time for me. Suppose I could muster a small golf clap for Epik, since the BASH 500W amp so widely available is compatible to the point of even having identical screw placements with the original amp. Just broke in the new amp by playing WOTW. Can't stop grinning.

What amp was that? I haven't been following this thread in quite awhile. I was the first conquest owner to buy over the internet (look way back on the first few pages of this thread as I posted pics and what not of the conquest). My amp went bad just after the 3 year mark (well over a year ago now). I tried to get a replacement on multiple occasions but Chad is always busy and never calls or emails me back. Where is this 500 watt amp? I'd love to get my sub out of the garage and back into my living room. I bought a $200 JBL sub a few months back to fill in until I can figure out what I'm going to do with my conquest and it does pretty good considering how much smaller/cheaper it was.
post #19814 of 20352
Quote:
Originally Posted by mwolfe38 View Post

What amp was that? I haven't been following this thread in quite awhile. I was the first conquest owner to buy over the internet (look way back on the first few pages of this thread as I posted pics and what not of the conquest). My amp went bad just after the 3 year mark (well over a year ago now). I tried to get a replacement on multiple occasions but Chad is always busy and never calls or emails me back. Where is this 500 watt amp? I'd love to get my sub out of the garage and back into my living room. I bought a $200 JBL sub a few months back to fill in until I can figure out what I'm going to do with my conquest and it does pretty good considering how much smaller/cheaper it was.

I as well have two Conquest's. My pair of Conquest's see very little usage and I'm sure I have a ways to go till they need to be replaced. I would love to know what amp to use to replace the current amp in the Conquest so when the time arrives, I know what to get. Hell, I'll just buy them now so there ready to go.
post #19815 of 20352
I have a Legend that I am willing to unload. I am looking to get a couple more 18 in. sub. Anyone interested, send me a PM. The Legend has one of the newer amp and has be trouble free.

As to worry about amp consumption, I run to 18 in. sub and my power console has never went higher than 1000 watts at reference level. I have an avr, 2 external amps one 200 watts and the other 250 watts, tv , BDP and cable box on the console. The normal power consumption is 350-400 watts at 75 db. The system can do over 120 watts with some Blurays. So, the subs never use more than 600 watt. My room is 6800 + 3ft. IMO no need to put in special circuit unless the home has an old electrical supply and the lights go dim in the house, lol. Just one man's opinion.smile.gif You will most likely reach the subs max output before you run out of amps from a typical 15 or 20 amp electrical supply outlet.
Edited by derrickdj1 - 9/15/13 at 6:15pm
post #19816 of 20352
Parts Express sells the Bash 500W plate amp for ~$200. It really is plug-and-play for the Conquest: cabinet cutout is same size, screw pattern is identical. It's half the power, but the last 3dB of output is something I rarely needed. Best of all: Chad's help is not needed to close the deal. Link posted below.

http://www.parts-express.com/pe/showdetl.cfm?partnumber=300-752
post #19817 of 20352
Quote:
Originally Posted by CFOPRO View Post

Parts Express sells the Bash 500W plate amp for ~$200. It really is plug-and-play for the Conquest: cabinet cutout is same size, screw pattern is identical. It's half the power, but the last 3dB of output is something I rarely needed. Best of all: Chad's help is not needed to close the deal. Link posted below.

http://www.parts-express.com/pe/showdetl.cfm?partnumber=300-752

Don't have a Conquest but there's no dsp difference between the original amp from Epik and this BASH?
post #19818 of 20352
Good question - I'm not sure what signal shaping took place in the original amp. That said, it makes sound. This is a pretty substantial improvement. Will run Audyssey again next weekend, so that should sort out delay and EQ (to some degree.)
post #19819 of 20352
Quote:
Originally Posted by CFOPRO View Post

Good question - I'm not sure what signal shaping took place in the original amp. That said, it makes sound. This is a pretty substantial improvement. Will run Audyssey again next weekend, so that should sort out delay and EQ (to some degree.)

HAHA, yes: Sound > No Sound.
I want one! Will order one of these ASAP, thanks guys!
post #19820 of 20352
Best of luck with this! I think you'll enjoy getting the beast back in service.
post #19821 of 20352
Has anyone tried to troubleshoot these failing Amps to see what internal component(s) have failed?
post #19822 of 20352
Quote:
Originally Posted by rpfisterer View Post

Has anyone tried to troubleshoot these failing Amps to see what internal component(s) have failed?

between the Yung, Kiega, and Bash amps that are about the same, ( there are only a few amp manufacturers... Epic does not make their own amps ) i've fixed a few hundred. typical of just about all the plate amps, it's the China made components that fail. cant really pin it down to one thing or another. they can just randomly fail... or, often be taken out by a failing driver. a total rebuild with quality non-Chinese components, can make a very reliable amp, as i have done to a lot of the amps in the eD thread.
post #19823 of 20352
So its been what 10 months now since Epik has sold any subs, any word as to when these new subs Chad's posted pictures of are actually going to go on sale?
post #19824 of 20352
Want to replace your XS30s or are you just trolling?
post #19825 of 20352
Quote:
Originally Posted by lovinthehd View Post

Want to replace your XS30s or are you just trolling?

Good job having Chad's back. I'm sure you'll be rewarded for it in the next life.
post #19826 of 20352
Look, didn't General MacArthur say he'd return to the Phillipines and he did? The Beatles had a song by that name and how many times has Arnold said he'd be back and he did? And don't Buddists say we all come back as something or other? And what about baby back ribs? Chad will be back but if you're lucky, your psycho girl friend won't.
post #19827 of 20352
Quote:
Originally Posted by lovinthehd View Post

Want to replace your XS30s or are you just trolling?

No just looking for an update, how's it trolling just looking to find out the details on the pictures of the sub that's supposedly coming out soon.
post #19828 of 20352
Quote:
Originally Posted by jbrown15 View Post

No just looking for an update, how's it trolling just looking to find out the details on the pictures of the sub that's supposedly coming out soon.

Having had a Conquest in the past, curious as to what chad is building with the 18" monster.
post #19829 of 20352
Quote:
Originally Posted by daveds50 View Post

between the Yung, Kiega, and Bash amps that are about the same, ( there are only a few amp manufacturers... Epic does not make their own amps ) i've fixed a few hundred. typical of just about all the plate amps, it's the China made components that fail. cant really pin it down to one thing or another. they can just randomly fail... or, often be taken out by a failing driver. a total rebuild with quality non-Chinese components, can make a very reliable amp, as i have done to a lot of the amps in the eD thread.

I mean is the driver components or the power supply components the problem?
Edited by rpfisterer - 9/18/13 at 6:26pm
post #19830 of 20352
Jim Wilson suggested I post in this thread as I have mint condition Epik Empire that I just put in the classified section here. NO issues with the amp and driver as it gets barely warm to the touch on use. I bought a set of Rythmik E15s, and really only have a place for two subs max. The Empire probably has less than 200 hours on it as we only watch the occasional movie in the living room. I'm afraid this unit is too heavy to ship unless the buyer wants to arrange a pickup via a freight carrier, etc. The sub is about 120lbs and was originally shipped on a pallet. I no longer have the box, but I might still have the foam inserts in the attic.

Piedmont Triad area, N.C.
New Posts  All Forums:Forum Nav:
  Return Home

Gear mentioned in this thread:

AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › Official Epik Subwoofer Thread