or Connect
AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › Official SVS Ultra 13 thread
New Posts  All Forums:Forum Nav:

Official SVS Ultra 13 thread - Page 332

post #9931 of 10329
SVS ASEQ-1
post #9932 of 10329
All five of my thermistors with the markings SCK 048 has a burn mark in them and the amplifier blows the fuse on power on. Lsound in Norway can't help me with repair and the local company that repairs amplifiers, tv:s and so on won't touch it without a scheme (spelling? smile.gif ).

Is the only way out here to buy a new amplifier for 599€? Is it only the thermistors or does this fault usualy come from something else in the beginning? If it's probably just the thermistors, where can I get new ones?

Edit: Pictures...

http://savarturbo.se/~jw/akustik/DSC_0001.JPG

http://savarturbo.se/~jw/akustik/DSC_0002.JPG
post #9933 of 10329
Quote:
Originally Posted by JonasW View Post

All five of my thermistors with the markings SCK 048 has a burn mark in them and the amplifier blows the fuse on power on. Lsound in Norway can't help me with repair and the local company that repairs amplifiers, tv:s and so on won't touch it without a scheme (spelling? smile.gif ).
Is the only way out here to buy a new amplifier for 599€? Is it only the thermistors or does this fault usualy come from something else in the beginning? If it's probably just the thermistors, where can I get new ones?
Edit: Pictures...
http://savarturbo.se/~jw/akustik/DSC_0001.JPG
http://savarturbo.se/~jw/akustik/DSC_0002.JPG
What a timing... My amp went out on one of my ultras this saturday. I noticed that thermistor was shot (the one shown on the second picture). I chatted with SVS tech support and Jack told me the schematic is not available and the only option he can offer is Sledge amp for $399.99. I did a google seach on phone while shopping at costco and came across this thread Ed Mullen posted a part number in newark. It is $0.97 part but the shipping is going to be ~$8. I ended up spending $50 buying bunch of different caps for another project. Temporarily I loaded different value thermistor (not recommended) and my amp is up and running. I got e-mail today that it was shipped via UPS 2day for the price of ground shipping. I should have the part on Thursday.
post #9934 of 10329
Quote:
Originally Posted by tpaxadpom View Post

What a timing... My amp went out on one of my ultras this saturday. I noticed that thermistor was shot (the one shown on the second picture). I chatted with SVS tech support and Jack told me the schematic is not available and the only option he can offer is Sledge amp for $399.99. I did a google seach on phone while shopping at costco and came across this thread Ed Mullen posted a part number in newark. It is $0.97 part but the shipping is going to be ~$8. I ended up spending $50 buying bunch of different caps for another project. Temporarily I loaded different value thermistor (not recommended) and my amp is up and running. I got e-mail today that it was shipped via UPS 2day for the price of ground shipping. I should have the part on Thursday.

Thank you for the information! Then there is hope to this amp.

It sucks that they can't provide us with schematics and/or parts. Over here, a new amp is 599€ +shipping!
I guess this is my first and last SVS even if I'm happy with the performance.
post #9935 of 10329
Quote:
Originally Posted by JonasW View Post

Thank you for the information! Then there is hope to this amp.
It sucks that they can't provide us with schematics and/or parts. Over here, a new amp is 599€ +shipping!
I guess this is my first and last SVS even if I'm happy with the performance.
Sledge 1000 in us retails for $600. Jack offered the special price due to circumstances. I wouldn't want to trade my bash amp for sledge... I agree it is bad that we cannot purchase the schematic. You may want to try Bash directly. I don't think svs can legally sell or provide the schematic even if they have it. Though looking up the part number wouldn't be a problem . I got schematics from companies like adcom and parasound. Parasound also sent me some free parts. Though I was still impress with svs customer service. I was able to chat with them on Sunday.
Edited by tpaxadpom - 9/5/12 at 8:10am
post #9936 of 10329
Anyone in the PA/NJ/MD/DE/VA/DC/NY area interested in a sub GTG? We are lacking sufficient SVS representation, HELP! Someone with a PB13U?? biggrin.gif

http://www.avsforum.com/t/1420544/ne-pa-ny-nj-de-md-va-gtg-take-two
post #9937 of 10329
Would my Denon 4311 w/ mutli xt32 be good enough to eq my 2 PC-Ultra 13's?
post #9938 of 10329
Definitely. MultEQ Xt32 is some of the best and most advanced EQ tech out there currently.
post #9939 of 10329
Need to change the title of this thread to PB13 Ultra since now SVS Ultra 13 now refers to the SB13 Ultra as well.
post #9940 of 10329
Quote:
Originally Posted by Auditor55 View Post

Need to change the title of this thread to PB13 Ultra since now SVS Ultra 13 now refers to the SB13 Ultra as well.

Not at all, since this thread applies to the entire Ultra 13 family, which consists of the PB13U, the PC13U, and now the SB13U...smile.gif
post #9941 of 10329
How about mixing SVS sub models. I Have had for a few years a cylinder, PC13-Ultra. For a number of reasons I want to experiment with a multiple sub arrangement. Anyone see a problem with adding a box, PB12-Plus instead of a PB13? The spec for the previous generation PC13Ultra and the newer PB12-Plus seem similar. My room is relatively small at about 1800 cubic feet. with a door opening to a much larger space.. This is not for volume pressurization but room bass equalization improvement.
post #9942 of 10329
As long as similar tuning modes are chosen, the two should work together well.
post #9943 of 10329
Quote:
Originally Posted by lynnwill1 View Post

How about mixing SVS sub models. I Have had for a few years a cylinder, PC13-Ultra. For a number of reasons I want to experiment with a multiple sub arrangement. Anyone see a problem with adding a box, PB12-Plus instead of a PB13? The spec for the previous generation PC13Ultra and the newer PB12-Plus seem similar. My room is relatively small at about 1800 cubic feet. with a door opening to a much larger space.. This is not for volume pressurization but room bass equalization improvement.


I use a 12/2 Ultra with my 3 PB13's and have had no issues. Just need to get them in phase and playing well together and you should be good. smile.gif As mentioned above though, use similar tunings.
post #9944 of 10329
i'm located in pa you could stop by and listen to my new pb ultra. schuylkill county to be exact. 17972 zip.
post #9945 of 10329
Quote:
Originally Posted by Elfather View Post

How much do you want for it?
I have a extra PB13 ULTRA Driver, I was thinking of maybe building a second sub box

Elfather,

By chance; do you still have this ULTRA driver?
(check your PMs)

Thanks,
Cuzed2
post #9946 of 10329
Quote:
Originally Posted by tpaxadpom View Post

What a timing... My amp went out on one of my ultras this saturday. I noticed that thermistor was shot (the one shown on the second picture). I chatted with SVS tech support and Jack told me the schematic is not available and the only option he can offer is Sledge amp for $399.99. I did a google seach on phone while shopping at costco and came across this thread Ed Mullen posted a part number in newark. It is $0.97 part but the shipping is going to be ~$8. I ended up spending $50 buying bunch of different caps for another project. Temporarily I loaded different value thermistor (not recommended) and my amp is up and running. I got e-mail today that it was shipped via UPS 2day for the price of ground shipping. I should have the part on Thursday.

Have you tried taking it to a local repair shop that repairs amps in general?
post #9947 of 10329
I have a almost new Bash amp after upgrading to the Sledge if anyone is interested?
post #9948 of 10329
I would like to have a spare(since I have 4). But I live in Southern Ontario about 30 miles from Buffalo NY.
post #9949 of 10329
I don't need an amp; but I'm looking for an SVS driver, anything from a 12.3 or up, will work for my project....
Send me a PM if you can help - Thanks!
post #9950 of 10329
Quote:
Originally Posted by pbc View Post

Have you tried taking it to a local repair shop that repairs amps in general?
I had no reason to but I dont see why not. I installed the right part and everything is working well. I am glad I got it fixed fast and easy. I would rather buy bash replacement than sledge.
Part number in case other thread disappears AMETHERM - SL15 4R008.
Edited by tpaxadpom - 9/15/12 at 11:48pm
post #9951 of 10329
Great to hear it's working well!
post #9952 of 10329
Quote:
Originally Posted by tpaxadpom View Post

I had no reason to but I dont see why not. I installed the right part and everything is working well. I am glad I got it fixed fast and easy. I would rather buy bash replacement than sledge.
Part number in case other thread disappears AMETHERM - SL15 4R008.

Great news tpaxadpom and there is nothing worse when one your main pieces in your system stops working.
post #9953 of 10329
b1
post #9954 of 10329
my svs ultra 13 amp panel seems to have also blown today ...

was away for a week -turned the sub off - like I always do if away for a period of time

turned it on this morning,and a loud sharp crack came from somewhere inside the panel, and I heard what Ithought was a "richochet" ?

checked the fuse - its fine, not blown, so only thing I can think is that a capacitor inside has blown its top ? a bit surprising for quality device thats less than 5 years old

anyone had anything similar?
post #9955 of 10329
Is this the BASH 750w amp?
post #9956 of 10329
Quote:
Originally Posted by markabuckley View Post

my svs ultra 13 amp panel seems to have also blown today ...
was away for a week -turned the sub off - like I always do if away for a period of time
turned it on this morning,and a loud sharp crack came from somewhere inside the panel, and I heard what Ithought was a "richochet" ?
checked the fuse - its fine, not blown, so only thing I can think is that a capacitor inside has blown its top ? a bit surprising for quality device thats less than 5 years old
anyone had anything similar



PM sent
post #9957 of 10329
took my SVS Ultra 13 amp off today (which has failed) - and has left more questions than answers

since it had made such an obvious bang - was expecting something reasonably obviously "wrong" - but everything looks good

will get the multimeter out on it tomorrow and start some preliminary fault finding

just surprised that something could have made such a bang and not look physically out of place - btw fuse is fine, and I've changed mains cables etc to no avail

SVS Ultra 13 Amp Photos

see photos in link above
post #9958 of 10329
Is anyone colocating a pair of PC's? I see a lot of people stacking their PB's, but haven't sen any posts regarding colocating PCs.
post #9959 of 10329
Quote:
Originally Posted by michaelscott73 View Post

Is anyone colocating a pair of PC's? I see a lot of people stacking their PB's, but haven't sen any posts regarding colocating PCs.

I tried colocating my 20-39s a while back, but unfortunately my room accoustics gave me a huge dip in the room reponse and I only had one location for the two subs. As a result, I relocated them across the front sound stage, separated by about 8 feet. I still get about a 4dB boost, and the response is +/-3dB 16Hz-100Hz...
post #9960 of 10329
Could it be the power module near the inlet? But, there isn't any damage visually.
New Posts  All Forums:Forum Nav:
  Return Home
AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › Official SVS Ultra 13 thread