or Connect
AVS › AVS Forum › Blu-ray & HD DVD › HD DVD Players › does anyone else have this problem with hdmi?
New Posts  All Forums:Forum Nav:

does anyone else have this problem with hdmi?

post #1 of 5
Thread Starter 
so about 40 days ago i bought a toshiba hd-a20. i use hdmi. about 10 days ago. i couldnt get anythign to work. i kept on getting a non supported data thing on my tv. i called toshiba and asked them to send me a replacement and they asked me before we do that we should double check something. so he asked me to hook up a/v cables or componet and see if it works. i hook up my a/v cables and to my amazement it does. so then i have to initialize the set up, and then restart the machine. so i asked him whats up with, is there something wrong with my hdmi port. he says no, and gives me some bs explanation. i then ask him so am i going to have to do this frequently, or is it fixed for ever. the tech guy was like well you may have to deal several times depending on use if this happens. im like well theres something wrong with your product because i shouldnt have to be doing this if your so called hdmi is auto. hes like well sir that is hdmi, not toshiba. since then i had do to it once more yesterday and it was very stubborn. i want to know if this a known issue or maybe just mine, because if its mine im going to call toshiba and say that the a/v cabes, anything doesnt work and i want a new one. i can't believe this type of service im getting from toshiba. it makes me so sick that i think to never buy one of there products. i have both hd and blu-ray players and the blu-ray player has never had one issue and it loads faster. i cant believe how long it takes for these hd-dvd to boot up and play a standard dvd or hd-dvd. my blu ray player boots up and is playing a movie like 15X faster. anyone esle notice this or is this just mine again. anyways thanks in advance who an help me.
post #2 of 5
Did you upograde the firmware that was supposed to correct the hdmi problem?
post #3 of 5
Thread Starter 
yup and once i did the initilize set up again the first thing i did was update the firmware again.
post #4 of 5
What's your Blu Ray player? From what I've heard and read, standalone BD players are as slow and problematic, especially the ones from Samsung. If you have a PS3, then you should compare it to XBox 360 HD DVD Add On. Both are comparable.

We're still in the infant stage of Hi Def players. Players from both camps are less than stable and slow.
post #5 of 5
Thread Starter 
yea one of my blu ray players is the ps3 and its fatser than the stand alone one but not by much.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: HD DVD Players
AVS › AVS Forum › Blu-ray & HD DVD › HD DVD Players › does anyone else have this problem with hdmi?