or Connect
AVS › AVS Forum › Blu-ray & HD DVD › HD DVD Players › Venturer SHD7000 End User Reports and Owner's Thread!
New Posts  All Forums:Forum Nav:

Venturer SHD7000 End User Reports and Owner's Thread! - Page 12

post #331 of 417
Same thing happened to me. Called FedEx on the September 15, fixed the problem and both of the 7000s were delivered yesterday.
post #332 of 417
Quote:
Originally Posted by rockin_master View Post

Yeah, I highly doubt either of these units will ever show up for me. You are correct that Buy.com gives out tracking numbers prior to merchandise shipping. Fedex reps will flat out tell you this.

Went into this with eyes wide open so it's no surprise. Ordered on the 4th, recieved tracking number on the 10th, and no doubt I'll be told both units were lost once the 9th business day from shipment comes around -at which point I'll have to contest the charge with my CC company because it will take 10 business days for Buy.com to cancel my order. SOP for them.

I should have paid for shipping because I know thats what caused the snag, they noticeably aren't offering free shipping anymore. The 5 percent coupon didn't help either, bringing the per unit shipped price to 56.99 -propably below the price threshold for those items(buy.com will LOSE money after shiiping).

Oh well, we'll see.


I received mine today. I received a tracking number the day after I made the purchase. Fedex did not have any information on it for about 3 days. Fedex received the information on the 4th but it did not ship until the 12th. I received The Perfect Storm and Firewall.
post #333 of 417
Can this unit play HD formatted content burned to standard DVD±Rs like the A3? Also, has anyone viewed Superbit SD DVDs? I have a number of these titles and I'm curious how they look and sound in the Venturer.
post #334 of 417
Ordered mine on the 15th, received on the 18th. Guess they like people that pay shipping. Maybe they shouldn't have offered free shipping in the first place. BTW they're now out of them. PP, I have a number of Superbit titles and if I get a spare hour or two I'll do a comparo between the Venturer and either my A1 or my A35.
post #335 of 417
Quote:
Originally Posted by hal9e3 View Post

Ordered mine on the 15th, received on the 18th. Guess they like people that pay shipping. Maybe they shouldn't have offered free shipping in the first place. BTW they're now out of them. PP, I have a number of Superbit titles and if I get a spare hour or two I'll do a comparo between the Venturer and either my A1 or my A35.


Cool beans man! I think I will skip the FW update since mine are working. LOL
post #336 of 417
I'll update mine...
post #337 of 417
Quote:
Originally Posted by Splicer010 View Post

I'll update mine...

Do DVDs and HD-DVDs play fine?
3.0 or 2.0?
post #338 of 417
Haven't even unpacked it yet...But I think the concensus is they all came with 1.0FW...
post #339 of 417
Here's hoping firmware helps mine. Have ran 4 HD-DVDs through it and every single one of them froze. Usually happens midway through or so (layer change prob?) and renders about 4 min. of the movie unwatchable.
post #340 of 417
Quote:
Originally Posted by Down View Post

Here's hoping firmware helps mine. Have ran 4 HD-DVDs through it and every single one of them froze. Usually happens midway through or so (layer change prob?) and renders about 4 min. of the movie unwatchable.

I upgraded my Venturer to 3.0 and it freezes solid on "The Warriors" but made it through "The Bourne Supremacy." I bought it to replace my 360 add-on since the 360 is so loud but it looks like I'm going to have to go back to it anyways.
post #341 of 417
I'll pull mine out of the box tomorrow and check with the original FW since I have those movies...
post #342 of 417
I use to have freezes on my Venturer. But since I loaded ver. 3, no problems. Also, clean your discs. I usually wipe my discs, even new ones with a wet tissue. Then I wipe it dry. Discs play fine.
post #343 of 417
So far this is EXACTLY like the A3 I had...Even has 1.3FW loaded...Will report back after I play 1 or 2 HD DVD and 1 or 2 SD DVD...
post #344 of 417
FW1.3 and all is well...I highly recommend this player...It is slower than my A35 with 3.0FW but the A35 was just as slow with the same FW...I will update the 7000 to 3.0 and I will be happy...No issues...
post #345 of 417
I downloaded the HD-A3's firmware 4.0 and burned it to a CD. When I insert the disc into the Venturer, it says "VERUP" on the player's front panel display, but the tv screen goes blank. This has me a little worried because my Toshiba player shows "VERUP" on the front panel display and asks you if you want to update on the tv screen as well.

Anyone try 4.0 on their Venturer and experience this as well?
post #346 of 417
I updated mine to 4.0 today via burned ISO and it went fine. It now reads "4.0/2.0" on the upgrade screen. Still has issues with the same discs as before but other than that it seems to be running fine.
post #347 of 417
Quote:
Originally Posted by pressranks View Post

Very happy to see my SHD7000 is in the shipping status as of today at buy.com. Took the entire 5 days of the promised 3-5 days shipping time. I bought this unit since I was already looking for a DVD player with HDMI and what better DVD player to get.

Would be very interesting to see the format revived based sales of this player.

Standing by my 42 inch plasma holding the free end of my HDMI cable waiting for UPS...........

Unit got delivered on 9/19 - 8 days after I ordered it. Came with Firewall and Perfect Storm. Hooked that bad boy up and started to enjoy perfect storm. 30 minutes into the movie, the sound quit. Picture was fine but no sound. Nothing I tried worked. I had HDMI from the unit to the TV, as well as RCA out from the unit to my stereo amplifier. None of the two produced any sound. I tried playing a regular music CD and got sound from the TV (HDMI) but nothing from the RCA jacks. Regular DVD produced no sound as well. I allowed the unit to perform a firmware upgrade via the ethernet connection , the ugrade was successful but that did not solve my sound problem. I hope the unit I received was just a bad one because I shipped it back to buy.com (RMA free return shipping) and asked for a replacement.

I should say, for the 30 minutes usage, I strained to find the visual advantage over regular DVD. But then, I have other reasons why I want the unit.
post #348 of 417
Ordered on 9/18/08, received 9/25/08. Came with Perfect Storm and Firewall. Like others, I also got a non-existent packing job. The Venturer retail packaged box was placed inside a larger box and that's it. Luckily it played fine. Hooked it up to my IF SP4805 via component and played Perfect Storm at 1080i. Looked great! Tried an SD DVD (Daddy Daycare) and it automatically switched to 480p. That looked horrible! Not sure what's going on with this player's 480p output. I will promptly get an HDMI->M1 cable from monoprice to keep things upsampled. Forgot to look at manufacture date and FW version. What settings are you guys using for Enhanced Black and RGB?
post #349 of 417
Quote:
Originally Posted by Michael Warner View Post

I updated mine to 4.0 today via burned ISO and it went fine. It now reads "4.0/2.0" on the upgrade screen. Still has issues with the same discs as before but other than that it seems to be running fine.

http://www.tacp.toshiba.com/customer...sp?model=hd-a3
post #350 of 417
@ksmut, over hdmi I've left my player at the default. It passes BTB and doesn't crush whites or blacks.
post #351 of 417
I updated my SHD7000 even though the screen went black after the CD was put in. I just hit the enter button on the remote when "VERUP" appeared on the player's display panel. Steps 1-3 of 4 seem to go very quickly and then step 4 takes the longest.

Does anyone know what this update does for the 7000/A3? I know people who have the XA2 are giddy as hell as it fixed their 1080/24 "jaggie" issue.
post #352 of 417
Quote:
Originally Posted by ksmut View Post

Ordered on 9/18/08, received 9/25/08. Came with Perfect Storm and Firewall. Like others, I also got a non-existent packing job. The Venturer was placed inside a larger box and that's it.

So there's no retail packaging at all? Odd...
post #353 of 417
I believe what they mean, and this happened to me as well, is that the Venturer comes in a regular audio equipment box but Buy.com just put it in a bigger outside box w/o any padding for shipping, which allow it to bounce around inside the outside box. It might have been better off shipping in just its own box.
post #354 of 417
Quote:
Originally Posted by Electone View Post

Does anyone know what this update does for the 7000/A3? I know people who have the XA2 are giddy as hell as it fixed their 1080/24 "jaggie" issue.

Not sure what it does, but this is what Toshiba says:

"This firmware update improves network connectivity for supporting the download of web- enabled network content associated with certain HD DVD discs, improves certain video and audio processing capabilities, and also addresses certain disc playback and HDMI/DVI related issues identified by Toshiba."

In any case, my Venturer seems to be working fine so far with 4.0.
post #355 of 417
Quote:
Originally Posted by hal9e3 View Post

I believe what they mean, and this happened to me as well, is that the Venturer comes in a regular audio equipment box but Buy.com just put it in a bigger outside box w/o any padding for shipping, which allow it to bounce around inside the outside box. It might have been better off shipping in just its own box.

Exactly hal9e3. Didn't state it as clearly as you and edited my original entry so there's no confusion. I like this player and don't notice the slowness as others have reported. The only bad thing is the terrible picture at 480p over component for those protected discs. Also noticed it's only certain discs that produce bad 480p. Tried 'The Incredibles' and it looked much cleaner than 'Daddy Daycare'. Need that HDMI->M1 cable pronto!
post #356 of 417
I pulled the trigger on one of these units from Buy.com. I had the same shipping timeframe and packing issues that everyone else seems to have had. Mine came with Bourne Identity and 300.

Hooked it up to my Panny TH-50px75u via HDMI and Toslink to my receiver.

Out of the box it had firmware 1.3. I updated it to 4.0 with no problems (other than I tried burning the ISO to a dvd first, then read the instructions and re-burned to a cd). Firmware now reads 4.0/2.0.

I set the output to 1080i (and let my TV do all of the downscaling).

Bourne Identity played fine. It looked and sounded great. I popped in my SD disc of Charlie and the Chocolate Factory and I could tell a distinct improvement over my JVC SDDVD player (running progressive via component). Seemed to be a bit sharper with better color reproduction and less banding in dark scenes.

The kicker is that with the Venturer, the difference between HDDVD and SDDVD is practically nil at my viewing distance (approx 16 ft). I haven't tried an A-B comparison with my JVC SDDVD player.

Granted, I've only had the unit for about a week and have only had time to watch two movies on it, but I'm very pleased with it so far (especially considering that it was only $64 shipped).

We'll see how it holds up over time.
post #357 of 417
Using the same design and parts as the Toshiba A3...I expect this unit to hold up very well...
post #358 of 417
Quote:
Originally Posted by Bengoshi2000 View Post

I popped in my SD disc of Charlie and the Chocolate Factory and I could tell a distinct improvement over my JVC SDDVD player (running progressive via component).

You're telling me...

I unloaded my BD-UP5000 Blu/HD player since I bought a total of one Blu-ray title in the three months that I owned it. And I got sick of the player's issues with many titles. So until my 7000s arrive, I've had to bring my 2002~ Samsung DVD player out of mothballs.

I'm one of those people who constantly warns people about buying into the upscaling DVD player hype, since most TVs have better upscalers than most DVD players.

But DVD playback technology has evolved tremendously over the past 6-7 years. And if I needed a reminder...

Even with my TV doing the upscaling job from my old Sammy (which was once high-end), the video is very soft and the colors washed out.

I can't wait until my SHD7000s arrive.
post #359 of 417
Quote:
Originally Posted by Splicer010 View Post

Using the same design and parts as the Toshiba A3...I expect this unit to hold up very well...

Did you update to 4.0 yet?
post #360 of 417
I updated my A35...Haven't received the disc for the A3 yet...Will update when I get it...I will not update any other way...
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: HD DVD Players
AVS › AVS Forum › Blu-ray & HD DVD › HD DVD Players › Venturer SHD7000 End User Reports and Owner's Thread!