or Connect
AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › Official Elemental Designs Subwoofer Thread
New Posts  All Forums:Forum Nav:

Official Elemental Designs Subwoofer Thread - Page 496

post #14851 of 15422
I have an old downfiring A5-350 with the LT550 amp upgrade. My driver started buzzing and I started a long and frustrating chain with Alex several months ago with most of my messages going unanswered and requiring multiple prods to get an answer. I was finally able to get him to admin the driver was the issue (which was still under warranty) about a month ago but never got any info on how to return it. I hooked it up to a different power source to rule out the amp. I really know nothing more than the average consumer when it comes to driver anatomy but it isn't apparent where the buzz is coming from, at least not to me.Clearly I'm SOL because I didn't technically have an active RMA and probably wouldn't matter even if I did. Can anyone suggest a decent driver that will fit my box to take over?
post #14852 of 15422
Quote:
Originally Posted by spl152db View Post

Can you prove it was them? I'm not defending them, but thats all speculation unless you have hard proof.

I was a huge fan of eD but I have to wonder after I had charges that weren't mine on 2 different cards that I used in 2 different transactions with eD. I have never had a card accessed by someone else before in my life until that happened.
post #14853 of 15422
Quote:
Originally Posted by boofa_2001 View Post

I have an old downfiring A5-350 with the LT550 amp upgrade. My driver started buzzing and I started a long and frustrating chain with Alex several months ago with most of my messages going unanswered and requiring multiple prods to get an answer. I was finally able to get him to admin the driver was the issue (which was still under warranty) about a month ago but never got any info on how to return it. I hooked it up to a different power source to rule out the amp. I really know nothing more than the average consumer when it comes to driver anatomy but it isn't apparent where the buzz is coming from, at least not to me.Clearly I'm SOL because I didn't technically have an active RMA and probably wouldn't matter even if I did. Can anyone suggest a decent driver that will fit my box to take over?

I had a similar issue with the sub. I unhooked some other devices on other nearby outlets and it fixed the problem. 2-3 years later still not having any issues.
post #14854 of 15422
Quote:
Originally Posted by boofa_2001 View Post

I have an old downfiring A5-350 with the LT550 amp upgrade. My driver started buzzing and I started a long and frustrating chain with Alex several months ago with most of my messages going unanswered and requiring multiple prods to get an answer. I was finally able to get him to admin the driver was the issue (which was still under warranty) about a month ago but never got any info on how to return it. I hooked it up to a different power source to rule out the amp. I really know nothing more than the average consumer when it comes to driver anatomy but it isn't apparent where the buzz is coming from, at least not to me.Clearly I'm SOL because I didn't technically have an active RMA and probably wouldn't matter even if I did. Can anyone suggest a decent driver that will fit my box to take over?

Anything here look good to you?

http://www.parts-express.com/cat/subwoofers/14?kg=497|3925

OR YOU CAN LOOK FOR A MACH AUDIO 15" driver...i have an 18" mach audio that is awesome!!
post #14855 of 15422
Quote:
Originally Posted by dmclone View Post

I had a similar issue with the sub. I unhooked some other devices on other nearby outlets and it fixed the problem. 2-3 years later still not having any issues.

Sadly my issue is definitely the driver. I hooked it to the amp in my car and it still buzzes like crazy. So would the Dayton MKIII 15" work in this box? Hate to cheap out, but now a single-income family of 4, so not the disposable income we had when the eD was purchased.
post #14856 of 15422
Check the dust cap. They come Unglued and will rattle.

Sent from my DROID RAZR using Tapatalk 2
post #14857 of 15422
Quote:
Originally Posted by spl152db View Post

Check the dust cap. They come Unglued and will rattle.
Sent from my DROID RAZR using Tapatalk 2

I've examined it as much as I know how (like I said, not much more than avg consumer as far as speaker-anatomy goes) and don't see anything wrong with it. The rattle seems to be coming from the innards best I can tell.
post #14858 of 15422
An innards rattle may not be the sub. Where are you located?

Sent from my DROID RAZR using Tapatalk 2
post #14859 of 15422
Also run your fingernail around the edge of the dust cap and see if its loose.

Sent from my DROID RAZR using Tapatalk 2
post #14860 of 15422
Quote:
Originally Posted by spl152db View Post

An innards rattle may not be the sub. Where are you located?
Sent from my DROID RAZR using Tapatalk 2

Nashville, TN
post #14861 of 15422
Tensil leads flapping on the spider maybe?
post #14862 of 15422
Looking back at this long thread it seems rattles, buzzes and amp failures seem to be the down fall of this company.

I still think their case design was top notch and not the source of most problems. Sadly I spent $1000 and have had rattle issues with both the driver and amp. Like others I don't have the disposable income I had when I purchased the sub woofer. I will have to go sub less until I can save up and buy a more recognized brand. Hopefully one that has ironed out all the NVH issues.
post #14863 of 15422
Quote:
Originally Posted by boofa_2001 View Post

I have an old downfiring A5-350 with the LT550 amp upgrade. My driver started buzzing and I started a long and frustrating chain with Alex several months ago with most of my messages going unanswered and requiring multiple prods to get an answer. I was finally able to get him to admin the driver was the issue (which was still under warranty) about a month ago but never got any info on how to return it. I hooked it up to a different power source to rule out the amp. I really know nothing more than the average consumer when it comes to driver anatomy but it isn't apparent where the buzz is coming from, at least not to me.Clearly I'm SOL because I didn't technically have an active RMA and probably wouldn't matter even if I did. Can anyone suggest a decent driver that will fit my box to take over?
Quote:
Originally Posted by lennon_68 View Post

Thanks Mark. I scanned the DIY forum a couple times for a thread but missed it. So the amps don't have any boost just an adjustable high pass, that's convenient! Anyone want to take a crack at generating a list of subs with their driver size, enclosure size, tuning frequency, and port measurements? Even just enclosure size driver size and port measurements would be adequate to back into tuning frequency. I know Chris posted the driver parameters but I'm not familiar enough with TS params to look at a set from one driver and determine which drivers might be comparable. Using the enclosure measurements I can certainly plug several drivers into the same sized enclosure and see which ones model well though smile.gif
What I'm looking for would a chart like:
subwoofer, driver size, enclosure volume, tuning frequency (if known, will need either this or port size and length), port size (are they all round ports? If so just the diameter will suffice), port length, amplifier power
A2-300, 12", 2cuft , 28hz, 3" diameter, 10", 200W
Those aren't real measurements just an example. I tried to find information on the the A2-300 to fill in the actual values but didn't find anything in a quick search.
I think we should pull this information together here as there are owners that can measure their subs to approximate enclosure volume and port measurements - in the DIY section it's unlikely we'll be able to get that information (unless we can grab it from the interwebs as Mark suggested above smile.gif)

Step right up wink.gif
post #14864 of 15422
Quote:
Originally Posted by caper_1 View Post

The icing on the cake is the unauthorized charges on credit cards for other stuff...

I had my credit card charged TWICE and thought it was an isolated incedent the first time. I wouldn't say that it's ED who did the unauthorized use of credit card rather I think their system is not secure. Although being an internet company, they should have made sure it is very secure.

Then again, they do give you discount if you pay by DWOLA, the safe and secure way of online payment. There's where the conflict is, in my opinion.
Edited by MarvelousMarvin - 9/6/12 at 5:35am
post #14865 of 15422
Quote:
Originally Posted by spl152db View Post

Can you prove it was them? I'm not defending them, but thats all speculation unless you have hard proof.
This isn't the supreme court. Lack of hard proof (which I obviously do not have without search warrants, etc), does NOT mean that it didn't happen. Look here:
Quote:
Originally Posted by carp View Post

I was a huge fan of eD but I have to wonder after I had charges that weren't mine on 2 different cards that I used in 2 different transactions with eD. I have never had a card accessed by someone else before in my life until that happened.

If you read back, there are more posts like this. Only people who have ordered from eD had mysterious unauthorized charges, around the same time... 2 + 2 = 4 not 5...
post #14866 of 15422
Quote:
Originally Posted by caper_1 View Post

This isn't the supreme court. Lack of hard proof (which I obviously do not have without search warrants, etc), does NOT mean that it didn't happen. Look here:
If you read back, there are more posts like this. Only people who have ordered from eD had mysterious unauthorized charges, around the same time... 2 + 2 = 4 not 5...

I'm not trying to say you're wrong, but I've had my cards stolen before (the numbers) and it wasn't always related to eD. I will agree though the correlation is strong.
post #14867 of 15422
I had to cancel two credit cards myself for unauthorized use. eD was not the only company who used them so who knows, it could have been a trend.
post #14868 of 15422
Unauthorized use of credit cards was also mentioned some time back in an Axiom thread.
post #14869 of 15422
Quote:
Originally Posted by caper_1 View Post

Only people who have ordered from eD had mysterious unauthorized charges, around the same time... 2 + 2 = 4 not 5...

well... i have never bought anything from eD. however, earlier this year i had a suspicious charge on the card i use only for electronic parts ordering. all of the vendors i use, i have been using for many years with no problems whatsoever. they are all large distributors of electronic parts. ( Avnet, Digikey, Mouser, Allied, Arrow, Newark, etc. )

however, the one and only time i ordered from Parts Express ( they were the only ones with a certain capacitor in stock ) the charge appeared about a week later.

i have no proof it was Parts Express... but it sure seems like it.
post #14870 of 15422
I recently had unauthorized charges on two of my credit cards. I have never done any business with eD. I have done business with both Axiom and Parts Express. confused.gif However, only one of those cards was used at both places. The other wasn't used at either. I've had both cards 37 years and 26 years, respectively. Never had an unauthorized charge on either until now. Seems that credit card fraud is epidemic. mad.gif
Edited by Rijax - 9/6/12 at 10:37am
post #14871 of 15422
The Monoprice & PSN security problems got two of my credit cards. I no longer let a web-site "store" my credit card information except for Amazon.
post #14872 of 15422
Quote:
Originally Posted by Rijax View Post

I recently had unauthorized charges on two of my credit cards. I have never done any business with eD. I have done business with both Axiom and Parts Express. confused.gif However, only one of those cards was used at both places. The other wasn't used at either. I've had both cards 37 years and 26 years, respectively. Never had an unauthorized charge on either until now. Seems that credit card fraud is epidemic. mad.gif
Absolutely, Jack. There's enough of this going on that IMO to feel these instances are ED shenanigan is unwarranted.
post #14873 of 15422
Quote:
Originally Posted by chrischaos View Post

Informitive post but we do not know what the future holds for ED or what type of bankruptcy protection they may have (if any) or what they owe creditors or secured creditors.
While possible, i think it would be doubtful for them to request product. So they can try and sell it themselves for pennies on the dollar? Nobody here has any concrete information about the situation. We don't know if they are a viable llc. We don't know if they are filing bankruptcy now, or anytime soon or at all. My advice-If you are given your money back, take it and don't look back. Everything else is nothing more than rumor and conjecture at this point.

I agree with you that as much as the courts can and will take these monies back from you, might as well take it....although I will add to seek legal advice and clarify what your protection is, as well.

Now, the question of the danger of purchasing any of these liquiation products is still up in the air. We are not informed of any concrete information other than what ED wants us to hear at this point. As far as ED had been posting and announcing, there will be a liquidation sale, a blowlout sale of their remaining inventories. Are customers aware of what the courts may or may not do? Is it worth the risk for people to participate in this liquidation sale.
post #14874 of 15422
So while moving I broke a spike on my a2-300... Any suggestions on where to get a replacement since ED no longer is answering emails or phone calls?

So far I was pointed in the direction of these http://www.parts-express.com/term/spikes?srch=spikes ..... but dont know which ones will actually fit and thread in the holes already there. Any suggestions?

Thanks
post #14875 of 15422
Quote:
Originally Posted by Cadrian View Post

So while moving I broke a spike on my a2-300... Any suggestions on where to get a replacement since ED no longer is answering emails or phone calls?
So far I was pointed in the direction of these http://www.parts-express.com/term/spikes?srch=spikes ..... but dont know which ones will actually fit and thread in the holes already there. Any suggestions?
Thanks

I'm pretty sure they all have the same threads, but the DSS4 series has what you want:

http://www.parts-express.com/term/dss4?srch=DSS4
post #14876 of 15422
Quote:
Originally Posted by Cadrian View Post

So while moving I broke a spike on my a2-300... Any suggestions on where to get a replacement since ED no longer is answering emails or phone calls?
So far I was pointed in the direction of these http://www.parts-express.com/term/spikes?srch=spikes ..... but dont know which ones will actually fit and thread in the holes already there. Any suggestions?
Thanks

take an old one up to home depot or lowes and use their thread match things up there adn figure out what size it is.
post #14877 of 15422
Quote:
Originally Posted by caper_1 View Post

... people who have ordered from eD had mysterious unauthorized charges, around the same time...

what time is that?
post #14878 of 15422
My charge was at 2:12 pm eastern standard.

But seriously, I've had bunk charges from companies that I've disputed quite a few times... and never did mine trail back to eD. I've made several purchases from them.
post #14879 of 15422
I had an unauthorized charge show up on my credit card shortly after I ordered a center speaker from eD. This was also shortly after a major credit card clearing house in the SE had their security compromised so, while you can blame eD for a lot of things, I don't think this one is valid.

By the way the speaker shipped the next day and is still working fine.
post #14880 of 15422
Quote:
Originally Posted by boofa_2001 View Post

Sadly my issue is definitely the driver. I hooked it to the amp in my car and it still buzzes like crazy. So would the Dayton MKIII 15" work in this box? Hate to cheap out, but now a single-income family of 4, so not the disposable income we had when the eD was purchased.

I'd go with the Dayton reference 15" driver, this one:

http://www.parts-express.com/pe/showdetl.cfm?partnumber=295-468

It's rated down to 18hz, and from the reviews I've read is a really good quality sub driver.

I gotta say, eD is now a disgrace. Their so called "liquidation" sale is a joke. $200 just for a subwoofer enclosure with nothing else? Good grief.
New Posts  All Forums:Forum Nav:
  Return Home
AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › Official Elemental Designs Subwoofer Thread