or Connect
AVS › AVS Forum › Gaming & Content Streaming › Microsoft UltimateTV PVR › Can't find v 3.8- UTV stuck at 3.0
New Posts  All Forums:Forum Nav:

Can't find v 3.8- UTV stuck at 3.0

post #1 of 19
Thread Starter 
I just had my second HD go belly up. I suspect a very hot XBOX 360 session and some heavy recording contributed to the scenario.
Also it was 5 years old.

I put in a new Seagate 160 GB drive and followed the same procedure I had when upgrading to the 129 a few years back.
I eventually got the OS to download over the phone line, but it is stuck on the original v3.0!

I tried the Jenny code (8675309) as is mentioned in this forum. But when it finished downloading the OS again, it was still at 3.0.
I knew something was up when it said there were only 103 parts to download. I think v 3.7 was 200+ parts.

I've tried to download it a second and 3rd time with the same results. After the Jenny code and a little phone line wriggling, always 103 parts: always v3.0.

Now I like to reminisce about old technology as much as the next guy, but I can't get local channels, nor organize my recordings using any of the new features.

It will be hard to stave off the cries for "TiVo" in the house if this continues much longer. Any troubleshooting suggestions would be highly appreciated.
Also, I would be willing to take a run at the WinHex solution if someone could direct me to v 3.8 bits somewhere.

Help.

TIA
post #2 of 19
Sorry to hear about your troubles. It has been mentioned recently that version 3.8 is still working via the UTV dial out. I replaced a HD a couple months ago and got 3.7 by letting the UTV dial out to MSN. Days later it was reported that the MSN servers had updated the OS to 3.8.

Maybe give it a day or so and try to dial out again?

If not, try this thread: http://www.avsforum.com/avs-vb/showthread.php?t=920047 RandCfilm has a modded version of the 3.8 image. Useful add ons there. PM him and see if he can send it to you.

I have the stock 3.8 image at home. I can post a (yousendit.com) link to the 3.8.bin file this weekend for you, if no one else posts it before hand.

Also check the FAQ thread for other free options that may work in lieu of the $50 WinHex program.
post #3 of 19
Thread Starter 
guitars911, thanks for the advice.

I will try the Jenny code again this evening. It's been a couple of days since I gave it a go.

I suspect that there is something amiss though and may have to take you up on your offer for a stock 3.8 image. Is there a charge for the service?


Thanks again.

If anyone has any suspicions on why this is not going anywhere for me, I'd love to hear them.
post #4 of 19
3.8 is still available by satellite download early every morning. I know it will automatically update version 3.7. Not sure about earlier versions. Try leaving it hooked up overnight and see what happens.
post #5 of 19
"Is there a charge for the service?"

NOPE!

You have found a great support forum for the aging UTV receiver. You can use the search feature of this forum and find out just about anything you ever wanted to know about this DVR.

j123 may have a simple solution, let v3.0 load then leave the UTV powered on and connected to your dish overnight. It should pull v3.8 from the stream sometime between 2am and 3am.
post #6 of 19
Right, according to www.ultimatetv.com the 3.8 release is being broadcast via satellite for a year, starting 9/2007. Leave your unit on and make sure you don't have any late night recordings scheduled. The box should upgrade to 3.8 from any previous release.
post #7 of 19
ultimateguy, here is a link to download the current v3.8 image of the UTV OS:

http://www.avsforum.com/avs-vb/showt...6#post12549916

Click on the link in the above thread. ^^^^
post #8 of 19
Hopefully letting it download via the Sat will work... however, if it doesn't could you explain what "followed the same procedure" entailed?

Now you didn't mention what your 120GB drive was running before it went belly up. I'd assume 3.8 right?

I'm curious if MSN is having some issues with it's "Master File"... someone accidentally dropping 3.0 in the 3.8 "folder". It's been awhile but I know there have been issues with dialup not having the OS available to EVERYONE for certain periods...

Might it be possible it is "downgrading" to a version it CAN find?

As far as procedure did you try any special "codes" when prompted during the download? I'm fairly certain specific codes would "force" specific OS (Beta?) downloads.
post #9 of 19
Thread Starter 
Hey. It's working! Thanks to everyone here who still believe in UTV and support this forum. Thanks especially to guitars911 who posted the 3.8 image for me.
Sorry it took me so long to post. It really was a bear for me to get this thing fixed during the holidays with relatives in town and general chaos.
I finally got to work on things a couple of days before New Years.
A few notes.

No amount of coaxing the image over the phone line was working. I always ended up with 3.0.

DirecTV was worthless for troubleshooting. One guy made a really honest effort, but the rest of them couldn't even get past the UTV model number.

NEWS!?! - I forgot to mention that I have an RCA receiver and my original smart card reader went poof too during this fiasco. By prying off the front panel of the unit I was able to expose the second reader, which works flawlessly. Take heart if you fry one. The 1" by 7" plastic piece comes of pretty easily.

I had a heckuva time using FlexHEX editor. I have not used bit level editor since my Macintosh days in the early 90's which added to my confusion and troubleshooting duration. If you blow it, the feedback cycle is a killer - About 5 hours or so, since you have to unlock you drive and zero it.
The instructions located elsewhere in this forum were not written specifically for this editor and were a little fuzzy to me. I hope the following are helpful to someone.


Here are the steps I found useful to apply an existing OS image on a target drive. (I appologize for the outline flattening. I am not only inept with FlexHex editor, I am having problems with the formatting function in the forum tonight.)

1.Install Target Drive in editing computer.

2.Once you locate the OS image you open that file with FlexHex Editor.
a.File-Open-File

3.Select everything in the file.
a.Cntrl + A'

4.Copy your selection.
a.Edit-Copy

5.Close the file. FlexHex will not let you paste into the new disk with the file open. (at least the version I have didn't.)

6.Open your Unlocked target drive with FlexHex editor.
a.File-Open-Physical Drive
b.If your drive was previously in your UTV, you'll need to unlock it and format it. Find instructions on how to do this elsewhere in this forum.

7.Zero the target drive
a.Select all Cntrl+'A'
b.Hit Delete'
c.This is not necessary if the drive is brand new (already all zero's)

8.Move your cursor to the start of the target image location.
a.Navigate-GoTo
b.Go To What? Disk Sector
c.631,811 (make sure you are in Decimal by noting the green arrow next to the Dec button. If the green arrow is in the hex button, change it to Dec)
d.Select the GoTo button
e.Make sure you landed in lba 000013480600. It will show up highlighted on the left hand side of the window

9.Paste the image you copied in step 4.
a.Edit-Paste

10.Commit the changes to your target drive
a.File-Save

11.Wait until it's done saving - should only be a few minutes (Under 5 for sure if you didn't have to do the zero-ing step).

12.Disconnect the Target Drive from your computer.

13.Install Target Drive in UTV

14.Re-assemble UTV.

15.Power up and voila!

16.It took me about 24 hours to receive my local channels in the guide.


Thanks again to those pitching in here to keep this forum going. May you never have to TiVo anything.
post #10 of 19
Glad to hear you got it working ultimateguy. Your patience paid off.

I vote that an admin or Kazak cut and paste these instructions over to the FAQ thread below the link to the free hex editor.

The FAQ keeps this kind of great info all in one place.
post #11 of 19
Quote:
Originally Posted by guitars911 View Post

I vote that an admin or Kazak cut and paste these instructions over to the FAQ thread below the link to the free hex editor.

The FAQ keeps this kind of great info all in one place.


Done


kazak
post #12 of 19
It's cool that after all these years the FAQ still continues to grow...

Thx Kazak..
post #13 of 19
Quote:


• NEWS!?! - I forgot to mention that I have an RCA receiver and my original smart card reader went “poof” too during this fiasco. By prying off the front panel of the unit I was able to expose the second reader, which works flawlessly. Take heart if you fry one. The 1" by 7" plastic piece comes of pretty easily.

Do you mean your access card worked in the "other" slot, or that you physically swapped the card reader sockets on the motherboard?
post #14 of 19
NEWS!?! - I forgot to mention that I have an RCA receiver and my original smart card reader went poof too during this fiasco. By prying off the front panel of the unit I was able to expose the second reader, which works flawlessly. Take heart if you fry one. The 1" by 7" plastic piece comes of pretty easily.

That is the only card slot that works for D*. You only have to push it in to expose the slot. The other card slot that is exposed was never active, and intended for buying stuff online.
post #15 of 19
Quote:
Originally Posted by DonCoolio View Post

NEWS!?! - I forgot to mention that I have an RCA receiver and my original smart card reader went poof too during this fiasco. By prying off the front panel of the unit I was able to expose the second reader, which works flawlessly. Take heart if you fry one. The 1" by 7" plastic piece comes of pretty easily.

That is the only card slot that works for D*. You only have to push it in to expose the slot. The other card slot that is exposed was never active, and intended for buying stuff online.


well then i'm completely lost as to what the first quote means....
post #16 of 19
Quote:
Originally Posted by MightyEric View Post

well then i'm completely lost as to what the first quote means....

There are two card slots on UTV. One exposed, one hidden behind a 1"x7" door that is accessed by pushing in. The Hidden card slot is the only one that can accept the D* access card. The exposed card slot was intended by Microsoft to be a payment system for online purchases. So the OP was confused by the exposed card slot not working, and thought it was broken. Having found the hidden card slot by Prying it open, the op got the system to work. This was a common problem when UTV was shipping, and many people, Including myself, made this mistake.
post #17 of 19
Quote:
Originally Posted by DonCoolio View Post

There are two card slots on UTV. One exposed, one hidden behind a 1"x7" door that is accessed by pushing in. The Hidden card slot is the only one that can accept the D* access card. The exposed card slot was intended by Microsoft to be a payment system for online purchases. So the OP was confused by the exposed card slot not working, and thought it was broken. Having found the hidden card slot by Prying it open, the op got the system to work. This was a common problem when UTV was shipping, and many people, Including myself, made this mistake.


I too made the mistake when I was a Jr. UTV'er
I didn't find the "other" slot until I opened her up.
It's so embarassing talking about it again...I'd rather talk about my Jr. days with girls.
post #18 of 19
AAAAHHHHHH! Thanks for clearing that up. I thought he was saying that the regular (hidden) D* card slot stopped functioning and he put the D* card into the exposed slot and it __worked__ !.? Now I'm up to speed.
post #19 of 19
FYI...

If you were to install a SMART Credit Card into the UTV Smart Card Reader slot... It would connect to WebTV/MSNTV... In my experience at least... As for any "real world" functionality that is/was associated with this card reader is unknown I'm sure to MANY.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Microsoft UltimateTV PVR
AVS › AVS Forum › Gaming & Content Streaming › Microsoft UltimateTV PVR › Can't find v 3.8- UTV stuck at 3.0