or Connect
AVS › lwj81's profile

lwj81

Location:

NC

Forum Post Count:

194

Join Date:

6/3/07

Last Online:

1 day, 2 hours ago

It looks like lwj81 hasn't added anything to their community profile yet.

lwj81's Recent Activity

settings
(Uncheck the summary view to see ALL the gory details!) (Check the summary view to simplify the activity feed.)
Time to play, identify the sub!
lwj81 posted in this thread in Subwoofers, Bass, and Transducers 2/2/14 at 8:21am | 4 replies | 133 views
Help finding AVS subwoffer comparison list
lwj81 posted in this thread in Subwoofers, Bass, and Transducers 4/7/13 at 9:18am | 3 replies | 211 views
MFW-15 Buzz Repair
lwj81 posted in this thread in Subwoofers, Bass, and Transducers 2/24/13 at 7:56am | 3 replies | 295 views
Subwoofer songs - recommendation of the day!
lwj81 posted in this thread in Subwoofers, Bass, and Transducers 10/29/12 at 9:53am | 613 replies | 57414 views
wow a 155 pounds!!!!!!!
lwj81 posted in this thread in Subwoofers, Bass, and Transducers 10/26/12 at 6:06am | 140 replies | 5567 views
Behringer DSP1124P Feedback Destroyer HELP PLEASE
lwj81 posted in this thread in Subwoofers, Bass, and Transducers 6/15/12 at 8:06pm | 1 replies | 591 views
Official Epik Subwoofer Thread
lwj81 posted in this thread in Subwoofers, Bass, and Transducers 5/24/12 at 4:23pm | 20351 replies | 2060833 views
New Empire. Auto-on not working?
lwj81 posted in this thread in Subwoofers, Bass, and Transducers 4/1/12 at 8:47am | 61 replies | 1853 views

 

lwj81's Lists

0 Lists
No lists.

AVS › lwj81's profile