HCFR - Open source projector and display calibration software - Page 45 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 1405Likes
Reply
 
Thread Tools
post #1321 of 11714 Old 01-31-2013, 09:24 PM
AVS Forum Special Member
 
jdbimmer's Avatar
 
Join Date: Jan 2007
Posts: 1,088
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 64 Post(s)
Liked: 46
Quote:
Originally Posted by zoyd View Post

There is some esoteric usb com problem with the i1pro. The current status is:

1. Initial version 3.0.0.0 of the argyll wrapper code works fine with the i1pro but supports only one meter at a time and doesn't support the d3 or colormunki.
2. Versions >3.0.0.0 which support multiple meters (including the d3/colormunki) but throws an error in icoms when trying to open the i1pro. Spotread works fine.
3. If I modify the i1pro inf to include the standard winusb.dll as a required device driver everybody's happy but so far working on win32xp only.
Just to clarify a few things..

In my tests using using your modified (winusb) i1pro.inf, windows can't start the device, so it's doesn't work in Windows 7 with your HCFR build or spotread. I looked at the inf, and as far as I can tell (not my area of expertise), it looks okay, although the related oemxx.inf copies the ptlibusb0 section. This doesn't occur with the (not DTP94, but "C5-ish") MonacoOptix.inf installation, which uses winusb and works fine. I did some googling and found some mention of the i1Pro revision D and later being incompatible with winusb on Windows 7, with some other references to device descriptors and max packet size issues.

I may be confused a little by our usage of "multiple" vs. "simultaenous" meters. The 3.0.4 code I compiled from Git seems to work with multiple meters that I have - the i1Pro, MonacoOptix, and DTP94 using the regular Argyll 1.4 drivers. I don't know if the D3 works since I don't own one yet - but that's the big question. I don't think that build supports simultaneously connected meters, but this is not something I use often, and it can be worked around by unplugging and maybe restartingHCFR.

I would be happy with a build that supports the i1Pro, D3, and other meters separately on Windows 7 using the Argyll 1.40 drivers, and also contained your fix for the D3 stability. Do you think that's possible?

____________________________________________
C8/E8 Questions? Try JCC's_FAQ Or LiQiCE's_Wiki
jdbimmer is offline  
Sponsored Links
Advertisement
 
post #1322 of 11714 Old 02-01-2013, 03:43 AM - Thread Starter
AVS Forum Special Member
 
zoyd's Avatar
 
Join Date: Sep 2006
Location: Planet Dog
Posts: 6,804
Mentioned: 148 Post(s)
Tagged: 0 Thread(s)
Quoted: 1783 Post(s)
Liked: 1348
Sorry for the lack of clarity regarding multiple vs. simultaneous, I've used them interchangeably so yes the current build supports simultaneous meters in the same program instance including the D3 and the i1pro. The D3 meter fix is there regardless of which drivers get loaded so that will work as well.
zoyd is offline  
post #1323 of 11714 Old 02-01-2013, 06:08 AM
AVS Forum Special Member
 
vega509's Avatar
 
Join Date: Apr 2003
Location: The Northeast
Posts: 1,043
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 197 Post(s)
Liked: 55
The Argyll v 1.4 drivers for the i1pro work in Windows7 64 bit, it can be tested using the spotread.exe in the lib directory. HCFR throws an error when trying to access the driver.
vega509 is offline  
post #1324 of 11714 Old 02-01-2013, 06:57 AM
AVS Forum Special Member
 
jdbimmer's Avatar
 
Join Date: Jan 2007
Posts: 1,088
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 64 Post(s)
Liked: 46
Quote:
Originally Posted by zoyd View Post

..so yes the current build supports simultaneous meters in the same program instance including the D3 and the i1pro. .
Yes, in Win XP 32. But we've concluded that this build will not support the i1Pro in Windows 7 with 1.40 libusb0 or winusb drivers.

My point is that I would prefer to forgo the simultaneously connected meters feature if I can have a 3.0.4.x version that supports the (stability fixed) D3 and i1Pro meters in Windows 7. Could you post or PM the adaptive integration changes you made to the D3 code? I'm planning on purchasing a D3, so I would like to add your changes to what I have and see if it works for both meters in Win7.

____________________________________________
C8/E8 Questions? Try JCC's_FAQ Or LiQiCE's_Wiki
jdbimmer is offline  
post #1325 of 11714 Old 02-01-2013, 12:08 PM
Member
 
Spinnenschwein's Avatar
 
Join Date: Dec 2011
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 11
Hello
I have a problem by intalling the Spyder 3 driver

1. Install hcfr
2. Plug in Spyder
3. Selecting Spyder at the device manager
4. Selecting the driver folder

Windows finds the driver, but it didnt install the driver.

I get this Message (german Windows)
http://db.tt/CNmwurbq


It says something like: Cant finde hash , driver damaged.

Its the same on 2 Windows8 x64 machines.

Thanks for your help.
Spinnenschwein is offline  
post #1326 of 11714 Old 02-01-2013, 01:26 PM
AVS Forum Special Member
 
vega509's Avatar
 
Join Date: Apr 2003
Location: The Northeast
Posts: 1,043
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 197 Post(s)
Liked: 55
Quote:
Originally Posted by Spinnenschwein View Post

Hello
I have a problem by intalling the Spyder 3 driver

1. Install hcfr
2. Plug in Spyder
3. Selecting Spyder at the device manager
4. Selecting the driver folder

Windows finds the driver, but it didnt install the driver.

I get this Message (german Windows)
http://db.tt/CNmwurbq


It says something like: Cant finde hash , driver damaged.

Its the same on 2 Windows8 x64 machines.

Thanks for your help.

when you install the driver use the driver in the libusb1 folder in the HCFR directory
vega509 is offline  
post #1327 of 11714 Old 02-01-2013, 01:52 PM
Member
 
Spinnenschwein's Avatar
 
Join Date: Dec 2011
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 11
I cant find the folder frown.gif
I have version 3.0.4.0 installed
Spinnenschwein is offline  
post #1328 of 11714 Old 02-01-2013, 02:20 PM
AVS Forum Special Member
 
vega509's Avatar
 
Join Date: Apr 2003
Location: The Northeast
Posts: 1,043
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 197 Post(s)
Liked: 55
Quote:
Originally Posted by Spinnenschwein View Post

I cant find the folder frown.gif
I have version 3.0.4.0 installed

............ \Colorimeter_HCFR 3\libusb1
vega509 is offline  
post #1329 of 11714 Old 02-01-2013, 03:07 PM
Member
 
Spinnenschwein's Avatar
 
Join Date: Dec 2011
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 11
Thats all in it
http://db.tt/DgAGibrH
Spinnenschwein is offline  
post #1330 of 11714 Old 02-01-2013, 03:27 PM
AVS Forum Special Member
 
LarryInRI's Avatar
 
Join Date: Jun 2007
Location: in Rhode Island
Posts: 5,377
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 19 Post(s)
Liked: 192
Quote:
Originally Posted by Spinnenschwein View Post

Thats all in it
http://db.tt/DgAGibrH


What about in the driver folder:



Larry
LarryInRI is offline  
post #1331 of 11714 Old 02-01-2013, 03:59 PM
Member
 
Spinnenschwein's Avatar
 
Join Date: Dec 2011
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 11
I can just select a folder
Spinnenschwein is offline  
post #1332 of 11714 Old 02-01-2013, 06:10 PM
AVS Forum Special Member
 
vega509's Avatar
 
Join Date: Apr 2003
Location: The Northeast
Posts: 1,043
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 197 Post(s)
Liked: 55
Quote:
Originally Posted by Spinnenschwein View Post

I can just select a folder

you have to select the spider4 driver, Spyd4.inf
vega509 is offline  
post #1333 of 11714 Old 02-01-2013, 11:39 PM
Newbie
 
ganymede123's Avatar
 
Join Date: Jan 2013
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Hi,
I am trying to use HCFR to calibrate my 65lw6500 tv (led backlit lcd tv) with i1 display pro. Am I right to say that I should use the i1D3 NON-refresh display type? How about spectral sample? Does it matter which one i choose? I saw there are 2 LED options: LCD RGB LED IPS and LCD White LED IPS. But the samples seem to be more applicable for computer monitors. Which one should I choose?

thanks a lot for any advice.
ganymede123 is offline  
post #1334 of 11714 Old 02-02-2013, 12:18 AM
AVS Forum Special Member
 
rahzel's Avatar
 
Join Date: Jan 2006
Location: Canada
Posts: 3,645
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 148
Quote:
Originally Posted by ganymede123 View Post

Hi,
I am trying to use HCFR to calibrate my 65lw6500 tv (led backlit lcd tv) with i1 display pro. Am I right to say that I should use the i1D3 NON-refresh display type? How about spectral sample? Does it matter which one i choose? I saw there are 2 LED options: LCD RGB LED IPS and LCD White LED IPS. But the samples seem to be more applicable for computer monitors. Which one should I choose?

thanks a lot for any advice.
Yes, use non-refresh on an LCD.

If your LW6500 is an IPS panel, then I would use the White LED IPS spectral sample. That's what I used on my LG LH90.
rahzel is offline  
post #1335 of 11714 Old 02-02-2013, 02:31 AM
Member
 
Spinnenschwein's Avatar
 
Join Date: Dec 2011
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 11
Quote:
Originally Posted by vega509 View Post

you have to select the spider4 driver, Spyd4.inf
It says no driver found

But why do you get the libusb1 folder?
I downloaded it from here http://sourceforge.net/p/hcfr/wiki/Home/
Spinnenschwein is offline  
post #1336 of 11714 Old 02-02-2013, 04:43 AM - Thread Starter
AVS Forum Special Member
 
zoyd's Avatar
 
Join Date: Sep 2006
Location: Planet Dog
Posts: 6,804
Mentioned: 148 Post(s)
Tagged: 0 Thread(s)
Quoted: 1783 Post(s)
Liked: 1348
Here is a new build which works with both my D3 and i1pro 2 using the ArgyllCMS 1.4 driver code libusb0 instead of winusb0. This version also has the D3 tweaks to improve low-light precision. Update your i1pro drivers from the Drivers directory and let me know if it works on win7.

I can't help with the spyder installation since I don't have one to test but the general procedure for installation is to:

1. Load the Argyll driver using the spyder.inf file from the Drivers directory
2. copy the driver .dll file from the vendor software to the HCFR directory and then run either spyd2en or spyd4en on that file.




HCFRsetup.exe
rahzel likes this.
zoyd is offline  
post #1337 of 11714 Old 02-02-2013, 05:12 AM - Thread Starter
AVS Forum Special Member
 
zoyd's Avatar
 
Join Date: Sep 2006
Location: Planet Dog
Posts: 6,804
Mentioned: 148 Post(s)
Tagged: 0 Thread(s)
Quoted: 1783 Post(s)
Liked: 1348
Quote:
Originally Posted by rahzel View Post

Yes, use non-refresh on an LCD.

Regarding refresh vs. non-refresh mode and the D3. In the current code it makes absolutely no difference which mode you use with LCDs because after failing to find sync it will default to the non-refresh integration time anyway. As for plasmas, I also found it makes no measurable difference which mode you use. The probe will sync to patterns with luma values >40% (~30 Hz is a typical value it finds on my plasma) but measurements with it synced and in non-refresh mode are identical (within probe precision) throughout the gray scale. I made it a little easier to test this in the current code so if you want to sync it with your plasma display:

1. When you open the probe page click calibrate.
2. Display a bright white pattern (50% or more)
3. Take measurements (the probe will retain the measured refresh period until you click calibrate again)
zoyd is offline  
post #1338 of 11714 Old 02-02-2013, 05:34 AM
Member
 
Spinnenschwein's Avatar
 
Join Date: Dec 2011
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 11
Quote:
Originally Posted by zoyd View Post


HCFRsetup.exe
It works with it.
Windows said "driver not signed" so I disabled the signature checking...

Thanks for your help.
Spinnenschwein is offline  
post #1339 of 11714 Old 02-02-2013, 07:49 AM
AVS Forum Special Member
 
vega509's Avatar
 
Join Date: Apr 2003
Location: The Northeast
Posts: 1,043
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 197 Post(s)
Liked: 55
Quote:
Originally Posted by zoyd View Post

Here is a new build which works with both my D3 and i1pro 2 using the ArgyllCMS 1.4 driver code libusb0 instead of winusb0. This version also has the D3 tweaks to improve low-light precision. Update your i1pro drivers from the Drivers directory and let me know if it works on win7.

I can't help with the spyder installation since I don't have one to test but the general procedure for installation is to:

1. Load the Argyll driver using the spyder.inf file from the Drivers directory
2. copy the driver .dll file from the vendor software to the HCFR directory and then run either spyd2en or spyd4en on that file.




HCFRsetup.exe

works on windows 7 64bit. thanks zoyd
vega509 is offline  
post #1340 of 11714 Old 02-02-2013, 10:08 AM
AVS Forum Special Member
 
rahzel's Avatar
 
Join Date: Jan 2006
Location: Canada
Posts: 3,645
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 148
Quote:
Originally Posted by zoyd View Post

Here is a new build which works with both my D3 and i1pro 2 using the ArgyllCMS 1.4 driver code libusb0 instead of winusb0. This version also has the D3 tweaks to improve low-light precision. Update your i1pro drivers from the Drivers directory and let me know if it works on win7.

HCFRsetup.exe
Thanks zoyd.
rahzel is offline  
post #1341 of 11714 Old 02-02-2013, 10:25 AM
AVS Forum Special Member
 
jdbimmer's Avatar
 
Join Date: Jan 2007
Posts: 1,088
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 64 Post(s)
Liked: 46
Quote:
Originally Posted by zoyd View Post

Here is a new build which works with both my D3 and i1pro 2 using the ArgyllCMS 1.4 driver code libusb0 instead of winusb0. This version also has the D3 tweaks to improve low-light precision. Update your i1pro drivers from the Drivers directory and let me know if it works on win7.
Excellent, thanks Zoyd!
Works in Win 7 64 and Win 7 32 bit with i1Pro, DTP94, and original Monaco Optix (c5-ish).

Simultaneous measures work between the DTP94 (w/native xrite driver) and one Argyll device. It doesn't work with my 2 Argyll devices (Monaco Optix/i1Pro), but I rarely find use for this feature - I would rather read the same spot on the display for profiling anyway.

____________________________________________
C8/E8 Questions? Try JCC's_FAQ Or LiQiCE's_Wiki
jdbimmer is offline  
post #1342 of 11714 Old 02-02-2013, 10:52 AM
AVS Forum Special Member
 
vega509's Avatar
 
Join Date: Apr 2003
Location: The Northeast
Posts: 1,043
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 197 Post(s)
Liked: 55
Quote:
Originally Posted by jdbimmer View Post

Excellent, thanks Zoyd!
Works in Win 7 64 and Win 7 32 bit with i1Pro, DTP94, and original Monaco Optix (c5-ish).

Simultaneous measures work between the DTP94 (w/native xrite driver) and one Argyll device. It doesn't work with my 2 Argyll devices (Monaco Optix/i1Pro), but I rarely find use for this feature - I would rather read the same spot on the display for profiling anyway.

simultaneous works for my i1pro and my i1display pro
vega509 is offline  
post #1343 of 11714 Old 02-02-2013, 11:01 AM
AVS Forum Special Member
 
jdbimmer's Avatar
 
Join Date: Jan 2007
Posts: 1,088
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 64 Post(s)
Liked: 46
Quote:
Originally Posted by vega509 View Post

simultaneous works for my i1pro and my i1display pro
That's good news. I'm planning on purchasing the D3 soon. Unfortunately, the $50 rebate expired.

____________________________________________
C8/E8 Questions? Try JCC's_FAQ Or LiQiCE's_Wiki
jdbimmer is offline  
post #1344 of 11714 Old 02-02-2013, 06:24 PM - Thread Starter
AVS Forum Special Member
 
zoyd's Avatar
 
Join Date: Sep 2006
Location: Planet Dog
Posts: 6,804
Mentioned: 148 Post(s)
Tagged: 0 Thread(s)
Quoted: 1783 Post(s)
Liked: 1348
Here is a new build to play around with. It incorporates all of the changes that John had been working on, code optimization and reconfiguring the profiling options. I was able to measure and apply a matrix correction but couldn't manage to save or load one, you can manually enter a matrix correction if needed. I also made CIE94 the default deltaE metric, you can use the original (Luv) calculation by selecting it in the advanced preferences. Also, the ability to use vendor dlls has been reenabled so you run either Argyll or original drivers.


HCFRsetup_CIE94.exe
zoyd is offline  
post #1345 of 11714 Old 02-02-2013, 08:10 PM
AVS Forum Special Member
 
vega509's Avatar
 
Join Date: Apr 2003
Location: The Northeast
Posts: 1,043
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 197 Post(s)
Liked: 55
Quote:
Originally Posted by zoyd View Post

Here is a new build to play around with. It incorporates all of the changes that John had been working on, code optimization and reconfiguring the profiling options. I was able to measure and apply a matrix correction but couldn't manage to save or load one, you can manually enter a matrix correction if needed. I also made CIE94 the default deltaE metric, you can use the original (Luv) calculation by selecting it in the advanced preferences. Also, the ability to use vendor dlls has been reenabled so you run either Argyll or original drivers.


HCFRsetup_CIE94.exe

is it possible to zip the HCFR folder? the install program wants to remove all the other versions.

thanks zoyd
vega509 is offline  
post #1346 of 11714 Old 02-02-2013, 08:37 PM - Thread Starter
AVS Forum Special Member
 
zoyd's Avatar
 
Join Date: Sep 2006
Location: Planet Dog
Posts: 6,804
Mentioned: 148 Post(s)
Tagged: 0 Thread(s)
Quoted: 1783 Post(s)
Liked: 1348
zoyd is offline  
post #1347 of 11714 Old 02-02-2013, 08:51 PM
AVS Forum Special Member
 
vega509's Avatar
 
Join Date: Apr 2003
Location: The Northeast
Posts: 1,043
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 197 Post(s)
Liked: 55
Quote:
Originally Posted by zoyd View Post

no problem - HCFR Calibration.zip

I believe there may be a deltaE calculation error on the grayscale 0% and 10%.

3.0.4.0 cuv


3.0.4.0 cie94


the gamut deltaE looks a little off, but I haven't done the math.

thank you once again for all the time you have put into this.

vega
vega509 is offline  
post #1348 of 11714 Old 02-03-2013, 01:00 AM
Senior Member
 
Make73's Avatar
 
Join Date: Jan 2010
Location: Finland
Posts: 288
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 54 Post(s)
Liked: 60
Quote:
Originally Posted by zoyd View Post

...you can manually enter a matrix correction if needed...

Where i can do that?
Sensor matrix?

I hope we get matrix load/save option back because many use matrix at every measuring.

So i1D3 with plasma should calibrate/sync with 50% IRE window?
Earlier there was instructions that it should be done with 30% IRE window.
Make73 is offline  
post #1349 of 11714 Old 02-03-2013, 02:37 AM - Thread Starter
AVS Forum Special Member
 
zoyd's Avatar
 
Join Date: Sep 2006
Location: Planet Dog
Posts: 6,804
Mentioned: 148 Post(s)
Tagged: 0 Thread(s)
Quoted: 1783 Post(s)
Liked: 1348
Quote:
Originally Posted by vega509 View Post

I believe there may be a deltaE calculation error on the grayscale 0% and 10%.

the gamut deltaE looks a little off, but I haven't done the math.

thank you once again for all the time you have put into this.

vega


grayscale dE uses Luv only which is standard practice so switching between Luv/CIE94 the number should not change. 0% dE needs to be removed in future version.


You are right, gamut dE for CIE94 has an error, will fix later.


@Make73: Sometimes 30% isn't bright enough for the probe to sync, need to add a success indicator somewhere.
zoyd is offline  
post #1350 of 11714 Old 02-03-2013, 06:00 AM
AVS Forum Special Member
 
vega509's Avatar
 
Join Date: Apr 2003
Location: The Northeast
Posts: 1,043
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 197 Post(s)
Liked: 55
Quote:
Originally Posted by Make73 View Post

Where i can do that?
Sensor matrix?

I hope we get matrix load/save option back because many use matrix at every measuring.

So i1D3 with plasma should calibrate/sync with 50% IRE window?
Earlier there was instructions that it should be done with 30% IRE window.

you can enter the sensor matrix in the Measures Sensor Configure panel.
vega509 is offline  
Sponsored Links
Advertisement
 
Reply Display Calibration

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off