NEC NDH-80 Displays "please wait" then shuts down - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 09-08-2010, 01:03 PM - Thread Starter
Newbie
 
DevilsAdvocate#1's Avatar
 
Join Date: Sep 2010
Location: NEWCASTLE, AUSTRALIA
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
my nec ndh-80 hdd/dvd was working fine then froze, rebooted and ever since it just keeps displaying "please wait". It will do this several times then turn off can anyone tell me an easy (or hard) fix, or weather replacing the HDD will help and whats involved in replacing it. thanks heaps....
DevilsAdvocate#1 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 09-08-2010, 05:15 PM
AVS Forum Special Member
 
tomwil's Avatar
 
Join Date: Feb 2008
Posts: 1,356
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Liked: 26
I am not familiar with the NEC recorders, but it sure sounds like it could be a power supply capacitor problem. Check out the following site:

http://www.vassfamily.net/projects/DMRE85H/dmre85h.html

That which may be known of God is evident within man, for God has shown it to them, so that they are without excuse. (Romans 1:19-20)
tomwil is offline  
post #3 of 3 Old 09-09-2010, 09:45 AM - Thread Starter
Newbie
 
DevilsAdvocate#1's Avatar
 
Join Date: Sep 2010
Location: NEWCASTLE, AUSTRALIA
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
thanks heaps mate i'll investigate the capasitors in mine tomorrow, and let you know how it went. cheers again
DevilsAdvocate#1 is offline  
Sponsored Links
Advertisement
 
Reply DVD Recorders (Standard Def)

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off