Klipsch Sub 10 question - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 
Thread Tools
post #1 of 2 Old 09-10-2019, 03:57 PM - Thread Starter
Newbie
 
Join Date: Jun 2015
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 2
Klipsch Sub 10 question

So I replaced my Klipsch Sub 10 with a BIC F12. The BIC is now in my home theater along with a Polk sub. I relocated the Klipsch to my den where I only listen to music, is connected to an older Denon receiver that I don't have the remote for. Don't need it since I don't use it that often and my music sources are streaming so volume and tone controls are handled through the app. I'm not trying to put any more $$ into this system, it's basically for when people come over and party so please don't suggest upgrading the receiver. The Klipsch overpowers the speakers, went to the sub to turn the volume down and discovered that the amp goes off if I move the volume one notch in either direction. I tried for a long time but it only works at two notches from max. Anyone have any idea??
cad700 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old Yesterday, 11:39 AM
AVS Forum Addicted Member
 
Alan P's Avatar
 
Join Date: Jan 2003
Location: South Dakota
Posts: 11,613
Mentioned: 106 Post(s)
Tagged: 0 Thread(s)
Quoted: 6282 Post(s)
Liked: 5614
Pull the plastic volume knob off of the sub amp and try cleaning the potentiometer with some Deoxit or similar electronics cleaner.
Alan P is offline  
Sponsored Links
Advertisement
 
Reply Subwoofers, Bass, and Transducers

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off