Sub hum from baseboard heater - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 
Thread Tools
post #1 of 3 Old 11-13-2019, 06:43 PM - Thread Starter
Advanced Member
 
Jsin_N's Avatar
 
Join Date: Dec 2009
Posts: 766
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 445 Post(s)
Liked: 198
Sub hum from baseboard heater

I have two sub amps on two different breaker that are causing hum when my electric baseboard heater kicks on.

One sub amp is on the same breaker, but the 240 volt amp is not. Both suffer from hum.

Is there anything I can do to remedy this with the baseboard electric heater without running long runs of wire between amp chassis to ground them?

Any other solutions?

I use a minidsp HD, so unfortunately unbalanced cables.

Help. This is annoying.
Jsin_N is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 11-14-2019, 03:19 AM
Senior Member
 
Join Date: Jun 2019
Posts: 203
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 126 Post(s)
Liked: 30
You could try the Emotiva Cmx-2? I haven’t but when I had your problem I was going to try that solution out. If you ever do, let me know if it fixes it for you, thanks.
yodog is online now  
post #3 of 3 Old 11-27-2019, 03:26 AM
AVS Forum Special Member
 
markmon1's Avatar
 
Join Date: Dec 2006
Posts: 6,531
Mentioned: 118 Post(s)
Tagged: 0 Thread(s)
Quoted: 5487 Post(s)
Liked: 3576
What happens if you bypass the miniDSP? What happens if you lift the ground plugs on the sub amps and the miniDSP? If that's not successful, then a blue jeans cable isolation transformer will probably solve it and do so without any other ill effects. The Blue jeans isolation transformer is the only one that I've ever seen that did not also take away some bass.

https://www.amazon.com/Transformer-E.../dp/B00GG1PK5W

Video: JVC RS4500 135" screen in pure black room no light, htpc nvidia 1080ti.
Audio: Anthem mrx720 running 7.1.4, McIntosh MC-303, MC-152, B&W 802d3 LR, B&W HTM1D3 center, B&W 805d3 surround, B&W 702S2 rear, B&W 706s2 x 4 shelf mounted for atmos, 2 sub arrays both infinite baffle: 4x15 fi audio running on behringer ep4000 + 4x12 fi audio running on 2nd ep4000.
markmon1 is offline  
Sponsored Links
Advertisement
 
Reply Subwoofers, Bass, and Transducers

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off