Official OPPO BDP-95 Owner's Thread - Page 400 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 79Likes
Reply
 
Thread Tools
post #11971 of 11995 Old 06-23-2019, 04:48 PM
Newbie
 
Join Date: Jun 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 0
Quote:
Originally Posted by rdgrimes View Post
You may be over-thinking this. Is the player connected to something via HDMI? An HDMI handshake can cause a brief audio dropout on the analog output.
Thanks for the tip, but there is nothing else plugged in.

I'm in Australia, and the support has dried up. The importer doesn't have any spares for the 95.

My next plan is to let it play, and watch the voltages from the power supply, and see if there are any changes that match the audio losses.
Garry Moore is offline  
Sponsored Links
Advertisement
 
post #11972 of 11995 Old 06-25-2019, 03:38 PM
AVS Forum Special Member
 
Jon S's Avatar
 
Join Date: Nov 1999
Location: Sunny Hawaii
Posts: 4,421
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 1119 Post(s)
Liked: 399
It's probably the audio board... My Oppo had similar issues and it had to be replaced...

If it's not a BIG screen, it's not a theater...
Jon S is offline  
post #11973 of 11995 Old 06-26-2019, 04:39 AM
AVS Forum Special Member
 
glangford's Avatar
 
Join Date: Dec 2008
Posts: 3,189
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 708 Post(s)
Liked: 626
Quote:
Originally Posted by Garry Moore View Post
Thanks for the tip, but there is nothing else plugged in.

I'm in Australia, and the support has dried up. The importer doesn't have any spares for the 95.

My next plan is to let it play, and watch the voltages from the power supply, and see if there are any changes that match the audio losses.
Try to find a used player in non working order, scavenge the audio board. Maybe contact Oppo support in the us and see if they'd send you one. (I doubt it, I wanted to buy a spare loader, and no dice.

Supercharged Song Towers, Oppo BDP-203, Anthem MRX-520, LG B6 OLED
Headphone Rig: Oppo BDP-95, Burson Audio Soloist MKII Headphone amp/ Sennheiser HD800S, Sennheiser HD650
glangford is offline  
Sponsored Links
Advertisement
 
post #11974 of 11995 Old 06-28-2019, 04:18 PM
Newbie
 
Join Date: Jun 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 0
Quote:
Originally Posted by Jon S View Post
It's probably the audio board... My Oppo had similar issues and it had to be replaced...
Oppo support have been very generous with answering my questions, and the audio board is something that has been suggested. What symptoms were you getting?

The other possible lead is the main power supply, which sits under a metal cover, and may be failing at higher temperatures.
Garry Moore is offline  
post #11975 of 11995 Old 06-28-2019, 07:33 PM
AVS Forum Special Member
 
Jon S's Avatar
 
Join Date: Nov 1999
Location: Sunny Hawaii
Posts: 4,421
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 1119 Post(s)
Liked: 399
I was getting intermittent audio from the analog and HDMI outputs. Video on the HDMI output was also iffy... Sent to Oppo and they replaced the audio board... They were pretty quick... two days and it was fixed.... I am not sure if Oppo USA will fix overseas units as the parts may be different. You should check with them first...

If it's not a BIG screen, it's not a theater...
Jon S is offline  
post #11976 of 11995 Old 07-16-2019, 09:36 PM
Member
 
tinman143's Avatar
 
Join Date: Dec 2018
Location: Bay Area
Posts: 163
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 67 Post(s)
Liked: 15
How much could I buy a well conditioned unit for these days?
tinman143 is offline  
post #11977 of 11995 Old 07-17-2019, 08:22 AM
AVS Forum Addicted Member
 
rdgrimes's Avatar
 
Join Date: Mar 2004
Location: Nuevo Mexico
Posts: 21,621
Mentioned: 25 Post(s)
Tagged: 0 Thread(s)
Quoted: 3799 Post(s)
Liked: 2994
Quote:
Originally Posted by tinman143 View Post
How much could I buy a well conditioned unit for these days?
We're not supposed to discuss price in this forum. But there are several on eBay at any time. Seems to depend on if its the Darbee variation or not too. Generally speaking $500-700. I wouldn't buy one without the factory packing.
Compared to some of the newer options, these are a terrific value.
tinman143 likes this.
rdgrimes is offline  
post #11978 of 11995 Old 07-18-2019, 02:24 AM
AVS Forum Special Member
 
glangford's Avatar
 
Join Date: Dec 2008
Posts: 3,189
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 708 Post(s)
Liked: 626
Quote:
Originally Posted by rdgrimes View Post
We're not supposed to discuss price in this forum. But there are several on eBay at any time. Seems to depend on if its the Darbee variation or not too. Generally speaking $500-700. I wouldn't buy one without the factory packing.
Compared to some of the newer options, these are a terrific value.
You are thinking of the 105, there was no Darbee option for the 95, just straight BD.

Supercharged Song Towers, Oppo BDP-203, Anthem MRX-520, LG B6 OLED
Headphone Rig: Oppo BDP-95, Burson Audio Soloist MKII Headphone amp/ Sennheiser HD800S, Sennheiser HD650
glangford is offline  
post #11979 of 11995 Old 07-21-2019, 05:40 PM
Member
 
JAM1415's Avatar
 
Join Date: Aug 2011
Location: North Carolina
Posts: 36
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 11
Hi all. I have been using a USB drive on the front of the Oppo just fine. I recently purchased another usb drive, loaded flac files with no problem, but the Oppo will not see this usb. Does it have to be a certain type as I thought they were backwards compatible. I couldn't find anything in the manual. Any ideas? Thanks!
JAM1415 is offline  
post #11980 of 11995 Old 07-21-2019, 06:37 PM
Read the FAQ!
 
Bob Pariseau's Avatar
 
Join Date: Jul 2004
Posts: 35,226
Mentioned: 68 Post(s)
Tagged: 0 Thread(s)
Quoted: 5795 Post(s)
Liked: 8267
Quote:
Originally Posted by JAM1415 View Post
Hi all. I have been using a USB drive on the front of the Oppo just fine. I recently purchased another usb drive, loaded flac files with no problem, but the Oppo will not see this usb. Does it have to be a certain type as I thought they were backwards compatible. I couldn't find anything in the manual. Any ideas? Thanks!
The 95 doesn’t support all types of file systems and partitioning. The drive must be partitioned using the MBR style partitioning table, and the volume created by the partitioning must be formatted as FAT, FAT32, or NTFS. In particular a drive partitioned and formatted in the standard way for an Apple Mac won’t work. You need to repartition and reformat and then reload your files onto the drive.

See Bill’s Unofficial FAQ — link available at the top of the first post of this thread.
—Bob

Need personal consultation/training? Or just curious about my Blog? Check out my web site!
Bob Pariseau is offline  
post #11981 of 11995 Old 07-21-2019, 07:58 PM
Member
 
JAM1415's Avatar
 
Join Date: Aug 2011
Location: North Carolina
Posts: 36
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 11
Thanks Bob!
JAM1415 is offline  
post #11982 of 11995 Old 07-25-2019, 04:26 PM
Member
 
JAM1415's Avatar
 
Join Date: Aug 2011
Location: North Carolina
Posts: 36
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 11
Quote:
Originally Posted by Bob Pariseau View Post
The 95 doesn’t support all types of file systems and partitioning. The drive must be partitioned using the MBR style partitioning table, and the volume created by the partitioning must be formatted as FAT, FAT32, or NTFS. In particular a drive partitioned and formatted in the standard way for an Apple Mac won’t work. You need to repartition and reformat and then reload your files onto the drive.

See Bill’s Unofficial FAQ — link available at the top of the first post of this thread.
—Bob
I meant to be asking about a thumb drive that the Oppo did not recognize -- do the same partition rules apply to those?
JAM1415 is offline  
post #11983 of 11995 Old 07-25-2019, 07:05 PM
AVS Forum Addicted Member
 
rdgrimes's Avatar
 
Join Date: Mar 2004
Location: Nuevo Mexico
Posts: 21,621
Mentioned: 25 Post(s)
Tagged: 0 Thread(s)
Quoted: 3799 Post(s)
Liked: 2994
Quote:
Originally Posted by JAM1415 View Post
I meant to be asking about a thumb drive that the Oppo did not recognize -- do the same partition rules apply to those?
Yes, same.
rdgrimes is offline  
post #11984 of 11995 Old 07-31-2019, 03:01 AM
Newbie
 
Join Date: Jul 2019
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 1
Hi guys!
As a last resort for me, your expertise might help me out of what seems like a dead end! I signed up for AVS forums just to post this.
Last year, I purchased a used Oppo BDP-95 with a regionfree pro modkit. Being in Europe, essentially, I would need it to play back region B disks of course. I have some region A disks, that's why I decided to get one with a regionfree kit.
So far, the device was always set to region B. I used the instructions to set it to region A recently (out of standby, press "1" on the remote) and this worked. After watching the disk, I tried to go back to region B... but yikes, it does not work anymore. I have tried this 20 times, to no avail. Turning on the player out of standby by pressing "2" (as per instructions) sometimes makes the player get stuck on the "Hello" splash screen, OR simply does not change the region as it is supposed to. Region B disks are now refused with the "wrong region code" error message.
I think I read at some point that somebody had a similar issue here, but no actual solution was posted.
Am I doing wrong something essential? Anybody have an idea?

All help would be greatly appreciated!
WrathCollector is offline  
post #11985 of 11995 Old 07-31-2019, 03:21 PM
Read the FAQ!
 
Bob Pariseau's Avatar
 
Join Date: Jul 2004
Posts: 35,226
Mentioned: 68 Post(s)
Tagged: 0 Thread(s)
Quoted: 5795 Post(s)
Liked: 8267
^ Erase Persistent Storage and try again with your Region B disc.

The player may be trying to “resume” the disc, with it jumping right to the error message from the previous failed attempt.
—Bob

Need personal consultation/training? Or just curious about my Blog? Check out my web site!
Bob Pariseau is offline  
post #11986 of 11995 Old 07-31-2019, 11:09 PM
Newbie
 
Join Date: Jul 2019
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 1
Hi Bob!

Thanks for your suggestion, unfortunately it did not work. The menu called up by the button combination 0-7-7-0 also shows that BD region is still set to "A", so the resume feature is not the cause of the issue here. Oppo support also suggested to remove the kit and reset factory defaults - but unlucky me, the Oppo BDP-95 (as opposed to BDP-95EU) seems to have "A" as the factory default!

Best,
Dom
WrathCollector is offline  
post #11987 of 11995 Old 08-01-2019, 06:35 AM
Read the FAQ!
 
Bob Pariseau's Avatar
 
Join Date: Jul 2004
Posts: 35,226
Mentioned: 68 Post(s)
Tagged: 0 Thread(s)
Quoted: 5795 Post(s)
Liked: 8267
^ You have to reinstall the Region Free mod after doing the OPPO Reset Factory Defaults.

If that doesn't do it for you, you'll need to get in touch with whoever sold you that Region Free mod.
--Bob

Need personal consultation/training? Or just curious about my Blog? Check out my web site!
Bob Pariseau is offline  
post #11988 of 11995 Old 08-01-2019, 11:20 PM
Newbie
 
Join Date: Jul 2019
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 1
Hi Bob, hi all,

Are you sure that reinstalling the mod after resetting factory defaults will make any difference? I have worked through the defaulting procedure with the mod installed and without, and it didn't change anything. Since the firmwares of player and mod seem independent, did this really do the trick in some cases before?
I purchased the player used from a private person, already including the mod. And not surprisingly, when I reported the issues to the seller, nothing was ever heard from him again. Not sure if he knew about this error or just wanted to spare himself the troubleshooting!

Best,
Dom
WrathCollector is offline  
post #11989 of 11995 Old 08-02-2019, 05:34 AM
Read the FAQ!
 
Bob Pariseau's Avatar
 
Join Date: Jul 2004
Posts: 35,226
Mentioned: 68 Post(s)
Tagged: 0 Thread(s)
Quoted: 5795 Post(s)
Liked: 8267
^ The player is of course locked to its home Region for Blu-ray discs when the mod is not installed.

I don’t know if the mod you have is working properly, but it can’t possibly work when it is not installed.

Given that doing the Erase Persistent Storage trick did not fix the problem your best bet is to try resetting the player. The full Monty on this would be:

1) Remove any disc in the tray
2) Power off and remove the mod
3) Power up and Reset the player
4) Turn the player off and back on again
5) Get a fresh copy of the player firmware for install via USB stick from the OPPO Support page for the player
6) Re-install the player firmware from that USB stick
7) Reset the player once again
8) Turn the player off and back on again
9) Power off and re-install the mod

—Bob

Need personal consultation/training? Or just curious about my Blog? Check out my web site!
Bob Pariseau is offline  
post #11990 of 11995 Old 08-02-2019, 10:21 AM
AVS Forum Addicted Member
 
rdgrimes's Avatar
 
Join Date: Mar 2004
Location: Nuevo Mexico
Posts: 21,621
Mentioned: 25 Post(s)
Tagged: 0 Thread(s)
Quoted: 3799 Post(s)
Liked: 2994
Quote:
Originally Posted by WrathCollector View Post
Hi Bob, hi all,

Are you sure that reinstalling the mod after resetting factory defaults will make any difference? I have worked through the defaulting procedure with the mod installed and without, and it didn't change anything. Since the firmwares of player and mod seem independent, did this really do the trick in some cases before?
I purchased the player used from a private person, already including the mod. And not surprisingly, when I reported the issues to the seller, nothing was ever heard from him again. Not sure if he knew about this error or just wanted to spare himself the troubleshooting!

Best,
Dom
FWIW there are a number of mods available for sale that you can use with the 95. One can be installed externally to the serial port on the player. Here's one from a reputable seller: https://www.ebay.com/itm/OPPO-DIGITA...ss!87123!US!-1
Note that this mod can actually be used on any of the Oppo BD players.
rdgrimes is offline  
post #11991 of 11995 Old 08-03-2019, 03:48 AM
Newbie
 
Join Date: Jul 2019
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 1
Hi all,
Bob and rdgrimes, thanks for your suggestions. @rdgrimes : I was somewhat expecting that this would be the final word on trying to "save my player" - to get the standard modkit on top of my pro mod, hoping that one will successfully change the region again. I get from reading many posts that the kit you linked is in fact more "reliable". Since it would be an investment of another 100+ dollars, I am a bit insecure if it will work properly on my player.

@Bob : Does the Oppo fully update the firmware when it already has the latest version installed? I did as you suggested, followed steps 1-8 so far. The player prompted me to update the "BD loader" software. Is that a full firmware upgrade or did it only do a part of the process?
I have not yet reinstalled the mod, as when I removed it, one of the plastic lids fixing the flat band cable broke off. I am a bit worried I might not get it back in afterwards, which would render the player unusable.


Best,
Dom
WrathCollector is offline  
post #11992 of 11995 Old 08-03-2019, 05:43 AM
Read the FAQ!
 
Bob Pariseau's Avatar
 
Join Date: Jul 2004
Posts: 35,226
Mentioned: 68 Post(s)
Tagged: 0 Thread(s)
Quoted: 5795 Post(s)
Liked: 8267
^ Do the Install From USB again. If you already have the same versions installed, the player should ask if you want to re-install each piece. That’s what you are looking for. Select Yes each time you are asked.
—Bob

Need personal consultation/training? Or just curious about my Blog? Check out my web site!
Bob Pariseau is offline  
post #11993 of 11995 Old 08-05-2019, 12:08 AM
Newbie
 
Join Date: Jul 2019
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 1
Hi Bob,
that is odd. I have downloaded the latest update file from the Oppo homepage, but when I put it on the USB and plug it in (all files contained in the archive), prompting the USB install, it will always only mention the "BD loader" update and nothing else. I assume this is only one of the multiple "pieces" contained in the update archive, and that it should do more than that? I have done this update 3 times, I cannot get it to prompt me for more.

Best,
Dom
WrathCollector is offline  
post #11994 of 11995 Old 08-05-2019, 05:04 AM
Read the FAQ!
 
Bob Pariseau's Avatar
 
Join Date: Jul 2004
Posts: 35,226
Mentioned: 68 Post(s)
Tagged: 0 Thread(s)
Quoted: 5795 Post(s)
Liked: 8267
^ Get in touch with OPPO Tech Support. You can use the Email Us link on OPPO’s support page for the player. If the update from USB repeatedly states that the Loader firmware on the USB is newer then something is broken in your update process.
—Bob

Need personal consultation/training? Or just curious about my Blog? Check out my web site!
Bob Pariseau is offline  
post #11995 of 11995 Old 08-09-2019, 02:38 AM
Newbie
 
Join Date: Jul 2019
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 1
Hi Bob!
Thanks for your great suggestion - got in touch with Oppo support and you were right, I mistakenly tried to use the EU firmware update file before. Support provided me with the fitting US files and this worked in its entirety now! I will try to open up the player again and reconnect the regionfree kit. I don't have much hope it will work. Fingers crossed I can get the player back together even with that one plastic lid broken off!

Dom
Bob Pariseau likes this.
WrathCollector is offline  
Sponsored Links
Advertisement
 
Reply Blu-ray Players

Tags
Blu Ray Players , Oppo , Oppo Bdp 95 Blu Ray Disc Player

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off