Official Samsung UBD-K8500 4K HDR Ultra HD Blu-Ray Player Owner's Thread - Page 231 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 40336Likes
Reply
 
Thread Tools
post #6901 of 14196 Old 06-05-2016, 06:29 PM
AVS Forum Special Member
 
Musician's Avatar
 
Join Date: Nov 2014
Location: Canada
Posts: 4,196
Mentioned: 184 Post(s)
Tagged: 0 Thread(s)
Quoted: 2642 Post(s)
Liked: 5236
Quote:
Originally Posted by ray0414 View Post
Anybody else having avr issues?

This thing annoys me on a daily basis still. Apps, bds, uhd bds, don't matter. Anytime I pause/rw/FW, my AVR switches inputs and needs to be manually changed back.
Yes!!

The only workaround I have found at this point is going into the player's Settings >> System >> Anynet+ (HDMI-CEC) and turning it Off.

Considering that we both have Samsung TV's and pretty decent AVR's it's a shame that Anynet+ has to be disabled to avoid these issues.

Hopefully this is resolved in the next Firmware Update.
mc_avs likes this.

Samsung UN78HU9000 & SEK-3500U/ZA - Firmware 1540.3
Samsung UN40HU7000 & SEK-3500U/ZA - Firmware 1540.3
Samsung UBD-K8500 UHD Blu-ray Player; Apple TV 4K
Arris VIP5662W UHD Whole Home DVR; Chromecast Ultra
Marantz SR7005 Receiver; Magnepan Speakers; Martin Logan Subwoofer
Musician is offline  
Sponsored Links
Advertisement
 
post #6902 of 14196 Old 06-05-2016, 10:31 PM
Member
 
Steven James 2's Avatar
 
Join Date: Oct 2015
Posts: 142
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 120 Post(s)
Liked: 32
Quote:
Originally Posted by cmdrdredd View Post
Strangely the effect only occurs on 1080p discs.


I agree its quite strange. I dont even know where to begin to fix the issue. I just hope samsung is aware of the issue and working on a fix!
Steven James 2 is offline  
post #6903 of 14196 Old 06-05-2016, 11:31 PM
Newbie
 
tool2010's Avatar
 
Join Date: Nov 2009
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 10
Hello,
I am owner of a Samsung JS9000 TV. What settings have i to change for the Samsung K8500 ?
UHD Color.......
And what Settings in the Samsung K8500 ?

Best regards Jürgen
tool2010 is offline  
Sponsored Links
Advertisement
 
post #6904 of 14196 Old 06-06-2016, 04:14 AM
Newbie
 
tool2010's Avatar
 
Join Date: Nov 2009
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 10
Quote:
Originally Posted by tool2010 View Post
Hello,
I am owner of a Samsung JS9000 TV. What settings have i to change for the Samsung K8500 ?
UHD Color.......
And what Settings in the Samsung K8500 ?

Best regards Jürgen
Can i use any HDMI Input ? 1,2,3 or 4 at my JS9000 ??
tool2010 is offline  
post #6905 of 14196 Old 06-06-2016, 04:56 AM
Advanced Member
 
DaMacFunkin's Avatar
 
Join Date: Mar 2008
Location: Manchester, Not the one by the sea
Posts: 862
Mentioned: 27 Post(s)
Tagged: 0 Thread(s)
Quoted: 629 Post(s)
Liked: 418
Quote:
Originally Posted by rlb View Post
Since you mention pbrowne, the following applies to your comments about native: https://www.avsforum.com/forum/member...-p5browne.html
I'm not sure what I'm supposed to be looking at with that link, just come out and say it, there is no need to be coy.
DaMacFunkin is offline  
post #6906 of 14196 Old 06-06-2016, 07:15 AM
AVS Forum Addicted Member
 
ray0414's Avatar
 
Join Date: Feb 2011
Location: michigan
Posts: 16,690
Mentioned: 255 Post(s)
Tagged: 0 Thread(s)
Quoted: 12560 Post(s)
Liked: 11741
Quote:
Originally Posted by Musician View Post
Yes!!

The only workaround I have found at this point is going into the player's Settings >> System >> Anynet+ (HDMI-CEC) and turning it Off.

Considering that we both have Samsung TV's and pretty decent AVR's it's a shame that Anynet+ has to be disabled to avoid these issues.

Hopefully this is resolved in the next Firmware Update.
Thanks I'll give this a try later today! And disadvantages with turning off Anynet+?
ray0414 is online now  
post #6907 of 14196 Old 06-06-2016, 11:11 AM
AVS Forum Special Member
 
Musician's Avatar
 
Join Date: Nov 2014
Location: Canada
Posts: 4,196
Mentioned: 184 Post(s)
Tagged: 0 Thread(s)
Quoted: 2642 Post(s)
Liked: 5236
Quote:
Originally Posted by ray0414 View Post
Thanks I'll give this a try later today! And disadvantages with turning off Anynet+?
With Anynet+ turned on in the player settings it would turn on automatically when I switched to the input it is plugged into and I could use either the TV remote or the K8500 remote without having to point it directly at the player.

Disadvantages for sure but beats the crap out of constantly having to reach for my AVR remote!

Samsung UN78HU9000 & SEK-3500U/ZA - Firmware 1540.3
Samsung UN40HU7000 & SEK-3500U/ZA - Firmware 1540.3
Samsung UBD-K8500 UHD Blu-ray Player; Apple TV 4K
Arris VIP5662W UHD Whole Home DVR; Chromecast Ultra
Marantz SR7005 Receiver; Magnepan Speakers; Martin Logan Subwoofer
Musician is offline  
post #6908 of 14196 Old 06-06-2016, 11:22 AM
rlb
AVS Forum Special Member
 
rlb's Avatar
 
Join Date: Apr 2002
Location: OH
Posts: 6,211
Mentioned: 60 Post(s)
Tagged: 0 Thread(s)
Quoted: 2250 Post(s)
Liked: 1900
Quote:
Originally Posted by DaMacFunkin View Post
I'm not sure what I'm supposed to be looking at with that link, just come out and say it, there is no need to be coy.

I've never been accused of being coy and don't believe I was this time. I recommended that another poster use several settings, including "native", to get close to the correct HDR picture. You jumped in, said that you calibrate (but not as same level as pbrowne); then pointed out how your calibrations show "native" provides bad results and a calibrated "custom" is the correct way to do it (i.e., I gave a bad recommendation).


My post/link pointed to where pbrowne recommends "native" (i.e., you pronouncement may not have been the absolute fact you thought it was). I referenced his post since you had mention him; but I can find many, many posts on these threads recommending the use of "native".


Surprised you didn't get most of the above from reading the link; but hope this helps.

Edit: As someone points out on a later post, I linked to pbrowne's profile page, not the post itself. Sorry about that! First mistake I ever made.

Sony XBR75Z9D, Samsung 65F9000 , Yamaha CX-A5200 & Outlaw 770
Samsung K8500, OPPO 103-D, Genie 2 and C61Ks, Roku Ultra, ATV4K, and Harmony Elite

Last edited by rlb; 06-07-2016 at 05:30 AM.
rlb is offline  
post #6909 of 14196 Old 06-06-2016, 11:56 AM
Senior Member
 
williamwallace's Avatar
 
Join Date: Apr 2016
Posts: 352
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 273 Post(s)
Liked: 379
Quote:
Originally Posted by rlb View Post
My post/link pointed to where pbrowne recommends "native" (i.e., you pronouncement may not have been the absolute fact you thought it was). I referenced his post since you had mention him; but I can find many, many posts on these threads recommending the use of "native".


Surprised you didn't get most of the above from reading the link; but hope this helps.
FWIW, when I click that link it goes to pbrowne's "About Me" profile page, not to a specific post about using "native." So if the other gentleman experienced the same thing, it may explain his confusion.
rlb likes this.
williamwallace is offline  
post #6910 of 14196 Old 06-06-2016, 12:27 PM
Member
 
Agentbolt's Avatar
 
Join Date: Oct 2007
Posts: 129
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 58 Post(s)
Liked: 45
Hey, so can anyone help me out with this? My father-in-law purchased us a birthday present, a UBD-K8500 Blu-Ray player. We were super excited to try it out, however we're unable to get the new UHD player functionining properly. We're plugging it into a JU7100 65"

To rule out other variables, I just have the k8500 connected cirectly to the TV. I'm using one of these HDMI cables:

http://www.monoprice.com/category?c_...&cs_id=1024008

The problem is that as soon as the K8500 tries to output in 4K, I lose signal. I've confirmed this by setting the resolution manually, if I set it to 1080p then everything works fine (including playing a 4K disk of Mad Max, it just outputs at 1080p). If I set the resolution to 2160p, the whole screen goes blank and I get the "no signal" screen. If I set it to "Auto", the menu screen works fine, it just goes blank as soon as the movie tries to play.

On the TV, I've tried enabling HDMI UHD color, and turning on/off BD Wise. I had the JS Mod installed on the TV so I uninstalled it just in case that was causing the issue. I then did a factory reset on the TV. I also have tried plugging the L8500 into both HDMI1 and HDMI3 on the One connect mini box. Nothing worked.

On the player itself, I tried turning off/on BD Wise, changing the output resolution (as mentioned above) and I've tried both a Mad Max 4K disk and a USB drive with the SUHD HDR demo video downloaded to it. The demo video on the flash drive plays just fine when plugged into the TV itself.

Since I can play 4K content on the TV itself without an issue (via a flash drive plugged into the back) I'm guessing it's the K8500 that's borked? I have had an issue with the OC mini box where an HDMI cord won't register as being plugged in. The finicky connection appears to be the cord from the TV to the box, at the box itself. If I unplug and plug back in the black OC cord into the box itself, very firmly, everything works fine. It just seems a little finicky.

I'm assuming the HDMI cord I'm using shouldn't be the issue, I've tried two other types just to be sure and they both had the same issue. I have the receipt and the K8500 boxed back up, my father in law was nice enough to keep the receipt and give it to us. Right now, my guess is that I should just try to swap out the K8500, but I'm wondering if any of you see a different problem before I do that after work today.

Thanks!
Agentbolt is offline  
post #6911 of 14196 Old 06-06-2016, 04:11 PM
Senior Member
 
gparris's Avatar
 
Join Date: Jun 2005
Location: Caledonia, WI
Posts: 367
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 44 Post(s)
Liked: 33
Quote:
Originally Posted by Agentbolt View Post
Hey, so can anyone help me out with this? My father-in-law purchased us a birthday present, a UBD-K8500 Blu-Ray player. We were super excited to try it out, however we're unable to get the new UHD player functionining properly. We're plugging it into a JU7100 65"

To rule out other variables, I just have the k8500 connected cirectly to the TV. I'm using one of these HDMI cables:

http://www.monoprice.com/category?c_...&cs_id=1024008

The problem is that as soon as the K8500 tries to output in 4K, I lose signal. I've confirmed this by setting the resolution manually, if I set it to 1080p then everything works fine (including playing a 4K disk of Mad Max, it just outputs at 1080p). If I set the resolution to 2160p, the whole screen goes blank and I get the "no signal" screen. If I set it to "Auto", the menu screen works fine, it just goes blank as soon as the movie tries to play.

On the TV, I've tried enabling HDMI UHD color, and turning on/off BD Wise. I had the JS Mod installed on the TV so I uninstalled it just in case that was causing the issue. I then did a factory reset on the TV. I also have tried plugging the L8500 into both HDMI1 and HDMI3 on the One connect mini box. Nothing worked.

On the player itself, I tried turning off/on BD Wise, changing the output resolution (as mentioned above) and I've tried both a Mad Max 4K disk and a USB drive with the SUHD HDR demo video downloaded to it. The demo video on the flash drive plays just fine when plugged into the TV itself.

Since I can play 4K content on the TV itself without an issue (via a flash drive plugged into the back) I'm guessing it's the K8500 that's borked? I have had an issue with the OC mini box where an HDMI cord won't register as being plugged in. The finicky connection appears to be the cord from the TV to the box, at the box itself. If I unplug and plug back in the black OC cord into the box itself, very firmly, everything works fine. It just seems a little finicky.

I'm assuming the HDMI cord I'm using shouldn't be the issue, I've tried two other types just to be sure and they both had the same issue. I have the receipt and the K8500 boxed back up, my father in law was nice enough to keep the receipt and give it to us. Right now, my guess is that I should just try to swap out the K8500, but I'm wondering if any of you see a different problem before I do that after work today.

Thanks!
I have a 75JU7100 and the K8500 player and thought I had a good HDMI cable, but it did the same thing when I tried playing 4K Blu-ray Discs and 4K streaming, too. The link you show only references 1080p, not 2160p (4K) rating, which should always be 18 Gbps not any less to allow for 4K pass thru. Once I got the 18Gbps rated HDMI connected directly to the One-Connect box on the Samsung TV from the player's Main output (I use BDwise, my preference), it worked. I don't really think your HDMI cable is rated correctly.
dmercer3 likes this.
gparris is offline  
post #6912 of 14196 Old 06-06-2016, 04:27 PM
AVS Forum Special Member
 
Rudy1's Avatar
 
Join Date: Oct 2000
Location: Ft. Lauderdale, FL
Posts: 5,744
Mentioned: 189 Post(s)
Tagged: 0 Thread(s)
Quoted: 1960 Post(s)
Liked: 3259
Agentbolt,

gparris is correct...the cable you're using is the problem as it is only rated for 1080p. I have used the one in the link below with excellent results (just be mindful to connect the end labeled "SOURCE" to the HDMI 1 port on the BDP and you should be okay):

http://www.monoprice.com/product?c_i...seq=1&format=2

Definition of "Stupid": Knowing the truth, seeing the truth, but still believing the lies.
Rudy1 is offline  
post #6913 of 14196 Old 06-06-2016, 04:51 PM
Member
 
Agentbolt's Avatar
 
Join Date: Oct 2007
Posts: 129
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 58 Post(s)
Liked: 45
Quote:
Originally Posted by Rudy1 View Post
Agentbolt,

gparris is correct...the cable you're using is the problem as it is only rated for 1080p. I have used the one in the link below with excellent results (just be mindful to connect the end labeled "SOURCE" to the HDMI 1 port on the BDP and you should be okay):

http://www.monoprice.com/product?c_i...seq=1&format=2
Huh, interesting. I'll definitely try it out! Although I gotta say, it's a bit annoying that everything I read said "4K doesn't need new cables" when in reality what should have been said was "Only purchase cables rated for 4K even though technically they should all be the same"
Agentbolt is offline  
post #6914 of 14196 Old 06-06-2016, 05:28 PM
AVS Forum Special Member
 
bluemoon737's Avatar
 
Join Date: Mar 2007
Location: Portsmouth, NH
Posts: 3,725
Mentioned: 24 Post(s)
Tagged: 0 Thread(s)
Quoted: 2204 Post(s)
Liked: 2705
Quote:
Originally Posted by Musician View Post
Yes!!

The only workaround I have found at this point is going into the player's Settings >> System >> Anynet+ (HDMI-CEC) and turning it Off.

Considering that we both have Samsung TV's and pretty decent AVR's it's a shame that Anynet+ has to be disabled to avoid these issues.

Hopefully this is resolved in the next Firmware Update.
Never met a CEC implementation I didn't like.

(Hopefully my sarcasm is dripping enough )
Musician and williamwallace like this.

-Jeff-
Man cave: Sony XBR75Z9D, Marantz SR8012, and OPPO UDP-203
Living room: Sony XBR75X950G, Denon x4500, and Sony UBP-X800M2
bluemoon737 is online now  
post #6915 of 14196 Old 06-06-2016, 05:58 PM
Member
 
larry2456's Avatar
 
Join Date: Feb 2007
Posts: 140
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 66 Post(s)
Liked: 35
Quote:
Originally Posted by gparris View Post
I have a 75JU7100 and the K8500 player and thought I had a good HDMI cable, but it did the same thing when I tried playing 4K Blu-ray Discs and 4K streaming, too. The link you show only references 1080p, not 2160p (4K) rating, which should always be 18 Gbps not any less to allow for 4K pass thru. Once I got the 18Gbps rated HDMI connected directly to the One-Connect box on the Samsung TV from the player's Main output (I use BDwise, my preference), it worked. I don't really think your HDMI cable is rated correctly.
I'm having the exact same problem as Agentbolt. The menu comes on and then the movie starts and goes blank, only audio is heard. If I use the remote and do a quick change of inputs on the AVR (move it to a different input, then back to the Samsung), the picture comes back and stays on. The cables I'm currently using were purchased from Monoprice and, though I can't be certain, I'm almost positive I purchased them with 4K in mind so I believe I bought the 18Gbs-rated. Can't remember and be absolutely sure though. So, for a little over $24, I'm giving a new set of cables a chance. I just now purchased two 4K-rated 18Gbs gold-plated 10-foot cables off Amazon, made by a company named Mediabridge. Not very expensive, only $12 each, so I hope they're adequate. Has anyone else used this brand and are they any good?

http://smile.amazon.com/Mediabridge-...ilpage_o00_s00

You know what they say about expensive HDMI cables not making much of a difference. Anyway, I'll change both the cable from the player to the AVR and from the AVR to the TV. If that doesn't work, the player's going back and I'll wait for the Panasonic or, even better, the Oppo 4K player (hopefully released before the holidays).

I appreciate the advise going around on the forum about having the right cables because I DO think that's probably the issue on mine.
larry2456 is offline  
post #6916 of 14196 Old 06-06-2016, 06:36 PM
Member
 
larry2456's Avatar
 
Join Date: Feb 2007
Posts: 140
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 66 Post(s)
Liked: 35
Ok, so I guess there's way to set this player so it allows the TV to do the upscaling when playing 1080p, except to go into the settings every time and selecting 1080p output resolution. I searched the entire forum and just find this strange? Also, playing an HDR 4K disc and forcing the output resolution to 1080p (in this case, letting the TV upscale a native 4K disc, which no one would ever do) it still kicks the HDR in and it looks great. To clarify, I'm forcing a 1080p signal to my TV from a native 4K HDR-encoded disc and the HDR kicks in and works just like it would if I were sending the full 4K to the TV. Does anyone else find that strange? Doesn't this then imply that normal 1080p blu-ray discs can be encoded with HDR if they wanted them to?

If anyone knows a quicker way to allow the TV to do the upscaling on a normal 1080p blu-ray instead of the player (other than going into the settings and manually making that setting every time), please advise. I can't really tell quite honestly if the TV IS better at upscaling but I assume it is. It's a Sony XBR-X850C 4K TV. Anyone know which would be better at upscaling? Ok, that's really two questions.

Thanks!
larry2456 is offline  
post #6917 of 14196 Old 06-06-2016, 07:37 PM
Advanced Member
 
tomcrown1's Avatar
 
Join Date: May 2008
Posts: 854
Mentioned: 13 Post(s)
Tagged: 0 Thread(s)
Quoted: 558 Post(s)
Liked: 263
Quote:
Originally Posted by larry2456 View Post
I'm having the exact same problem as Agentbolt. The menu comes on and then the movie starts and goes blank, only audio is heard. If I use the remote and do a quick change of inputs on the AVR (move it to a different input, then back to the Samsung), the picture comes back and stays on. The cables I'm currently using were purchased from Monoprice and, though I can't be certain, I'm almost positive I purchased them with 4K in mind so I believe I bought the 18Gbs-rated. Can't remember and be absolutely sure though. So, for a little over $24, I'm giving a new set of cables a chance. I just now purchased two 4K-rated 18Gbs gold-plated 10-foot cables off Amazon, made by a company named Mediabridge. Not very expensive, only $12 each, so I hope they're adequate. Has anyone else used this brand and are they any good?



http://smile.amazon.com/Mediabridge-...ilpage_o00_s00



You know what they say about expensive HDMI cables not making much of a difference. Anyway, I'll change both the cable from the player to the AVR and from the AVR to the TV. If that doesn't work, the player's going back and I'll wait for the Panasonic or, even better, the Oppo 4K player (hopefully released before the holidays).



I appreciate the advise going around on the forum about having the right cables because I DO think that's probably the issue on mine.


It could be a problem with how samsung tvs handle HDMI input or their maybe a problem with the player. What firmware is the Samsung player On? On firmware 1004 had issues with HDMI handshake. Firmware 1005 supposedly fixed the problem. It did not for me. I have to wait 10 minutes for video handshake to happen.

Next month both Phillips and Panasonic will have their 4k player available.

If you're interested in the Panasonic player I would suggest you try to read the thread on the Panasonic player


Samsung 65hu9000
Samsung K8500
Arcam AVR550

Samsung un659000/SEK-3500
tomcrown1 is offline  
post #6918 of 14196 Old 06-06-2016, 08:36 PM
UHD Addict
 
aaronwt's Avatar
 
Join Date: Aug 2001
Location: Northern VA(Woodbridge)
Posts: 35,646
Mentioned: 65 Post(s)
Tagged: 0 Thread(s)
Quoted: 9099 Post(s)
Liked: 5845
Quote:
Originally Posted by larry2456 View Post
Ok, so I guess there's way to set this player so it allows the TV to do the upscaling when playing 1080p, except to go into the settings every time and selecting 1080p output resolution. I searched the entire forum and just find this strange? Also, playing an HDR 4K disc and forcing the output resolution to 1080p (in this case, letting the TV upscale a native 4K disc, which no one would ever do) it still kicks the HDR in and it looks great. To clarify, I'm forcing a 1080p signal to my TV from a native 4K HDR-encoded disc and the HDR kicks in and works just like it would if I were sending the full 4K to the TV. Does anyone else find that strange? Doesn't this then imply that normal 1080p blu-ray discs can be encoded with HDR if they wanted them to?

If anyone knows a quicker way to allow the TV to do the upscaling on a normal 1080p blu-ray instead of the player (other than going into the settings and manually making that setting every time), please advise. I can't really tell quite honestly if the TV IS better at upscaling but I assume it is. It's a Sony XBR-X850C 4K TV. Anyone know which would be better at upscaling? Ok, that's really two questions.

Thanks!
There is no native output resolution function with the K8500. So if you want it to send 1080P you will need to go into the settings to manually change. Personally I just leave mine on auto and let the player always send 2160. I'm not about to go into the settings everytime I put in a 1080P BD to change the resolution.

53TB unRAID1a--49TB unRAID2--76TB unRAID3
TCL 6 Series--Sony UBP-X800--Philips BDP7502--Onkyo HT-S7800
XBL/PSN: WormholeXtreme
aaronwt is online now  
post #6919 of 14196 Old 06-07-2016, 04:30 AM
AVS Forum Special Member
 
mt14942's Avatar
 
Join Date: May 2007
Location: Pembroke Pines, Florida
Posts: 2,261
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 751 Post(s)
Liked: 225
Quote:
Originally Posted by aaronwt View Post
There is no native output resolution function with the K8500. So if you want it to send 1080P you will need to go into the settings to manually change. Personally I just leave mine on auto and let the player always send 2160. I'm not about to go into the settings everytime I put in a 1080P BD to change the resolution.
Quote:
Originally Posted by larry2456 View Post
Ok, so I guess there's way to set this player so it allows the TV to do the upscaling when playing 1080p, except to go into the settings every time and selecting 1080p output resolution. I searched the entire forum and just find this strange? Also, playing an HDR 4K disc and forcing the output resolution to 1080p (in this case, letting the TV upscale a native 4K disc, which no one would ever do) it still kicks the HDR in and it looks great. To clarify, I'm forcing a 1080p signal to my TV from a native 4K HDR-encoded disc and the HDR kicks in and works just like it would if I were sending the full 4K to the TV. Does anyone else find that strange? Doesn't this then imply that normal 1080p blu-ray discs can be encoded with HDR if they wanted them to?

If anyone knows a quicker way to allow the TV to do the upscaling on a normal 1080p blu-ray instead of the player (other than going into the settings and manually making that setting every time), please advise. I can't really tell quite honestly if the TV IS better at upscaling but I assume it is. It's a Sony XBR-X850C 4K TV. Anyone know which would be better at upscaling? Ok, that's really two questions.

Thanks!

It is as Aaron said you have to manually change the resolution in the player to 1080P if you want the TV to do the upscaling. I have the Sony 940C TV and I would think that the TV would do a better job of upscaling but I honestly have not really critically compared between the player and the TV I am just leaving the player at 2160 so I don't have to remember to switch it back when I play a 4K disc. I have not ever played a 4K disc in the Samsung 4K player with the resolution set at 1080P but might just try it to see if it does HDR. I believe I read somewhere that Netflix was thinking about having shows that were 1080P with HDR so it wouldn't require as much bandwidth. As of yet they have not done that and only presently have one show Marco Polo with HDR and it is at 2160 resolution but I have to watch this thru my TV as the Samsung 4K player doesn't do HDR with Netflix yet. Supposedly a firmware update for that is coming soon.

Sony 75xZ9D
Sony UBP-X800 4K player
Oppo UDP-205 4k player
Classe SSP-800 pre/pro
Parasound Halo 5 channel Amp
mt14942 is offline  
post #6920 of 14196 Old 06-07-2016, 05:22 AM
rlb
AVS Forum Special Member
 
rlb's Avatar
 
Join Date: Apr 2002
Location: OH
Posts: 6,211
Mentioned: 60 Post(s)
Tagged: 0 Thread(s)
Quoted: 2250 Post(s)
Liked: 1900
Quote:
Originally Posted by aaronwt View Post
There is no native output resolution function with the K8500. So if you want it to send 1080P you will need to go into the settings to manually change. Personally I just leave mine on auto and let the player always send 2160. I'm not about to go into the settings everytime I put in a 1080P BD to change the resolution.
Unless you have a Samsung TV and turn-on "BD Wise" on the player. It then outputs at the native resolution. If you do, suggest you don't turn-on "BD Wise" on the display. This allows you to maintain control of settings instead of letting "BD Wise" automatically setting up per Samsung's desires.

Sony XBR75Z9D, Samsung 65F9000 , Yamaha CX-A5200 & Outlaw 770
Samsung K8500, OPPO 103-D, Genie 2 and C61Ks, Roku Ultra, ATV4K, and Harmony Elite
rlb is offline  
post #6921 of 14196 Old 06-07-2016, 02:03 PM
Senior Member
 
gparris's Avatar
 
Join Date: Jun 2005
Location: Caledonia, WI
Posts: 367
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 44 Post(s)
Liked: 33
Quote:
Originally Posted by Musician View Post
The crazy part is that it is Version 4.113, exactly the same version number updated Feb 15, 2016.

Want to hear something even crazier? I happen to have a photo of the screen taken before the upgrade as per the attached thumbnail.
That is insane, I wonder if it is Netflix or Samsung doing this repeat, non-update thing, or both? Maybe its a total lack of communication on their part. I like the Amazon HDR shows enough to enjoy their HDR pictures, but Netflix seems to have a lot more 4K offerings included in the subscription than Amazon, or shows I like more, so if Netflix and Amazon ever truly DO the update for the K8500 like Amazon has, it will appreciated, but come on, no more tricks!
gparris is offline  
post #6922 of 14196 Old 06-07-2016, 02:57 PM
Advanced Member
 
ReSultZ's Avatar
 
Join Date: Aug 2007
Posts: 581
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 215 Post(s)
Liked: 118
Is Samsung ever going to update the terrible UI?
It needs......

More Apps (Vudu 4K etc)
The ability to customize what is on the main page ie add/remove what you want.
ReSultZ is offline  
post #6923 of 14196 Old 06-07-2016, 04:36 PM
AVS Forum Special Member
 
dreaux's Avatar
 
Join Date: May 2006
Location: Washington DC
Posts: 2,056
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 575 Post(s)
Liked: 673
Quote:
Originally Posted by tomcrown1 View Post
It could be a problem with how samsung tvs handle HDMI input or their maybe a problem with the player. What firmware is the Samsung player On? On firmware 1004 had issues with HDMI handshake. Firmware 1005 supposedly fixed the problem. It did not for me. I have to wait 10 minutes for video handshake to happen.

Next month both Phillips and Panasonic will have their 4k player available.

If you're interested in the Panasonic player I would suggest you try to read the thread on the Panasonic player


Samsung 65hu9000
Samsung K8500
Arcam AVR550

I see the PanasonicDMP-UB900 is available for Pre-order for $700. What exactly is in the Panasonic that makes it cost almost twice what the K8500 costs.
I have read the reviews and it get a glowing recommendation in both audio and PQ but $700?
dreaux is online now  
post #6924 of 14196 Old 06-07-2016, 04:45 PM
AVS Forum Addicted Member
 
Dan Hitchman's Avatar
 
Join Date: Jul 2000
Location: Northern Colorado
Posts: 14,431
Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 4503 Post(s)
Liked: 2566
Quote:
Originally Posted by dreaux View Post
I see the PanasonicDMP-UB900 is available for Pre-order for $700. What exactly is in the Panasonic that makes it cost almost twice what the K8500 costs.
I have read the reviews and it get a glowing recommendation in both audio and PQ but $700?
If it was an Oppo with Dolby Vision support, I could see that as the price, but not that Panasonic! Waaaaaay over priced considering the Samsung is really, really waaaaaay overpriced as well (it's a $250 player on its best day).

Listen up, studios! Dolby Atmos Lite™ print-outs must stop!!
Dan Hitchman is offline  
post #6925 of 14196 Old 06-07-2016, 05:43 PM
Member
 
marc1006's Avatar
 
Join Date: Nov 2013
Posts: 54
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Liked: 11
Is there a way to turn upscaling off for 1080P movies on this player?
marc1006 is offline  
post #6926 of 14196 Old 06-07-2016, 06:09 PM
AVS Forum Special Member
 
Musician's Avatar
 
Join Date: Nov 2014
Location: Canada
Posts: 4,196
Mentioned: 184 Post(s)
Tagged: 0 Thread(s)
Quoted: 2642 Post(s)
Liked: 5236
Quote:
Originally Posted by ReSultZ View Post
Is Samsung ever going to update the terrible UI?
It needs......

More Apps (Vudu 4K etc)
The ability to customize what is on the main page ie add/remove what you want.
Unfortunately I can't fix the UI, nor can I add more apps, but I can help you out by providing you with instructions on how to customize what is on the main page (i.e. add/remove what you want).

Although the RECOMMENDED section is based on Samsung's selections and the order they want them to appear, the MY APPS section are customizable based on how you have them ordered under the SAMSUNG APPS menu.

From the Home screen click on SAMSUNG APPS and once you are in that screen navigate to the MY APPS section.

1. On the MY APPS section, select the app you want to move, and then press the OK button for 3 seconds (see attached thumbnail).

2. Select Move, and then press the OK button.

3. Use the buttons to move the app.

4. When the app is where you want it, press the OK.

For additional details refer to page 42 and 43 of the manual which can be downloaded here...

http://downloadcenter.samsung.com/co...00-ZA_1203.pdf
Attached Thumbnails
Click image for larger version

Name:	image.jpg
Views:	143
Size:	173.3 KB
ID:	1485017  

Samsung UN78HU9000 & SEK-3500U/ZA - Firmware 1540.3
Samsung UN40HU7000 & SEK-3500U/ZA - Firmware 1540.3
Samsung UBD-K8500 UHD Blu-ray Player; Apple TV 4K
Arris VIP5662W UHD Whole Home DVR; Chromecast Ultra
Marantz SR7005 Receiver; Magnepan Speakers; Martin Logan Subwoofer
Musician is offline  
post #6927 of 14196 Old 06-07-2016, 06:29 PM
AVS Forum Special Member
 
Musician's Avatar
 
Join Date: Nov 2014
Location: Canada
Posts: 4,196
Mentioned: 184 Post(s)
Tagged: 0 Thread(s)
Quoted: 2642 Post(s)
Liked: 5236
Quote:
Originally Posted by marc1006 View Post
Is there a way to turn upscaling off for 1080P movies on this player?

Yes! Anything else I could help you with?

Thank you for reaching out to Samsung Support.


_____________________________

Go into the K8500's Settings >> Picture >> Resolution and change it to 1080p.

Don't forget to change it back to 2160p or Auto afterwards to view 4K content.

If you have a Samsung TV it is possible to use the Player's BD Wise feature to toggle the resolution automatically depending on the type of disc loaded. Details on this are included in the following post of mine which also includes an overview of the affects of the various UBD-K8500 Resolution settings:

Post 5302: https://www.avsforum.com/forum/149-bl...l#post43484850
rlb, MALICIOUS ONE and galonzo like this.

Samsung UN78HU9000 & SEK-3500U/ZA - Firmware 1540.3
Samsung UN40HU7000 & SEK-3500U/ZA - Firmware 1540.3
Samsung UBD-K8500 UHD Blu-ray Player; Apple TV 4K
Arris VIP5662W UHD Whole Home DVR; Chromecast Ultra
Marantz SR7005 Receiver; Magnepan Speakers; Martin Logan Subwoofer

Last edited by Musician; 06-07-2016 at 07:03 PM. Reason: Typo
Musician is offline  
post #6928 of 14196 Old 06-07-2016, 07:15 PM
UHD Addict
 
aaronwt's Avatar
 
Join Date: Aug 2001
Location: Northern VA(Woodbridge)
Posts: 35,646
Mentioned: 65 Post(s)
Tagged: 0 Thread(s)
Quoted: 9099 Post(s)
Liked: 5845
Quote:
Originally Posted by marc1006 View Post
Is there a way to turn upscaling off for 1080P movies on this player?
Manually set the output for 1080P.

53TB unRAID1a--49TB unRAID2--76TB unRAID3
TCL 6 Series--Sony UBP-X800--Philips BDP7502--Onkyo HT-S7800
XBL/PSN: WormholeXtreme
aaronwt is online now  
post #6929 of 14196 Old 06-07-2016, 09:14 PM
Senior Member
 
Kazz063's Avatar
 
Join Date: Feb 2007
Location: Australia
Posts: 226
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 103 Post(s)
Liked: 102
Is anyone using the Monoprice Cabernet Ultra CL2 Active High Speed HDMI 35ft Cable, for 4K between the K8500 and the JVC X5000/7000/9000?

If so how are you finding it?
Kazz063 is offline  
post #6930 of 14196 Old 06-07-2016, 10:02 PM
AVS Forum Special Member
 
Cam1977's Avatar
 
Join Date: Apr 2016
Location: El paso
Posts: 5,290
Mentioned: 31 Post(s)
Tagged: 0 Thread(s)
Quoted: 2964 Post(s)
Liked: 3568
Quote:
Originally Posted by Dan Hitchman View Post
If it was an Oppo with Dolby Vision support, I could see that as the price, but not that Panasonic! Waaaaaay over priced considering the Samsung is really, really waaaaaay overpriced as well (it's a $250 player on its best day).
Exactly! And thank goodness I found my old sammy remote because the one that comes with this is terrible!
Cam1977 is online now  
Sponsored Links
Advertisement
 
Reply Blu-ray Players

Tags
color calibration , hdr player , member , settings

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off