Official Samsung UBD-K8500 4K HDR Ultra HD Blu-Ray Player Owner's Thread - Page 280 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 40366Likes
Reply
 
Thread Tools
post #8371 of 14222 Old 08-09-2016, 08:22 AM
Advanced Member
 
TomWheeler's Avatar
 
Join Date: Aug 2004
Location: Raleigh, NC
Posts: 561
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 190 Post(s)
Liked: 108
Quote:
Originally Posted by pevco View Post
Sure would like to see new firmware to work with the Sony 665 ES projector.
Picture way to dark and to much red etc.
Blu-ray good , 4K very bad.
The latest firmware update to the Sony 665ES projector (version 2.203 if I recall correctly) has mostly resolved the issues that you refer to. I own both the Sony 665ES and the Samsung K8500 and I am now getting what I consider to be a very good, albeit not quite perfect, image for UHD blu-ray discs played on the K8500 and viewed on the 665ES. I have found thatin laying UHD blu-ray discs on the Samsung K8500 one needs to invoke the Tools Menu >Picture Mode>User>Custom settings and adjust the birghtness and contrast settings to get a picture that is not too dark while still retaining shadow detail and excellent blacks. The red push of the K8500 used with the 665ES has been largely solved with the referred to update for the 665ES, but you may wish to adjust the Tint controls in the Tools Menu as described above. Note that the Tools Menu is only available when a UHD blu-ray disc is playing or paused. Remember also that you must go into the 66ES Menu and set color space to Bt. 2020 when playing UHD blu-ray discs as this is not done automatically.

Using these adjustments I am able to leave all of my settings for the 65ES (other than color space) in the same positions that I use for "normal" viewing of broadcst and other material. If I wish to watch a standard blu-ray disc, I go into the Samsung K8500 Tools Menu and set Picture Mode back to Standard or Movie.

I urge you to be sure that you have installed the latest firmware update on your 665ES and that you give the procedures I have suggested a try as they made a huge improvement in my enjoyment of UHD blu-ray movies. The only problem I have remaining is that ocassionally in the very brightnest parts of the on screen image, I do have occasional blown out highlights but these occur very rarely, in small areas, and are not overly objectionable to me.

Tom
Rudy1 likes this.
TomWheeler is offline  
Sponsored Links
Advertisement
 
post #8372 of 14222 Old 08-09-2016, 08:23 AM
AVS Forum Special Member
 
Musician's Avatar
 
Join Date: Nov 2014
Location: Canada
Posts: 4,226
Mentioned: 185 Post(s)
Tagged: 0 Thread(s)
Quoted: 2656 Post(s)
Liked: 5319
Quote:
Originally Posted by jrogers View Post
For me, two reasons: audio quality and HDR (hopefully for Netflix soon as well)
We posted at the exact same time!

Yes, DD+ and I didn't want to appear over anxious but also looking forward to Netflix HDR.

Which reminds me, some guys TV's don't support HDR via the Amazon app so another reason they might want to use the K8500.

I need a coffee!

jrogers and MALICIOUS ONE like this.

Samsung UN78HU9000 & SEK-3500U/ZA - Firmware 1540.3
Samsung UN40HU7000 & SEK-3500U/ZA - Firmware 1540.3
Samsung UBD-K8500 UHD Blu-ray Player; Apple TV 4K
Arris VIP5662W UHD Whole Home DVR; Chromecast Ultra
Marantz SR7005 Receiver; Magnepan Speakers; Martin Logan Subwoofer
Musician is offline  
post #8373 of 14222 Old 08-09-2016, 09:01 AM
Advanced Member
 
marine92104's Avatar
 
Join Date: Nov 2006
Posts: 755
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 306 Post(s)
Liked: 144
Quote:
Originally Posted by fatherom View Post
I'm curious. Why don't you just use the native apps on the tv? That's what I do and they play perfectly.
I have a 7.1 sound system. On a lot of shows on Netflix I only get stereo sound from the TV apps. Thru the Samsung I get Dolby Digital Plus sound & 5.1 sound.

Big difference. I really wish the LG OLED offered Dolby Digital Plus & at least 5.1 sound. The interface with Netflix is a lot better on the TV.
fatherom likes this.
marine92104 is offline  
Sponsored Links
Advertisement
 
post #8374 of 14222 Old 08-09-2016, 09:47 AM
Member
 
Jerod Keller's Avatar
 
Join Date: Jul 2016
Posts: 58
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 60 Post(s)
Liked: 14
I apologize if anyone else in here has asked this question, because frankly I didn't search through all 280 pages. Has anyone else had an issue with the Netflix app on this player not properly reverting back to the menu or the main Netflix screen after watching a movie/TV show? For example, I watched Stranger Things via the player's Netflix app, and as long as I allowed the show to progress from one episode to the next without interrupting it, everything worked just fine. But, if I tried to stop the progression to the next episode after watching and want to go back to the menu or to the main screen, Netflix would just halt at a blank, black screen. Nothing would work and no combination of stop or go-back, etc would do anything. The only resolution is to power down the player and turn it back and go back into the Netflix app. This is pretty consistent and happens after everything I watch.
namirkhan and jackstar7 like this.
Jerod Keller is offline  
post #8375 of 14222 Old 08-09-2016, 11:16 AM
Newbie
 
Join Date: Jun 2016
Location: Melbourne Florida
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 0
Playing Blue Ray and UHD

Quote:
Originally Posted by Steven James 2 View Post
Has anyone had any issues playing regular blu rays? Uhd blu rays play fine but watching regular blu rays i get at least one drop out to black per movie for about 6-8 seconds. Cant seem to figure it out.
I have tried several Blue Ray disks and they all work great. Upscaling to 4K is very good. I have also bought 3 UHD disks. Star Trek and Revenant work fine. Sicario would not load. I returned it to Best Buy and got another. It would not load either. I took the second one back. BB tried it on one of their players on the floor. It didn't load either. I exchanged it for Mad Max and it works OK.

Has anyone else had problems with Sicario?
CountMike is offline  
post #8376 of 14222 Old 08-09-2016, 11:18 AM
AVS Forum Addicted Member
 
Dan Hitchman's Avatar
 
Join Date: Jul 2000
Location: Northern Colorado
Posts: 14,629
Mentioned: 32 Post(s)
Tagged: 0 Thread(s)
Quoted: 4636 Post(s)
Liked: 2703
Quote:
Originally Posted by CountMike View Post
I have tried several Blue Ray disks and they all work great. Upscaling to 4K is very good. I have also bought 3 UHD disks. Star Trek and Revenant work fine. Sicario would not load. I returned it to Best Buy and got another. It would not load either. I took the second one back. BB tried it on one of their players on the floor. It didn't load either. I exchanged it for Mad Max and it works OK.

Has anyone else had problems with Sicario?
Sicario will not load on mine either. I went through two and both times it wouldn't load. All my other UHD discs do. I have to wonder if the pressing plant used pumped out a bunch of duds for Lionsgate.

Listen up, studios! Dolby Atmos Lite™ print-outs must stop!!
Dan Hitchman is offline  
post #8377 of 14222 Old 08-09-2016, 01:10 PM
Member
 
rockhound76s's Avatar
 
Join Date: Mar 2012
Posts: 93
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 50 Post(s)
Liked: 25
^^
I've played the Sicario UHD disc more than any of the others I own, and have never had any playback issues. This is my second K8500 player and didn't have this issue with either of them.
rockhound76s is online now  
post #8378 of 14222 Old 08-09-2016, 01:12 PM
AVS Forum Addicted Member
 
Dan Hitchman's Avatar
 
Join Date: Jul 2000
Location: Northern Colorado
Posts: 14,629
Mentioned: 32 Post(s)
Tagged: 0 Thread(s)
Quoted: 4636 Post(s)
Liked: 2703
Quote:
Originally Posted by rockhound76s View Post
^^
I've played the Sicario UHD disc more than any of the others I own, and have never had any playback issues. This is my second K8500 player and didn't have this issue with either of them.
You've been lucky. Where did you purchase your copy?

Like I stated above, it's probably that quite a few duds are floating around. Either that or the player has very low tolerances for data errors.

Listen up, studios! Dolby Atmos Lite™ print-outs must stop!!
Dan Hitchman is offline  
post #8379 of 14222 Old 08-09-2016, 01:17 PM
Member
 
rockhound76s's Avatar
 
Join Date: Mar 2012
Posts: 93
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 50 Post(s)
Liked: 25
Quote:
Originally Posted by Dan Hitchman View Post
You've been lucky. Where did you purchase your copy?

Like I stated above, it's probably that quite a few duds are floating around. Either that or the player has very low tolerances for data errors.
Fry's Electronics in Sunnyvale CA. Makes sense if it was a bad pressing, I've had that happen with a bluray once before.
rockhound76s is online now  
post #8380 of 14222 Old 08-09-2016, 01:19 PM
AVS Forum Special Member
 
cmdrdredd's Avatar
 
Join Date: Apr 2002
Location: FL
Posts: 7,103
Mentioned: 39 Post(s)
Tagged: 0 Thread(s)
Quoted: 4254 Post(s)
Liked: 4545
Quote:
Originally Posted by Dan Hitchman View Post
You've been lucky. Where did you purchase your copy?

Like I stated above, it's probably that quite a few duds are floating around. Either that or the player has very low tolerances for data errors.


My copy if sicario was from Best Buy and I never had trouble. I have seen that title mentioned more than once as being problematic though.

LG 65" B7A OLED, Samsung 55" JS9000, Sony 43" x800e, Denon AVR-X2200w 5.1.2, PS4 Pro, Nintendo Switch, Gaming PC(GTX 1080ti + 4.7Ghz 8700k), Sony UBP-x800, Philips BDP-7501, Oppo BDP-203, Nvidia Shield TV
2x Elac F5/Elac C5/2x AR PS2052/2x Pioneer SP-T22A-LR/Power Sound Audio 15v w/ Anti-Mode 8033S-II
cmdrdredd is offline  
post #8381 of 14222 Old 08-09-2016, 01:20 PM
AVS Forum Special Member
 
cmdrdredd's Avatar
 
Join Date: Apr 2002
Location: FL
Posts: 7,103
Mentioned: 39 Post(s)
Tagged: 0 Thread(s)
Quoted: 4254 Post(s)
Liked: 4545
Quote:
Originally Posted by marine92104 View Post
I have a 7.1 sound system. On a lot of shows on Netflix I only get stereo sound from the TV apps. Thru the Samsung I get Dolby Digital Plus sound & 5.1 sound.



Big difference. I really wish the LG OLED offered Dolby Digital Plus & at least 5.1 sound. The interface with Netflix is a lot better on the TV.


Odd, my Samsung gives me 5.1 options for every show that has 5.1. If it's stereo it's because there is no 5.1 release on Netflix. Dunno why your app works differently on the tv.

LG 65" B7A OLED, Samsung 55" JS9000, Sony 43" x800e, Denon AVR-X2200w 5.1.2, PS4 Pro, Nintendo Switch, Gaming PC(GTX 1080ti + 4.7Ghz 8700k), Sony UBP-x800, Philips BDP-7501, Oppo BDP-203, Nvidia Shield TV
2x Elac F5/Elac C5/2x AR PS2052/2x Pioneer SP-T22A-LR/Power Sound Audio 15v w/ Anti-Mode 8033S-II
cmdrdredd is offline  
post #8382 of 14222 Old 08-09-2016, 01:35 PM
AVS Forum Special Member
 
Ralarcon's Avatar
 
Join Date: Jul 2003
Posts: 1,132
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 332 Post(s)
Liked: 245
Quote:
Originally Posted by Jerod Keller View Post
I apologize if anyone else in here has asked this question, because frankly I didn't search through all 280 pages. Has anyone else had an issue with the Netflix app on this player not properly reverting back to the menu or the main Netflix screen after watching a movie/TV show? For example, I watched Stranger Things via the player's Netflix app, and as long as I allowed the show to progress from one episode to the next without interrupting it, everything worked just fine. But, if I tried to stop the progression to the next episode after watching and want to go back to the menu or to the main screen, Netflix would just halt at a blank, black screen. Nothing would work and no combination of stop or go-back, etc would do anything. The only resolution is to power down the player and turn it back and go back into the Netflix app. This is pretty consistent and happens after everything I watch.
Wow, what a pain in the @$$ ! That has not happened to me. At least not up to now.

Cheers
Ralarcon is offline  
post #8383 of 14222 Old 08-09-2016, 01:46 PM
AVS Forum Special Member
 
Rudy1's Avatar
 
Join Date: Oct 2000
Location: Ft. Lauderdale, FL
Posts: 5,750
Mentioned: 190 Post(s)
Tagged: 0 Thread(s)
Quoted: 1966 Post(s)
Liked: 3270
Quote:
Originally Posted by Jerod Keller View Post
I apologize if anyone else in here has asked this question, because frankly I didn't search through all 280 pages. Has anyone else had an issue with the Netflix app on this player not properly reverting back to the menu or the main Netflix screen after watching a movie/TV show? For example, I watched Stranger Things via the player's Netflix app, and as long as I allowed the show to progress from one episode to the next without interrupting it, everything worked just fine. But, if I tried to stop the progression to the next episode after watching and want to go back to the menu or to the main screen, Netflix would just halt at a blank, black screen. Nothing would work and no combination of stop or go-back, etc would do anything. The only resolution is to power down the player and turn it back and go back into the Netflix app. This is pretty consistent and happens after everything I watch.
Log out of your account on the BDP, then log in to your Netflix account on a computer, and set up your prefs so that the next episode in a series doesn't automatically play. While you're in there, you may want to make any other desirable changes to your preferences (subtitles, fonts, etc.). And keep in mind that the REWIND and FAST FORWARD buttons aren't really meant for streaming. With Netflix, for example, press PLAY/PAUSE (or ENTER, depending on your device) to access the onscreen transport functions, then use the LEFT/RIGHT arrow keys on your remote to move around within the stream.

Definition of "Stupid": Knowing the truth, seeing the truth, but still believing the lies.
Rudy1 is offline  
post #8384 of 14222 Old 08-09-2016, 01:53 PM
Member
 
Jerod Keller's Avatar
 
Join Date: Jul 2016
Posts: 58
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 60 Post(s)
Liked: 14
Quote:
Originally Posted by Rudy1 View Post
Log out of your account on the BDP, then log in to your Netflix account on a computer, and set up your prefs so that the next episode in a series doesn't automatically play. While you're in there, you may want to make any other desirable changes to your preferences (subtitles, fonts, etc.). And keep in mind that the REWIND and FAST FORWARD buttons aren't really meant for streaming. With Netflix, for example, press PLAY/PAUSE (or ENTER, depending on your device) to access the onscreen transport functions, then use the LEFT/RIGHT arrow keys on your remote to move around within the stream.
Sure, I will try this as well. Just for reference, this also happen when I finish a movie and attempt to press the STOP button during the credits. The screen will flicker as if it is going to return to the menu screen, but just stops at a black screen and will not respond any further until rebooted.
Jerod Keller is offline  
post #8385 of 14222 Old 08-09-2016, 01:58 PM
AVS Forum Special Member
 
Rudy1's Avatar
 
Join Date: Oct 2000
Location: Ft. Lauderdale, FL
Posts: 5,750
Mentioned: 190 Post(s)
Tagged: 0 Thread(s)
Quoted: 1966 Post(s)
Liked: 3270
Quote:
Originally Posted by Jerod Keller View Post
Sure, I will try this as well. Just for reference, this also happen when I finish a movie and attempt to press the STOP button during the credits. The screen will flicker as if it is going to return to the menu screen, but just stops at a black screen and will not respond any further until rebooted.
Netflix did this repeatedly with my Roku 4, so I never use that device anymore. I don't think I've ever owned a single TV or device where, at one point or another, Netflix didn't do something weird or unexpected.

Definition of "Stupid": Knowing the truth, seeing the truth, but still believing the lies.
Rudy1 is offline  
post #8386 of 14222 Old 08-09-2016, 02:42 PM
Advanced Member
 
DVD MAN's Avatar
 
Join Date: Oct 2002
Location: Marlboro, NJ
Posts: 972
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 231 Post(s)
Liked: 113
Black Crush on the Samsung.
I had to add +4 on the brightness user setting picture mode to correct.
DVD MAN is offline  
post #8387 of 14222 Old 08-09-2016, 02:59 PM
Newbie
 
John Webb's Avatar
 
Join Date: Oct 2002
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Have a 940D to be delivered week from Friday. Week before last weekend BB had the K8500 on sale so we purchased one. As the 15 day return policy will expire before we take delivery on the 940D, is there any issue or problem in hooking it up to our current tv that will do 1080, to make sure it 's functioning correctly. Didn't know if there is a set up issue or not when using a non 4k monitor.
John Webb is offline  
post #8388 of 14222 Old 08-09-2016, 03:21 PM
AVS Forum Special Member
 
cmdrdredd's Avatar
 
Join Date: Apr 2002
Location: FL
Posts: 7,103
Mentioned: 39 Post(s)
Tagged: 0 Thread(s)
Quoted: 4254 Post(s)
Liked: 4545
Quote:
Originally Posted by DVD MAN View Post
Black Crush on the Samsung.

I had to add +4 on the brightness user setting picture mode to correct.


That is your display or the settings you set on the k8500. I never got black crush unless I mismatched rgb black levels.

LG 65" B7A OLED, Samsung 55" JS9000, Sony 43" x800e, Denon AVR-X2200w 5.1.2, PS4 Pro, Nintendo Switch, Gaming PC(GTX 1080ti + 4.7Ghz 8700k), Sony UBP-x800, Philips BDP-7501, Oppo BDP-203, Nvidia Shield TV
2x Elac F5/Elac C5/2x AR PS2052/2x Pioneer SP-T22A-LR/Power Sound Audio 15v w/ Anti-Mode 8033S-II
cmdrdredd is offline  
post #8389 of 14222 Old 08-09-2016, 03:41 PM
Member
 
tor ove's Avatar
 
Join Date: Feb 2005
Location: Norway, Bergen
Posts: 166
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 62 Post(s)
Liked: 28
Quote:
Originally Posted by John Webb View Post
Have a 940D to be delivered week from Friday. Week before last weekend BB had the K8500 on sale so we purchased one. As the 15 day return policy will expire before we take delivery on the 940D, is there any issue or problem in hooking it up to our current tv that will do 1080, to make sure it 's functioning correctly. Didn't know if there is a set up issue or not when using a non 4k monitor.
No problem. It will output at 1080p.
And if you play an UHD-disc, it will tell you that your display doesn't support 4k HDR, and it will show the disc in 1080p settings.

BUT.....
I've previously had 2 K8500 failing on me, now on my third. And knock on wood, this seems to be working.
And the others failed me watching UHD-discs. My theory is, the UHD-discs stresses the player more. My first player froze ocasionally and required a restart.
My second player froze more often, ending up as a brick only starting up with lots of colors and a harsh buzzing noise.
AND......my third player seems ok. And my theory expands.
The two first players, I could not hear the fan-noise. My third player, and I can hear it.
Did my previous 2 player have faulty fans, not cooling enough, and toasting the players?.
Or has Samsung upped the fan speed on some players?
I've read somewhere that the first K8500 players were bundled with The Martian UHD-disc for early adopters. My two first players were from this bundle. (Here in Norway).
They both failed on me. My third player was a production outside this bundle offer.
So maybe it is a newer player with another fan, more fan-speed or whatever. It works and has never frozen once on me.
tor ove is offline  
post #8390 of 14222 Old 08-09-2016, 04:09 PM
Advanced Member
 
DVD MAN's Avatar
 
Join Date: Oct 2002
Location: Marlboro, NJ
Posts: 972
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 231 Post(s)
Liked: 113
My display is the JVC RS 500U.
Having the Samsung set to YUV the Samsung crushes black. When set to RGB it does not.
DVD MAN is offline  
post #8391 of 14222 Old 08-09-2016, 04:32 PM
Advanced Member
 
acefr's Avatar
 
Join Date: Dec 2007
Posts: 851
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 584 Post(s)
Liked: 530
Quote:
Originally Posted by CountMike View Post
I have tried several Blue Ray disks and they all work great. Upscaling to 4K is very good. I have also bought 3 UHD disks. Star Trek and Revenant work fine. Sicario would not load. I returned it to Best Buy and got another. It would not load either. I took the second one back. BB tried it on one of their players on the floor. It didn't load either. I exchanged it for Mad Max and it works OK.

Has anyone else had problems with Sicario?
I played Sicario UHD on my K8500, no issues at all. Probably a bad batch from BB.
acefr is offline  
post #8392 of 14222 Old 08-09-2016, 04:44 PM
AVS Forum Special Member
 
cmdrdredd's Avatar
 
Join Date: Apr 2002
Location: FL
Posts: 7,103
Mentioned: 39 Post(s)
Tagged: 0 Thread(s)
Quoted: 4254 Post(s)
Liked: 4545
Quote:
Originally Posted by DVD MAN View Post
My display is the JVC RS 500U.
Having the Samsung set to YUV the Samsung crushes black. When set to RGB it does not.
You can probably find additional help in the RS500 thread. There have been some firmware updates as well.

LG 65" B7A OLED, Samsung 55" JS9000, Sony 43" x800e, Denon AVR-X2200w 5.1.2, PS4 Pro, Nintendo Switch, Gaming PC(GTX 1080ti + 4.7Ghz 8700k), Sony UBP-x800, Philips BDP-7501, Oppo BDP-203, Nvidia Shield TV
2x Elac F5/Elac C5/2x AR PS2052/2x Pioneer SP-T22A-LR/Power Sound Audio 15v w/ Anti-Mode 8033S-II
cmdrdredd is offline  
post #8393 of 14222 Old 08-10-2016, 12:49 AM
Member
 
Join Date: May 2016
Location: Denmark
Posts: 102
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 69 Post(s)
Liked: 6
Quote:
Originally Posted by tor ove View Post
No problem. It will output at 1080p.
And if you play an UHD-disc, it will tell you that your display doesn't support 4k HDR, and it will show the disc in 1080p settings.

BUT.....
I've previously had 2 K8500 failing on me, now on my third. And knock on wood, this seems to be working.
And the others failed me watching UHD-discs. My theory is, the UHD-discs stresses the player more. My first player froze ocasionally and required a restart.
My second player froze more often, ending up as a brick only starting up with lots of colors and a harsh buzzing noise.
AND......my third player seems ok. And my theory expands.
The two first players, I could not hear the fan-noise. My third player, and I can hear it.
Did my previous 2 player have faulty fans, not cooling enough, and toasting the players?.
Or has Samsung upped the fan speed on some players?
I've read somewhere that the first K8500 players were bundled with The Martian UHD-disc for early adopters. My two first players were from this bundle. (Here in Norway).
They both failed on me. My third player was a production outside this bundle offer.
So maybe it is a newer player with another fan, more fan-speed or whatever. It works and has never frozen once on me.
same experience I had..
Bought the bundle when the player was launched.
I couldnt believe how bad a player it was... Noisy,, froze etc. I returned it.
Now I have waited a few month and bought one again.. (no bundle)
It is much better than the first one.. nice and quiet and responce quickly.

Regarding settings.. I have read that if you have a Samsung 2016 TV (I have a KS9000) you should not do any settings on the player..
The player and TV will recognize each other perfectly.
mbm1000 is offline  
post #8394 of 14222 Old 08-10-2016, 09:19 AM
AVS Forum Special Member
 
cobolisdead's Avatar
 
Join Date: Aug 2007
Location: Prattville, AL
Posts: 2,036
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 53 Post(s)
Liked: 29
Woot! My Samsung UHD Pack is going to be here today! I can't wait to see how the movies and documentaries look played through the player!

Quis custodiet ipsos custodes?
cobolisdead is offline  
post #8395 of 14222 Old 08-10-2016, 11:02 AM
UHD Addict
 
aaronwt's Avatar
 
Join Date: Aug 2001
Location: Northern VA(Woodbridge)
Posts: 35,964
Mentioned: 71 Post(s)
Tagged: 0 Thread(s)
Quoted: 9318 Post(s)
Liked: 6002
Quote:
Originally Posted by cobolisdead View Post
Woot! My Samsung UHD Pack is going to be here today! I can't wait to see how the movies and documentaries look played through the player!
So this works directly with the K8500 without needing a Samsung UHD TV?

53TB unRAID1a--49TB unRAID2--76TB unRAID3
TCL 6 Series--Sony UBP-X800--Philips BDP7502--Onkyo HT-S7800
XBL/PSN: WormholeXtreme
aaronwt is offline  
post #8396 of 14222 Old 08-10-2016, 11:18 AM
AVS Forum Special Member
 
claw's Avatar
 
Join Date: Jun 2001
Location: L'Etoile du Nord
Posts: 2,955
Mentioned: 82 Post(s)
Tagged: 0 Thread(s)
Quoted: 2319 Post(s)
Liked: 2174
Quote:
Originally Posted by aaronwt View Post
So this works directly with the K8500 without needing a Samsung UHD TV?
Yes. At least the second version of the pack that I have.
aaronwt likes this.

CJ
JVC RS500|LG B7A OLED|Denon X6400H/X4200W|Panasonic UB820|Two Oppo 203|Samsung K8500|Apple TV 4K|HDfury Diva/Vertex/Linker/Integral
claw is offline  
post #8397 of 14222 Old 08-10-2016, 11:23 AM
Member
 
Join Date: Oct 2015
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 31 Post(s)
Liked: 4
Picked up the K8500 last weekend and finally got around to setting it up last night. I've read through some of this forum and decided to follow the recommended settings in Post #1.

Hooked the HDMI up directly to the LG EF9500 OLED and everything worked fine. HDR kicked in when playing the deadpool UHD BD. When I tried to change the color settings from Auto to YCbCr 4:4:4, the screen cut out and I got the no source detected message. Had to hard reset the player to get it back to factory settings.

Is this an issue with my HDMI cable or settings on the Tv and/or sammy player? Hopefully its not the HDMI as the current cables are run through the wall behind a built in media center/fireplace moulding. it's a pain in the a$$ to run another.

Also wanted to add that when i switched color to YCbCr I was still on the main sammy window when the picture dropped out, unlike others that had the image drop out when playing a UHD BD

Last edited by ksumi; 08-10-2016 at 11:46 AM.
ksumi is offline  
post #8398 of 14222 Old 08-10-2016, 11:50 AM
AVS Forum Special Member
 
Rudy1's Avatar
 
Join Date: Oct 2000
Location: Ft. Lauderdale, FL
Posts: 5,750
Mentioned: 190 Post(s)
Tagged: 0 Thread(s)
Quoted: 1966 Post(s)
Liked: 3270
INTERESTING ARTICLE ON LIP-SYNC PROBLEMS:

http://www.tvtechnology.com/opinions...go-away/279183

Definition of "Stupid": Knowing the truth, seeing the truth, but still believing the lies.
Rudy1 is offline  
post #8399 of 14222 Old 08-10-2016, 11:53 AM
AVS Forum Special Member
 
Rudy1's Avatar
 
Join Date: Oct 2000
Location: Ft. Lauderdale, FL
Posts: 5,750
Mentioned: 190 Post(s)
Tagged: 0 Thread(s)
Quoted: 1966 Post(s)
Liked: 3270
Quote:
Originally Posted by ksumi View Post
Picked up the K8500 last weekend and finally got around to setting it up last night. I've read through some of this forum and decided to follow the recommended settings in Post #1.

Hooked the HDMI up directly to the LG EF9500 OLED and everything worked fine. HDR kicked in when playing the deadpool UHD BD. When I tried to change the color settings from Auto to YCbCr 4:4:4, the screen cut out and I got the no source detected message. Had to hard reset the player to get it back to factory settings.

Is this an issue with my HDMI cable or settings on the Tv and/or sammy player? Hopefully its not the HDMI as the current cables are run through the wall behind a built in media center/fireplace moulding. it's a pain in the a$$ to run another.

Also wanted to add that when i switched color to YCbCr I was still on the main sammy window when the picture dropped out, unlike others that had the image drop out when playing a UHD BD
It could be that the cable is not rated for your current usage. If the picture is acceptable with the color setting at AUTO and you're not experiencing any issues, I would suggest that you just leave it that way.

Definition of "Stupid": Knowing the truth, seeing the truth, but still believing the lies.
Rudy1 is offline  
post #8400 of 14222 Old 08-10-2016, 11:55 AM
Newbie
 
John Webb's Avatar
 
Join Date: Oct 2002
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Tor Ove Thank You...hooked it up and watched UHD the Martian with no issues, also played one of the standard Blue ray and it also looked really good. Watched on a Samsung 26" LCD so really looking forward to the picture when the new monitor arrives.

Our prior TV was a 2003 rear projection Pioneer Pro 630-hd which took a lightning hit. Awaiting delivery next Friday of a Sony 75XBR940D to replace the Pioneer and a Marantz 5011 AVR to replace our 2005 Outlaw 1070 whose video outputs were also damaged by the lightning strike even though both were connected to a Surge Protector. Have since added a whole house Surge Protector as well as Surge Protectors on both the incoming cable and phone lines.

Sure I'll have plenty of question in the future as I'm new to the world of smart tv's and players with the ability to stream content.

Regards



Quote:
Originally Posted by tor ove View Post
No problem. It will output at 1080p.
And if you play an UHD-disc, it will tell you that your display doesn't support 4k HDR, and it will show the disc in 1080p settings.

BUT.....
I've previously had 2 K8500 failing on me, now on my third. And knock on wood, this seems to be working.
And the others failed me watching UHD-discs. My theory is, the UHD-discs stresses the player more. My first player froze ocasionally and required a restart.
My second player froze more often, ending up as a brick only starting up with lots of colors and a harsh buzzing noise.
AND......my third player seems ok. And my theory expands.
The two first players, I could not hear the fan-noise. My third player, and I can hear it.
Did my previous 2 player have faulty fans, not cooling enough, and toasting the players?.
Or has Samsung upped the fan speed on some players?
I've read somewhere that the first K8500 players were bundled with The Martian UHD-disc for early adopters. My two first players were from this bundle. (Here in Norway).
They both failed on me. My third player was a production outside this bundle offer.
So maybe it is a newer player with another fan, more fan-speed or whatever. It works and has never frozen once on me.
John Webb is offline  
Sponsored Links
Advertisement
 
Reply Blu-ray Players

Tags
color calibration , hdr player , member , settings

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off