Official Samsung UBD-K8500 4K HDR Ultra HD Blu-Ray Player Owner's Thread - Page 388 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 40358Likes
Reply
 
Thread Tools
post #11611 of 14212 Old 01-16-2017, 11:05 AM
AVS Forum Special Member
 
mrtickleuk's Avatar
 
Join Date: May 2016
Location: Birmingham, UK - you know, the original one!
Posts: 6,647
Mentioned: 169 Post(s)
Tagged: 0 Thread(s)
Quoted: 4531 Post(s)
Liked: 6831
Quote:
Originally Posted by jtrosky View Post
I remember when Windows 2000 (I think) came it, it allowed you to use USB thumb drives as additional RAM. Not sure if Windows machines still allow that or not (I'm a Unix guy!). :-)
That's a feature first introduced with Windows 7.

_______________
Denon AVR-X4200W, Arcam Alpha 8P; 5.1.4 setup: Mission 702e, M7C1i, 77DS, 731. Rel T5 Sub. Monitor Audio CT165 4 Tops | LG OLED55C8PLA TV | Samsung UBD-K8500 UHD Blu-Ray

HDMI 2.0 4K modes | Dolby & DTS core+outer audio tracks on (UHD) Blu-Rays | Hello to Jason Isaacs
mrtickleuk is online now  
Sponsored Links
Advertisement
 
post #11612 of 14212 Old 01-16-2017, 12:53 PM
AVS Forum Addicted Member
 
p5browne's Avatar
 
Join Date: Jun 2008
Location: Sudbury, Ontario, CANADA
Posts: 10,175
Mentioned: 238 Post(s)
Tagged: 0 Thread(s)
Quoted: 3995 Post(s)
Liked: 3169
NOTE: Instructions re the added flashstick, usually states that the benefits come from it being installed in the back, not the front.

UN65KS9800 - Mine
UN65HU9000 + SEK-3500U / UN75JU7100 / UN55HU7250 with SEK-3500U in UJS9000 Mod Mode / UN40J5200AF / HiSense 40H5507 - Wife's
UN55NU8000 X 2 - my 2 kids families (or should I say adults?)
p5browne is offline  
post #11613 of 14212 Old 01-16-2017, 01:46 PM
Member
 
Join Date: Aug 2016
Location: Chandler, Arizona
Posts: 37
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 29 Post(s)
Liked: 24
Quote:
Originally Posted by p5browne View Post
NOTE: Instructions re the added flashstick, usually states that the benefits come from it being installed in the back, not the front.
Unfortunately the UBD K8500 only has one USB port which is on the front behind a little door which hangs loose when you put a flash drive in it...

Living Rm: Samsung 78JS9500, Samsung UBD-K8500, Yamaha RX-A3050, Emitiva XPA-5, Direct TV Genie DVR, Monoprice Certified HDMI Cables
Bedroom: Samsung 55HU8550 w/SEK-3500, Samsung UBD- K8500, Yamaha TRS-7810, Direct TV DVR, Monoprice Certified HDMI Cables
Game Rm and patio: Samsung 46, Visio 39” and LG 32” 1080P tvs, Yamaha RX-A3000, Samsung BD-7500, Direct TV DVR
rickcleveland is offline  
Sponsored Links
Advertisement
 
post #11614 of 14212 Old 01-16-2017, 05:11 PM
AVS Forum Special Member
 
poppagene's Avatar
 
Join Date: Apr 2006
Location: Bethesda. MD
Posts: 1,535
Mentioned: 33 Post(s)
Tagged: 0 Thread(s)
Quoted: 857 Post(s)
Liked: 743
Quote:
Originally Posted by aaronwt View Post
Yes. That has been there. But the person posted about checking the speed while streaming content. Which you can't do. WHich is what I was commenting on. It's never showed the bitrate of the encode being played. Only the resolution of the encode that is being played. And each resolution has multiple encodes.
Your interpretation, obviously not my interpretation. To my mind the connection speed while in the "app" is the speed that the app streams at. You are entitled to your own interpretation, and your interpretation may well be what the original poster was interested in.

Nevertheless, I find that the test your connection feature is useful. Comparing the Netflix connection speed on my Samsung TV, Samsung UBD-K8500, TiVo Bolt and Xbox One S, the Xbox One S has by far the most consistently fastest connection (Xbox 360 also fast,but not UHD).

UN48JS8500 UN55HU6950 w/SEK-3500U UN40HU6950 w/SEK-3500U UBD-K8500 UN37C5000
poppagene is offline  
post #11615 of 14212 Old 01-16-2017, 05:34 PM
AVS Forum Special Member
 
jedurocher's Avatar
 
Join Date: Dec 2005
Location: Spring, TX (North of Houston)
Posts: 1,246
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 108 Post(s)
Liked: 57
Official Samsung UBD-K8500 4K HDR Ultra HD Blu-Ray Player Owner's Thread

Quote:
Originally Posted by jeffs316 View Post
Just purchased this player. Few quick questions (sorry if this has been beat to death in previous posts):

I have a Visio P-65-c1 UHD HDR/DV Tv.

1)I have turned HDR Color Sampling option to ON in the Visio settings, allowing my tv to output HDR. Do i have to turn the color sampling option on the bluray player to on, as well? or leave it off?

2) Within the player, do i set the resolution to auto? or 4K? I will be watching mostly bluray and 4k bluray.

Thanks!

1) I have the M series Vizio. Turn on color sampling. Take advantage of the duel HDMI and run one to the TV and one to your receiver (if that is your setup), setting audio output to HDMI 2. There isn't a setting to turn "on" for the disc player in regards to color sampling.

2) Set it to auto and it sends everything to the TV in 4K (native or scaled).

Check page 1 for the other settings. I have mine set up that way and things are great.

Also, to make sure the player isn't affecting your tv calibrations, go to Tools->Picture->User and set everything to 0.



Sent from my iPhone using Tapatalk

JD

"Listen to advice and accept instruction, and in the end you will be wise." Proverbs 19:20

Last edited by jedurocher; 01-16-2017 at 06:59 PM.
jedurocher is offline  
post #11616 of 14212 Old 01-16-2017, 09:12 PM
Senior Member
 
SLYDoggie's Avatar
 
Join Date: Nov 2007
Location: Nashville, TN
Posts: 486
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 250 Post(s)
Liked: 167
Unit Freezing From Extended "Pause"

Have any of you experienced freezes of the player when trying to come out of an extended period on Pause? It just happened to me for the 2nd time this evening. I paused a Blu-Ray (not UHD) movie to eat dinner and when I returned to the player, I couldn't get it out of pause. The screensaver had kicked in and hitting play would remove the screensaver and go back to the frozen picture but it wouldn't resume playing. I tried play, FF, Rew, Pause, Menu, and several other buttons on the remote but none of them had any impact... It just remained paused. I even tried the eject button on the remote and player itself with no results. I finally had to power off the unit from the power button on the player itself.

I just thought it was a quirk the first time it happened last week but now it has happened twice within a week. I am on the latest 7009 Firmware and have been for weeks now so nothing has changed that I know of.

Regards, Steve
Projector/Receiver - Sony VPL-VW1100ES 4K PJ & Sony STR-ZA5000ES 4K Atmos AVR
Media Devices - Panasonic DP-UB820 4K BR, Sony UBP-X800 4K BR, ATV 4K, and Roku 4K
Screen - 145" Dragonfly, 1.2 Gain, 16:9, Matte White Fixed Screen
Theater Remote/Cables - Universal MX-990 RF Remote, Monoprice Certified 18Gb HDMI Cables
SLYDoggie is offline  
post #11617 of 14212 Old 01-17-2017, 06:11 AM
UHD Addict
 
aaronwt's Avatar
 
Join Date: Aug 2001
Location: Northern VA(Woodbridge)
Posts: 35,674
Mentioned: 65 Post(s)
Tagged: 0 Thread(s)
Quoted: 9120 Post(s)
Liked: 5853
Quote:
Originally Posted by poppagene View Post
Your interpretation, obviously not my interpretation. To my mind the connection speed while in the "app" is the speed that the app streams at. You are entitled to your own interpretation, and your interpretation may well be what the original poster was interested in.

Nevertheless, I find that the test your connection feature is useful. Comparing the Netflix connection speed on my Samsung TV, Samsung UBD-K8500, TiVo Bolt and Xbox One S, the Xbox One S has by far the most consistently fastest connection (Xbox 360 also fast,but not UHD).
I've never found those speeds to be accurate. SInce when I stream from Netflix or Amazon and other streaming apps on any device, I will hit speeds of up to 150Mb/s on most devices that have GigE connections. And over 90Mb/s on most devices that have 100BT ethernet ports. When it initially fills the buffer it downloads as fast as possible. While the speed test in the Netflix app never reflects those speeds. I just look at the bandwidth info from my router when streaming from a device on my network.

Although I've found my PS4pro/PS4 seem to be the worst with the streaming apps. Other devices are typically streaming UHD or HD right away. While with the PS4 it takes a long time(like 30 seconds) to reach the UHD/HD encodes for some reason.

53TB unRAID1a--49TB unRAID2--76TB unRAID3
TCL 6 Series--Sony UBP-X800--Philips BDP7502--Onkyo HT-S7800
XBL/PSN: WormholeXtreme

Last edited by aaronwt; 01-17-2017 at 06:15 AM.
aaronwt is offline  
post #11618 of 14212 Old 01-17-2017, 07:43 AM
Member
 
Join Date: Aug 2016
Location: Chandler, Arizona
Posts: 37
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 29 Post(s)
Liked: 24
Quote:
Originally Posted by SLYDoggie View Post
Have any of you experienced freezes of the player when trying to come out of an extended period on Pause? It just happened to me for the 2nd time this evening. I paused a Blu-Ray (not UHD) movie to eat dinner and when I returned to the player, I couldn't get it out of pause. The screensaver had kicked in and hitting play would remove the screensaver and go back to the frozen picture but it wouldn't resume playing. I tried play, FF, Rew, Pause, Menu, and several other buttons on the remote but none of them had any impact... It just remained paused. I even tried the eject button on the remote and player itself with no results. I finally had to power off the unit from the power button on the player itself.

I just thought it was a quirk the first time it happened last week but now it has happened twice within a week. I am on the latest 7009 Firmware and have been for weeks now so nothing has changed that I know of.
I almost always have to press the enter button to come out of a long pause. And sometimes I have to press enter then play.

Living Rm: Samsung 78JS9500, Samsung UBD-K8500, Yamaha RX-A3050, Emitiva XPA-5, Direct TV Genie DVR, Monoprice Certified HDMI Cables
Bedroom: Samsung 55HU8550 w/SEK-3500, Samsung UBD- K8500, Yamaha TRS-7810, Direct TV DVR, Monoprice Certified HDMI Cables
Game Rm and patio: Samsung 46, Visio 39” and LG 32” 1080P tvs, Yamaha RX-A3000, Samsung BD-7500, Direct TV DVR
rickcleveland is offline  
post #11619 of 14212 Old 01-17-2017, 09:12 AM
Member
 
bhpizza's Avatar
 
Join Date: Mar 2009
Posts: 175
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Liked: 15
Finally purchased this player on Sunday night and got it set up and running Monday night. Only have 3 UHD BD movies at the moment, (Jason Bourne, Sully and Storks), but have 5 more pre-ordered. Loving the player so far. Other than the initial spinning, it's much quieter than our Sony ES BD player ever was. Glad we have a Harmony Elite to control our system because I can see why people complain about the dinky remote.

For those of you who are running this BD player in conjunction with a newer Samsung 4K UHD TV, are there any Samsung specific settings that you would recommend? We have a UN65KS9500...

bhpizza is offline  
post #11620 of 14212 Old 01-17-2017, 09:23 AM
AVS Forum Addicted Member
 
p5browne's Avatar
 
Join Date: Jun 2008
Location: Sudbury, Ontario, CANADA
Posts: 10,175
Mentioned: 238 Post(s)
Tagged: 0 Thread(s)
Quoted: 3995 Post(s)
Liked: 3169
Coming out of Pause, Play must be pushed 2 times.

UN65KS9800 - Mine
UN65HU9000 + SEK-3500U / UN75JU7100 / UN55HU7250 with SEK-3500U in UJS9000 Mod Mode / UN40J5200AF / HiSense 40H5507 - Wife's
UN55NU8000 X 2 - my 2 kids families (or should I say adults?)
p5browne is offline  
post #11621 of 14212 Old 01-17-2017, 10:05 AM
NTC
Senior Member
 
NTC's Avatar
 
Join Date: Jul 2004
Location: Aabama, USA
Posts: 358
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 229 Post(s)
Liked: 308
Quote:
Originally Posted by SLYDoggie View Post
Have any of you experienced freezes of the player when trying to come out of an extended period on Pause? It just happened to me for the 2nd time this evening. I paused a Blu-Ray (not UHD) movie to eat dinner and when I returned to the player, I couldn't get it out of pause. The screensaver had kicked in and hitting play would remove the screensaver and go back to the frozen picture but it wouldn't resume playing. I tried play, FF, Rew, Pause, Menu, and several other buttons on the remote but none of them had any impact... It just remained paused. I even tried the eject button on the remote and player itself with no results. I finally had to power off the unit from the power button on the player itself.

I just thought it was a quirk the first time it happened last week but now it has happened twice within a week. I am on the latest 7009 Firmware and have been for weeks now so nothing has changed that I know of.
You have to press to a button on the remote to wake it from the screen saver, then press the button you want the player to do.

7009? I assume you meant 1009.1, which is the firmware Samsung has re-issued or rolled back to. There was a later version which for an unknown reason was pulled back.
Rudy1 likes this.
NTC is offline  
post #11622 of 14212 Old 01-17-2017, 12:16 PM
Newbie
 
fred37's Avatar
 
Join Date: Apr 2007
Location: Alberta
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 10
Has anyone had an issue outputting a 2160 signal from the Samsung UBD-K8500 through a 20' 2.0a HDMI cable? Connected it directly to a JVC DLA-X550R projector with a Maestro 2.0a HDMI cable, no luck. Connected the player to a 4k LED TV with a 6' cable and it works. Set the player to 1080 and brought it back to the projector and it worked. With the player menu displaying on the projector screen I set it the player back to 2160 and got 10 seconds of black screen and then resets back to 1080p. Feel like I've gone back in time to the early days of HDMI!
An installer told me I may have to use an HDMI extender over fiber, hope not.
fred37 is offline  
post #11623 of 14212 Old 01-17-2017, 12:28 PM
UHD Addict
 
aaronwt's Avatar
 
Join Date: Aug 2001
Location: Northern VA(Woodbridge)
Posts: 35,674
Mentioned: 65 Post(s)
Tagged: 0 Thread(s)
Quoted: 9120 Post(s)
Liked: 5853
Quote:
Originally Posted by fred37 View Post
Has anyone had an issue outputting a 2160 signal from the Samsung UBD-K8500 through a 20' 2.0a HDMI cable? Connected it directly to a JVC DLA-X550R projector with a Maestro 2.0a HDMI cable, no luck. Connected the player to a 4k LED TV with a 6' cable and it works. Set the player to 1080 and brought it back to the projector and it worked. With the player menu displaying on the projector screen I set it the player back to 2160 and got 10 seconds of black screen and then resets back to 1080p. Feel like I've gone back in time to the early days of HDMI!
An installer told me I may have to use an HDMI extender over fiber, hope not.
DId you try a 20' certified Premium HDMI cable? Monoprice has them for $15. 20 feet is the longest certified length.
rickcleveland likes this.

53TB unRAID1a--49TB unRAID2--76TB unRAID3
TCL 6 Series--Sony UBP-X800--Philips BDP7502--Onkyo HT-S7800
XBL/PSN: WormholeXtreme
aaronwt is offline  
post #11624 of 14212 Old 01-17-2017, 12:53 PM
AVS Forum Special Member
 
poppagene's Avatar
 
Join Date: Apr 2006
Location: Bethesda. MD
Posts: 1,535
Mentioned: 33 Post(s)
Tagged: 0 Thread(s)
Quoted: 857 Post(s)
Liked: 743
Quote:
Originally Posted by fred37 View Post
Has anyone had an issue outputting a 2160 signal from the Samsung UBD-K8500 through a 20' 2.0a HDMI cable? Connected it directly to a JVC DLA-X550R projector with a Maestro 2.0a HDMI cable, no luck. Connected the player to a 4k LED TV with a 6' cable and it works. Set the player to 1080 and brought it back to the projector and it worked. With the player menu displaying on the projector screen I set it the player back to 2160 and got 10 seconds of black screen and then resets back to 1080p. Feel like I've gone back in time to the early days of HDMI!
An installer told me I may have to use an HDMI extender over fiber, hope not.
Did you try the disk trick? Try putting in a disk and see if it plays with your 20 foot cable

UN48JS8500 UN55HU6950 w/SEK-3500U UN40HU6950 w/SEK-3500U UBD-K8500 UN37C5000
poppagene is offline  
post #11625 of 14212 Old 01-17-2017, 05:16 PM
Newbie
 
fred37's Avatar
 
Join Date: Apr 2007
Location: Alberta
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 10
Thanks, I will pick up a certified cable and, before opening the package, try the disk. Funny, didn't think of putting a disk in. haha
fred37 is offline  
post #11626 of 14212 Old 01-17-2017, 05:53 PM
Member
 
0hwell's Avatar
 
Join Date: Dec 2010
Posts: 48
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 24 Post(s)
Liked: 15
Quote:
Originally Posted by NTC View Post
You have to press to a button on the remote to wake it from the screen saver, then press the button you want the player to do.

7009? I assume you meant 1009.1, which is the firmware Samsung has re-issued or rolled back to. There was a later version which for an unknown reason was pulled back.
That later firmware version is 1010. I downloaded and installed it than they removed it the same day. I chatted with a Samsung rep and he told me I couldn't roll back but I should be able to upgrade to newer versions when they arrive. All he said the 1010 version did was add more efficiency to some tasks.
0hwell is offline  
post #11627 of 14212 Old 01-17-2017, 06:20 PM
NTC
Senior Member
 
NTC's Avatar
 
Join Date: Jul 2004
Location: Aabama, USA
Posts: 358
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 229 Post(s)
Liked: 308
Quote:
Originally Posted by 0hwell View Post
That later firmware version is 1010. I downloaded and installed it than they removed it the same day. I chatted with a Samsung rep and he told me I couldn't roll back but I should be able to upgrade to newer versions when they arrive. All he said the 1010 version did was add more efficiency to some tasks.
It was available on the support page for approximately 3 1/2 hours.

Click image for larger version

Name:	K8500_Support.jpg
Views:	209
Size:	54.1 KB
ID:	1902201

So they said it added more efficiency to some task, yet they pulled it. Considering the short period of time it was in the website, I think it was for other reasons that they pulled the update, and I do not think it has to do with a bug in the firmware. The German, French, and Hungarian AV forums reported no issues thus far, and I see none.
aaronwt and mrtickleuk like this.
NTC is offline  
post #11628 of 14212 Old 01-18-2017, 11:57 AM
AVS Forum Special Member
 
jedurocher's Avatar
 
Join Date: Dec 2005
Location: Spring, TX (North of Houston)
Posts: 1,246
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 108 Post(s)
Liked: 57
Quote:
Originally Posted by jeffs316 View Post

1)I have turned HDR Color Sampling option to ON in the Visio settings, allowing my tv to output HDR.


One more thing I forgot to mention. Color sampling on Vizio allows for full color gamut to be displayed on the screen. It is not really necessary to get HDR, but to get full color spectrum from any source, turn it on.

JD

"Listen to advice and accept instruction, and in the end you will be wise." Proverbs 19:20
jedurocher is offline  
post #11629 of 14212 Old 01-18-2017, 12:50 PM
AVS Forum Special Member
 
mrtickleuk's Avatar
 
Join Date: May 2016
Location: Birmingham, UK - you know, the original one!
Posts: 6,647
Mentioned: 169 Post(s)
Tagged: 0 Thread(s)
Quoted: 4531 Post(s)
Liked: 6831
Quote:
Originally Posted by NTC View Post
It was available on the support page for approximately 3 1/2 hours.

Attachment 1902201

So they said it added more efficiency to some task, yet they pulled it. Considering the short period of time it was in the website, I think it was for other reasons that they pulled the update, and I do not think it has to do with a bug in the firmware. The German, French, and Hungarian AV forums reported no issues thus far, and I see none.
Don't suppose it added some multi-region DVD support (with secret keypresses) and that's why they have pulled it. Not having working multi-region DVD playback from this player is a huge pain, I could free up so much space in my TV unit if I could playback my DVDs from this player

_______________
Denon AVR-X4200W, Arcam Alpha 8P; 5.1.4 setup: Mission 702e, M7C1i, 77DS, 731. Rel T5 Sub. Monitor Audio CT165 4 Tops | LG OLED55C8PLA TV | Samsung UBD-K8500 UHD Blu-Ray

HDMI 2.0 4K modes | Dolby & DTS core+outer audio tracks on (UHD) Blu-Rays | Hello to Jason Isaacs
mrtickleuk is online now  
post #11630 of 14212 Old 01-18-2017, 01:11 PM
NTC
Senior Member
 
NTC's Avatar
 
Join Date: Jul 2004
Location: Aabama, USA
Posts: 358
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 229 Post(s)
Liked: 308
Quote:
Originally Posted by mrtickleuk View Post
Don't suppose it added some multi-region DVD support (with secret keypresses) and that's why they have pulled it. Not having working multi-region DVD playback from this player is a huge pain, I could free up so much space in my TV unit if I could playback my DVDs from this player
Cannot honestly say what it added, nothing I can see, and I agree on not having a region free player is annoying if you have DVDs or even blu-ray locked to a specific region. I have a few blu-rays that I purchased through Amazon UK because sometimes the extras on a disc can be very different region to region, but I ensure that they are at least playable here.

As for the specifics to the firmware, it is more than 25Mb larger in file size compare to version 1009.1. That's a significant increase for a firmware that size. To compare, each firmware update to the KS series of TVs increased the file size between 1/2 to 2 Mb. The last five updates total 5Mb. So you can see something was added but have yet to find what it is. I will say for full disclosure I do not use this player for any kind of streaming, so there may be something done there.

But you can check it out yourself, check your PM.

Regards
mrtickleuk likes this.
NTC is offline  
post #11631 of 14212 Old 01-18-2017, 02:28 PM
Senior Member
 
jrogers's Avatar
 
Join Date: Dec 2000
Location: MN
Posts: 430
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 275 Post(s)
Liked: 174
Quote:
Originally Posted by NTC View Post
Cannot honestly say what it added, nothing I can see, and I agree on not having a region free player is annoying if you have DVDs or even blu-ray locked to a specific region. I have a few blu-rays that I purchased through Amazon UK because sometimes the extras on a disc can be very different region to region, but I ensure that they are at least playable here.

As for the specifics to the firmware, it is more than 25Mb larger in file size compare to version 1009.1. That's a significant increase for a firmware that size. To compare, each firmware update to the KS series of TVs increased the file size between 1/2 to 2 Mb. The last five updates total 5Mb. So you can see something was added but have yet to find what it is. I will say for full disclosure I do not use this player for any kind of streaming, so there may be something done there.

But you can check it out yourself, check your PM.

Regards
Somewhat surprised it didn't include Netflix HDR given that the SEK-3500 boxes were just upgraded to support it. I'd love it if 1010 addresses the lip sync issues with streaming.

Samsung UN75HU8500 TS01 w/SEK-3500U, K8500 UHD Blu-ray Player; Xbox One; Xfinity X1
Dolby Atmos and DTS:X 7w.1.4; Denon X6200W; Audiosource AMP102; GoldenEar SuperSat 60/60C, SuperSat 50, SuperSat 3/3C, Invisa 525; SVS PB-2000
Harmony Ultimate One; Insteon; Acoustimac
jrogers is offline  
post #11632 of 14212 Old 01-19-2017, 09:28 AM
Member
 
121dj's Avatar
 
Join Date: Apr 2015
Posts: 139
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 95 Post(s)
Liked: 35
2 service returns, same result. Samsung's customer service policy has ruined me from EVER buying the brand again.

Sent from my E6883 using Tapatalk
121dj is offline  
post #11633 of 14212 Old 01-19-2017, 11:35 AM
AVS Forum Special Member
 
checker9's Avatar
 
Join Date: Feb 2010
Posts: 2,195
Mentioned: 14 Post(s)
Tagged: 0 Thread(s)
Quoted: 1533 Post(s)
Liked: 363
How do you keep the K8500 from upmixing to 4K?

I have my TV resolution set to Auto. Everything I watched gets feed to my AVR as 4K, whether it is or is not. For example, anything I watch on Amazon Prime, even regular HD, is sent as 4K. Even regular blu ray movies are sent as 4K. I can find no setting to turn upscaling off. Can you turn it off? How?
checker9 is offline  
post #11634 of 14212 Old 01-19-2017, 11:37 AM
Senior Member
 
Join Date: Jun 2016
Posts: 395
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 218 Post(s)
Liked: 189
Quote:
Originally Posted by jrogers View Post
Somewhat surprised it didn't include Netflix HDR given that the SEK-3500 boxes were just upgraded to support it. I'd love it if 1010 addresses the lip sync issues with streaming.
Agreed. I have to enable HDMI auto lip sync on my Marantz anytime I use the Amazon app. That fixes it but it's annoying to deal with because leaving it on whacks out my Kodi NUC.
Karnis2 is offline  
post #11635 of 14212 Old 01-19-2017, 12:16 PM
AVS Forum Special Member
 
mrtickleuk's Avatar
 
Join Date: May 2016
Location: Birmingham, UK - you know, the original one!
Posts: 6,647
Mentioned: 169 Post(s)
Tagged: 0 Thread(s)
Quoted: 4531 Post(s)
Liked: 6831
Quote:
Originally Posted by checker9 View Post
How do you keep the K8500 from upmixing to 4K?

I have my TV resolution set to Auto. Everything I watched gets feed to my AVR as 4K, whether it is or is not. For example, anything I watch on Amazon Prime, even regular HD, is sent as 4K. Even regular blu ray movies are sent as 4K. I can find no setting to turn upscaling off. Can you turn it off? How?
Unfortunately, you can't. "Auto" means "please output the highest resolution my TV says it can handle". There's no "Native resolution of the source" option

The only way to prevent scaling is to keep laboriously changing the output resolution, ie manually change it to "1080p" when watching a Blu-Ray, then manually change it to "576" or "480" when watching a DVD, etc.
galonzo likes this.

_______________
Denon AVR-X4200W, Arcam Alpha 8P; 5.1.4 setup: Mission 702e, M7C1i, 77DS, 731. Rel T5 Sub. Monitor Audio CT165 4 Tops | LG OLED55C8PLA TV | Samsung UBD-K8500 UHD Blu-Ray

HDMI 2.0 4K modes | Dolby & DTS core+outer audio tracks on (UHD) Blu-Rays | Hello to Jason Isaacs
mrtickleuk is online now  
post #11636 of 14212 Old 01-19-2017, 12:47 PM
Newbie
 
Join Date: Feb 2016
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 0
Hello, all.

I apologize in advance for the question, as I know such a thing has probably been asked many times over the course of the year the player has been released.

I have UHD Color turned OFF on the player as recommended in the FAQ in this thread. On my TV (2016 Samsung KS9 series), under HDMI UHD Color, should it be turned ON for the HDMI receiving the signal from the player? Right now, all 4 ports are listed as OFF.

I do receive an HDR signal while playing UHD Blu-rays; I get the prompt on my screen and the picture settings obviously change as well. Is it working correctly? Am I getting the best picture quality?

Thanks, everyone.
Strategos is offline  
post #11637 of 14212 Old 01-19-2017, 12:54 PM
AVS Forum Special Member
 
mrtickleuk's Avatar
 
Join Date: May 2016
Location: Birmingham, UK - you know, the original one!
Posts: 6,647
Mentioned: 169 Post(s)
Tagged: 0 Thread(s)
Quoted: 4531 Post(s)
Liked: 6831
Quote:
Originally Posted by Strategos View Post
I have UHD Color turned OFF on the player as recommended in the FAQ in this thread.
Erm, no such option in the player. Instead, you should set
HDMI Colour Format = Auto
HDMI Deep Colour = Off.

Quote:
Originally Posted by Strategos View Post
On my TV (2016 Samsung KS9 series), under HDMI UHD Color, should it be turned ON for the HDMI receiving the signal from the player? Right now, all 4 ports are listed as OFF.
Yes, turn it on for the HDMI port that's connected to the player. Or all of them if it doesn't cause issues, then forget about it.

Without HDMI UHD Color=On on the TV, it won't accept anything higher then 8-bit colour. HDR UHD content is 10bit, that's the "10" in "HDR10".
Strategos likes this.

_______________
Denon AVR-X4200W, Arcam Alpha 8P; 5.1.4 setup: Mission 702e, M7C1i, 77DS, 731. Rel T5 Sub. Monitor Audio CT165 4 Tops | LG OLED55C8PLA TV | Samsung UBD-K8500 UHD Blu-Ray

HDMI 2.0 4K modes | Dolby & DTS core+outer audio tracks on (UHD) Blu-Rays | Hello to Jason Isaacs
mrtickleuk is online now  
post #11638 of 14212 Old 01-19-2017, 01:09 PM - Thread Starter
Super Moderator
 
teachsac's Avatar
 
Join Date: May 2006
Location: Elk Grove, CA
Posts: 14,202
Mentioned: 77 Post(s)
Tagged: 0 Thread(s)
Quoted: 1254 Post(s)
Liked: 2063
As Mr. T said. Those settings are correct. UHD Color is a TV setting, not a player setting, which should be on in your display.
Strategos likes this.

Please use the report post button to alert staff to problematic posts. Never quote or respond to them yourself.

Panasonic DP-UB820 -> Yamaha CX-A5100 -> Sony XBR-75X940C; Mediabridge 6' and 15' HDMI cables.
teachsac is offline  
post #11639 of 14212 Old 01-19-2017, 06:58 PM
AVS Forum Special Member
 
docrog's Avatar
 
Join Date: Sep 2001
Location: Okatie, SC
Posts: 1,319
Mentioned: 14 Post(s)
Tagged: 0 Thread(s)
Quoted: 1079 Post(s)
Liked: 366
Quote:
Originally Posted by poppagene View Post
The UBD-K8500 has 2 HDMI outputs. If the direct hdmi solves your issue you could run HDMI 2 for audio only to your AVR and HDMI 1 to your TV.
Sending only the audio stream to the AVR will lead to an inability to see the AVR's GUI on the display, no???
docrog is offline  
post #11640 of 14212 Old 01-19-2017, 07:19 PM
Member
 
Join Date: Nov 2015
Location: a packer fan in michigan
Posts: 102
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 67 Post(s)
Liked: 39
Quote:
Originally Posted by docrog View Post
Sending only the audio stream to the AVR will lead to an inability to see the AVR's GUI on the display, no???
Yes. But it ensures that you have no handshake issues.

Sony XBR-55X850C
Onkyo TX-SR444
PS4
Polk Audio 5.1.2

Packer fan living in Michigan.
brilithos is offline  
Sponsored Links
Advertisement
 
Reply Blu-ray Players

Tags
color calibration , hdr player , member , settings

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off