Official Samsung UBD-K8500 4K HDR Ultra HD Blu-Ray Player Owner's Thread - Page 463 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 40358Likes
Reply
 
Thread Tools
post #13861 of 14212 Old 04-14-2018, 04:04 AM
Advanced Member
 
Quicksilv3r's Avatar
 
Join Date: Apr 2012
Location: Orangeville Canada
Posts: 833
Mentioned: 12 Post(s)
Tagged: 0 Thread(s)
Quoted: 458 Post(s)
Liked: 355
Quote:
Originally Posted by Musician View Post
Good to see guys like you and @mr.kludge are interested in this article that really demonstrates the added dimensions and nuances of HDR.



I am lapping up the sun in Cabo right now and a lot of Don Julio [yeah, poor me right] and think I may have saved a copy of the PDF on my PC back home but found that we are in luck. Click below to find a copy of the 30 page article...



https://issuu.com/sonyprofessional/d...erpt/1?ff=true



Cheers!


Thanks @Musician

Enjoy Cabo. I’m just at the cottage with limited internet myself.


Sent from my iPad using Tapatalk
Musician likes this.

tv: Samsung UN75MU800, Receiver: Denon AVR 730H, speakers: 4x M&K S-1B and M&K S85c for center, sub: MKsound V12 HTPC, Samsung UBP-K8500, Rogers Digital PVR, Chromecast Ultra
Quicksilv3r is offline  
Sponsored Links
Advertisement
 
post #13862 of 14212 Old 04-14-2018, 04:16 AM
AVS Forum Special Member
 
mrtickleuk's Avatar
 
Join Date: May 2016
Location: Birmingham, UK - you know, the original one!
Posts: 6,647
Mentioned: 169 Post(s)
Tagged: 0 Thread(s)
Quoted: 4531 Post(s)
Liked: 6831
Quote:
Originally Posted by Quicksilv3r View Post
Thanks @Musician
Enjoy Cabo. I’m just at the cottage with limited internet myself.
I'm glad you asked about it - I'd forgotten that it contains a very nice "colour volume" diagram:

Attached Thumbnails
Click image for larger version

Name:	Sony Colour Volume (from pdf).png
Views:	1613
Size:	155.2 KB
ID:	2390328  

_______________
Denon AVR-X4200W, Arcam Alpha 8P; 5.1.4 setup: Mission 702e, M7C1i, 77DS, 731. Rel T5 Sub. Monitor Audio CT165 4 Tops | LG OLED55C8PLA TV | Samsung UBD-K8500 UHD Blu-Ray

HDMI 2.0 4K modes | Dolby & DTS core+outer audio tracks on (UHD) Blu-Rays | Hello to Jason Isaacs
mrtickleuk is offline  
post #13863 of 14212 Old 04-14-2018, 07:38 AM
Member
 
junglist1319's Avatar
 
Join Date: Jul 2007
Posts: 63
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 26 Post(s)
Liked: 22
I haven't used my UBD-K8500 since October but recently upgraded the family room TV to 4k.

Heads up for anyone but I just saw a new firmware update posted yesterday on Samsung. I'll be updating sometime today.
galonzo, Musician and mrtickleuk like this.
junglist1319 is offline  
Sponsored Links
Advertisement
 
post #13864 of 14212 Old 04-14-2018, 01:53 PM
AVS Forum Special Member
 
mrtickleuk's Avatar
 
Join Date: May 2016
Location: Birmingham, UK - you know, the original one!
Posts: 6,647
Mentioned: 169 Post(s)
Tagged: 0 Thread(s)
Quoted: 4531 Post(s)
Liked: 6831
Quote:
Originally Posted by junglist1319 View Post
I haven't used my UBD-K8500 since October but recently upgraded the family room TV to 4k.

Heads up for anyone but I just saw a new firmware update posted yesterday on Samsung. I'll be updating sometime today.
It's dated Friday 13th... good luck!
joe221, galonzo and Musician like this.

_______________
Denon AVR-X4200W, Arcam Alpha 8P; 5.1.4 setup: Mission 702e, M7C1i, 77DS, 731. Rel T5 Sub. Monitor Audio CT165 4 Tops | LG OLED55C8PLA TV | Samsung UBD-K8500 UHD Blu-Ray

HDMI 2.0 4K modes | Dolby & DTS core+outer audio tracks on (UHD) Blu-Rays | Hello to Jason Isaacs
mrtickleuk is offline  
post #13865 of 14212 Old 04-14-2018, 06:33 PM
Member
 
jerryp5503's Avatar
 
Join Date: Jun 2002
Location: Salinas,CA
Posts: 46
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 20 Post(s)
Liked: 12
Quote:
Originally Posted by mrtickleuk View Post
It's dated Friday 13th... good luck!
Since this is a firmware update, will it be available to update from the device itself? Or can you only get it by going the USB route?
jerryp5503 is offline  
post #13866 of 14212 Old 04-14-2018, 06:40 PM
Advanced Member
 
Sal1950's Avatar
 
Join Date: Nov 2015
Location: Central FL
Posts: 738
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 469 Post(s)
Liked: 531
Quote:
Originally Posted by jerryp5503 View Post
Since this is a firmware update, will it be available to update from the device itself? Or can you only get it by going the USB route?
Should be available via the internal updating software soon and will auto-update unless you shut that off. They usually don't roll out firmware updates to all owners at the same time, could overload the servers.

Sony XBR75-X940D, Samsung UBD-K8500 UHD-BD, Xfinity X1 Voice DVR, Marantz AV-7703 Pre/Pro w/Auro, (3) Adcom GFA-545II amps, (2) Adcom GFA-535II amps for ATMOS speakers.
HSU Research 5.2 speaker system (4) HB-1 MK2, (1) HC-1 MK2, (2) STF-2,
Klipsch HT500 satalites (4) for ceiling mounted ATMOS playback
DIY Linux desktop w/Clementine bit perfect media center. Emotiva Stealth DC-1 DAC
Sal1950 is offline  
post #13867 of 14212 Old 04-15-2018, 07:09 PM
Advanced Member
 
Sal1950's Avatar
 
Join Date: Nov 2015
Location: Central FL
Posts: 738
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 469 Post(s)
Liked: 531
Quote:
Originally Posted by jerryp5503 View Post
Since this is a firmware update, will it be available to update from the device itself? Or can you only get it by going the USB route?
Took a look out of curiosity. Version number took a big jump to 1109.1 and is a very large file, almost 1 gb? Checked my players software, it's still on 1014 and doesn't see any update available yet. I'll just wait till it's ready, I'll drink no wine before it's time, LOL.

Sony XBR75-X940D, Samsung UBD-K8500 UHD-BD, Xfinity X1 Voice DVR, Marantz AV-7703 Pre/Pro w/Auro, (3) Adcom GFA-545II amps, (2) Adcom GFA-535II amps for ATMOS speakers.
HSU Research 5.2 speaker system (4) HB-1 MK2, (1) HC-1 MK2, (2) STF-2,
Klipsch HT500 satalites (4) for ceiling mounted ATMOS playback
DIY Linux desktop w/Clementine bit perfect media center. Emotiva Stealth DC-1 DAC
Sal1950 is offline  
post #13868 of 14212 Old 04-15-2018, 07:35 PM
AVS Forum Special Member
 
mr.kludge's Avatar
 
Join Date: May 2008
Posts: 2,604
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 247 Post(s)
Liked: 174
Quote:
Originally Posted by Sal1950 View Post
Took a look out of curiosity. Version number took a big jump to 1109.1 and is a very large file, almost 1 gb? Checked my players software, it's still on 1014 and doesn't see any update available yet. I'll just wait till it's ready, I'll drink no wine before it's time, LOL.
Only 557.13mb. Not unheard of considering all the streaming software etc. So who is going to take the plunge and update via USB? I checked and mine still says, "no soup for you".
mr.kludge is offline  
post #13869 of 14212 Old 04-15-2018, 08:01 PM
AVS Forum Special Member
 
mr.kludge's Avatar
 
Join Date: May 2008
Posts: 2,604
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 247 Post(s)
Liked: 174
Quote:
Originally Posted by Sal1950 View Post
Took a look out of curiosity. Version number took a big jump to 1109.1 and is a very large file, almost 1 gb? Checked my players software, it's still on 1014 and doesn't see any update available yet. I'll just wait till it's ready, I'll drink no wine before it's time, LOL.
This should have been a late April Fools joke. I downloaded it but noticed that it is from December and is 1014. That is what I see on the support site. Oddly I dowloaded what was there on the site in February and that was 1012 from August. I attempted to load either and it said no valid files found and my player says it is on 1014 however I swear that I saw the same 1109.1 version on there a min. ago. Might be a sign that something is coming? They probably just finally got around to posting 1014 to the website is my guess. They are really slow dong that. Maybe they update the website with that LAST version and leave the Internet updates for the latest????
mr.kludge is offline  
post #13870 of 14212 Old 04-15-2018, 08:07 PM
AVS Forum Special Member
 
mr.kludge's Avatar
 
Join Date: May 2008
Posts: 2,604
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 247 Post(s)
Liked: 174
I checked the UK and Canadian sites also. All still showing 1014 and last Friday the 13th. Very odd.
mr.kludge is offline  
post #13871 of 14212 Old 04-15-2018, 11:30 PM
Advanced Member
 
Sal1950's Avatar
 
Join Date: Nov 2015
Location: Central FL
Posts: 738
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 469 Post(s)
Liked: 531
Quote:
Originally Posted by mr.kludge View Post
Only 557.13mb. Not unheard of considering all the streaming software etc. So who is going to take the plunge and update via USB? I checked and mine still says, "no soup for you".
Quote:
Originally Posted by mr.kludge View Post
I checked the UK and Canadian sites also. All still showing 1014 and last Friday the 13th. Very odd.
Strange, link I used now takes me to the M8500 download page, but the file I got before was 904.4 mb in size, the one on the M8500 site now says it's only 862.46? And yes the old file on the K8500 link is now dated 4-13-2018 and back to version 1004 and 557.13mb.
There's something werry screwy going on at Samsung. LOL

Sony XBR75-X940D, Samsung UBD-K8500 UHD-BD, Xfinity X1 Voice DVR, Marantz AV-7703 Pre/Pro w/Auro, (3) Adcom GFA-545II amps, (2) Adcom GFA-535II amps for ATMOS speakers.
HSU Research 5.2 speaker system (4) HB-1 MK2, (1) HC-1 MK2, (2) STF-2,
Klipsch HT500 satalites (4) for ceiling mounted ATMOS playback
DIY Linux desktop w/Clementine bit perfect media center. Emotiva Stealth DC-1 DAC

Last edited by Sal1950; 04-15-2018 at 11:44 PM.
Sal1950 is offline  
post #13872 of 14212 Old 04-16-2018, 03:13 PM
AVS Forum Special Member
 
mrtickleuk's Avatar
 
Join Date: May 2016
Location: Birmingham, UK - you know, the original one!
Posts: 6,647
Mentioned: 169 Post(s)
Tagged: 0 Thread(s)
Quoted: 4531 Post(s)
Liked: 6831
Quote:
Originally Posted by mr.kludge View Post
I checked and mine still says, "no soup for you".
So does mine

galonzo, Terminader and Musician like this.

_______________
Denon AVR-X4200W, Arcam Alpha 8P; 5.1.4 setup: Mission 702e, M7C1i, 77DS, 731. Rel T5 Sub. Monitor Audio CT165 4 Tops | LG OLED55C8PLA TV | Samsung UBD-K8500 UHD Blu-Ray

HDMI 2.0 4K modes | Dolby & DTS core+outer audio tracks on (UHD) Blu-Rays | Hello to Jason Isaacs
mrtickleuk is offline  
post #13873 of 14212 Old 04-17-2018, 06:22 AM
Member
 
David Jacobs's Avatar
 
Join Date: Jan 2014
Location: new jersey
Posts: 64
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 44 Post(s)
Liked: 19
I have the K8500 and a Denon x2200w receiver and a Lg Oled B7 TV. I have been having some issues with video cutting out when everything is running through the receiver. So now I am plugging in the main hdmi to the tv and the audio hdmi to the receiver for hd sound. I have the player run audio to the receiver from hdmi 2. But when the player is plugged into the tv and the receiver, I only get PCM sound from the receiver. As soon as I unplug the hdmi that goes from the player to the TV, the receiver lights up dolby atmos or Dolby True HD. As soon as I plug the tv back into the player it goes back to PCM. It's driving me crazy. I bought the Philips bdp7502 player and it works correctly with the sound with plugging the second hdmi into the receiver, but I have video issues with that player. I really don't want to buy another Blu-ray player.

Does anyone have any ideas why this isn't working correctly for me?
David Jacobs is offline  
post #13874 of 14212 Old 04-17-2018, 07:09 AM
AVS Forum Special Member
 
Stephen Hopkins's Avatar
 
Join Date: Feb 2004
Location: Douglasville, GA
Posts: 4,177
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 424 Post(s)
Liked: 196
I've had this player for several months anticipating a 4K projector upgrade, but just did the upgrade this week. With a BenQ TK800 projector and Monoprice DynamicView 35' active HDMI cable I get noticable noise/grain in the image that was not present with the same discs on my 1080p projector, other sources (4K or 1080p), or even streaming sources from this player (4K or 1080p). It is EXTREMELY noticable in Snoke's face in the throne room scenes of Last Jedi... it's extremely noisy and looks like his skin is literally crawling. I don't see the same on 4K my Shield TV or 1080p stream from the player. It is also EXTREMELY noticable in many of the solid white backgrounds on the Westworld UHD discs, but not in HBO GO 1080p streams from the player or Shield TV. It seems to be specific to UHD discs played back from this device.

Does anyone know of any setting that can tame/eliminate this? Would a newer Samsung player be any better? Or a Sony X800? I really don't have the budget for an Oppo right now and I'm sure they'll become rare and expensive once stock starts to run low/out.

Thoughts? Thanks!

BenQ TK800 | Silver Ticket 106" 16:9 1.0 Grey | Marantz SR6011 | B&W P6 | B&W CDMC SE | Sonance .5 THX SUR | MCM In-Ceiling Atmos | Ascendant Avalanche 12" in 6 ft^3 @ 18Hz w/ BASH 500w Plate Amp | Sony X800 | NVidia Shield TV Pro | XBox One 500gb | Nintendo Switch | Harmony Smart Control | SmartThings Hub | Google Home | AT&T Fiber 300 | YouTube TV | Netflix | HBO Now | Spotify
Stephen Hopkins is offline  
post #13875 of 14212 Old 04-17-2018, 10:46 AM
AVS Forum Special Member
 
mrtickleuk's Avatar
 
Join Date: May 2016
Location: Birmingham, UK - you know, the original one!
Posts: 6,647
Mentioned: 169 Post(s)
Tagged: 0 Thread(s)
Quoted: 4531 Post(s)
Liked: 6831
Quote:
Originally Posted by David Jacobs View Post
I have the K8500 and a Denon x2200w receiver and a Lg Oled B7 TV. I have been having some issues with video cutting out when everything is running through the receiver. So now I am plugging in the main hdmi to the tv and the audio hdmi to the receiver for hd sound. I have the player run audio to the receiver from hdmi 2. But when the player is plugged into the tv and the receiver, I only get PCM sound from the receiver. As soon as I unplug the hdmi that goes from the player to the TV, the receiver lights up dolby atmos or Dolby True HD. As soon as I plug the tv back into the player it goes back to PCM. It's driving me crazy. I bought the Philips bdp7502 player and it works correctly with the sound with plugging the second hdmi into the receiver, but I have video issues with that player. I really don't want to buy another Blu-ray player.

Does anyone have any ideas why this isn't working correctly for me?
Yes. See >THIS POST< .

To resolve your issue either LG have to fix their problem in their firmware (which it is - it doesn't happen with other makes of TV). Or, better, you resolve your problem with running through the Denon (only use cables which have passed the "HDMI Premium Certified" testing and badging programme and bear the anti-counterfeit label and can be verified using the free smartphone app). Ie use a single HDMI output from the player.



HTH
Rudy1, MALICIOUS ONE and Musician like this.

_______________
Denon AVR-X4200W, Arcam Alpha 8P; 5.1.4 setup: Mission 702e, M7C1i, 77DS, 731. Rel T5 Sub. Monitor Audio CT165 4 Tops | LG OLED55C8PLA TV | Samsung UBD-K8500 UHD Blu-Ray

HDMI 2.0 4K modes | Dolby & DTS core+outer audio tracks on (UHD) Blu-Rays | Hello to Jason Isaacs
mrtickleuk is offline  
post #13876 of 14212 Old 04-17-2018, 06:32 PM
AVS Forum Special Member
 
Stephen Hopkins's Avatar
 
Join Date: Feb 2004
Location: Douglasville, GA
Posts: 4,177
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 424 Post(s)
Liked: 196
Anyone have any input on the UHD Disc specific noise/grain I'm seeing with the K8500 and BenQ TK800 projector? I'm about ready to try an X800 to replace it but would love it if there was a fix/workaround/setting I'm just not aware of.

BenQ TK800 | Silver Ticket 106" 16:9 1.0 Grey | Marantz SR6011 | B&W P6 | B&W CDMC SE | Sonance .5 THX SUR | MCM In-Ceiling Atmos | Ascendant Avalanche 12" in 6 ft^3 @ 18Hz w/ BASH 500w Plate Amp | Sony X800 | NVidia Shield TV Pro | XBox One 500gb | Nintendo Switch | Harmony Smart Control | SmartThings Hub | Google Home | AT&T Fiber 300 | YouTube TV | Netflix | HBO Now | Spotify
Stephen Hopkins is offline  
post #13877 of 14212 Old 04-17-2018, 06:36 PM
Advanced Member
 
Quicksilv3r's Avatar
 
Join Date: Apr 2012
Location: Orangeville Canada
Posts: 833
Mentioned: 12 Post(s)
Tagged: 0 Thread(s)
Quoted: 458 Post(s)
Liked: 355
Official Samsung UBD-K8500 4K HDR Ultra HD Blu-Ray Player Owner's Thread

Quote:
Originally Posted by Stephen Hopkins View Post
Anyone have any input on the UHD Disc specific noise/grain I'm seeing with the K8500 and BenQ TK800 projector? I'm about ready to try an X800 to replace it but would love it if there was a fix/workaround/setting I'm just not aware of.


Check your settings once in a movie. Could be that your picture mode isn’t correct. Or it could be the colour settings.



Sent from my iPad using Tapatalk

tv: Samsung UN75MU800, Receiver: Denon AVR 730H, speakers: 4x M&K S-1B and M&K S85c for center, sub: MKsound V12 HTPC, Samsung UBP-K8500, Rogers Digital PVR, Chromecast Ultra

Last edited by Quicksilv3r; 04-17-2018 at 06:43 PM.
Quicksilv3r is offline  
post #13878 of 14212 Old 04-17-2018, 06:37 PM
AVS Forum Special Member
 
Stephen Hopkins's Avatar
 
Join Date: Feb 2004
Location: Douglasville, GA
Posts: 4,177
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 424 Post(s)
Liked: 196
Thanks for your placation, I'll give it a shot.

BenQ TK800 | Silver Ticket 106" 16:9 1.0 Grey | Marantz SR6011 | B&W P6 | B&W CDMC SE | Sonance .5 THX SUR | MCM In-Ceiling Atmos | Ascendant Avalanche 12" in 6 ft^3 @ 18Hz w/ BASH 500w Plate Amp | Sony X800 | NVidia Shield TV Pro | XBox One 500gb | Nintendo Switch | Harmony Smart Control | SmartThings Hub | Google Home | AT&T Fiber 300 | YouTube TV | Netflix | HBO Now | Spotify
Stephen Hopkins is offline  
post #13879 of 14212 Old 04-20-2018, 08:39 AM
Newbie
 
Join Date: Mar 2018
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 1
Quote:
Originally Posted by mr.kludge View Post
/snip/
Supplying Internet bandwidth is my day job but it still mystifies even myself.
I do tech support and the inconsistencies and bizarre behavior of computers never ceases to amaze me.

Okay, so I went to check the Amazon app on my player and noticed it has a new layout. Doesn't seem to work any better, but it looks different. I can't figure out how to force it to check for updates, but it seems to have done it on its own.
mid_life_crisis is offline  
post #13880 of 14212 Old 04-20-2018, 02:07 PM
AVS Forum Special Member
 
mrtickleuk's Avatar
 
Join Date: May 2016
Location: Birmingham, UK - you know, the original one!
Posts: 6,647
Mentioned: 169 Post(s)
Tagged: 0 Thread(s)
Quoted: 4531 Post(s)
Liked: 6831
An app just checks for updates of itself each time you run it, AFAIK.
Terminader likes this.

_______________
Denon AVR-X4200W, Arcam Alpha 8P; 5.1.4 setup: Mission 702e, M7C1i, 77DS, 731. Rel T5 Sub. Monitor Audio CT165 4 Tops | LG OLED55C8PLA TV | Samsung UBD-K8500 UHD Blu-Ray

HDMI 2.0 4K modes | Dolby & DTS core+outer audio tracks on (UHD) Blu-Rays | Hello to Jason Isaacs
mrtickleuk is offline  
post #13881 of 14212 Old 04-22-2018, 08:56 PM
Advanced Member
 
Sal1950's Avatar
 
Join Date: Nov 2015
Location: Central FL
Posts: 738
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 469 Post(s)
Liked: 531
Just got a notice screen that a update was available from my 8500. Told it to go ahead and update, after completion software version now showing as 1015. Maybe it does Dolby Vision now? LOL

Sony XBR75-X940D, Samsung UBD-K8500 UHD-BD, Xfinity X1 Voice DVR, Marantz AV-7703 Pre/Pro w/Auro, (3) Adcom GFA-545II amps, (2) Adcom GFA-535II amps for ATMOS speakers.
HSU Research 5.2 speaker system (4) HB-1 MK2, (1) HC-1 MK2, (2) STF-2,
Klipsch HT500 satalites (4) for ceiling mounted ATMOS playback
DIY Linux desktop w/Clementine bit perfect media center. Emotiva Stealth DC-1 DAC
Sal1950 is offline  
post #13882 of 14212 Old 04-23-2018, 04:17 AM
AVS Forum Special Member
 
CHASLS2's Avatar
 
Join Date: Feb 2009
Location: Tampa FL area
Posts: 3,147
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 1097 Post(s)
Liked: 492
I just gave my 8500 away to a friend. Never liked the remote.

Sony 65" A1E Pioneer Elite DV-59 AVI
OPPO203,103&83 Sony BD player
Pioneer Elite SC61 AVR Acurus 200x 3
Paradigm 60V5'S 490 CC V5
B&W 685 S2's 2 SVS subs
CHASLS2 is offline  
post #13883 of 14212 Old 04-23-2018, 04:31 AM
Advanced Member
 
Quicksilv3r's Avatar
 
Join Date: Apr 2012
Location: Orangeville Canada
Posts: 833
Mentioned: 12 Post(s)
Tagged: 0 Thread(s)
Quoted: 458 Post(s)
Liked: 355
Quote:
Originally Posted by CHASLS2 View Post
I just gave my 8500 away to a friend. Never liked the remote.
I don't like the remote either, so i programmed my Harmony remote

Sent from my SM-G935W8 using Tapatalk
Rudy1, JoeTiVo, joe221 and 1 others like this.

tv: Samsung UN75MU800, Receiver: Denon AVR 730H, speakers: 4x M&K S-1B and M&K S85c for center, sub: MKsound V12 HTPC, Samsung UBP-K8500, Rogers Digital PVR, Chromecast Ultra
Quicksilv3r is offline  
post #13884 of 14212 Old 04-23-2018, 07:47 AM
AVS Forum Addicted Member
 
p5browne's Avatar
 
Join Date: Jun 2008
Location: Sudbury, Ontario, CANADA
Posts: 10,175
Mentioned: 238 Post(s)
Tagged: 0 Thread(s)
Quoted: 3995 Post(s)
Liked: 3169
Quote:
Originally Posted by CHASLS2 View Post
I just gave my 8500 away to a friend. Never liked the remote.
I just use the remote from old Samsung players. Besides, the Hersey Bar remotes can be purchased for less than $20.

With all the changes going on, if it works, stick with it, elsewise you'll be buying a new player every year to keep up with all the changes going on.

And for my wife, 3D playback is a must! After watching several 4K movies, then the 3D version after, I'm starting to agree with her.
joe221 and MALICIOUS ONE like this.

UN65KS9800 - Mine
UN65HU9000 + SEK-3500U / UN75JU7100 / UN55HU7250 with SEK-3500U in UJS9000 Mod Mode / UN40J5200AF / HiSense 40H5507 - Wife's
UN55NU8000 X 2 - my 2 kids families (or should I say adults?)
p5browne is offline  
post #13885 of 14212 Old 04-23-2018, 11:00 AM
AVS Forum Special Member
 
NorthJersey's Avatar
 
Join Date: Jan 2003
Location: Northern NJ
Posts: 3,505
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 574 Post(s)
Liked: 246
Quote:
Originally Posted by Sal1950 View Post
Just got a notice screen that a update was available from my 8500. Told it to go ahead and update, after completion software version now showing as 1015. Maybe it does Dolby Vision now? LOL
highly doubtful, Samsung doesn't support DV, but rather HDR10+
NorthJersey is offline  
post #13886 of 14212 Old 04-23-2018, 11:01 AM
Advanced Member
 
Quicksilv3r's Avatar
 
Join Date: Apr 2012
Location: Orangeville Canada
Posts: 833
Mentioned: 12 Post(s)
Tagged: 0 Thread(s)
Quoted: 458 Post(s)
Liked: 355
Quote:
Originally Posted by NorthJersey View Post
highly doubtful, Samsung doesn't support DV, but rather HDR10+
He knows that.... He's just being not so bright and maybe sarcastic

Sent from my SM-G935W8 using Tapatalk

tv: Samsung UN75MU800, Receiver: Denon AVR 730H, speakers: 4x M&K S-1B and M&K S85c for center, sub: MKsound V12 HTPC, Samsung UBP-K8500, Rogers Digital PVR, Chromecast Ultra
Quicksilv3r is offline  
post #13887 of 14212 Old 04-23-2018, 01:31 PM
AVS Forum Special Member
 
mrtickleuk's Avatar
 
Join Date: May 2016
Location: Birmingham, UK - you know, the original one!
Posts: 6,647
Mentioned: 169 Post(s)
Tagged: 0 Thread(s)
Quoted: 4531 Post(s)
Liked: 6831
I explained very politely earlier, but my post about it has inexplicably vanished.
sparky7, Quicksilv3r and Musician like this.

_______________
Denon AVR-X4200W, Arcam Alpha 8P; 5.1.4 setup: Mission 702e, M7C1i, 77DS, 731. Rel T5 Sub. Monitor Audio CT165 4 Tops | LG OLED55C8PLA TV | Samsung UBD-K8500 UHD Blu-Ray

HDMI 2.0 4K modes | Dolby & DTS core+outer audio tracks on (UHD) Blu-Rays | Hello to Jason Isaacs
mrtickleuk is offline  
post #13888 of 14212 Old 04-23-2018, 02:09 PM
AVS Forum Addicted Member
 
p5browne's Avatar
 
Join Date: Jun 2008
Location: Sudbury, Ontario, CANADA
Posts: 10,175
Mentioned: 238 Post(s)
Tagged: 0 Thread(s)
Quoted: 3995 Post(s)
Liked: 3169
Question here is, with all the surrounding, competing brands now including DV, will Samsung sub-comb ?

UN65KS9800 - Mine
UN65HU9000 + SEK-3500U / UN75JU7100 / UN55HU7250 with SEK-3500U in UJS9000 Mod Mode / UN40J5200AF / HiSense 40H5507 - Wife's
UN55NU8000 X 2 - my 2 kids families (or should I say adults?)
p5browne is offline  
post #13889 of 14212 Old 04-23-2018, 02:33 PM
Advanced Member
 
Quicksilv3r's Avatar
 
Join Date: Apr 2012
Location: Orangeville Canada
Posts: 833
Mentioned: 12 Post(s)
Tagged: 0 Thread(s)
Quoted: 458 Post(s)
Liked: 355
Quote:
Originally Posted by p5browne View Post
Question here is, with all the surrounding, competing brands now including DV, will Samsung sub-comb ?
Nope. DV isn't all that great. Just read the forums.

Samsung won't give in.

Sent from my SM-G935W8 using Tapatalk
mrtickleuk likes this.

tv: Samsung UN75MU800, Receiver: Denon AVR 730H, speakers: 4x M&K S-1B and M&K S85c for center, sub: MKsound V12 HTPC, Samsung UBP-K8500, Rogers Digital PVR, Chromecast Ultra
Quicksilv3r is offline  
post #13890 of 14212 Old 04-23-2018, 03:23 PM
AVS Forum Special Member
 
mrtickleuk's Avatar
 
Join Date: May 2016
Location: Birmingham, UK - you know, the original one!
Posts: 6,647
Mentioned: 169 Post(s)
Tagged: 0 Thread(s)
Quoted: 4531 Post(s)
Liked: 6831
Comb:


Sub comb:


Daryl L, galonzo and Musician like this.

_______________
Denon AVR-X4200W, Arcam Alpha 8P; 5.1.4 setup: Mission 702e, M7C1i, 77DS, 731. Rel T5 Sub. Monitor Audio CT165 4 Tops | LG OLED55C8PLA TV | Samsung UBD-K8500 UHD Blu-Ray

HDMI 2.0 4K modes | Dolby & DTS core+outer audio tracks on (UHD) Blu-Rays | Hello to Jason Isaacs
mrtickleuk is offline  
Sponsored Links
Advertisement
 
Reply Blu-ray Players

Tags
color calibration , hdr player , member , settings

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off