OFFICIAL Sony UBP-X800 Owners Thread (No Price Talk) - Page 314 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 25411Likes
Reply
 
Thread Tools
post #9391 of 9896 Old 03-02-2019, 01:54 PM
UHD Addict
 
aaronwt's Avatar
 
Join Date: Aug 2001
Location: Northern VA(Woodbridge)
Posts: 36,128
Mentioned: 72 Post(s)
Tagged: 0 Thread(s)
Quoted: 9444 Post(s)
Liked: 6130
Quote:
Originally Posted by Robert Simandl View Post
Hey sometimes when I'm done watching a 4K disc and eject it, I get all kinds of weird video noise and other stuff going on.

I would try to do a search through this form, but I have no idea what this is called or what to search for.

But this is what I sometimes (about once after every three 4K discs?) get when ejecting a 4K disc:

YouTube Clip

Any ideas what's causing this or how to fix? Thanks!
Looks like you have sparkles on the screen. That has always been indicative of a cable issue. Sometimes re-seating the cable will fix it. But otherwise I would replace the cable. Those issues have been around with HDMi going back to the early days in 2004/2005.

With the properly working cable you should not see anything like that. I know with my X800 I never see anything like that. I"m using Monoprice Premium Certified cables in my setups. They have worked great with all my UHD devices.
Sharp1080 and PJL99 like this.

57TB unRAID1a--49TB unRAID2--76TB unRAID3
TCL 6 Series--Sony UBP-X800--Philips BDP7502--Onkyo HT-S7800
XBL/PSN: WormholeXtreme
aaronwt is offline  
Sponsored Links
Advertisement
 
post #9392 of 9896 Old 03-03-2019, 10:47 AM
AVS Forum Special Member
 
Sharp1080's Avatar
 
Join Date: Aug 2000
Location: Dallas Texas
Posts: 3,487
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 1064 Post(s)
Liked: 766
Aaron's correct

It has been around and apparently still is. I had the same issue years ago with an Infocus projector! I swapped out the HDMI cable for a Monoprice and no more handshake issues in that older system.
aaronwt likes this.
Sharp1080 is offline  
post #9393 of 9896 Old 03-04-2019, 04:52 PM
Senior Member
 
gentlejax's Avatar
 
Join Date: Feb 2006
Location: Shreveport Louisiana 71112
Posts: 208
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 45 Post(s)
Liked: 25
I tried to read all these posts but had to jump to middle and then now end.



I ordered a refurbed unit off ebay. is there something I should be watching for as far as being wrong with it. it only comes with 90 day warranty




I also have a Sony XBR55 90E TV smart tv so any tips on best settings would be also helpful. I only have a 2.1 system using an emotiva umc-1



not sure I needed this . I just figured my panasonic BDT330 is getting old and the pic of movies on this would be better. I dont watch a lot of dvds though. bought this mainly cause I had a $100 burning a hole in my pocket lol...
gentlejax is offline  
Sponsored Links
Advertisement
 
post #9394 of 9896 Old 03-04-2019, 09:58 PM
Senior Member
 
SLYDoggie's Avatar
 
Join Date: Nov 2007
Location: Nashville, TN
Posts: 486
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 250 Post(s)
Liked: 167
Quote:
Originally Posted by aaronwt View Post
Looks like you have sparkles on the screen. That has always been indicative of a cable issue. Sometimes re-seating the cable will fix it. But otherwise I would replace the cable. Those issues have been around with HDMi going back to the early days in 2004/2005.

With the properly working cable you should not see anything like that. I know with my X800 I never see anything like that. I"m using Monoprice Premium Certified cables in my setups. They have worked great with all my UHD devices.
I agree that this is probably an HDMI cable issue. This is an easy fix as Monoprice Premium Certified cables aren't very expensive. Also, I always thought that the shortest cable possible between units is the best but there are those who believe that you shouldn't use anything shorter than a 6' cable. On the other hand, cables that are too long can also introduce issues like this as well.

Regards, Steve
Projector/Receiver - Sony VPL-VW1100ES 4K PJ & Sony STR-ZA5000ES 4K Atmos AVR
Media Devices - Panasonic DP-UB820 4K BR, Sony UBP-X800 4K BR, ATV 4K, and Roku 4K
Screen - 145" Dragonfly, 1.2 Gain, 16:9, Matte White Fixed Screen
Theater Remote/Cables - Universal MX-990 RF Remote, Monoprice Certified 18Gb HDMI Cables
SLYDoggie is offline  
post #9395 of 9896 Old 03-05-2019, 12:22 PM
UHD Addict
 
aaronwt's Avatar
 
Join Date: Aug 2001
Location: Northern VA(Woodbridge)
Posts: 36,128
Mentioned: 72 Post(s)
Tagged: 0 Thread(s)
Quoted: 9444 Post(s)
Liked: 6130
Quote:
Originally Posted by SLYDoggie View Post
I agree that this is probably an HDMI cable issue. This is an easy fix as Monoprice Premium Certified cables aren't very expensive. Also, I always thought that the shortest cable possible between units is the best but there are those who believe that you shouldn't use anything shorter than a 6' cable. On the other hand, cables that are too long can also introduce issues like this as well.
I've read that before about short cables. But I use a bunch of the three foot cables with no issues with some of my UHD and HD devices.

57TB unRAID1a--49TB unRAID2--76TB unRAID3
TCL 6 Series--Sony UBP-X800--Philips BDP7502--Onkyo HT-S7800
XBL/PSN: WormholeXtreme
aaronwt is offline  
post #9396 of 9896 Old 03-06-2019, 06:57 AM
AVS Forum Special Member
 
Tweakophyte's Avatar
 
Join Date: Jan 2001
Location: Boulder, CO, USA
Posts: 3,482
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 96 Post(s)
Liked: 49
Any pros/cons for connecting this to an Epson 5040UB? I happen to have a Panny 820, but my buddy is looking at this player.

Thx

Panny UB820, Denon X6300H in 6.1.4 mode, Epson 5040UB, SVS PCUltra paired with a MiniDSP HD and BEQ (of course!)
Working on making things blacker...
Tweakophyte is offline  
post #9397 of 9896 Old 03-06-2019, 07:42 PM
Member
 
eJeremye's Avatar
 
Join Date: Jan 2014
Posts: 163
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 167 Post(s)
Liked: 32
X800 x X700 performance

Not counting Dolby Vision support, Build Quality and DVD Audio support, which is the better player the X700 or X800?

Thanks
eJeremye is offline  
post #9398 of 9896 Old 03-06-2019, 10:35 PM
Advanced Member
 
welldun's Avatar
 
Join Date: Jan 2007
Location: Long Island NY
Posts: 522
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 313 Post(s)
Liked: 157
Quote:
Originally Posted by Tweakophyte View Post
Any pros/cons for connecting this to an Epson 5040UB? I happen to have a Panny 820, but my buddy is looking at this player.

Thx
No issue for me. I have the 5040ub and X800.
Davemusic likes this.
welldun is offline  
post #9399 of 9896 Old 03-08-2019, 04:28 PM
Senior Member
 
Mike999's Avatar
 
Join Date: Dec 2007
Posts: 476
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Liked: 10
Does the X800 have a service menu I can call up to defeat noise reduction? I'm currently using this player with a 1080p TV and DVDs and Blu-Rays look very soft when doing A/B comparisons with my old BDP-BX2. The faces of actors lack detail and look very waxy, and film grain has mostly been scrubbed from the image. The X800 is clearly employing a lot of noise reduction, but I can't find any video setting to adjust it for disc playback. There are only settings to change it for internet content. The LG UP875 I owned was $100 cheaper and had various video modes - standard, movie, etc. - that had different levels of noise reduction. I'm surprised that a premium player like the X800 doesn't have similar settings.
Mike999 is offline  
post #9400 of 9896 Old 03-09-2019, 06:53 AM
AVS Forum Special Member
 
deano86's Avatar
 
Join Date: Apr 2008
Location: Wisconsin
Posts: 2,428
Mentioned: 8 Post(s)
Tagged: 0 Thread(s)
Quoted: 650 Post(s)
Liked: 321
Quote:
Originally Posted by Mike999 View Post
Does the X800 have a service menu I can call up to defeat noise reduction? I'm currently using this player with a 1080p TV and DVDs and Blu-Rays look very soft when doing A/B comparisons with my old BDP-BX2. The faces of actors lack detail and look very waxy, and film grain has mostly been scrubbed from the image. The X800 is clearly employing a lot of noise reduction, but I can't find any video setting to adjust it for disc playback. There are only settings to change it for internet content. The LG UP875 I owned was $100 cheaper and had various video modes - standard, movie, etc. - that had different levels of noise reduction. I'm surprised that a premium player like the X800 doesn't have similar settings.
Did you download the owners manual? Did you hit the Options button while a disc is playing and check your various picture settings there? And if it was most likely purchased used... make sure to do a full reset to factory settings to start with...
deano86 is offline  
post #9401 of 9896 Old 03-09-2019, 01:58 PM
Advanced Member
 
Join Date: Oct 2016
Location: Cleveland
Posts: 687
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 406 Post(s)
Liked: 44
Quote:
Originally Posted by Mike999 View Post
Does the X800 have a service menu I can call up to defeat noise reduction? I'm currently using this player with a 1080p TV and DVDs and Blu-Rays look very soft when doing A/B comparisons with my old BDP-BX2. The faces of actors lack detail and look very waxy, and film grain has mostly been scrubbed from the image. The X800 is clearly employing a lot of noise reduction, but I can't find any video setting to adjust it for disc playback. There are only settings to change it for internet content. The LG UP875 I owned was $100 cheaper and had various video modes - standard, movie, etc. - that had different levels of noise reduction. I'm surprised that a premium player like the X800 doesn't have similar settings.
As well as using the Options button while playing a disc as deano86 suggested, you should check the output resolution as that may also be an issue. You can leave it on Original Resolution and let the tv upscale, or leave it on the highest setting such as 1080p or 4K and let the player upscale. Try both and see what looks better for your television. The x800 is a great player. I have two of them. Even regular dvd's look great.
jkeldo is offline  
post #9402 of 9896 Old 03-09-2019, 04:55 PM
Senior Member
 
Join Date: Jun 2015
Posts: 442
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 332 Post(s)
Liked: 158
Quote:
Originally Posted by SLYDoggie View Post
In my case, I was having HDMI Handshake issues between my 4K (but not HDR) Sony Projector and the X800. My projector was also limited to 8-Bit 4:2:0 on 60P content as well. I solved my issue by adding an HDFury Integral 2 device between my receiver and my projector. That allows me to specify what capability the source device sees and convert that to the signal which the projector will accept. The HDFury Vertex will also do this. There are separate discussion threads on both products. Since then, I have not had an issue with my Roku 4K, Sony X800, AppleTV, or Panasonic 820. All of which had exhibited issues from time to time after firmware updates which "broke" the HDMI handshake process.


This may not be your issue but it certainly solved mine.


Turns out it was the cable. Went from a 35’ cable to a 25’ cable (both were Certified Premium high speed) and that did the trick. Phew!
IIDexII likes this.

Legacy Audio Silhouette Pro L/C/R
DefTech ProCinema 1000 SL/SR
DefTech Supercube III
Denon AVR790
Oppo PM-3
GIK bass traps and absorption
sunPin is offline  
post #9403 of 9896 Old 03-09-2019, 06:57 PM
 
IIDexII's Avatar
 
Join Date: Sep 2009
Posts: 739
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 319 Post(s)
Liked: 206
Quote:
Originally Posted by sunPin View Post
Turns out it was the cable. Went from a 35’ cable to a 25’ cable (both were Certified Premium high speed) and that did the trick. Phew!
Your not the first... So many fix issues on 4k long strech with a shorter or better hdmi cable.

On 4k 10meters 4.4.4 it must almost always be optical HDMI.

Think I have 15+ encounters with that fix in the forum's.
sunPin likes this.
IIDexII is offline  
post #9404 of 9896 Old 03-10-2019, 04:55 AM
Advanced Member
 
Join Date: Jun 2016
Posts: 515
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 339 Post(s)
Liked: 105
Quote:
Originally Posted by IIDexII View Post
Think I have 15+ encounters with that fix in the forum's.
As it turns out, the problem oftentimes can be in DDC. This is a good read on the topic:
http://digital.cepro.com/publication...articleBrowser
priitv8 is offline  
post #9405 of 9896 Old 03-11-2019, 01:10 PM
Advanced Member
 
Join Date: Jun 2016
Posts: 515
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 339 Post(s)
Liked: 105
Quote:
Originally Posted by Mike999 View Post
Does the X800 have a service menu I can call up to defeat noise reduction?
It does have a service mode, but there is nothing in there that would affect player settings.
priitv8 is offline  
post #9406 of 9896 Old 03-12-2019, 12:11 AM
Senior Member
 
Mike999's Avatar
 
Join Date: Dec 2007
Posts: 476
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Liked: 10
Quote:
Originally Posted by deano86 View Post
Did you download the owners manual? Did you hit the Options button while a disc is playing and check your various picture settings there? And if it was most likely purchased used... make sure to do a full reset to factory settings to start with...

You're right. I should've read the owner's manual rather than simply assuming the only video settings were in the set-up menu. I didn't realize there was a totally separate set of settings available using the Options button. It was set on Auto by default. I switched it to Direct and that seems to have brought the picture into line with what I get on my BX2. There isn't any indication in the owner's manual, however, as to what the Direct or Auto setting actually do. I'm assuming Direct means no picture adjustment or DNR is applied? Anyway, thanks the help.
Mike999 is offline  
post #9407 of 9896 Old 03-12-2019, 02:32 AM
Member
 
Join Date: Aug 2017
Posts: 182
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 105 Post(s)
Liked: 59
Firmware M36.R.0338


Benefits and improvements from the latest update
  • Removes the Gracenote® function
EU: https://www.sony.co.uk/electronics/s...loads/00015918

SONY KD-65A1
SONY UBP-X800
SONY HT-ST5000
lukv is offline  
post #9408 of 9896 Old 03-12-2019, 03:13 AM
Member
 
Join Date: Jun 2017
Location: Gembrook, Victoria
Posts: 35
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Liked: 2
Send a message via Skype™ to bernievink
Quote:
Originally Posted by lukv View Post
Firmware M36.R.0338


Benefits and improvements from the latest update
  • Removes the Gracenote® function
EU: https://www.sony.co.uk/electronics/s...loads/00015918
The same firmware is available from Sony Australia for Australian model.
Get it here or wait for your player to update itself if auto update is turned on.
https://www.sony.com.au/electronics/...loads/00015919

whenever I try to do this via USB I always get the message "file is corrupt"
I follow the instructions to the letter but no avail.
And when I try to update via the internet I get "already updated" even though it is still at firmware version M36.R.0239

Samsung UA60KU6000WXXY TV, Sony STR#dh770 Receiver with wall, ceiling, and floor mounted 7.1 Sony Speaker system, Sony UBP-X800 Ultra HD Blu-ray™/DVD Player

Last edited by bernievink; 03-13-2019 at 11:10 PM.
bernievink is offline  
post #9409 of 9896 Old 03-12-2019, 06:19 AM
AVS Forum Special Member
 
deano86's Avatar
 
Join Date: Apr 2008
Location: Wisconsin
Posts: 2,428
Mentioned: 8 Post(s)
Tagged: 0 Thread(s)
Quoted: 650 Post(s)
Liked: 321
Quote:
Originally Posted by Mike999 View Post
You're right. I should've read the owner's manual rather than simply assuming the only video settings were in the set-up menu. I didn't realize there was a totally separate set of settings available using the Options button. It was set on Auto by default. I switched it to Direct and that seems to have brought the picture into line with what I get on my BX2. There isn't any indication in the owner's manual, however, as to what the Direct or Auto setting actually do. I'm assuming Direct means no picture adjustment or DNR is applied? Anyway, thanks the help.
I too am operating under the assumption that Direct mode has no additional processing... and that is what I am using... but would indeed be nice to have that confirmed in the manual though...
deano86 is offline  
post #9410 of 9896 Old 03-12-2019, 11:12 AM
Advanced Member
 
erick granato's Avatar
 
Join Date: Nov 2002
Location: toronto area
Posts: 880
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 138 Post(s)
Liked: 107
Does anybody know if the X800 in us/Canada are region 2 compatible?
erick granato is offline  
post #9411 of 9896 Old 03-12-2019, 12:08 PM
Advanced Member
 
LNEWoLF's Avatar
 
Join Date: Jan 2006
Posts: 940
Mentioned: 11 Post(s)
Tagged: 0 Thread(s)
Quoted: 477 Post(s)
Liked: 293
USA Firmware update version M36.R.0338 for UBP-X800/UBP-UX80

https://www.sony.com/electronics/sup...loads/00015920

Benefits and improvements from the latest update
Removes the Gracenote® function


Previous Benefits and Improvements
Improves HDMI connection stability
Enables HDR10 for Prime Video content
Solves playback issue for specific Blu-ray titles
Extends Ultra HD Blu-ray compatibility (Japan and North America)
Improves the stability of network service
Solves possible disc playback issues
Improved intense color quality on HDR Content playback
Improved compatibility with OLED TVs from other brands
Supports additional network services (YouTube, Spotify Connect)
Extends 4K UHD content availability on some TVs
UI (background) has been changed
Supports some network services

Twin Pioneer AVR Locomotives-Elite SC 97, SC 1222 7.2.4, DOLBY Atmos and DTS X, (Front Pre Out,) JBL Pro Synthesis LS Series Speakers, F L R-LS80, Cen-LS, S L R-LS60, SB L R-LS60, 4 Dolby Atmos Enabled Klipsch R41SA, Twin Klipsch R120SW. Mitz 73740 DLP, Sony UBP-X800, ATV G4, Yamaha ATS 1060 Sound Bar, True Depth Firestorm 2.0 3D Glasses, Harmony Hub with Utlimate 1 Remote, Broadlink RM Pro2, EYE Pad Air, Winegard FL6550A
LNEWoLF is offline  
post #9412 of 9896 Old 03-12-2019, 03:17 PM
Newbie
 
Join Date: Feb 2019
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Liked: 1
Well I updated to 338 but still not able to play any bluray disc from Alien Quadrilogy without turning off internet connection in BD/DVD viewing settings. It is a fox collection.
rmontero1701 is offline  
post #9413 of 9896 Old 03-13-2019, 06:30 AM
Senior Member
 
akosoft's Avatar
 
Join Date: Jul 2006
Location: Netherlands
Posts: 305
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 42 Post(s)
Liked: 50
The picture looks sharper on my projector after the update...cool, even if it is a placebo...
akosoft is offline  
post #9414 of 9896 Old 03-13-2019, 02:41 PM
Advanced Member
 
bradman's Avatar
 
Join Date: Feb 2006
Posts: 737
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 190 Post(s)
Liked: 144
If you read the patch notes posted above, you'll see all of the changes are from previous updates, the only thing changed with 338 is the removal of Gracenote.
aaronwt likes this.

PSN BradCompany
bradman is offline  
post #9415 of 9896 Old 03-13-2019, 03:04 PM
 
IIDexII's Avatar
 
Join Date: Sep 2009
Posts: 739
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 319 Post(s)
Liked: 206
Why can't we delete the Gracenote app then?

It's still there in the menu.
aaronwt likes this.
IIDexII is offline  
post #9416 of 9896 Old 03-13-2019, 11:25 PM
Member
 
Join Date: Feb 2017
Posts: 69
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 55 Post(s)
Liked: 5
Quote:
Originally Posted by rmontero1701 View Post
Well I updated to 338 but still not able to play any bluray disc from Alien Quadrilogy without turning off internet connection in BD/DVD viewing settings. It is a fox collection.
I’m assuming you are referring to the BD Live option and not really a network problem. Network settings should not affect disc playback. BD Live was a feature that was on early Blu-ray Discs. It never took off, and frequently caused disc to not play. Like you are experiencing. That feature has been useless for years and should be set to “Do Not Allow”, which is the default setting to begin with.

Last edited by Cjminer72; 03-13-2019 at 11:49 PM.
Cjminer72 is offline  
post #9417 of 9896 Old 03-14-2019, 12:07 PM
Newbie
 
Join Date: Feb 2019
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Liked: 1
Quote:
Originally Posted by Cjminer72 View Post
I’m assuming you are referring to the BD Live option and not really a network problem. Network settings should not affect disc playback. BD Live was a feature that was on early Blu-ray Discs. It never took off, and frequently caused disc to not play. Like you are experiencing. That feature has been useless for years and should be set to “Do Not Allow”, which is the default setting to begin with.
Specifically referring to BD Internet Connection in the BD/DVD Viewing Settings, which by not allowing the connection blocks BD Live.
rmontero1701 is offline  
post #9418 of 9896 Old 03-14-2019, 01:04 PM
 
IIDexII's Avatar
 
Join Date: Sep 2009
Posts: 739
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 319 Post(s)
Liked: 206
Quote:
Originally Posted by Cjminer72 View Post
I’m assuming you are referring to the BD Live option and not really a network problem. Network settings should not affect disc playback. BD Live was a feature that was on early Blu-ray Discs. It never took off, and frequently caused disc to not play. Like you are experiencing. That feature has been useless for years and should be set to “Do Not Allow”, which is the default setting to begin with.
I agree it only takes up place usb for my hi Rez downloaded music.
IIDexII is offline  
post #9419 of 9896 Old 03-15-2019, 07:35 AM
Newbie
 
Join Date: Mar 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 0
Quote:
Originally Posted by LNEWoLF View Post
USA Firmware update version M36.R.0338 for UBP-X800/UBP-UX80

Benefits and improvements from the latest update
Removes the Gracenote® function


Previous Benefits and Improvements
Improves HDMI connection stability
Enables HDR10 for Prime Video content
Solves playback issue for specific Blu-ray titles
Extends Ultra HD Blu-ray compatibility (Japan and North America)
Improves the stability of network service
Solves possible disc playback issues
Improved intense color quality on HDR Content playback
Improved compatibility with OLED TVs from other brands
Supports additional network services (YouTube, Spotify Connect)
Extends 4K UHD content availability on some TVs
UI (background) has been changed
Supports some network services
Hi all,


New here to the forum.


Anyone know if the update addresses playback apps like VUDU or PS/Video, just got the player yesterday and did not find any of those two apps installed nor any way of downloading them. If anyone can share any light on this, tried looking in the forum but couldn't find anything or I missed it. Also I saw in the VUDU page of applicable devices for 4k playback, UBP-X700 listed so if its available for the X700 it should be also for the X800 right?


Thanks in advanced!
Jakle is offline  
post #9420 of 9896 Old 03-15-2019, 08:44 AM
AVS Forum Special Member
 
nathan_h's Avatar
 
Join Date: Mar 2001
Posts: 9,330
Mentioned: 43 Post(s)
Tagged: 0 Thread(s)
Quoted: 2730 Post(s)
Liked: 1961
Quote:
Originally Posted by eJeremye View Post
Not counting Dolby Vision support, Build Quality and DVD Audio support, which is the better player the X700 or X800?

Thanks
So you don't want Dolby Vision? Then either player is fine. (If you care, then the 700 is your only option AFAIK.)

You don't care about build quality? Either player is fine. (If you care, then the 800 is typically considered better.)

You don't care about DVD Audio? Then either player is fine. (If you care, then the 800 is your player, AFAIK.)

It would probably be better to say what you want. For example, do Apps matter? If so, which ones and do you care about HDR in them? Does price matter? Etc.
nathan_h is offline  
Sponsored Links
Advertisement
 
Reply Blu-ray Players

Tags
4kupscale , 5040 , dsf , Epson , problem , Sony , sony ubp-x800 , streaming music , surround decode , ubp-ux80 , ubp-x1000es , x800

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off