OFFICAL SAMSUNG UBD-M9500 OWNER'S THREAD (No price talk, please) - Page 3 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 689Likes
Reply
 
Thread Tools
post #61 of 1070 Old 04-30-2017, 09:50 AM
Advanced Member
 
aKa DaShiznit's Avatar
 
Join Date: Jan 2007
Location: Old Bridge, NJ
Posts: 900
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 448 Post(s)
Liked: 281
Quote:
Originally Posted by wmoss35 View Post
Quote:
Originally Posted by b0rnarian View Post
Its too bad the regular BluRay quality isnt as good as the Sony player. Hurts even more as you can't have your TV do the upscaling on the fly. But might be worth the investment if the player gets the HDR10+ update in the future.
they are real real close pq wise, resolution wise probably equal if you manually set 1080p on the player so the tv upscales it. Color wise though the sony is better on blu rays, it almost gives is that faux hdr effect like the 930e, hard to explain. Most folks probably wouldnt be able to see any difference between the two.
Off the top of my head I believe the reason for this is deep color is set to auto default on the x800 and off default on the m9500. I have not played with this and since I no longer have the x800. Maybe try turning on deep color on the Sammy and try regular blu-rays then to see how the colors compare?

I use my standard Sony player for blu playback and that player is set to deep color on which is what made me think of that.
aKa DaShiznit is offline  
Sponsored Links
Advertisement
 
post #62 of 1070 Old 04-30-2017, 10:58 AM
AVS Forum Special Member
 
Join Date: Jul 2015
Posts: 1,110
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 705 Post(s)
Liked: 625
Quote:
Originally Posted by aKa DaShiznit View Post
Quote:
Originally Posted by wmoss35 View Post
Quote:
Originally Posted by b0rnarian View Post
Its too bad the regular BluRay quality isnt as good as the Sony player. Hurts even more as you can't have your TV do the upscaling on the fly. But might be worth the investment if the player gets the HDR10+ update in the future.
they are real real close pq wise, resolution wise probably equal if you manually set 1080p on the player so the tv upscales it. Color wise though the sony is better on blu rays, it almost gives is that faux hdr effect like the 930e, hard to explain. Most folks probably wouldnt be able to see any difference between the two.
Off the top of my head I believe the reason for this is deep color is set to auto default on the x800 and off default on the m9500. I have not played with this and since I no longer have the x800. Maybe try turning on deep color on the Sammy and try regular blu-rays then to see how the colors compare?

I use my standard Sony player for blu playback and that player is set to deep color on which is what made me think of that.
I have it off on the sony, one of the first things i did when i got the player.
wmoss35 is offline  
post #63 of 1070 Old 04-30-2017, 12:43 PM
Advanced Member
 
aKa DaShiznit's Avatar
 
Join Date: Jan 2007
Location: Old Bridge, NJ
Posts: 900
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 448 Post(s)
Liked: 281
Quote:
Originally Posted by wmoss35 View Post
Quote:
Originally Posted by aKa DaShiznit View Post
Quote:
Originally Posted by wmoss35 View Post
Quote:
Originally Posted by b0rnarian View Post
Its too bad the regular BluRay quality isnt as good as the Sony player. Hurts even more as you can't have your TV do the upscaling on the fly. But might be worth the investment if the player gets the HDR10+ update in the future.
they are real real close pq wise, resolution wise probably equal if you manually set 1080p on the player so the tv upscales it. Color wise though the sony is better on blu rays, it almost gives is that faux hdr effect like the 930e, hard to explain. Most folks probably wouldnt be able to see any difference between the two.
Off the top of my head I believe the reason for this is deep color is set to auto default on the x800 and off default on the m9500. I have not played with this and since I no longer have the x800. Maybe try turning on deep color on the Sammy and try regular blu-rays then to see how the colors compare?

I use my standard Sony player for blu playback and that player is set to deep color on which is what made me think of that.
I have it off on the sony, one of the first things i did when i got the player.
Ah never mind then lol
aKa DaShiznit is offline  
Sponsored Links
Advertisement
 
post #64 of 1070 Old 05-01-2017, 06:30 AM
AVS Forum Special Member
 
b0rnarian's Avatar
 
Join Date: Jan 2008
Location: Indiana
Posts: 2,569
Mentioned: 15 Post(s)
Tagged: 0 Thread(s)
Quoted: 1970 Post(s)
Liked: 1168
This guys loves the M9500 player... though he's kinda annoying and super elementary in his commentary. Still, good overview of the player as there's not much else on the net for this player. Enjoy!


Best,
Main Living Room: Samsung 65 KS9800 + Denon X4500H 11.1 + Sony UBP-X800 + PS4
Other Living Room: Panasonic Plasma 55 + Onkyo Home Theater System 5.1 + PS3
Discs For SALE : 4Ks And 2Ks!
b0rnarian is offline  
post #65 of 1070 Old 05-01-2017, 08:12 AM
Advanced Member
 
aKa DaShiznit's Avatar
 
Join Date: Jan 2007
Location: Old Bridge, NJ
Posts: 900
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 448 Post(s)
Liked: 281
Quote:
Originally Posted by b0rnarian View Post
This guys loves the M9500 player... though he's kinda annoying and super elementary in his commentary. Still, good overview of the player as there's not much else on the net for this player. Enjoy!

I actually like his reviews. They may not come across as that professional but he tries and actually has all the players to compare.

He's done some decent comparison between the k8500, Sony and lg so I look forward to his thoughts on the m9500 vs those. Nice for me that he got the same TV as me too.
aKa DaShiznit is offline  
post #66 of 1070 Old 05-02-2017, 04:37 AM
Advanced Member
 
aKa DaShiznit's Avatar
 
Join Date: Jan 2007
Location: Old Bridge, NJ
Posts: 900
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 448 Post(s)
Liked: 281
Any of you other guys with this player have any issue with audio from the amazon app? For some reason I am not getting any audio but only from the amazon app.

Audio from discs, Netflix and vudu play perfectly. I tried unplugging the player and reinstalling the amazon app but still nothing. I will try resetting the hub to see if that helps but was curious if anyone else had this issue.
aKa DaShiznit is offline  
post #67 of 1070 Old 05-02-2017, 05:49 AM
AVS Forum Special Member
 
Join Date: Jul 2015
Posts: 1,110
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 705 Post(s)
Liked: 625
Quote:
Originally Posted by aKa DaShiznit View Post
Any of you other guys with this player have any issue with audio from the amazon app? For some reason I am not getting any audio but only from the amazon app.

Audio from discs, Netflix and vudu play perfectly. I tried unplugging the player and reinstalling the amazon app but still nothing. I will try resetting the hub to see if that helps but was curious if anyone else had this issue.
The only streaming ive done through the player is youtube so cant speak for the amazon app
wmoss35 is offline  
post #68 of 1070 Old 05-02-2017, 06:25 AM
AVS Forum Special Member
 
b0rnarian's Avatar
 
Join Date: Jan 2008
Location: Indiana
Posts: 2,569
Mentioned: 15 Post(s)
Tagged: 0 Thread(s)
Quoted: 1970 Post(s)
Liked: 1168
Quote:
Originally Posted by wmoss35 View Post
The only streaming ive done through the player is youtube so cant speak for the amazon app
Heard there's a ton of Apps loaded on the player, like 50 of em. Unlike any other Player out there, so that's awesome!

Best,
Main Living Room: Samsung 65 KS9800 + Denon X4500H 11.1 + Sony UBP-X800 + PS4
Other Living Room: Panasonic Plasma 55 + Onkyo Home Theater System 5.1 + PS3
Discs For SALE : 4Ks And 2Ks!
b0rnarian is offline  
post #69 of 1070 Old 05-02-2017, 07:31 AM
Advanced Member
 
aKa DaShiznit's Avatar
 
Join Date: Jan 2007
Location: Old Bridge, NJ
Posts: 900
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 448 Post(s)
Liked: 281
Quote:
Originally Posted by b0rnarian View Post
Quote:
Originally Posted by wmoss35 View Post
The only streaming ive done through the player is youtube so cant speak for the amazon app
Heard there's a ton of Apps loaded on the player, like 50 of em. Unlike any other Player out there, so that's awesome!
There are a lot. I went to start watching the 3rd season of Bosch last night but got no sound. Only a problem with amazon though so if anyone else can check theirs real quick I'm curious if it's just mine or a problem with the amazon app overall.
aKa DaShiznit is offline  
post #70 of 1070 Old 05-02-2017, 07:54 AM
AVS Forum Special Member
 
b0rnarian's Avatar
 
Join Date: Jan 2008
Location: Indiana
Posts: 2,569
Mentioned: 15 Post(s)
Tagged: 0 Thread(s)
Quoted: 1970 Post(s)
Liked: 1168
Quote:
Originally Posted by aKa DaShiznit View Post
There are a lot. I went to start watching the 3rd season of Bosch last night but got no sound. Only a problem with amazon though so if anyone else can check theirs real quick I'm curious if it's just mine or a problem with the amazon app overall.
Are you getting UHD / HDR from the stream... I sometime get a sound hiccup from Amazon b/c the steam hasn't caught up... not sure if that's your issue. And this is on my Samsung TV, not the player but who knows.

Best,
Main Living Room: Samsung 65 KS9800 + Denon X4500H 11.1 + Sony UBP-X800 + PS4
Other Living Room: Panasonic Plasma 55 + Onkyo Home Theater System 5.1 + PS3
Discs For SALE : 4Ks And 2Ks!
b0rnarian is offline  
post #71 of 1070 Old 05-02-2017, 08:22 AM
Advanced Member
 
aKa DaShiznit's Avatar
 
Join Date: Jan 2007
Location: Old Bridge, NJ
Posts: 900
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 448 Post(s)
Liked: 281
Quote:
Originally Posted by b0rnarian View Post
Quote:
Originally Posted by aKa DaShiznit View Post
There are a lot. I went to start watching the 3rd season of Bosch last night but got no sound. Only a problem with amazon though so if anyone else can check theirs real quick I'm curious if it's just mine or a problem with the amazon app overall.
Are you getting UHD / HDR from the stream... I sometime get a sound hiccup from Amazon b/c the steam hasn't caught up... not sure if that's your issue. And this is on my Samsung TV, not the player but who knows.
Yes I'm getting great video quality and hdr. What's weird I noticed is the AVR will only report stereo or if I restart the episode it'll say multichannel 7.1. Even when I get DD+ to kick on it still stays silent. Weird cause I get audio from all the other apps so must be an Amazon app glitch on the player.
aKa DaShiznit is offline  
post #72 of 1070 Old 05-02-2017, 08:51 AM
AVS Forum Special Member
 
b0rnarian's Avatar
 
Join Date: Jan 2008
Location: Indiana
Posts: 2,569
Mentioned: 15 Post(s)
Tagged: 0 Thread(s)
Quoted: 1970 Post(s)
Liked: 1168
Quote:
Originally Posted by aKa DaShiznit View Post
Yes I'm getting great video quality and hdr. What's weird I noticed is the AVR will only report stereo or if I restart the episode it'll say multichannel 7.1. Even when I get DD+ to kick on it still stays silent. Weird cause I get audio from all the other apps so must be an Amazon app glitch on the player.
Sounds like (no pun intended) the App is sending recognizable Audio since the tracks on AVR are changing... Try changing from BitStream to PCM and vice-versa, see if that makes a difference. PS: What AVR do you have?

Best,
Main Living Room: Samsung 65 KS9800 + Denon X4500H 11.1 + Sony UBP-X800 + PS4
Other Living Room: Panasonic Plasma 55 + Onkyo Home Theater System 5.1 + PS3
Discs For SALE : 4Ks And 2Ks!
b0rnarian is offline  
post #73 of 1070 Old 05-02-2017, 09:12 AM - Thread Starter
AVS Forum Special Member
 
Rudy1's Avatar
 
Join Date: Oct 2000
Location: Ft. Lauderdale, FL
Posts: 5,744
Mentioned: 189 Post(s)
Tagged: 0 Thread(s)
Quoted: 1960 Post(s)
Liked: 3259
Amazon was working fine for me on Sunday night...I began watching the first season of "The Expanse" in UHD for the second time and had no problems.

Definition of "Stupid": Knowing the truth, seeing the truth, but still believing the lies.
Rudy1 is offline  
post #74 of 1070 Old 05-02-2017, 09:51 AM
Advanced Member
 
aKa DaShiznit's Avatar
 
Join Date: Jan 2007
Location: Old Bridge, NJ
Posts: 900
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 448 Post(s)
Liked: 281
I have a Denon AVR-x6200w. I'm gonna try resetting the media hub when I get home from work as that seams to work for the tv apps lol.

It's not detecting the right signal though as it should be DD+ 5.1 but instead says stereo or multichannel in 7.1.
aKa DaShiznit is offline  
post #75 of 1070 Old 05-02-2017, 01:21 PM
Member
 
Join Date: Mar 2017
Location: Colchester, England UK
Posts: 97
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 69 Post(s)
Liked: 22
Hi Guys, As a Sonos user i'm really keen to find out if the M9500 re-encodes to DD5.1 bitstream output on the fly like the K8500 did. Looking at the M9500 manual the settings look the same as the K8500 'Audio Output Format (HDMI)' but it would be great if one of you could test it to make sure it's working as hoped? Please!

Sony KD-55XD9305
Samsung BD-J7500 & UBD-M9500
Sonos Soundbar/Sub/2 x Play 1's

Last edited by sonosman; 05-02-2017 at 01:37 PM.
sonosman is offline  
post #76 of 1070 Old 05-02-2017, 01:56 PM - Thread Starter
AVS Forum Special Member
 
Rudy1's Avatar
 
Join Date: Oct 2000
Location: Ft. Lauderdale, FL
Posts: 5,744
Mentioned: 189 Post(s)
Tagged: 0 Thread(s)
Quoted: 1960 Post(s)
Liked: 3259
Quote:
Originally Posted by sonosman View Post
Hi Guys, As a Sonos user i'm really keen to find out if the M9500 re-encodes to DD5.1 bitstream output on the fly like the K8500 did. Looking at the M9500 manual the settings look the same as the K8500 'Audio Output Format (HDMI)' but it would be great if one of you could test it to make sure it's working as hoped? Please!
Yes, it does have that capability.

Definition of "Stupid": Knowing the truth, seeing the truth, but still believing the lies.
Rudy1 is offline  
post #77 of 1070 Old 05-02-2017, 01:58 PM - Thread Starter
AVS Forum Special Member
 
Rudy1's Avatar
 
Join Date: Oct 2000
Location: Ft. Lauderdale, FL
Posts: 5,744
Mentioned: 189 Post(s)
Tagged: 0 Thread(s)
Quoted: 1960 Post(s)
Liked: 3259
Quote:
Originally Posted by aKa DaShiznit View Post
Any of you other guys with this player have any issue with audio from the amazon app? For some reason I am not getting any audio but only from the amazon app.

Audio from discs, Netflix and vudu play perfectly. I tried unplugging the player and reinstalling the amazon app but still nothing. I will try resetting the hub to see if that helps but was curious if anyone else had this issue.
I can confirm that there is no audio on any of the titles I've tested on Amazon Video. I have not tried resetting the Hub. I just emailed the engineers, so please post if any of you have found a cause or a workaround...nothing I tried seemed to work. All other sources are behaving as expected. Firmware version is 1101.4.
cydeweyz likes this.

Definition of "Stupid": Knowing the truth, seeing the truth, but still believing the lies.
Rudy1 is offline  
post #78 of 1070 Old 05-02-2017, 04:49 PM
AVS Forum Special Member
 
Join Date: Jul 2015
Posts: 1,110
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 705 Post(s)
Liked: 625
Fyi without mentioning specific price the price has dropped some since buying last week. Best buy just credited me the difference. Hope thats allowed to mention!
Rudy1 and MorganB like this.
wmoss35 is offline  
post #79 of 1070 Old 05-02-2017, 05:27 PM - Thread Starter
AVS Forum Special Member
 
Rudy1's Avatar
 
Join Date: Oct 2000
Location: Ft. Lauderdale, FL
Posts: 5,744
Mentioned: 189 Post(s)
Tagged: 0 Thread(s)
Quoted: 1960 Post(s)
Liked: 3259
Quote:
Originally Posted by wmoss35 View Post
Fyi without mentioning specific price the price has dropped some since buying last week. Best buy just credited me the difference. Hope thats allowed to mention!
Thanks for mentioning this here. I posted the exact amount and vendor in the Great Deals section for Blu-Ray players earlier today.

Definition of "Stupid": Knowing the truth, seeing the truth, but still believing the lies.
Rudy1 is offline  
post #80 of 1070 Old 05-02-2017, 06:27 PM
Member
 
djpault's Avatar
 
Join Date: May 2017
Location: Tulsa, Oklahoma USA
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 29 Post(s)
Liked: 10
Exclamation Amazon audio not working

Quote:
Originally Posted by aKa DaShiznit View Post
Any of you other guys with this player have any issue with audio from the amazon app? For some reason I am not getting any audio but only from the amazon app.

Audio from discs, Netflix and vudu play perfectly. I tried unplugging the player and reinstalling the amazon app but still nothing. I will try resetting the hub to see if that helps but was curious if anyone else had this issue.
I made an account just to chime in and say, I'm having this problem too! Audio quit working on Amazon app. It was working fine last time I used it, which was on Saturday. If anyone finds out a fix please let us know! thanks. I have a Samsung KS8500 tv and a Marantz NR-1607 AVR.

P.S. Someone asked about the wifi. KS8500 tv's wifi is not good, but the wifi on this blu-ray player has been strong for me.
b0rnarian likes this.
djpault is offline  
post #81 of 1070 Old 05-02-2017, 08:24 PM - Thread Starter
AVS Forum Special Member
 
Rudy1's Avatar
 
Join Date: Oct 2000
Location: Ft. Lauderdale, FL
Posts: 5,744
Mentioned: 189 Post(s)
Tagged: 0 Thread(s)
Quoted: 1960 Post(s)
Liked: 3259
Quote:
Originally Posted by djpault View Post
I made an account just to chime in and say, I'm having this problem too! Audio quit working on Amazon app. It was working fine last time I used it, which was on Saturday. If anyone finds out a fix please let us know! thanks. I have a Samsung KS8500 tv and a Marantz NR-1607 AVR.

P.S. Someone asked about the wifi. KS8500 tv's wifi is not good, but the wifi on this blu-ray player has been strong for me.
Thanks for signing up and posting. I've been back and forth with the software engineer earlier this evening, and he's unable to reproduce the problem on his end. We've tried taking the AVR out of the mix and still the only audio the unit produces on Amazon is 2-channel PCM...all other audio settings on the player result in no audio for Amazon content. We are using "The Last Tycoon" as the test title.

Definition of "Stupid": Knowing the truth, seeing the truth, but still believing the lies.
Rudy1 is offline  
post #82 of 1070 Old 05-02-2017, 09:07 PM
Member
 
djpault's Avatar
 
Join Date: May 2017
Location: Tulsa, Oklahoma USA
Posts: 30
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 29 Post(s)
Liked: 10
Quote:
Originally Posted by Rudy1 View Post
Thanks for signing up and posting. I've been back and forth with the software engineer earlier this evening, and he's unable to reproduce the problem on his end. We've tried taking the AVR out of the mix and still the only audio the unit produces on Amazon is 2-channel PCM...all other audio settings on the player result in no audio for Amazon content. We are using "The Last Tycoon" as the test title.
Thanks for the reply Rudy1. Who might I contact about this issue?
djpault is offline  
post #83 of 1070 Old 05-02-2017, 09:17 PM
Newbie
 
Join Date: May 2017
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 2
I'm driving them crazy at Best Buy. I replaced my Samsung UBD-K8500 with the new Samsung UBD-M9500. Always looking for a bargain I saw the new Sony UBP-X800 and exchanged the new Samsung for the Sony. Sony seems very well built and was fairly easy to set up. However, I had problems with sound and the picture quality was much better on Samsung. Returned the Sony and repurchased the Samsung UBD-K8500. Much easier to set up and very pleased with picture quality and sound on my Samsung HW-K950 ATMOS system is excellent. However, in setting up the streaming services I cannot get any sound from Amazon when broadcast are in HD. Apparently others are having a similar problem and hope a fix is forth coming from Samsung.
Gary F Martino is offline  
post #84 of 1070 Old 05-02-2017, 09:23 PM
Newbie
 
Join Date: May 2017
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 2
Quote:
Originally Posted by Gary F Martino View Post
I'm driving them crazy at Best Buy. I replaced my Samsung UBD-K8500 with the new Samsung UBD-M9500. Always looking for a bargain I saw the new Sony UBP-X800 and exchanged the new Samsung for the Sony. Sony seems very well built and was fairly easy to set up. However, I had problems with sound and the picture quality was much better on Samsung. Returned the Sony and repurchased the Samsung UBD-K8500. Much easier to set up and very pleased with picture quality and sound on my Samsung HW-K950 ATMOS system is excellent. However, in setting up the streaming services I cannot get any sound from Amazon when broadcast are in HD. Apparently others are having a similar problem and hope a fix is forth coming from Samsung.
Previous post should have said replaced Sony UBP-X800 with the Samsung UBD-M9500.
Gary F Martino is offline  
post #85 of 1070 Old 05-03-2017, 12:42 AM
Member
 
Join Date: Mar 2017
Location: Colchester, England UK
Posts: 97
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 69 Post(s)
Liked: 22
Quote:
Originally Posted by Gary F Martino View Post
Previous post should have said replaced Sony UBP-X800 with the Samsung UBD-M9500.
Hi Gary,

As you've experience of both the current K8500 and the new M9500 is it worth me waiting for it to be available in the UK or just bite the bullet and get the K8500??

Sony KD-55XD9305
Samsung BD-J7500 & UBD-M9500
Sonos Soundbar/Sub/2 x Play 1's
sonosman is offline  
post #86 of 1070 Old 05-03-2017, 05:15 AM - Thread Starter
AVS Forum Special Member
 
Rudy1's Avatar
 
Join Date: Oct 2000
Location: Ft. Lauderdale, FL
Posts: 5,744
Mentioned: 189 Post(s)
Tagged: 0 Thread(s)
Quoted: 1960 Post(s)
Liked: 3259
Quote:
Originally Posted by djpault View Post
Thanks for the reply Rudy1. Who might I contact about this issue?
All issues with this (and any other product from Samsung) should be reported to their customer support department. You'll find the appropriate contact info on their website. The more tickets are opened by owners for a specific problem, the higher the priority that each issue will be assigned.

Definition of "Stupid": Knowing the truth, seeing the truth, but still believing the lies.
Rudy1 is offline  
post #87 of 1070 Old 05-03-2017, 06:19 AM
AVS Forum Special Member
 
b0rnarian's Avatar
 
Join Date: Jan 2008
Location: Indiana
Posts: 2,569
Mentioned: 15 Post(s)
Tagged: 0 Thread(s)
Quoted: 1970 Post(s)
Liked: 1168
Quote:
Originally Posted by Gary F Martino View Post
I'm driving them crazy at Best Buy. I replaced my Samsung UBD-K8500 with the new Samsung UBD-M9500. Always looking for a bargain I saw the new Sony UBP-X800 and exchanged the new Samsung for the Sony. Sony seems very well built and was fairly easy to set up. However, I had problems with sound and the picture quality was much better on Samsung. Returned the Sony and repurchased the Samsung UBD-K8500. Much easier to set up and very pleased with picture quality and sound on my Samsung HW-K950 ATMOS system is excellent. However, in setting up the streaming services I cannot get any sound from Amazon when broadcast are in HD. Apparently others are having a similar problem and hope a fix is forth coming from Samsung.
Interesting... This is the first time I heard this. The two semi-pro overviews I've heard, both said Sony was slightly better in PQ.

Best,
Main Living Room: Samsung 65 KS9800 + Denon X4500H 11.1 + Sony UBP-X800 + PS4
Other Living Room: Panasonic Plasma 55 + Onkyo Home Theater System 5.1 + PS3
Discs For SALE : 4Ks And 2Ks!
b0rnarian is offline  
post #88 of 1070 Old 05-03-2017, 07:57 AM
Senior Member
 
FullyArray's Avatar
 
Join Date: Mar 2017
Posts: 309
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 214 Post(s)
Liked: 119
Quote:
Originally Posted by b0rnarian View Post
Interesting... This is the first time I heard this. The two semi-pro overviews I've heard, both said Sony was slightly better in PQ.
I'm very curious how big the differences really are between players. Why are there never any comparison pics?

I'm getting the X800 delivered. Will probably get the Panny in a few weeks after and compare.
FullyArray is offline  
post #89 of 1070 Old 05-03-2017, 08:24 AM
AVS Forum Special Member
 
b0rnarian's Avatar
 
Join Date: Jan 2008
Location: Indiana
Posts: 2,569
Mentioned: 15 Post(s)
Tagged: 0 Thread(s)
Quoted: 1970 Post(s)
Liked: 1168
Quote:
Originally Posted by FullyArray View Post
I'm very curious how big the differences really are between players. Why are there never any comparison pics?

I'm getting the X800 delivered. Will probably get the Panny in a few weeks after and compare.
I am picking up this M9500 soon as most have said its much improved over the K8500. However, Its gotta perform well with upscaling SDR content and if that's lacking, I will opt out for the Sony. Sometimes you just gotta experience it yourself before making a decision. Like you said there's never any pics to go along, so I will have to judge for myself.

PS: Hope they fix the Amazon app soon with audio issues.

Best,
Main Living Room: Samsung 65 KS9800 + Denon X4500H 11.1 + Sony UBP-X800 + PS4
Other Living Room: Panasonic Plasma 55 + Onkyo Home Theater System 5.1 + PS3
Discs For SALE : 4Ks And 2Ks!
b0rnarian is offline  
post #90 of 1070 Old 05-03-2017, 10:16 AM
Newbie
 
Join Date: May 2017
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 2
Deciding which player is "best" is very subjective. I have tried the Panasonic Ultra blu-ray and it was very, very good in my opinion. The Sony is solidly built and has exceptional picture and sound quality. I settled on the new Samsung UBD-M9500. I was looking for ease of use. My home theater system consists of a late model 55" Samsung 4K UHD, Samsung ATMOS Soundbar HW - K850, an Apple TV, Amazon Fire TV and the Samsung UBD-M9500. All controlled by a Harmony Elite. I opted for a setup with simple integration since my family use the system and it is set up for simple access and control. This works for us and the family is impressed with picture and sound quality no matter what mode we are in. The menu choice on the Samsung UBD-M9500 is easy to use and set up was a breeze. HDR and blu-ray picture quality was vibrant with excellent details. Sound is exceptional with the ATMOS system. Sound seems to surround you. Works for me.
Rudy1 likes this.
Gary F Martino is offline  
Sponsored Links
Advertisement
 
Reply Blu-ray Players

Tags
4:2:0 , 4:4:4 , hdmi , Samsung , uhd

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off