LG unveils 2018 UHD Blu-ray players - UBK90/80 - Page 8 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 74Likes
Reply
 
Thread Tools
post #211 of 230 Old 07-31-2018, 07:26 AM
Senior Member
 
Join Date: Aug 2017
Posts: 216
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 101 Post(s)
Liked: 91
Quote:
Originally Posted by dkwong View Post
I’ve heard that the Philips player has minor stuttering playing 3d Blu-ray Discs.
It's true. I does have minor stuttering with 3D, but it's VERY minor, and I barely noticed it the last time I played a 3D disc. What it does have, though, is rock solid UHD disc playing. I haven't had one freeze on any UHD, BD, or DVD that I have put in the player, something that a lot of more notable players can't say.

But if I didn't have the Philips, the LG would be my next pick.
Flickpal is offline  
Sponsored Links
Advertisement
 
post #212 of 230 Old 08-03-2018, 01:09 PM
Member
 
Pmilano's Avatar
 
Join Date: Sep 2010
Posts: 34
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 20 Post(s)
Liked: 2
I have LGUP970 and I have a single problem in Netflix application it stays all the time in DV, ie from the interface, profile page, HD movies run in DV, I wonder if this Netflix DV Bug problem has been solved in the UBK90 .
Pmilano is offline  
post #213 of 230 Old 08-04-2018, 06:20 AM
Member
 
Pmilano's Avatar
 
Join Date: Sep 2010
Posts: 34
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 20 Post(s)
Liked: 2
Quote:
Originally Posted by gnicks View Post
Thanks, Bob! This is incredibly helpful. I failed to mention that my speaker setup is only 5.1. Based on your post, it sounds possible that when 'bitstreaming' these Atmos tracks, the player determines that the full 7.1 is not needed, and therefore only sends 5.1. Whereas with other 7.1 content, all channels are sent and the receiver handles the mixing to 5.1 itself.

I also really appreciate the point about getting the lossy compatibility track. Fortunately, in all bitstream instances, the receiver is detecting Dolby TrueHD or DTS HD-MA.

Thanks again,
Greg
For you to get Atmos via USB in Auto bistream, you need to download a BDMV m2ts file, if it is MKV the Atmos only works on PCM- multi channel.
Pmilano is offline  
Sponsored Links
Advertisement
 
post #214 of 230 Old 08-28-2018, 11:14 AM
Member
 
Multi View's Avatar
 
Join Date: Aug 2018
Location: Toronto
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Liked: 3
Just purchased the LG UBK80 & would like to inquire about the availability of an upgrade for the remote. Thanks in advance for any insight.
B.
Multi View is offline  
post #215 of 230 Old 08-31-2018, 09:56 AM
Newbie
 
Join Date: Aug 2018
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 0
Hello everybody.
I bought the ubk90 recently together brought 7 movies in 4K.
Arriving here I connected on my B7 and it was just wonders. But about 3 days ago I put the movie Ready Player One to watch and had a small freeze of the image half of the end of the film. I started to test the others in one more movie happened this, the others turned legal. When I reboot and select the excerpt from the movie where it has such freezing. Sometimes it runs normal and others happens the damn freezing. The disks are perfect so using an HDMI 2.0 cable does anyone know if this has a way with a firmware update? Consulting forums had reports where these image freezes occurred. I'm desperate already ...: /
danielmarques is offline  
post #216 of 230 Old 08-31-2018, 10:46 AM
AVS Forum Addicted Member
 
Ph8te's Avatar
 
Join Date: Oct 2005
Posts: 19,451
Mentioned: 32 Post(s)
Tagged: 0 Thread(s)
Quoted: 6580 Post(s)
Liked: 6349
Quote:
Originally Posted by danielmarques View Post
Hello everybody.

I bought the ubk90 recently together brought 7 movies in 4K.

Arriving here I connected on my B7 and it was just wonders. But about 3 days ago I put the movie Ready Player One to watch and had a small freeze of the image half of the end of the film. I started to test the others in one more movie happened this, the others turned legal. When I reboot and select the excerpt from the movie where it has such freezing. Sometimes it runs normal and others happens the damn freezing. The disks are perfect so using an HDMI 2.0 cable does anyone know if this has a way with a firmware update? Consulting forums had reports where these image freezes occurred. I'm desperate already ...: /


If it only happens with one disc then it’s probably the disc. I would wipe it with a clean microfiber cloth and see if that helps. If anything exchange the disc to see if it still occurs.
Ph8te is online now  
post #217 of 230 Old 12-17-2018, 06:01 AM
Member
 
guerojose's Avatar
 
Join Date: Jan 2011
Posts: 41
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 29 Post(s)
Liked: 21
I think it's obvious by now: the UBK90 has occasional problems. It's not just the odd random unit, nor is it dirty discs. I've had mine for several months now, and it's a definite issue.

Yes, I and others know how to use a premium certified cable, and ensure the discs are pristine. The player will freeze at one point in a film, then play that section fine on the next try. I've encountered the problem on 5 different films now, so it's definitely a thing. I also find it oddly difficult to get the disc eject button to work without repeated presses. These issues I'll just have to live with, until/unless a more solid player comes along. When the player works it's still pretty fabulous. YMMV.
guerojose is offline  
post #218 of 230 Old 12-17-2018, 07:54 AM
Advanced Member
 
Merlin803's Avatar
 
Join Date: Nov 2001
Posts: 635
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 121 Post(s)
Liked: 34
Quote:
Originally Posted by guerojose View Post
I think it's obvious by now: the UBK90 has occasional problems. It's not just the odd random unit, nor is it dirty discs. I've had mine for several months now, and it's a definite issue.

Yes, I and others know how to use a premium certified cable, and ensure the discs are pristine. The player will freeze at one point in a film, then play that section fine on the next try. I've encountered the problem on 5 different films now, so it's definitely a thing. I also find it oddly difficult to get the disc eject button to work without repeated presses. These issues I'll just have to live with, until/unless a more solid player comes along. When the player works it's still pretty fabulous. YMMV.

I think you are right unfortunately. I have experienced both issues.



The difference with the freezing that I have with this player and other's that I have had freezing on is this one seems to often freeze and then continue without any intervention where as others that I have had would just freeze and not continue (causing me to eject and start over).

LG OLED B7
Denon X1200W AVR
KLIPSCH RF82 II mains, RP-140SA, RC62 II CENTER, RB-10 surrounds
SVS PB-2000
Roku Ultra
Merlin803 is offline  
post #219 of 230 Old 12-19-2018, 07:38 PM
AVS Forum Addicted Member
 
Otto Pylot's Avatar
 
Join Date: May 2004
Location: Bull Mountain, OR
Posts: 15,248
Mentioned: 28 Post(s)
Tagged: 1 Thread(s)
Quoted: 3533 Post(s)
Liked: 2553
Quote:
Originally Posted by Merlin803 View Post
I think you are right unfortunately. I have experienced both issues.



The difference with the freezing that I have with this player and other's that I have had freezing on is this one seems to often freeze and then continue without any intervention where as others that I have had would just freeze and not continue (causing me to eject and start over).

What is odd about this is that I haven't experienced any of the issues mentioned. However, I haven't played very many 4k UHD disks yet nor have I played any BD100 disks so we'll see.

I never trust an atom, they make up everything.
Otto Pylot is online now  
post #220 of 230 Old 12-24-2018, 10:37 AM
AVS Forum Special Member
 
RoadLizard's Avatar
 
Join Date: Jul 2016
Location: Upstate, NY
Posts: 2,331
Mentioned: 8 Post(s)
Tagged: 0 Thread(s)
Quoted: 1441 Post(s)
Liked: 1438
Quote:
Originally Posted by guerojose View Post
I think it's obvious by now: the UBK90 has occasional problems. It's not just the odd random unit, nor is it dirty discs. I've had mine for several months now, and it's a definite issue.

Yes, I and others know how to use a premium certified cable, and ensure the discs are pristine. The player will freeze at one point in a film, then play that section fine on the next try. I've encountered the problem on 5 different films now, so it's definitely a thing. I also find it oddly difficult to get the disc eject button to work without repeated presses. These issues I'll just have to live with, until/unless a more solid player comes along. When the player works it's still pretty fabulous. YMMV.
Yeah - mine has been mostly solid but I too have had random, WTF moments where something just aint right. Ive had sound cut outs occur during chapter advances and the ocassional skip or hesitation. It does usually resume though and its rare enough that I too will live with it. Keep those discs clean! I always wipe them down with a micro cloth prior to each viewing. Seems like UHD is a more picky format than blu-ray regarding perfectly clean/smudge/lint free discs. If you read the threads, just about every UHD player has some complaints of random weirdness. Its more normal than you'd think. Thats why trying another player isnt likely to really improve anything and I do want the Dolby Vision support!

Still, it works just fine most of the time so Ill go with it. And yeah, the cables are premium and seated properly

LG OLED65E6P, Samsung PN64H5000
LG UBK-90, Samsung UBD-8500K
Polk RTi Towers, STi surrounds
Polk Subwoofer
Sony DH550 AVR
RoadLizard is offline  
post #221 of 230 Old 12-29-2018, 07:19 PM
Senior Member
 
Rhizzlebop's Avatar
 
Join Date: Sep 2006
Posts: 332
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 100 Post(s)
Liked: 18
I have a silly silly rookie question that I've been googling around for and cannot find. I just installed a ubk90 in my home theatre and I use IR repeaters because my rack doesn't face towards my seating position. I can't find where to tape the IR sticker blocker onto the front of this player. Any help? Oddly it seems to be working to spite that fact but I'd still like to set it up correctly and i see no little black window where it receives signal. I don't think it's RF but am I won't?
Rhizzlebop is offline  
post #222 of 230 Old 01-04-2019, 01:02 PM
Senior Member
 
GoZags13's Avatar
 
Join Date: Feb 2014
Location: Gig Harbor, WA
Posts: 366
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 183 Post(s)
Liked: 92
I have the 80 and it's had issues with 4k discs that are not perfect. Ready Player One had a bad skip/stutter scene near the end, cleaned the disc and it did better. Similar issue with the incredibles 2, where it had some minor scratches and skipped.

I got mine on a great closeout deal, so for now I'll keep it. But I probably will look to upgrade to the Sony in the future. To note, this player has done flawless with blu-ray, so I'll probably move it to the 1080p TV when the time comes I upgrade.

Denon X4300H; Sony XBR75 900E; Definitive Technology RLS-II/DI 5.5LCR/DI 5.5R; NHT SW12
GoZags13 is offline  
post #223 of 230 Old 02-01-2019, 03:29 PM
Advanced Member
 
tlniec's Avatar
 
Join Date: Jan 2006
Posts: 778
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
Liked: 23
Quote:
Originally Posted by Rhizzlebop View Post
I have a silly silly rookie question that I've been googling around for and cannot find. I just installed a ubk90 in my home theatre and I use IR repeaters because my rack doesn't face towards my seating position. I can't find where to tape the IR sticker blocker onto the front of this player. Any help? Oddly it seems to be working to spite that fact but I'd still like to set it up correctly and i see no little black window where it receives signal. I don't think it's RF but am I won't?
I had this same question/problem. Eventually found out there is a spot on the front panel where you can stick an IR emitter and get good results - just to the left of the Eject button on the front of the unit. There is no visible sign of an IR receiver/window there, but that's where I put my emitter and it does indeed work.
tlniec is offline  
post #224 of 230 Old 02-03-2019, 03:22 PM
Member
 
Join Date: Jul 2016
Posts: 135
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 120 Post(s)
Liked: 25
I’m considering purchasing this and I couldn’t find the answer under a brief search. The Sony X700 with Dolby Vision is only enabled when you toggle it on. Does this LG model do the same thing or does it auto detect the DV layer and change the output automatically?


Sent from my iPhone using Tapatalk
Bigmizzoufan is offline  
post #225 of 230 Old 02-04-2019, 07:01 AM
Senior Member
 
Join Date: Aug 2017
Posts: 216
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 101 Post(s)
Liked: 91
Quote:
Originally Posted by Bigmizzoufan View Post
I’m considering purchasing this and I couldn’t find the answer under a brief search. The Sony X700 with Dolby Vision is only enabled when you toggle it on. Does this LG model do the same thing or does it auto detect the DV layer and change the output automatically?


Sent from my iPhone using Tapatalk
The LG has an auto capability that doesn't require manual switching from HDR to Dolby Vision.
Flickpal is offline  
post #226 of 230 Old 03-29-2019, 05:54 AM
Newbie
 
Join Date: Mar 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 0
LG UBK90 with SK9Y and B6OLED sandwich HELP!!!

Hey Guys,

Just purchased a UBK90 to go with my LG SK9Y soundbar (ATMOS) and my LG b6 oled tv.

Now I have my soundbar connected to my tv via ARC and the UBK90 connected to the soundbar (4K pass through)

The issue I have is HDMI2 or arc detects the player when there is a DVD in side and it goes to autoplay but the moment I hit the DVD player menu button to take me back to the DVD player menu (not the DVD's menu) its loses all detection and my tv goes to a screensaver background and I have to restart everything.

I tried to connect my dvd player straight to the TV but when it recognises the TV a promt comes up saying the TV needs to turn the HDMI port to HD deep colour and will need to reset (cant avoid the reset). But once the TV turns itself back on the DVD player doesnt like the HD deep colour and it goes all flickery.

Is it my HDMI cable? or is my set up wrong. considering Im playing with 3 LG devices youd think it would be seemless

Cheers

Jarrod
Jarrod Novak is offline  
post #227 of 230 Old 04-06-2019, 09:20 AM
Member
 
ensignlee's Avatar
 
Join Date: Dec 2012
Posts: 32
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Liked: 12
Quote:
Originally Posted by Jarrod Novak View Post
Hey Guys,

Just purchased a UBK90 to go with my LG SK9Y soundbar (ATMOS) and my LG b6 oled tv.

Now I have my soundbar connected to my tv via ARC and the UBK90 connected to the soundbar (4K pass through)

The issue I have is HDMI2 or arc detects the player when there is a DVD in side and it goes to autoplay but the moment I hit the DVD player menu button to take me back to the DVD player menu (not the DVD's menu) its loses all detection and my tv goes to a screensaver background and I have to restart everything.

I tried to connect my dvd player straight to the TV but when it recognises the TV a promt comes up saying the TV needs to turn the HDMI port to HD deep colour and will need to reset (cant avoid the reset). But once the TV turns itself back on the DVD player doesnt like the HD deep colour and it goes all flickery.

Is it my HDMI cable? or is my set up wrong. considering Im playing with 3 LG devices youd think it would be seemless

Cheers

Jarrod
Oh that's really weird. I have an identical setup in my office except mine is a B7.

Based on what you said, I'd bet it's the HDMI cable, especially since you still have problems when bypassing the SK9Y. I had a similar problem when no sound would work and that got fixed with a new HDMI cable. I was so pissed off at first thinking I bought a lemon SK9Y
ensignlee is offline  
post #228 of 230 Old 10-07-2019, 12:54 PM
AVS Forum Special Member
 
Wytchone's Avatar
 
Join Date: Feb 2006
Location: LaPlace, La.
Posts: 4,635
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 66 Post(s)
Liked: 70
Anyone have issues with this player and streaming Netflix?
Wytchone is offline  
post #229 of 230 Old 11-07-2019, 04:46 PM
Newbie
 
Join Date: Mar 2019
Posts: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Liked: 1
Can anyone comment of if Dolby Vision works with the TCL 6 Series tv? Or if the player works fine with the kS8000 tv(doesn't have dolby vision)?
Wytchone likes this.
Khan-El is offline  
post #230 of 230 Old 11-08-2019, 07:39 AM
AVS Forum Special Member
 
Wytchone's Avatar
 
Join Date: Feb 2006
Location: LaPlace, La.
Posts: 4,635
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 66 Post(s)
Liked: 70
Quote:
Originally Posted by Khan-El View Post
Can anyone comment of if Dolby Vision works with the TCL 6 Series tv? Or if the player works fine with the kS8000 tv(doesn't have dolby vision)?
I had it for 3 days and yes it worked with the TCL6 and Dolby Vision. Lack Amazon Prime and slow netflix had me take it back but it was a solid player. Only player that auto switched from DV and HDR that BB sold.
Wytchone is offline  
Sponsored Links
Advertisement
 
Reply Blu-ray Players

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off