OFFICIAL Sony UBP-X800M2 Owners Thread (No Price Talk) - Page 14 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 122Likes
Reply
 
Thread Tools
post #391 of 411 Old 08-14-2019, 08:45 AM
Advanced Member
 
Derek87's Avatar
 
Join Date: Sep 2005
Posts: 642
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 97 Post(s)
Liked: 44
Freezing issues: random, common?

hi all,
i can't see to figure out how to create a poll within this thread, but hopefully a few of you can comment...

how many of you out there have had freezing issues with your 800m2? are they repeatable? any speculation on the cause (hardware vs. software)?

we don't watch movies all that often (1-2/month typically), so i am concerned with buying a unit and only to discover that 3 months later, i have a bad unit with intermittent freezing. or worse, this freezing issue is a common element in all of these Sony UHD players and something i should have avoided.

this won't be a streaming machine for us, purely for renting 4K discs from Redbox and the few that we buy/own. (currently only own two)
Derek87 is online now  
Sponsored Links
Advertisement
 
post #392 of 411 Old 08-14-2019, 09:18 AM
AVS Forum Special Member
 
bwillcox's Avatar
 
Join Date: Jul 2003
Location: Austin, Tx
Posts: 2,316
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 869 Post(s)
Liked: 497
Quote:
Originally Posted by Derek87 View Post
hi all,
i can't see to figure out how to create a poll within this thread, but hopefully a few of you can comment...

how many of you out there have had freezing issues with your 800m2? are they repeatable? any speculation on the cause (hardware vs. software)?

we don't watch movies all that often (1-2/month typically), so i am concerned with buying a unit and only to discover that 3 months later, i have a bad unit with intermittent freezing. or worse, this freezing issue is a common element in all of these Sony UHD players and something i should have avoided.

this won't be a streaming machine for us, purely for renting 4K discs from Redbox and the few that we buy/own. (currently only own two)
I haven't had any freezing with my X800M2s, but then I don't watch movies very often with them. I mostly am using them to stream my multichannel audio tracks (DSD & FLAC) from my DLNA server since my Yamaha receivers don't do multichannel.

1) JVC DLA-NX7 & Sony 65Z9D, Yamaha CX-A5200, Outlaw Audio 7900 & 7700, UDP-203, DP-UB9000, UBP-X800M2, Roku Ultra
2) Sony 75Z9D, Yamaha RX-A3080, 2xOutlaw Audio 2200s, UDP-203, UBP-X800M2, Roku Ultra
3) Sony 75X940E, Yamaha RX-A2080, UDP-203, UBP-X800M2, Roku Ultra
bwillcox is online now  
post #393 of 411 Old 08-14-2019, 10:14 AM
Advanced Member
 
Cortiz's Avatar
 
Join Date: Jul 2007
Posts: 541
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 132 Post(s)
Liked: 99
The freezing issues is well known on these Sony players. The previous models, X800, X700 and X1000es all were/still plagued with this issue. I'm surprised Sony haven't been able to figure this out yet, or maybe they just don't care since it seems to me that Physical media is no longer a priority. Also, their DV capable players are the only ones in the market that doesn't do auto detection. When a company like Phillips offer an UHD player at Wal-Mart with DV auto detection for around $100 and Sony doesn't, that to me is a big telling of where Sony's mind set is at in regards to physical media. Anyway, the band aid to fix the freezing issue is to kill the network connection on the player, once you kill the network connection, turn off the new software notification under the player's settings, then go to the network settings and turn off everything from there. If you use the player for streaming, then I guess this player is not for you until or "IF" Sony ever decides to fix the freezing issue.
Cortiz is online now  
Sponsored Links
Advertisement
 
post #394 of 411 Old 08-14-2019, 10:25 AM
AVS Forum Special Member
 
Join Date: Jul 2017
Location: Out West
Posts: 1,090
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 619 Post(s)
Liked: 325
Quote:
Originally Posted by Cortiz View Post
The freezing issues is well known on these Sony players. The previous models, X800, X700 and X1000es all were/still plagued with this issue. I'm surprised Sony haven't been able to figure this out yet, or maybe they just don't care since it seems to me that Physical media is no longer a priority. Also, their DV capable players are the only ones in the market that doesn't do auto detection. When a company like Phillips offer an UHD player at Wal-Mart with DV auto detection for around $100 and Sony doesn't, that to me is a big telling of where Sony's mind set is at in regards to physical media. Anyway, the band aid to fix the freezing issue is to kill the network connection on the player, once you kill the network connection, turn off the new software notification under the player's settings, then go to the network settings and turn off everything from there. If you use the player for streaming, then I guess this player is not for you until or "IF" Sony ever decides to fix the freezing issue.
I've had a couple of freezes, mid disk, of my X700. I traced both of them to overheating which I reduced by providing more airflow around and under the X700.
DunMunro is online now  
post #395 of 411 Old 08-14-2019, 10:39 AM
Advanced Member
 
Cortiz's Avatar
 
Join Date: Jul 2007
Posts: 541
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 132 Post(s)
Liked: 99
Quote:
Originally Posted by DunMunro View Post
I've had a couple of freezes, mid disk, of my X700. I traced both of them to overheating which I reduced by providing more airflow around and under the X700.


I don't think it's the heat. I remenber having freezing issues right off the bat when i first started playing a disc. I know the X700 doesn't have the heat sink like the X800 and The ES models, but i still think is not heat related as both of these model still freezing. I think the network connections on these players is interferring with the disc playback somehow. I owned the X1000es and now the X1100es and i was able to fix the freezing issues on both machines by killing the network comnection.


Sent from my iPhone using Tapatalk
Cortiz is online now  
post #396 of 411 Old 08-14-2019, 10:51 AM
AVS Forum Special Member
 
Join Date: Jul 2017
Location: Out West
Posts: 1,090
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 619 Post(s)
Liked: 325
Quote:
Originally Posted by Cortiz View Post
I don't think it's the heat. I remenber having freezing issues right off the bat when i first started playing a disc. I know the X700 doesn't have the heat sink like the X800 and The ES models, but i still think is not heat related as both of these model still freezing. I think the network connections on these players is interferring with the disc playback somehow. I owned the X1000es and now the X1100es and i was able to fix the freezing issues on both machines by killing the network comnection.


Sent from my iPhone using Tapatalk
We use the X700 as our primary 4K streaming device to feed our projector. We often use it for 4K streaming via wifi, 3-4 hours at a time, and it's never had hiccup. It's possible that the recent firmware upgrade has made it more stable.
DunMunro is online now  
post #397 of 411 Old 08-14-2019, 11:10 AM
UHD Addict
 
aaronwt's Avatar
 
Join Date: Aug 2001
Location: Northern VA(Woodbridge)
Posts: 35,644
Mentioned: 65 Post(s)
Tagged: 0 Thread(s)
Quoted: 9097 Post(s)
Liked: 5844
Quote:
Originally Posted by Cortiz View Post
I don't think it's the heat. I remenber having freezing issues right off the bat when i first started playing a disc. I know the X700 doesn't have the heat sink like the X800 and The ES models, but i still think is not heat related as both of these model still freezing. I think the network connections on these players is interferring with the disc playback somehow. I owned the X1000es and now the X1100es and i was able to fix the freezing issues on both machines by killing the network comnection.


Sent from my iPhone using Tapatalk
Or like many of us, we dont have freezing issues. I've had an x800 since launch. I did have a few issues those first few months when I used both hdmi outputs, one for video and one for audio. But in the twenty five months since I switched to using the one hdmi output, for both audio and video, mine has been fine. Mine stays connected to the internet and I use the instant on function.

Sent from my Galaxy S10

53TB unRAID1a--49TB unRAID2--76TB unRAID3
TCL 6 Series--Sony UBP-X800--Philips BDP7502--Onkyo HT-S7800
XBL/PSN: WormholeXtreme
aaronwt is online now  
post #398 of 411 Old 08-14-2019, 11:13 AM
Advanced Member
 
Derek87's Avatar
 
Join Date: Sep 2005
Posts: 642
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 97 Post(s)
Liked: 44
Quote:
Originally Posted by Cortiz View Post
The freezing issues is well known on these Sony players. The previous models, X800, X700 and X1000es all were/still plagued with this issue. I'm surprised Sony haven't been able to figure this out yet, or maybe they just don't care since it seems to me that Physical media is no longer a priority. Also, their DV capable players are the only ones in the market that doesn't do auto detection. When a company like Phillips offer an UHD player at Wal-Mart with DV auto detection for around $100 and Sony doesn't, that to me is a big telling of where Sony's mind set is at in regards to physical media. Anyway, the band aid to fix the freezing issue is to kill the network connection on the player, once you kill the network connection, turn off the new software notification under the player's settings, then go to the network settings and turn off everything from there. If you use the player for streaming, then I guess this player is not for you until or "IF" Sony ever decides to fix the freezing issue.
hi Cortiz,

this very helpful information. i intend to use this as solely a disc player and i am hoping, based on your comments, i can just disable the network connection semi-permanently (and only reconnect it when i know there is a firmware update i want to install). this a reasonable fix for me. (in fact, i even disabled the network and BD-Live) on my old, but still running Oppo83.

the DV auto detection isn't a huge deal for me, at least now since our Sony TV is only an HDR10 model. (900e)
Derek87 is online now  
post #399 of 411 Old 08-14-2019, 11:14 AM
Advanced Member
 
Derek87's Avatar
 
Join Date: Sep 2005
Posts: 642
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 97 Post(s)
Liked: 44
Quote:
Originally Posted by aaronwt View Post
Or like many of us, we dont have freezing issues. I've had an x800 since launch. I did have a few issues those first few months when I used both hdmi outputs, one for video and one for audio. But in the twenty five months since I switched to using the one hdmi output, for both audio and video, mine has been fine. Mine stays connected to the internet and I use the instant on function.

Sent from my Galaxy S10
hmmm... i hope i don't have this problem as i will definitely be using both HDMI outputs... one to feed my legacy processor, and the other (Video) going directly to my TV.

what issues did you encounter using the dual outputs?
Derek87 is online now  
post #400 of 411 Old 08-14-2019, 12:36 PM
UHD Addict
 
aaronwt's Avatar
 
Join Date: Aug 2001
Location: Northern VA(Woodbridge)
Posts: 35,644
Mentioned: 65 Post(s)
Tagged: 0 Thread(s)
Quoted: 9097 Post(s)
Liked: 5844
Quote:
Originally Posted by Derek87 View Post
hmmm... i hope i don't have this problem as i will definitely be using both HDMI outputs... one to feed my legacy processor, and the other (Video) going directly to my TV.



what issues did you encounter using the dual outputs?
I had two or three freezes. But it was also their first UHD BD player and they were releasing firmware updates. No idea though if switching to one hdmi out was a coincidence or not. Only that things have been fine for me 99.9% of the time since then.

I also use the wireless network connection.since I can get much higher throughput over wireless than its wired connection. For instance my very high bitrate UHD files. Content exceeding 100mbps bitrates. It a buffering mess over the wired connection. But over the wireless connection it can play them with ease.

Sent from my Galaxy S10

53TB unRAID1a--49TB unRAID2--76TB unRAID3
TCL 6 Series--Sony UBP-X800--Philips BDP7502--Onkyo HT-S7800
XBL/PSN: WormholeXtreme

Last edited by aaronwt; 08-14-2019 at 12:45 PM.
aaronwt is online now  
post #401 of 411 Old 08-14-2019, 02:02 PM
Newbie
 
theLuggage's Avatar
 
Join Date: Mar 2008
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Liked: 3
Question When to turn on Dolby Vision for Discs

Hi,

I'm confused as to when I should turn on Dolby Vision when I'm playing a physical disc. If the disc only has HDR, does it make a difference if I have DV on? Or should I only have DV on when watching a disc that has DV?

Also, do discs have a certain logo or something that indicates what flavor of HDR it has (HDR, HDR10, HDR+, DV)?

Thanks!
theLuggage is offline  
post #402 of 411 Old 08-14-2019, 02:02 PM
AVS Forum Special Member
 
Join Date: Jan 2019
Posts: 1,595
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 540 Post(s)
Liked: 1234
Quote:
Originally Posted by Cortiz View Post
I don't think it's the heat. I remenber having freezing issues right off the bat when i first started playing a disc. I know the X700 doesn't have the heat sink like the X800 and The ES models, but i still think is not heat related as both of these model still freezing. I think the network connections on these players is interferring with the disc playback somehow. I owned the X1000es and now the X1100es and i was able to fix the freezing issues on both machines by killing the network comnection.

There's enough good feedback for Sony at many forums. There has been for a while with various models. Seems there's no basic function evolution for Sony 4K UHD players. Each one makes its users go through a ritual of workarounds often gleaned from fellow frustrated purchasers, until there may be a firmware update available, later rather than sooner.

Though player features have grown, you seem to be rewarded if you use as few as possible.

Dependability remains low. Good research and development, with quality control, seem to be missing at Sony. What is happening at Sony? We also see issues in their LCD televisions, that should have been eradicated by now.

Panasonic TC65CX850U Yamaha RX-V1079 Technics SU-V650 Panasonic DMP-UB900 Sony UBP-X800 Polk Audio SDA-2B
Panson is offline  
post #403 of 411 Old 08-14-2019, 02:23 PM
Member
 
Join Date: Dec 2018
Posts: 43
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 30 Post(s)
Liked: 9
Quote:
Originally Posted by DunMunro View Post
I've had a couple of freezes, mid disk, of my X700. I traced both of them to overheating which I reduced by providing more airflow around and under the X700.
Quote:
Originally Posted by Cortiz View Post
I don't think it's the heat. I remenber having freezing issues right off the bat when i first started playing a disc. I know the X700 doesn't have the heat sink like the X800 and The ES models, but i still think is not heat related as both of these model still freezing. I think the network connections on these players is interferring with the disc playback somehow. I owned the X1000es and now the X1100es and i was able to fix the freezing issues on both machines by killing the network comnection.
Quote:
Originally Posted by Derek87 View Post
hmmm... i hope i don't have this problem as i will definitely be using both HDMI outputs... one to feed my legacy processor, and the other (Video) going directly to my TV.

what issues did you encounter using the dual outputs?
Apologies for talking about the X700 on the X800M2 thread, but it seems to me they're probably pretty much identical from a core viewpoint (opinion, not fact, as I haven't seen inside an X800M2, they're not even available in NZ yet).

I had my X700 freeze on me a number of times early on. IMO it was definitely heat related as the bottom plate was really hot to touch, but the airflow around it was poor and it was sitting on top of another component. I think that did some damage as even after I improved the airflow, it got worse and worse. I ended up with the situation where settings like Netflix login details, screen modes etc would get lost.

The good news is that it was repaired under warranty, I assume with a motherboard swap, and I've not had any problems since. I also run both HDMI outputs with the audio going to my legacy processor and the video going to the TV, and I've had no problems related to that.

Sony XBR-65A9F, Sony UBP-X700, Denon AVR-890 (cooled by AC Infinity AIRCOM T10), Apple TV (non 4K), B&W 600 series & LM1s in 7.1 config, Harmony Elite
avsngaiouser is online now  
post #404 of 411 Old 08-14-2019, 10:30 PM
Senior Member
 
Join Date: Jun 2016
Posts: 443
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 285 Post(s)
Liked: 92
Quote:
Originally Posted by Tostones View Post
Do you all leave Dolby Vision ON for all 4k Ultra HD HDR movies? Will image quality suffer if Dolby Vision is ON for non Dolby Vision content?
I do on my X700. And I do not sense quality drop of any kind.
It has been measured, that in DV mode the picture brightness is lower than in HDR10 mode, but as the display has separate backlight settings for both modes, I have set them to be perceptually equally bright.
I only (need to) turn DV off for SDR and 3D content.
BUT - I am quite sure, that this usecase (whether you see PQ difference with HDR content), is heavily dependent on your screen's capabilities and tonemapping characteristics.

Last edited by priitv8; 08-15-2019 at 10:32 PM.
priitv8 is online now  
post #405 of 411 Old 08-15-2019, 02:18 PM
Member
 
Join Date: Dec 2016
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 0
Re: freezing - The only time my unit has ever frozen on me was when I left a 4TB hdd attached via USB overnight. After I powered down the unit - the next day I saw the power light was on by itself somehow - but the unit was unresponsive and needed to be unplugged. I just unplug my external HDD's now after powering off and have never had any freezing.

Here's my question:

And, I've come across an issue here, I'm hoping someone can shed some light on it. I'm surely missing something easy.

IF YOU HAVE a Hybrid SACD that has a 5.1 SACD mix, a 2.0 SACD mix and then the CD layer - how do you select between the different 5.1 and 2.0 SACD mixes?

Mine defaults to 5.1 mix and I cannot get it to change to 2.0 SACD - and no buttons will help on the remote, and pressing Audio or Options brings no way to change the audio feed....
McGilli is offline  
post #406 of 411 Old 08-15-2019, 02:39 PM
UHD Addict
 
aaronwt's Avatar
 
Join Date: Aug 2001
Location: Northern VA(Woodbridge)
Posts: 35,644
Mentioned: 65 Post(s)
Tagged: 0 Thread(s)
Quoted: 9097 Post(s)
Liked: 5844
Quote:
Originally Posted by McGilli View Post
Re: freezing - The only time my unit has ever frozen on me was when I left a 4TB hdd attached via USB overnight. After I powered down the unit - the next day I saw the power light was on by itself somehow - but the unit was unresponsive and needed to be unplugged. I just unplug my external HDD's now after powering off and have never had any freezing.

Here's my question:

And, I've come across an issue here, I'm hoping someone can shed some light on it. I'm surely missing something easy.

IF YOU HAVE a Hybrid SACD that has a 5.1 SACD mix, a 2.0 SACD mix and then the CD layer - how do you select between the different 5.1 and 2.0 SACD mixes?

Mine defaults to 5.1 mix and I cannot get it to change to 2.0 SACD - and no buttons will help on the remote, and pressing Audio or Options brings no way to change the audio feed....
Isn't there an option in the settings menu to pick the default layer you want? I thought that was typical in Sony SACD capable players?

53TB unRAID1a--49TB unRAID2--76TB unRAID3
TCL 6 Series--Sony UBP-X800--Philips BDP7502--Onkyo HT-S7800
XBL/PSN: WormholeXtreme
aaronwt is online now  
post #407 of 411 Old 08-15-2019, 05:20 PM
Member
 
Join Date: Dec 2016
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 0
Quote:
Originally Posted by aaronwt View Post
Isn't there an option in the settings menu to pick the default layer you want? I thought that was typical in Sony SACD capable players?
Thank you - you are correct. I had seen the option to choose either SACD or CD layer - but I hadn't paid attention to the next option in the options to then select DSD MULTI or DSD STEREO

I was assuming it would be something you can choose from the remote when playing. (First SACD player

thank again!
McGilli is offline  
post #408 of 411 Old Yesterday, 03:53 PM
Member
 
rlowell's Avatar
 
Join Date: Apr 2004
Posts: 151
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Hello Group/Thread...

I purchased a UBP-X800M2 last Friday (it's Sunday today) with the goal of getting the subtitle shift feature
to work.

And I'd most like it (because of some videos I create using this format) to work with MKV files.

So far, I haven't figured out how to get it to work. The user manual (I downloaded from Sony's webpage) isn't clear at all on this.

I also seem to think from one or two vague statements I've seen on the net that it may only work with
commercial blu-ray disks and not MKVs. I will try a commercial disk this evening to see if I can make this happen. But I have two questions for the group:

1. Does subtitle shift work to position a subtitle up/down on screen when playing an MKV? Please only post those who
have attempted this.

2. How do you engage this function (with whatever kind of disk works with it)? The subtitle button itself (I've had one or two Sony Blu Ray players before) behaves no differently than with older Sony players. The subtitles do play. I just don't have the freedom to change their screen position.


The media I'm playing the MKVs from is DVD+R disks.

Thanks in advance.

rlowell
rlowell is offline  
post #409 of 411 Old Yesterday, 05:42 PM
Member
 
rlowell's Avatar
 
Join Date: Apr 2004
Posts: 151
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
Quote:
Originally Posted by rlowell View Post
Hello Group/Thread...

I purchased a UBP-X800M2 last Friday (it's Sunday today) with the goal of getting the subtitle shift feature
to work.

And I'd most like it (because of some videos I create using this format) to work with MKV files.

So far, I haven't figured out how to get it to work. The user manual (I downloaded from Sony's webpage) isn't clear at all on this.

I also seem to think from one or two vague statements I've seen on the net that it may only work with
commercial blu-ray disks and not MKVs. I will try a commercial disk this evening to see if I can make this happen. But I have two questions for the group:

1. Does subtitle shift work to position a subtitle up/down on screen when playing an MKV? Please only post those who
have attempted this.

2. How do you engage this function (with whatever kind of disk works with it)? The subtitle button itself (I've had one or two Sony Blu Ray players before) behaves no differently than with older Sony players. The subtitles do play. I just don't have the freedom to change their screen position.


The media I'm playing the MKVs from is DVD+R disks.

Thanks in advance.

rlowell
Hello everyone on this thread.

I just tried a commercial blu ray (The Spiderman disc that ships with the player). Once I hit the "Options" button on the remote, "Subtitle Shift" came up as an explicitly named option.

I tried it and was able to move the whole subtitle down from the active video area (changing position from
"0" to "-4") into the black area on the screen below the active video area.

So what I had heard appears to be true... this Subtitle Shift option works for commercial blu rays, but not
MKVs. Bummer.


Even on a commercial blu ray, I think I'll enjoy having this option.

But does anyone know of another blu ray player (Panasonic, Oppo etc.) where you shift subtitles up or down when
the subtitles are *.srt subtitles inside an MKV container?

Just curious.

rlowell
rlowell is offline  
post #410 of 411 Old Today, 11:55 AM
Advanced Member
 
Derek87's Avatar
 
Join Date: Sep 2005
Posts: 642
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 97 Post(s)
Liked: 44
Off topic but in reference to your post: where did you buy the x800m2?
i'm curious to see who may still have the boxes which include the two free movies. (note: not asking price so i hope i'm not violating any forum rules)

thanks!

Quote:
Originally Posted by rlowell View Post
Hello Group/Thread...

I purchased a UBP-X800M2 last Friday (it's Sunday today) with the goal of getting the subtitle shift feature
to work.

And I'd most like it (because of some videos I create using this format) to work with MKV files.

So far, I haven't figured out how to get it to work. The user manual (I downloaded from Sony's webpage) isn't clear at all on this.

I also seem to think from one or two vague statements I've seen on the net that it may only work with
commercial blu-ray disks and not MKVs. I will try a commercial disk this evening to see if I can make this happen. But I have two questions for the group:

1. Does subtitle shift work to position a subtitle up/down on screen when playing an MKV? Please only post those who
have attempted this.

2. How do you engage this function (with whatever kind of disk works with it)? The subtitle button itself (I've had one or two Sony Blu Ray players before) behaves no differently than with older Sony players. The subtitles do play. I just don't have the freedom to change their screen position.


The media I'm playing the MKVs from is DVD+R disks.

Thanks in advance.

rlowell
Derek87 is online now  
post #411 of 411 Old Today, 12:08 PM
Member
 
Dave3000's Avatar
 
Join Date: Jan 2010
Posts: 184
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 79 Post(s)
Liked: 16
I'm considering purchasing the X800 M2 and how is the drive noise compare to the X700 player? Also how is it's reliability when playing triple layered 4k Blu-ray discs?
Dave3000 is offline  
Sponsored Links
Advertisement
 
Reply Blu-ray Players

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off