Panasonic DP-UB420 4K HDR10+ (non-Dolby Vision) Blu-ray Player now available.. - Page 13 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 85Likes
Reply
 
Thread Tools
post #361 of 378 Old 01-11-2020, 12:11 PM
Advanced Member
 
ToonMasterTim's Avatar
 
Join Date: Dec 2011
Posts: 543
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 171 Post(s)
Liked: 106
I won't be using the UB420 anymore for DVDs, and likely not for Blu-rays either. https://www.avforums.com/threads/lx5.../post-26730615 provides an example of what I have been seeing on my LG B7 OLED with DVDs. It's one of those 'once you see it, you can't un-see it' situations. Plus, I still feel like the DVD and Blu-ray playback of the Sony X800 is excellent. The 4K UHD playback is quite good on the UB420, so I am considering keeping it just for that. The HDR optimiser does a great job of producing what I consider a well-balanced, impactful HDR picture...rivaling Dolby Vision, if not surpassing it.
ToonMasterTim is offline  
Sponsored Links
Advertisement
 
post #362 of 378 Old 01-11-2020, 12:28 PM
AVS Forum Special Member
 
Dreamliner's Avatar
 
Join Date: Aug 2009
Location: Minnesota
Posts: 2,207
Mentioned: 29 Post(s)
Tagged: 0 Thread(s)
Quoted: 1489 Post(s)
Liked: 794
Quote:
Originally Posted by ToonMasterTim View Post
I won't be using the UB420 anymore for DVDs, and likely not for Blu-rays either. https://www.avforums.com/threads/lx5.../post-26730615 provides an example of what I have been seeing on my LG B7 OLED with DVDs. It's one of those 'once you see it, you can't un-see it' situations. Plus, I still feel like the DVD and Blu-ray playback of the Sony X800 is excellent. The 4K UHD playback is quite good on the UB420, so I am considering keeping it just for that. The HDR optimiser does a great job of producing what I consider a well-balanced, impactful HDR picture...rivaling Dolby Vision, if not surpassing it.
Interesting. If you know a specific scene in which you definitely see it on your display, try changing your Panny output to 1080 and let us know what you think. I also wonder if your X800 & 420 are on different TV inputs an your 420 TV input has some image processing on or something...

Ultimately, I'd be interested to see the same image with the Panasonic output set to 1080: Panny 4K upscale vs Panny 1080 vs Other Brand 4K upscale vs Other Brand 1080.
Dreamliner is offline  
post #363 of 378 Old 01-12-2020, 06:38 AM
AVS Forum Special Member
 
humbland's Avatar
 
Join Date: Apr 2003
Posts: 2,599
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 1104 Post(s)
Liked: 312
Quote:
Originally Posted by ToonMasterTim View Post
I won't be using the UB420 anymore for DVDs, and likely not for Blu-rays either. https://www.avforums.com/threads/lx5.../post-26730615 provides an example of what I have been seeing on my LG B7 OLED with DVDs. It's one of those 'once you see it, you can't un-see it' situations. Plus, I still feel like the DVD and Blu-ray playback of the Sony X800 is excellent. The 4K UHD playback is quite good on the UB420, so I am considering keeping it just for that. The HDR optimiser does a great job of producing what I consider a well-balanced, impactful HDR picture...rivaling Dolby Vision, if not surpassing it.
Interesting. This mirrors (HT humor) my own subjective experience with the Panny 420 vs an LG UBK90.
INMO, the LG displayed a sharper image with DVDs and BR discs on our 1080p PJ. Plus, the load time is faster. The image with Ultra BR discs is about the same, except that of course the 420 has the HDR slider. After much deliberation, I kept the Panny 420 for that feature, but ultimately, we have been using the LG UBK90 most of the time...
humbland is online now  
Sponsored Links
Advertisement
 
post #364 of 378 Old 01-12-2020, 11:11 PM
Member
 
Join Date: Jan 2015
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Liked: 3
Help, please. Bought this a few weeks ago. Watched martian, revenant and a few other 4k discs with no issue. Tonight it played the hobbit desolation of smaug (1080p) well for about an hour, then there was audio but no video image, only snowflakes. I powered it off and then on. It played a while and then the same issue came up. I tried other discs, same problem. I ckecked and the avr, tv and amp all work fine. So I think it's the Panny.

Last edited by aarn; 01-13-2020 at 12:22 AM.
aarn is offline  
post #365 of 378 Old 01-12-2020, 11:14 PM
Senior Member
 
SALadder22FF's Avatar
 
Join Date: Sep 2016
Location: Texas
Posts: 215
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 194 Post(s)
Liked: 49
Mine is not loading Blu Ray any more. We watched one movie and it worked fine other than saying it wasn't giving Atmos. Now it acts like is loading the movie and then cuts to home screen. Netflix will not load either. Any ideas? I did a reset already on settings

Sent from my SM-N950U using Tapatalk

Epson 5040UBe, 120" Black Diamond Zero Edge 7 Screen 1.4 gain with LEDs
Marantz SR6011 Reciever, Xbox One X Project Scorpio Edition, Nvidia Shield,BDI Ola 8137 stand, Logitech Harmony One Remote with Alexa,
Klipsch Dolby Atmos 7.1.2 surround sound
SALadder22FF is offline  
post #366 of 378 Old 01-13-2020, 12:38 AM
AVS Forum Special Member
 
Join Date: Jul 2017
Location: Out West
Posts: 1,627
Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 908 Post(s)
Liked: 452
Quote:
Originally Posted by aarn View Post
Help, please. Bought this a few weeks ago. Watched martian, revenant and a few other 4k discs with no issue. Tonight it played the hobbit desolation of smaug (1080p) well for about an hour, then there was audio but no video image, only snowflakes. I powered it off and then on. It played a while and then the same issue came up. I tried other discs, same problem. I ckecked and the avr, tv and amp all work fine. So I think it's the Panny.
It's always best to test by bypassing other devices and connect the UB420 directly to the TV, using a very short HDMI cable.
DunMunro is offline  
post #367 of 378 Old 01-14-2020, 12:49 PM
Senior Member
 
CHUCKCHILLOUT's Avatar
 
Join Date: Jul 2007
Location: Magnolia, Seattle, WA, USA
Posts: 354
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 63 Post(s)
Liked: 14
Quote:
Originally Posted by aarn View Post
Help, please. Bought this a few weeks ago. Watched martian, revenant and a few other 4k discs with no issue. Tonight it played the hobbit desolation of smaug (1080p) well for about an hour, then there was audio but no video image, only snowflakes. I powered it off and then on. It played a while and then the same issue came up. I tried other discs, same problem. I ckecked and the avr, tv and amp all work fine. So I think it's the Panny.

I have had the same issue. There was an instance of no sound, but video. I then have had my JVC RR540 lose signal when playing YouTube, but the audio was still working. I've had to change sources or HDMI inputs and then re-sync. I don't know if it's the player or the projector.
CHUCKCHILLOUT is offline  
post #368 of 378 Old 01-14-2020, 09:45 PM
Member
 
Join Date: Jan 2015
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Liked: 3
In my case, connecting directly to the TV instead of through the Denon x3500 doesn't resolve the issue. So I had an interesting experiment. When the movie was playing, once the screen turned black or into snowflakes, I changed the cable from one brand, Caivov, to another, Bifale. Voila, problem solved! Both cables support 8k, are 10ft long, and have great reviews on amazon. I don't know what happened, but glad it worked.
DunMunro likes this.
aarn is offline  
post #369 of 378 Old 01-14-2020, 10:26 PM
AVS Forum Special Member
 
Dreamliner's Avatar
 
Join Date: Aug 2009
Location: Minnesota
Posts: 2,207
Mentioned: 29 Post(s)
Tagged: 0 Thread(s)
Quoted: 1489 Post(s)
Liked: 794
It sounds like some of you have recently been having issues. I certainly hope it’s not a sign of things to come. I had my 820 for about a year without issues and so far the 420 has been trouble free.

I originally posted this a couple years ago but is a good refresher to those of you new to 4K:


HDMI Cable Choice Matters

HDCP 2.2 & 4K is extremely finicky with cables. I only recommend this cable. Others will recommend other brands but it must say EXACTLY: "Certified Premium High Speed HDMI Cable" (which currently is limited to 25 feet). Any variation of that language is not a genuine certified cable and may not work. My previous cable was "4K 60Hz compatible" but did NOT work. If you screw around with cables, you will have problems.

There are no HDCP 2.2 4K certified cables over 25 feet but many people have had long-run success with these cables if over 25 feet.

No matter what you buy, if it is 25 feet or shorter and does not say EXACTLY "Certified Premium High Speed" you are taking a risk.
ToonMasterTim likes this.
Dreamliner is offline  
post #370 of 378 Old 01-15-2020, 01:24 AM
AVS Forum Special Member
 
Join Date: Jul 2017
Location: Out West
Posts: 1,627
Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 908 Post(s)
Liked: 452
Netflix at 24FPS?

Has anyone been able to get Netflix content to play at 24fps? I can't get the UB420 to output at anything other than 60hz. my X700 would output netflix at 24hz.
DunMunro is offline  
post #371 of 378 Old 01-15-2020, 07:05 AM
AVS Forum Addicted Member
 
gadgtfreek's Avatar
 
Join Date: Aug 2012
Location: Bama
Posts: 12,293
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 634 Post(s)
Liked: 6093
Quote:
Originally Posted by DunMunro View Post
Netflix at 24FPS?

Has anyone been able to get Netflix content to play at 24fps? I can't get the UB420 to output at anything other than 60hz. my X700 would output netflix at 24hz.
Pannys only do 60hz.
DunMunro likes this.

XBR65A9G / XBR65A8F / 55R615
DP-UB420 / Uverse / Roku Ultra
AVRX6500H / RP-8000F / RP-504C / RP-502S / RP-500SA / FV15HP (5.1.2)
gadgtfreek is offline  
post #372 of 378 Old 01-15-2020, 11:21 AM
Member
 
Join Date: Jan 2015
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Liked: 3
Quote:
Originally Posted by Dreamliner View Post
It sounds like some of you have recently been having issues. I certainly hope it’️s not a sign of things to come. I had my 820 for about a year without issues and so far the 420 has been trouble free.

I originally posted this a couple years ago but is a good refresher to those of you new to 4K:


HDMI Cable Choice Matters

HDCP 2.2 & 4K is extremely finicky with cables. I only recommend this cable. Others will recommend other brands but it must say EXACTLY: "Certified Premium High Speed HDMI Cable" (which currently is limited to 25 feet). Any variation of that language is not a genuine certified cable and may not work. My previous cable was "4K 60Hz compatible" but did NOT work. If you screw around with cables, you will have problems.

There are no HDCP 2.2 4K certified cables over 25 feet but many people have had long-run success with these cables if over 25 feet.

No matter what you buy, if it is 25 feet or shorter and does not say EXACTLY "Certified Premium High Speed" you are taking a risk.
Wish I saw your post earlier. I went with the 8k cables based on Amazon reviews. Would you recommend the monoprice cables over the 8k cables?

Last edited by aarn; 01-15-2020 at 11:27 AM.
aarn is offline  
post #373 of 378 Old 01-15-2020, 11:42 AM
Senior Member
 
Jbhur212's Avatar
 
Join Date: Jun 2016
Location: Akron
Posts: 405
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 202 Post(s)
Liked: 176
Quote:
Originally Posted by aarn View Post
Wish I saw your post earlier. I went with the 8k cables based on Amazon reviews. Would you recommend the monoprice cables over the 8k cables?
Well I certainly do. When I upgraded my HT to 4K in May of 2018, I replaced every HDMI cable with the Monoprice cables, even for the 1080p sources I was still using, and zero problems.

EQUIPMENT:LG OLED77C8PUA (ISF calibrated by Jeff Meier)-OPPO BDP-203 blu-ray player-OPPO DV-983H dvd player-Pioneer CLD-99 laser disc player-Marantz 7703 Preamplifier-200x3 Acurus amplifier-150x2 Acurus amplifier-Emotiva UPA-2 amplifier-Outlaw Model 5000 amplifier-2 Mythos 4-1 Mythos 8-2 Mythos BPX-2 NHT Super Zeros-4 SVS Prime Elevation speakers-Hsu VTF-2 MK3 subwoofer-Elite-Xbox One S-Roku Ultra streaming player
Jbhur212 is offline  
post #374 of 378 Old 01-15-2020, 11:43 AM
AVS Forum Special Member
 
Dreamliner's Avatar
 
Join Date: Aug 2009
Location: Minnesota
Posts: 2,207
Mentioned: 29 Post(s)
Tagged: 0 Thread(s)
Quoted: 1489 Post(s)
Liked: 794
Quote:
Originally Posted by aarn View Post
Wish I saw your post earlier. I went with the 8k cables based on Amazon reviews. Would you recommend the monoprice cables over the 8k cables?
I don't know anything about those Amazon 8K cables but I personally trust actual certifications over marketing hyperbole. That said, as time goes on other cable manufacturers will eventually catch up. Sometimes streaming services or streamers have their menus at 60FPS 4K HDR which causes a lot of problems with lower quality HDMI cables. The real trouble with this is the problems are random so it is very hard to track down. I replaced ALL of my HDMI cables with the Monoprice Certified Premium ones at the same time. That way I was certain to not have HDMI cable issues and I haven't had a single cable issue.

The best way to really stress test an HDMI cable is by playing Billy Lynn's Long Halftime Walk 4K or Gemini Man 4K. Both of those are 4K HDR 60FPS, you'll know if your cable works by playing those movies for an extended amount of time. Unfortunately they are both pretty bad movies, so...there is that.
Dreamliner is offline  
post #375 of 378 Old Yesterday, 12:44 AM
Member
 
momofx's Avatar
 
Join Date: Oct 2013
Posts: 90
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 69 Post(s)
Liked: 26
So I just got the UB420 and while I did notice a picture difference compared to my Sony X800, I must say the UB420 looks cheap compared to the Sony but I'm happy the picture looks a little more better. Is it just me, or does anyone else have problems hitting that darn Netflix button instead of the UP arrow button??! I wish they had put the Netflix button somewhere else!


Does anyone know if the UB9000 remote will work this model?
ToonMasterTim likes this.
momofx is offline  
post #376 of 378 Old Yesterday, 02:15 AM
AVS Forum Special Member
 
Join Date: Jul 2017
Location: Out West
Posts: 1,627
Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 908 Post(s)
Liked: 452
Quote:
Originally Posted by momofx View Post
So I just got the UB420 and while I did notice a picture difference compared to my Sony X800, I must say the UB420 looks cheap compared to the Sony but I'm happy the picture looks a little more better. Is it just me, or does anyone else have problems hitting that darn Netflix button instead of the UP arrow button??! I wish they had put the Netflix button somewhere else!


Does anyone know if the UB9000 remote will work this model?
All three of the curved buttons around the 4 way selectors are a real PITA. IIRC, there is discussion about using a UB9000 remote, earlier in the thread.
momofx likes this.
DunMunro is offline  
post #377 of 378 Old Yesterday, 03:18 PM
Senior Member
 
john hunter's Avatar
 
Join Date: Apr 2007
Posts: 204
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 83 Post(s)
Liked: 26
Quote:
Originally Posted by momofx View Post
So I just got the UB420 and while I did notice a picture difference compared to my Sony X800, I must say the UB420 looks cheap compared to the Sony but I'm happy the picture looks a little more better. Is it just me, or does anyone else have problems hitting that darn Netflix button instead of the UP arrow button??! I wish they had put the Netflix button somewhere else!


Does anyone know if the UB9000 remote will work this model?

Apparently so.
Like you I find that Netflix button is a real pain.
Have ordered the 9000 remote which will take a few weeks to get here from China and will report back if no one else has in the mean time.
john hunter is offline  
post #378 of 378 Old Yesterday, 11:04 PM
AVS Forum Special Member
 
MidnightWatcher's Avatar
 
Join Date: Mar 2005
Location: The Great White North
Posts: 5,579
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 218 Post(s)
Liked: 216
Quote:
Originally Posted by momofx View Post
So I just got the UB420 and while I did notice a picture difference compared to my Sony X800, I must say the UB420 looks cheap compared to the Sony but I'm happy the picture looks a little more better. Is it just me, or does anyone else have problems hitting that darn Netflix button instead of the UP arrow button??! I wish they had put the Netflix button somewhere else!


Does anyone know if the UB9000 remote will work this model?
Yes, works great! Got a genuine remote off eBay for $25.
Attached Thumbnails
Click image for larger version

Name:	photostudio_1579327365296.jpg
Views:	23
Size:	702.0 KB
ID:	2671596  
DunMunro likes this.

--------------------------------------------------------------------------------------
My Theater | Vero 4K | Epson 5030UB + Peerless PRG-UNV | 100" EluneVision Reference 4K Screen | Denon X3600H @ 5.2.4 | 4 x ADX Maximus w/ Dayton Audio SA230 | Polk Audio RTi A9 + CSi A6 + OWM3 + Micca M8C + SVS PC2000 + Monolith 15 | 40" HDTV w/ Z83V Mini PC + MoviePosterApp | Z83V + DietPi FTP Server + 4 x 8TB HDDs + 4 x DLink DHP-701AV
MidnightWatcher is offline  
Sponsored Links
Advertisement
 
Reply Blu-ray Players

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off