No Left Channel Sound On Turntable - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 
Thread Tools
post #1 of 2 Old 08-16-2019, 11:05 AM - Thread Starter
Member
 
pjg991's Avatar
 
Join Date: Oct 2010
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 10
No Left Channel Sound On Turntable

I have a pioneer elite sc 35 receiver and a technics sl 23 turntable,everything has been working great and all of a sudden I have no sound from the left channel. I have checked all of my wiring, I switched the phono input left & right cables, right to left & left to right, and still no left channel sound. The left channel works on the tv & blu ray player. I tried using another input on my receiver but come up with no sound at all. I checked all the settings on my receiver input setting. Can someone help me????
pjg991 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 08-17-2019, 09:35 PM
AVS Forum Special Member
 
crn3371's Avatar
 
Join Date: Mar 2013
Posts: 1,481
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 318 Post(s)
Liked: 274
Switching cables eliminates the turntable. Sounds like an issue with the left channel on your phono input. If that’s the case then you’ll need to get an external phono preamp.
crn3371 is offline  
Sponsored Links
Advertisement
 
Reply CD Players & Dedicated Music Transports

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off