Thinking about active xover DIYSG - Crown ComTech? - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 4Likes
  • 1 Post By ZX3ST
  • 2 Post By ZX3ST
  • 1 Post By Rowan611
 
Thread Tools
post #1 of 11 Old 01-27-2019, 09:54 AM - Thread Starter
Member
 
ZX3ST's Avatar
 
Join Date: May 2011
Posts: 47
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Liked: 26
Thinking about active xover DIYSG - Crown ComTech?

So I've been thinking about tinkering with going full-active on my DIYSG 1299s. Currently passive and powered by Marantz 7000 series amps.

I was browsing online and came upon what appears to be newish ComTech amps from Crown.
https://www.crownaudio.com/en-US/pro...ivecore-series

Spec looks pretty decent. They're fanless, but can't say I have a fan noise complaint with the XLS2502s I'm using for subs. Quite compact at 1U for each chassis.

Anyone have any experience with these? I was thinking a CT4150 for each cabinet would be a decent setup. 1 channel for each woofer (or bridge 2 channels and run them parallel), 1 channel for the mids, 1 channel for the CD.

Open to suggestions of course. All you active users out there - what are you running?
ZX3ST is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 01-27-2019, 10:08 AM
AVS Forum Special Member
 
Rowan611's Avatar
 
Join Date: Apr 2011
Location: Pella, IA
Posts: 1,498
Mentioned: 86 Post(s)
Tagged: 0 Thread(s)
Quoted: 602 Post(s)
Liked: 701
Quote:
Originally Posted by ZX3ST View Post
So I've been thinking about tinkering with going full-active on my DIYSG 1299s. Currently passive and powered by Marantz 7000 series amps.



I was browsing online and came upon what appears to be newish ComTech amps from Crown.

https://www.crownaudio.com/en-US/pro...ivecore-series



Spec looks pretty decent. They're fanless, but can't say I have a fan noise complaint with the XLS2502s I'm using for subs. Quite compact at 1U for each chassis.



Anyone have any experience with these? I was thinking a CT4150 for each cabinet would be a decent setup. 1 channel for each woofer (or bridge 2 channels and run them parallel), 1 channel for the mids, 1 channel for the CD.



Open to suggestions of course. All you active users out there - what are you running?
Why?

Sent from my Pixel XL using Tapatalk

HT: Oppo UHD-203 | Crown Amps | NX3000D | NX6000D | 1299s | Volt 8s | THTs | Crowson Shadow 8s | BOSS riser | Panamax 5300PM | LG OLED 65B6P
Family: Denon AVR-S740 | PSB Alpha AVs | Sony X900F | X1
Rowan611 is offline  
post #3 of 11 Old 01-27-2019, 10:11 AM - Thread Starter
Member
 
ZX3ST's Avatar
 
Join Date: May 2011
Posts: 47
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Liked: 26
Quote:
Originally Posted by Rowan611 View Post
Why?

Sent from my Pixel XL using Tapatalk

I suppose because I can't leave well enough alone. All hypothetical at this point.
Chris Popovich likes this.
ZX3ST is offline  
Sponsored Links
Advertisement
 
post #4 of 11 Old 01-27-2019, 10:16 AM
AVS Forum Special Member
 
Rowan611's Avatar
 
Join Date: Apr 2011
Location: Pella, IA
Posts: 1,498
Mentioned: 86 Post(s)
Tagged: 0 Thread(s)
Quoted: 602 Post(s)
Liked: 701
Quote:
Originally Posted by ZX3ST View Post
I suppose because I can't leave well enough alone. All hypothetical at this point.
Lol...yeah I get that. Another way to ask the question; what are you hoping to achieve?

I can't imagine them sounding that much better. I run 1299 LCR off two XLS 1500 Crowns. And, they sound awesome. So, I guess that's where I'm coming from with the "Why".

Not trying to be an antagonist.

Sent from my Pixel XL using Tapatalk

HT: Oppo UHD-203 | Crown Amps | NX3000D | NX6000D | 1299s | Volt 8s | THTs | Crowson Shadow 8s | BOSS riser | Panamax 5300PM | LG OLED 65B6P
Family: Denon AVR-S740 | PSB Alpha AVs | Sony X900F | X1
Rowan611 is offline  
post #5 of 11 Old 01-27-2019, 10:56 AM - Thread Starter
Member
 
ZX3ST's Avatar
 
Join Date: May 2011
Posts: 47
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Liked: 26
Well TBH, I'm experiencing some intelligibility in my center channel that I just can't seem to get rid of. Mostly with male voices. It feels like the mids are sometimes slightly out of phase, creating a hollow presence. I thought the combo of active xover and manual EQ adjustment for each driver might allow me to get a bit more fine-tuned. Plus more power never hurt anyone!

I've already done the troubleshooting dance with swapping xovers and drivers from the mains so I'm confident this isn't an electrical or driver issue.
ZX3ST is offline  
post #6 of 11 Old 01-27-2019, 12:27 PM
Member
 
Ming696's Avatar
 
Join Date: Mar 2015
Location: Kansas
Posts: 64
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 16 Post(s)
Liked: 13
I can vouch for the CT series. I had a CT475 which was great, but I sold it for a CT8150. The 8150 is the same as a Lexicon DD-8 only the Lexicon uses unbalanced RCA inputs instead of balanced Phoenix connectors. These amps have good SNR and good power and don't use fans. I use mine with a Marantz AV7703 for surrounds and Atmos duty. If your budget is a little higher and you want more power with an option for DSP look up the DCI series. I have a DCI 4/1250N for subs and a DCI 8/300N for fronts, center and whatever else I want. Awesome amps in my opinion.
Ming696 is offline  
post #7 of 11 Old 01-28-2019, 04:19 AM
Senior Member
 
kennyandersen's Avatar
 
Join Date: Feb 2014
Posts: 376
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 139 Post(s)
Liked: 103
Quote:
Originally Posted by ZX3ST View Post
I suppose because I can't leave well enough alone. All hypothetical at this point.
Obviously you have too much money. Please PM me and I'll give you an address where you can send money -- I assure you it will go to a good home where it will be loved and cuddled.

Sent from my Moto G (5) Plus using Tapatalk
kennyandersen is offline  
post #8 of 11 Old 01-28-2019, 09:44 AM - Thread Starter
Member
 
ZX3ST's Avatar
 
Join Date: May 2011
Posts: 47
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Liked: 26
Quote:
Originally Posted by kennyandersen View Post
Obviously you have too much money. Please PM me and I'll give you an address where you can send money -- I assure you it will go to a good home where it will be loved and cuddled.

Sent from my Moto G (5) Plus using Tapatalk
LOL

Gonna go all Scrooge-McDuck and swim in it.
Heide264 and kennyandersen like this.
ZX3ST is offline  
post #9 of 11 Old 01-28-2019, 10:36 AM
Senior Member
 
Chris Popovich's Avatar
 
Join Date: Dec 2005
Posts: 336
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 164 Post(s)
Liked: 147
Quote:
Originally Posted by Rowan611 View Post
Why?
I'm almost hurt that you would ask that question in the DIY section.
Chris Popovich is offline  
post #10 of 11 Old 01-28-2019, 10:52 AM
AVS Forum Special Member
 
Rowan611's Avatar
 
Join Date: Apr 2011
Location: Pella, IA
Posts: 1,498
Mentioned: 86 Post(s)
Tagged: 0 Thread(s)
Quoted: 602 Post(s)
Liked: 701
Quote:
Originally Posted by Chris Popovich View Post
I'm almost hurt that you would ask that question in the DIY section.
I'm sure you'll manage
Chris Popovich likes this.

HT: Oppo UHD-203 | Crown Amps | NX3000D | NX6000D | 1299s | Volt 8s | THTs | Crowson Shadow 8s | BOSS riser | Panamax 5300PM | LG OLED 65B6P
Family: Denon AVR-S740 | PSB Alpha AVs | Sony X900F | X1
Rowan611 is offline  
post #11 of 11 Old 01-28-2019, 04:56 PM
AVS Forum Special Member
 
dwaleke's Avatar
 
Join Date: Feb 2006
Location: Michigan
Posts: 2,644
Mentioned: 29 Post(s)
Tagged: 0 Thread(s)
Quoted: 1412 Post(s)
Liked: 719
Quote:
Originally Posted by ZX3ST View Post
So I've been thinking about tinkering with going full-active on my DIYSG 1299s. Currently passive and powered by Marantz 7000 series amps.

I was browsing online and came upon what appears to be newish ComTech amps from Crown.
https://www.crownaudio.com/en-US/pro...ivecore-series

Spec looks pretty decent. They're fanless, but can't say I have a fan noise complaint with the XLS2502s I'm using for subs. Quite compact at 1U for each chassis.

Anyone have any experience with these? I was thinking a CT4150 for each cabinet would be a decent setup. 1 channel for each woofer (or bridge 2 channels and run them parallel), 1 channel for the mids, 1 channel for the CD.

Open to suggestions of course. All you active users out there - what are you running?
I did a similar thing with these amplifiers. I had a CT4150 and two CT875s running my L/C/R 3-way JTR 212HTRs fully active driven from a Motu 24AO with Jriver running Audiolense XO convolution filters.

Probably the best audio experience I had in my space.

If Audiolense didn't take care of the crossovers for me I likely would never have attempted it. At the end of the day I tore it all down as more and more content was coming through streaming services and there was no good way to pipe that into Jriver.
dwaleke is offline  
Sponsored Links
Advertisement
 
Reply DIY Speakers and Subs

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off