NX3000D No Sound - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 2Likes
  • 1 Post By Kpilk
  • 1 Post By audiosq
 
Thread Tools
post #1 of 7 Old 06-05-2019, 07:06 PM - Thread Starter
Member
 
audiosq's Avatar
 
Join Date: Dec 2012
Posts: 73
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 24 Post(s)
Liked: 14
NX3000D No Sound

I just got an NX3000, hooked it up and no sound, any ideas? Everything seems secure. Trying to run two subs dual mono, AVR has two sub outs. The only thing I can guess is the Speakon NL2FX connectors aren't right somewhere, but it only has two holes to screw in the wire and things seemed tight before I screwed everything together. Now I can't get them unscrewed to check to make sure they are tight so any help there woulds also be appreciated. I haven't messed with any of the dsp settings yet. Do I need to do something there to get sound? Photo attached.

Also the signal strength indicators don't even light up unless I turn the knobs all the way up and then they only show one tick of green, even with the AVR at +12. Any help would be appreciated.
Attached Thumbnails
Click image for larger version

Name:	IMG_20190605_203054_1559786325269.jpg
Views:	77
Size:	2.36 MB
ID:	2576470  
audiosq is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 06-05-2019, 08:58 PM - Thread Starter
Member
 
audiosq's Avatar
 
Join Date: Dec 2012
Posts: 73
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 24 Post(s)
Liked: 14
It's tough being ignorant.. figured it out.
audiosq is offline  
post #3 of 7 Old 06-06-2019, 05:43 AM
AVS Forum Special Member
 
jcmccorm's Avatar
 
Join Date: Mar 2001
Location: Madison, AL, USA
Posts: 4,491
Mentioned: 19 Post(s)
Tagged: 0 Thread(s)
Quoted: 597 Post(s)
Liked: 444
Ha! Nice. Care to share? We've probably all done it before (whatever it was). Might save someone else.
jcmccorm is offline  
Sponsored Links
Advertisement
 
post #4 of 7 Old 06-06-2019, 09:26 AM
Senior Member
 
Kpilk's Avatar
 
Join Date: Dec 2007
Posts: 454
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 63 Post(s)
Liked: 69
Quote:
Originally Posted by jcmccorm View Post
Ha! Nice. Care to share? We've probably all done it before (whatever it was). Might save someone else.
Yes...we must know the depths of this stupidity...so we can feel better about our's.
kaiforce likes this.
Kpilk is offline  
post #5 of 7 Old 06-06-2019, 11:55 AM - Thread Starter
Member
 
audiosq's Avatar
 
Join Date: Dec 2012
Posts: 73
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 24 Post(s)
Liked: 14
When I plugged in the Speakon cables I didn't know you had to turn them..
LTD02 likes this.
audiosq is offline  
post #6 of 7 Old 06-06-2019, 12:11 PM
AVS Forum Special Member
 
jcmccorm's Avatar
 
Join Date: Mar 2001
Location: Madison, AL, USA
Posts: 4,491
Mentioned: 19 Post(s)
Tagged: 0 Thread(s)
Quoted: 597 Post(s)
Liked: 444
Quote:
Originally Posted by audiosq View Post
When I plugged in the Speakon cables I didn't know you had to turn them..
Ah that's not so bad. I've never seen a Speakon connector before getting into DIY. The stuff most of us are familiar with, 1/4" TRS, RCA, XLR, etc. doesn't require a twist.

Glad you got it sorted out.
jcmccorm is offline  
post #7 of 7 Old 06-06-2019, 03:25 PM
Advanced Member
 
Red Five's Avatar
 
Join Date: Mar 2018
Location: Wisconsin
Posts: 805
Mentioned: 23 Post(s)
Tagged: 0 Thread(s)
Quoted: 398 Post(s)
Liked: 448
The generic name makes more sense - twist and lock. At least it was a simple issue and not an RMA request

Stormbreaker | Wisconsin Home Theater Meet Thread | B.M.D. (in progress)
You can always turn it down, but you can only turn it up so much (before you run out of power, excursion or structural integrity).
7.1.4 | Yamaha A3070 | Crown XLS 1502 | iNuke 3000 DSP | 2x Aphex 124A | 2x Bic EV15 | 7x Bic FH6 LCR | 2x Bic FH65-B | Sub 21" Stormbreaker | Epson 5010e | 120" DIY AT Screen
Red Five is offline  
Sponsored Links
Advertisement
 
Reply DIY Speakers and Subs

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off