**Official** Sony X930C / X940C Owners Thread - Page 453 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 7009Likes
Reply
 
Thread Tools
post #13561 of 14302 Old 09-15-2017, 06:11 AM
AVS Forum Special Member
 
mt14942's Avatar
 
Join Date: May 2007
Location: Pembroke Pines, Florida
Posts: 2,259
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 750 Post(s)
Liked: 225
Quote:
Originally Posted by derreckla View Post
Is it me or does anyone else hate the HDR effect on our TV? Is there a way to turn it off? It greys out night scenes instead of it being black.

Thanks

Is this the case when streaming HDR programs from apps on the TV like Amazon or Netflix? Do you also have this issue with 4K disc's?

Sony 75xZ9D
Sony UBP-X800 4K player
Oppo UDP-205 4k player
Classe SSP-800 pre/pro
Parasound Halo 5 channel Amp
mt14942 is offline  
Sponsored Links
Advertisement
 
post #13562 of 14302 Old 09-15-2017, 07:22 AM
Member
 
Join Date: May 2016
Posts: 59
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 38 Post(s)
Liked: 10
Quote:
Originally Posted by derreckla View Post
Is it me or does anyone else hate the HDR effect on our TV? Is there a way to turn it off? It greys out night scenes instead of it being black.

Thanks
Make sure your TV's firmware is up to date. Previously people had issues with HDR "being too grey" if they were watching HDR content and they did not turn on MotionFlow and/or Cinemotion to something other than OFF.

Also, check if your HDMI inputs are correctly setup to Enhanced HDMI in the settings menu and that your Color is set to match your source, preferably "Auto" instead of "Full" or "Limited".

No black issues here with 940C tv, x800 player, and SC-97 receiver.
Tom Riddle likes this.
TotoyZ4 is offline  
post #13563 of 14302 Old 09-19-2017, 05:12 PM
pee
Member
 
pee's Avatar
 
Join Date: Oct 2005
Location: Carlsbad, CA
Posts: 181
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 88 Post(s)
Liked: 53
Mark on screen

I just noticed a small mark on my screen. It appears to be on the inside of the screen. I’ve tried wiping it, but it doesn’t come off.

Any ideas what it could be? (It’s all I see now).












Sent from my iPhone using Tapatalk
pee is online now  
Sponsored Links
Advertisement
 
post #13564 of 14302 Old 09-22-2017, 09:35 AM
pee
Member
 
pee's Avatar
 
Join Date: Oct 2005
Location: Carlsbad, CA
Posts: 181
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 88 Post(s)
Liked: 53
Quote:
Originally Posted by pee View Post
Mark on screen

I just noticed a small mark on my screen. It appears to be on the inside of the screen. I’ve tried wiping it, but it doesn’t come off.

Any ideas what it could be? (It’s all I see now).












Sent from my iPhone using Tapatalk
Well, I contacted my Warranty company (SquareTrade) to see if they could take a look at this small spot. I sent them the photos, and they requested a few more. Their response was, it is the panel and they offered to send me a replacement TV. (To me, it looks like a spec or dust on the lens honestly).

Their initial offer for a replacement was laughable. They gave 3 options:
1. LG UH6150 - Negative!
2. LG UJ6300 - Double Negative!
3. Samsung MU6300 - Triple Negative!

I responded and let them know that these were nowhere close to comparable to my 930C. I sighted the differences, and let them know how important 3D was to me. and that I wanted to stay with a Sony.

Their next response was about how 3D is limited and they could not offer an equal replacement with it. I again responded letting them there are 3D options and I should be able to at a minimum get a check worth the value of my TV.

They then offered a 850E. Although I appreciated them at least offering a Sony, I still rejected it. Letting them know that this was still a step down from my 930C, even if it's a 2017.

So just now, they responded offering a 900E as a replacement. Much better and it's Full Array. But it's also lacking 3D and it doesn't have as good Local Dimming from what I've read here at AVS and other sites.

I LOVE my 930C. This small spot really isn't noticeable to anyone but me.
They are allowing me to keep my 930C and dispose of it myself.

My dilemma now is:
Do I accept their 900E offer, and maybe try to sell that TV myself?(although I don't know where to start to go sell it). Then just stay with my 930C until that spot gets worse(if it does).
Or maybe I can find a local authorized sony repair place and pay them to try to fix it with the money from the sale?

Ultimately, the only TV I would want to actually replace my 930C is the 65Z9D. I could possibly take the money I get from selling the 900E and then apply it to a Z9D now, or at some point in the future.

I'm just talking out loud here to fellow TV enthusiast, looking for input. Because my wife, neighbors and friends think a TV is a TV.

Any thoughts?
pee is online now  
post #13565 of 14302 Old 09-22-2017, 02:43 PM
Senior Member
 
400MHz MAN's Avatar
 
Join Date: May 2007
Posts: 431
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 262 Post(s)
Liked: 153
Quote:
Originally Posted by pee View Post
Well, I contacted my Warranty company (SquareTrade) to see if they could take a look at this small spot. I sent them the photos, and they requested a few more. Their response was, it is the panel and they offered to send me a replacement TV. (To me, it looks like a spec or dust on the lens honestly).

Their initial offer for a replacement was laughable. They gave 3 options:
1. LG UH6150 - Negative!
2. LG UJ6300 - Double Negative!
3. Samsung MU6300 - Triple Negative!

I responded and let them know that these were nowhere close to comparable to my 930C. I sighted the differences, and let them know how important 3D was to me. and that I wanted to stay with a Sony.

Their next response was about how 3D is limited and they could not offer an equal replacement with it. I again responded letting them there are 3D options and I should be able to at a minimum get a check worth the value of my TV.

They then offered a 850E. Although I appreciated them at least offering a Sony, I still rejected it. Letting them know that this was still a step down from my 930C, even if it's a 2017.

So just now, they responded offering a 900E as a replacement. Much better and it's Full Array. But it's also lacking 3D and it doesn't have as good Local Dimming from what I've read here at AVS and other sites.

I LOVE my 930C. This small spot really isn't noticeable to anyone but me.
They are allowing me to keep my 930C and dispose of it myself.

My dilemma now is:
Do I accept their 900E offer, and maybe try to sell that TV myself?(although I don't know where to start to go sell it). Then just stay with my 930C until that spot gets worse(if it does).
Or maybe I can find a local authorized sony repair place and pay them to try to fix it with the money from the sale?

Ultimately, the only TV I would want to actually replace my 930C is the 65Z9D. I could possibly take the money I get from selling the 900E and then apply it to a Z9D now, or at some point in the future.

I'm just talking out loud here to fellow TV enthusiast, looking for input. Because my wife, neighbors and friends think a TV is a TV.

Any thoughts?
Try tapping on the panel, you might get it to move.
400MHz MAN is offline  
post #13566 of 14302 Old 09-22-2017, 03:08 PM
pee
Member
 
pee's Avatar
 
Join Date: Oct 2005
Location: Carlsbad, CA
Posts: 181
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 88 Post(s)
Liked: 53
Quote:
Originally Posted by 400MHz MAN View Post
Try tapping on the panel, you might get it to move.
400MHz Man,

Thanks for the advice. I just tried tapping at that location on the panel. It didn't appear to move. Also tried tapping from the back of the TV.

I wonder if I could/should try using some compressed air and blowing into one of the vents? If it is indeed as simple as some dust or a dead bug, maybe it will blow it off?

At any rate, I think I'll go with them sending me the 900E as a replacement and sell it to a neighbor or friend. I'll keep my 930C as is until the spot starts to bother me too much if it is actually a panel issue.
pee is online now  
post #13567 of 14302 Old 09-23-2017, 07:14 PM
Advanced Member
 
Join Date: Nov 2015
Posts: 625
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 396 Post(s)
Liked: 112
Apple TV 4K

Hey guys,

Just hooked up the ATV. It is the first 4K source used with the 940C. HDMI is set to enhanced. When going to Pic Adjustment, the mode is greyed out as HDR Video, no Cinema Pro/ Home etc is available when HDR signal is sent to the TV. Is this normal for the 940C?
daimler2015 is offline  
post #13568 of 14302 Old 09-24-2017, 10:23 AM
 
Join Date: May 2016
Posts: 106
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 47 Post(s)
Liked: 19
Quote:
Originally Posted by pee View Post
Mark on screen

I just noticed a small mark on my screen. It appears to be on the inside of the screen. I’ve tried wiping it, but it doesn’t come off.

Any ideas what it could be? (It’s all I see now).


Incredibly, I just noticed a nearly identical mark on my screen. I also have the Square Trade warranty, so the details of your experience are really helpful, thanks.
pee likes this.
Pupator is offline  
post #13569 of 14302 Old 09-24-2017, 10:30 AM
pee
Member
 
pee's Avatar
 
Join Date: Oct 2005
Location: Carlsbad, CA
Posts: 181
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 88 Post(s)
Liked: 53
Quote:
Originally Posted by Pupator View Post
Incredibly, I just noticed a nearly identical mark on my screen. I also have the Square Trade warranty, so the details of your experience are really helpful, thanks.


Stick to your guns with them.
I still gave one last effort to have them send me a check. I guess they will respond on Monday.

Regarding the spot, it’s not that much of a distraction. It’s just annoying because it’s in the center of the screen.




Sent from my iPhone using Tapatalk
pee is online now  
post #13570 of 14302 Old 09-24-2017, 11:08 AM
Senior Member
 
Join Date: Aug 2015
Location: Los Angeles, CA
Posts: 463
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 284 Post(s)
Liked: 219
Quote:
Originally Posted by Pupator View Post
Incredibly, I just noticed a nearly identical mark on my screen. I also have the Square Trade warranty, so the details of your experience are really helpful, thanks.
Could those be bugs/small flys?

In case you're wondering, my setup: Sony 65x930E, Denon x3200W, 2 Martin Logan 35XT, 1 ML Motion 8 Center Channel, and 1 ML Dynamo 700W Sub.
Radvlad is offline  
post #13571 of 14302 Old 09-24-2017, 11:10 AM
pee
Member
 
pee's Avatar
 
Join Date: Oct 2005
Location: Carlsbad, CA
Posts: 181
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 88 Post(s)
Liked: 53
Quote:
Originally Posted by Radvlad View Post
Could those be bugs/small flys?


That’s exactly what it looks like to me. A gnat or fruit fly.



Sent from my iPhone using Tapatalk
pee is online now  
post #13572 of 14302 Old 09-24-2017, 11:12 AM
Senior Member
 
Join Date: Aug 2015
Location: Los Angeles, CA
Posts: 463
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 284 Post(s)
Liked: 219
Quote:
Originally Posted by pee View Post
That’s exactly what it looks like to me. A gnat or fruit fly.



Sent from my iPhone using Tapatalk
A guy in the UK AV Forum had that problem w/his 940D, and it turned out to be flys... he actually had multiple flys get into his screen.

In case you're wondering, my setup: Sony 65x930E, Denon x3200W, 2 Martin Logan 35XT, 1 ML Motion 8 Center Channel, and 1 ML Dynamo 700W Sub.
Radvlad is offline  
post #13573 of 14302 Old 09-24-2017, 11:14 AM
pee
Member
 
pee's Avatar
 
Join Date: Oct 2005
Location: Carlsbad, CA
Posts: 181
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 88 Post(s)
Liked: 53
Quote:
Originally Posted by Radvlad View Post
A guy in the UK AV Forum had that problem w/his 940D, and it turned out to be flys... he actually had multiple flys get into his screen.


Do you know if he was able to get them out?



Sent from my iPhone using Tapatalk
pee is online now  
post #13574 of 14302 Old 09-24-2017, 11:18 AM
Senior Member
 
Join Date: Aug 2015
Location: Los Angeles, CA
Posts: 463
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 284 Post(s)
Liked: 219
Quote:
Originally Posted by pee View Post
Do you know if he was able to get them out?



Sent from my iPhone using Tapatalk
If I recall correctly, his ID was @zandy , and I believe that he was able to return the TV and ended up with an LG E6 after briefly also owning a 75Z9D, which he ended up selling (he and some other UK peeps were able to buy 75Z9Ds for 5K Pounds, which was a pricing error that was honored by their retailer, Curry’s).
pee likes this.

In case you're wondering, my setup: Sony 65x930E, Denon x3200W, 2 Martin Logan 35XT, 1 ML Motion 8 Center Channel, and 1 ML Dynamo 700W Sub.
Radvlad is offline  
post #13575 of 14302 Old 09-28-2017, 04:13 PM
Newbie
 
Join Date: Aug 2016
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 0
Please help me guys!

I just bought & installed a new Apple TV 4K with my X390C.

Everything is hooked up to a Yamaha RX-A2050 receiver via ARC. Receiver is a 2015 model that supports HDMI 2.0 and 4k HDR pass-thru according to Yamaha, so...

Tell me why when I booted up the new Apple TV, it won't let me enable HDR? It goes through an HDR-testing phase in which the screen goes blank, and I keep getting this message: "Your TV has been returned to its previous settings. Try adjusting your color to DEEP setting or adjusting your TV settings according to manufacturer."

Basically its saying my 930C doesn't support HDR which I know it does, right?

BTW I don't have the latest firmware installed on my 930C, does that have anything to do with it? Do I need to update the firmware before I even try anything?
XciteMe is offline  
post #13576 of 14302 Old 09-28-2017, 04:27 PM
Member
 
Join Date: Jan 2016
Posts: 41
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 41 Post(s)
Liked: 10
Quote:
Originally Posted by XciteMe View Post
Please help me guys!

I just bought & installed a new Apple TV 4K with my X390C.

Everything is hooked up to a Yamaha RX-A2050 receiver via ARC. Receiver is a 2015 model that supports HDMI 2.0 and 4k HDR pass-thru according to Yamaha, so...

Tell me why when I booted up the new Apple TV, it won't let me enable HDR? It goes through an HDR-testing phase in which the screen goes blank, and I keep getting this message: "Your TV has been returned to its previous settings. Try adjusting your color to DEEP setting or adjusting your TV settings according to manufacturer."

Basically its saying my 930C doesn't support HDR which I know it does, right?

BTW I don't have the latest firmware installed on my 930C, does that have anything to do with it? Do I need to update the firmware before I even try anything?
Did you turn on Enhanced mode for the HDMI port your AVR is connected to?
gutter24 is offline  
post #13577 of 14302 Old 09-28-2017, 08:36 PM
Newbie
 
Join Date: Aug 2016
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 0
Quote:
Originally Posted by gutter24 View Post
Did you turn on Enhanced mode for the HDMI port your AVR is connected to?
Er, no. Where do I do that? on the TV or the receiver? Pls help
XciteMe is offline  
post #13578 of 14302 Old 09-29-2017, 12:20 AM
Advanced Member
 
Join Date: Nov 2015
Posts: 625
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 396 Post(s)
Liked: 112
Quote:
Originally Posted by XciteMe View Post
Er, no. Where do I do that? on the TV or the receiver? Pls help
Go to Settings on the Home Screen

>Picture and Display > Dynamic Range > Auto

then...

>External Inputs >HDMI Signal Format > select desired HDMi input and change to "ENHANCED"

TV will reboot.
daimler2015 is offline  
post #13579 of 14302 Old 09-29-2017, 07:06 AM
AVS Forum Special Member
 
CCsoftball7's Avatar
 
Join Date: Dec 2002
Location: Cary, NC
Posts: 3,693
Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 1692 Post(s)
Liked: 1286
Quote:
Originally Posted by XciteMe View Post
Er, no. Where do I do that? on the TV or the receiver? Pls help
In addition to the answer you received above, there are several helpful links in my signature (they may not look like links, but they are)

Sony XBR75X940C & XBR65A1E Samsung UBD K8500
My Recommended Daytime Settings Apps(Video), My Recommended Daytime Settings Apps, My non-HDR and HDR Settings, Setting HDMI to show no overscan
Sony XBR75X940C, Samsung UBD K8500, Roku Ultra, DirecTV RVU and C61K, Chromecast Ultra
CCsoftball7 is offline  
post #13580 of 14302 Old 09-29-2017, 02:28 PM
Member
 
Join Date: Dec 2004
Location: Honolulu
Posts: 191
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 51
xciteme- also ck out the advanced setup in the yamaha avr to be sure its set to "mode 1"- comes set to mode 2-
bgrpph is offline  
post #13581 of 14302 Old 09-30-2017, 03:36 PM
 
Join Date: May 2016
Posts: 106
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 47 Post(s)
Liked: 19
Quote:
Originally Posted by pee View Post
Do you know if he was able to get them out?
Mine aren’t bugs. Called SquareTrade today.
Pupator is offline  
post #13582 of 14302 Old 10-01-2017, 11:09 AM
AVS Forum Special Member
 
bobbino421's Avatar
 
Join Date: Nov 2016
Location: New York City
Posts: 1,804
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1154 Post(s)
Liked: 726
Anyone have the New Apple 4KTV? I'm try to find the correct PQ settings for 4K HDR for our particular models. Not familiar with how frame rates work? I've tried 24, 30, and 60 on this device. Just looking for some consistency. I wish it had an auto setting also for native content.

Sony 55 A9F
Panasonic DP-UB820
Sony UBP-X700
Samsung HW-K950 Dolby Atmos sound bar
bobbino421 is offline  
post #13583 of 14302 Old 10-02-2017, 06:09 AM
AVS Forum Special Member
 
CCsoftball7's Avatar
 
Join Date: Dec 2002
Location: Cary, NC
Posts: 3,693
Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 1692 Post(s)
Liked: 1286
Quote:
Originally Posted by bobbino421 View Post
Anyone have the New Apple 4KTV? I'm try to find the correct PQ settings for 4K HDR for our particular models. Not familiar with how frame rates work? I've tried 24, 30, and 60 on this device. Just looking for some consistency. I wish it had an auto setting also for native content.
I have one and use the default on the device: 4K/HDR/60 fps

You can always switch to 1080p if you watch an HD movie. I too wish there was a native mode...my only complaint about it.

Sony XBR75X940C & XBR65A1E Samsung UBD K8500
My Recommended Daytime Settings Apps(Video), My Recommended Daytime Settings Apps, My non-HDR and HDR Settings, Setting HDMI to show no overscan
Sony XBR75X940C, Samsung UBD K8500, Roku Ultra, DirecTV RVU and C61K, Chromecast Ultra
CCsoftball7 is offline  
post #13584 of 14302 Old 10-02-2017, 09:49 AM
AVS Forum Special Member
 
bobbino421's Avatar
 
Join Date: Nov 2016
Location: New York City
Posts: 1,804
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1154 Post(s)
Liked: 726
Quote:
Originally Posted by CCsoftball7 View Post
Quote:
Originally Posted by bobbino421 View Post
Anyone have the New Apple 4KTV? I'm try to find the correct PQ settings for 4K HDR for our particular models. Not familiar with how frame rates work? I've tried 24, 30, and 60 on this device. Just looking for some consistency. I wish it had an auto setting also for native content.
I have one and use the default on the device: 4K/HDR/60 fps

You can always switch to 1080p if you watch an HD movie. I too wish there was a native mode...my only complaint about it.
[QUOTE=CCsoftball7;54890636]
Quote:
Originally Posted by bobbino421 View Post
Anyone have the New Apple 4KTV? I'm try to find the correct PQ settings for 4K HDR for our particular models. Not familiar with how frame rates work? I've tried 24, 30, and 60 on this device. Just looking for some consistency. I wish it had an auto setting also for native content.
Ok thanks I already decided to leave it at 4K HDR 60 and I'm only gonna really use for 4K UHD iTunes movies I had redeemed and maybe rent a few titles. The only movie I have seen so far in its entirety is Prometheus but I don't have the UHD disc to compare, but I do have alien covenant on UHD disc and iTunes version! On disc it was top notch PQ when I get around to it I'll rewatch to compare! I still like discs over streaming still.
CCsoftball7 likes this.

Sony 55 A9F
Panasonic DP-UB820
Sony UBP-X700
Samsung HW-K950 Dolby Atmos sound bar
bobbino421 is offline  
post #13585 of 14302 Old 10-02-2017, 07:27 PM
Newbie
 
ksaifullah's Avatar
 
Join Date: Sep 2005
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 10
Quote:
Originally Posted by WillieC View Post
I just connected my Logitech Harmony Hub directly to the IR input port on the back of the 940C. It works great!

This means I no longer have to use an IR blaster in order to control my TV, and the hardwired connection is much more reliable.

I used a 3.5 mm stereo audio cable connected to the "IR In" on back of the TV. For the Harmony Hub, I used a 3.5 mm stereo to 2.5 mm mono adapter. In the TV settings I left the "RS232C control" setting set to off.
I tried to do this but no success on My 930C. I must be doing something wrong.

Sony XBR-65X930C
Samsung UN65H7150
Panasonic TC-P50ST50
ksaifullah is offline  
post #13586 of 14302 Old 10-03-2017, 12:06 PM
Senior Member
 
jsessler's Avatar
 
Join Date: Oct 2001
Location: Southern California
Posts: 217
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 128 Post(s)
Liked: 153
930C had a software update pending when I got home. It had already been on the most current release that had been posted online for some time now. Anyone else get an update notice? It's in the middle of doing it so I don't know what the version is yet.

It's now at PKG3.915.0139NAB

Well, it's still Android 6, so it wasn't the upgrade to Nougat.

Security patch level is now Aug 1st 2017, version is 6.0.1, Build SVP4KDTV15_UC-user 6.0.1 MMB29V.S41 3.915
iatacs19 likes this.

Last edited by jsessler; 10-03-2017 at 12:58 PM.
jsessler is offline  
post #13587 of 14302 Old 10-03-2017, 05:28 PM
Senior Member
 
jsessler's Avatar
 
Join Date: Oct 2001
Location: Southern California
Posts: 217
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 128 Post(s)
Liked: 153
Quote:
Originally Posted by jsessler View Post
930C had a software update pending when I got home. It had already been on the most current release that had been posted online for some time now. Anyone else get an update notice? It's in the middle of doing it so I don't know what the version is yet.

It's now at PKG3.915.0139NAB

Well, it's still Android 6, so it wasn't the upgrade to Nougat.

Security patch level is now Aug 1st 2017, version is 6.0.1, Build SVP4KDTV15_UC-user 6.0.1 MMB29V.S41 3.915
I did notice one change - if you've set the auto-power off, the volume buttons now reset the counter. In the previous releases, you had to press something other than the volume buttons.
waja likes this.
jsessler is offline  
post #13588 of 14302 Old 10-05-2017, 05:32 PM
 
Join Date: May 2016
Posts: 106
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 47 Post(s)
Liked: 19
Well, here’s the deal. Kudos to SquareTrade for how quickly and easily they’ve offered a replacement. But here’s what they’re offering.


Last edited by Pupator; 10-05-2017 at 05:43 PM.
Pupator is offline  
post #13589 of 14302 Old 10-05-2017, 06:03 PM
Advanced Member
 
Join Date: Nov 2015
Posts: 625
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 396 Post(s)
Liked: 112
Quote:
Originally Posted by Pupator View Post
Well, here’s the deal. Kudos to SquareTrade for how quickly and easily they’ve offered a replacement. But here’s what they’re offering.

Are they kidding??

Why aren't they offering a 940E???
daimler2015 is offline  
post #13590 of 14302 Old 10-05-2017, 06:14 PM
 
Join Date: May 2016
Posts: 106
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 47 Post(s)
Liked: 19
Quote:
Originally Posted by daimler2015 View Post
Are they kidding??

Why aren't they offering a 940E???
So I’m obviously going to ask for a Z9D, and they’re obviously going to say no. Looking at these reviews, and caring about HDR movies AND sports, I’m not sure if I push for the 940E or accept the 900E.

Pupator is offline  
Sponsored Links
Advertisement
 
Reply LCD Flat Panel Displays

Tags
940C , hdr , Sony , X930C , X940C

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off