**Official** 2015 Sony X940C Only Owners Thread - Page 11 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 82Likes
Reply
 
Thread Tools
post #301 of 342 Old 05-11-2016, 08:36 AM
Advanced Member
 
NJChris's Avatar
 
Join Date: May 2001
Location: Riverdale, NJ USA
Posts: 535
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 35 Post(s)
Liked: 37
I got an email yesterday from Ultra 4k sony thing and it says about getting up to $120 in 4k movies for their app. I finished my registration on it yesterday. Wonder if I'll get an email with that promotion.


I don't think that one had any model limitations listed.

Xiaomi Wemax One Projector
NJChris is offline  
Sponsored Links
Advertisement
 
post #302 of 342 Old 05-11-2016, 08:52 AM
AVS Forum Special Member
 
iatacs19's Avatar
 
Join Date: Sep 2005
Location: DC Metro
Posts: 1,650
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 282 Post(s)
Liked: 173
Quote:
Originally Posted by NJChris View Post
I got an email yesterday from Ultra 4k sony thing and it says about getting up to $120 in 4k movies for their app. I finished my registration on it yesterday. Wonder if I'll get an email with that promotion.


I don't think that one had any model limitations listed.
This sounds promising. Did you create an account using the TV app?

-

OLED65C9PUA, AVR-X4200W, NVIDIA SHIELD TV, SVS SB12-NSD, RC-52 II, RB-41 II, KEF E301, BDI 8179
iatacs19 is offline  
post #303 of 342 Old 05-11-2016, 11:12 AM
Advanced Member
 
NJChris's Avatar
 
Join Date: May 2001
Location: Riverdale, NJ USA
Posts: 535
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 35 Post(s)
Liked: 37
Quote:
Originally Posted by iatacs19 View Post
This sounds promising. Did you create an account using the TV app?
I think the app told me to register on their site first.
Still no email with any of the free stuff. I'll prob try their online chat when I have time.


Edit: My bad.. the email did list the models in tiny print. Only the D models.

Xiaomi Wemax One Projector

Last edited by NJChris; 05-11-2016 at 03:12 PM.
NJChris is offline  
Sponsored Links
Advertisement
 
post #304 of 342 Old 05-11-2016, 03:42 PM
Senior Member
 
drock0221's Avatar
 
Join Date: Mar 2016
Location: Charlotte, NC
Posts: 267
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 197 Post(s)
Liked: 41
Here are the settings I am using. I like a little more pop in my picture (like most Samsung AMOLED screens on phone).

SONY XBR75X940C

Picture Adjustments
Picture Mode: Cinema Pro
Auto Picture Mode: Off
Brightness: 40
Color: 60
Light Sensor: Off

Advanced Settings
Brightness
Brightness: 40
Contrast: 90
Gamma: -2
Black Level: 50
Black Adjust: Off
Adv. Contrast Enhancer: Off
Auto Local Dimming: Medium
Extended Dynamic Range: Low

Color
Color: 60
Hue: 0
Color Temp: Cool
Color Space: Auto
Live Color: Medium

Advanced Color Temperature
Basic
R-Gain: Max
G-Gain: Max
B-Gain: Max
R-Bias: 0
G-Bias: 0
B-Bias: 0
Multipoint (10P)
Color Gamma Adjustment Points: 1
R-Offset: 0
G-Offset: 0
B-Offset: 0

Clarity
Sharpness: 28
Reality Creation: Off
Mastered in 4K: Off
Random Noise: Off (Auto or Low for sports)
Digital Noise: Off (Auto or High for sports)

Motion
Motionflow: Smooth
Cinemotion: Off


Let me know what everyone thinks. Viper32, feel free to add these to your list if you want.
bruceames likes this.
drock0221 is offline  
post #305 of 342 Old 05-11-2016, 06:46 PM
Member
 
EricQ's Avatar
 
Join Date: Sep 2003
Location: Portland, OR
Posts: 134
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 35 Post(s)
Liked: 22
Ordered a 940C from Chris at CP. Will probably be here next week. What wall mounts are you guys using? I'm gonna have to mount it due to the bottom portion of the screen not clearing my center channel.

"Guns at dawn, swords at dusk."
EricQ is offline  
post #306 of 342 Old 05-12-2016, 12:48 PM - Thread Starter
AVS Forum Special Member
 
Viper32's Avatar
 
Join Date: Mar 2003
Posts: 2,211
Mentioned: 10 Post(s)
Tagged: 1 Thread(s)
Quoted: 1341 Post(s)
Liked: 1029
Quote:
Originally Posted by iatacs19 View Post
On my 930C it only gave me free Playstation Now for 30 days after I gave them my email. Worthless to me. :/


Edit:


It seems like it's only for the 2016 D-series:


http://www.amazon.com/gp/feature.htm...cId=1002995671
Yeah the Playstation stuff is no good to me either...
CCsoftball7 likes this.

Current Sets: Sony XBR65A9F Master Series, Sony XBR75X940C, Sony XBR75X940D, Samsung UN65KS9800, TCL 65R617
Previous Sets: Samsung Q9FN, Sony XBR65X930D, XBR65X900B, XBR49X830C, Samsung KS8000, KU6500, UN55KS8500, UN49JS8500, JS9000, JU7090, JU6500, JU6400, HU9000, HU7250, PN64F8500, Vizio P65, LG 65EF9500, LG 55EC9300, Hisense 55H8C, TCL P-Series (55P607)
Viper32 is offline  
post #307 of 342 Old 05-12-2016, 08:03 PM
Senior Member
 
drock0221's Avatar
 
Join Date: Mar 2016
Location: Charlotte, NC
Posts: 267
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 197 Post(s)
Liked: 41
Well my 940C just broke today. Not very happy. Never had a TV break and only had this one for one month. Now I get to deal with Sony. I hope the warranty is covered even though I bought from Cleveland Plasma.
drock0221 is offline  
post #308 of 342 Old 05-13-2016, 03:10 AM - Thread Starter
AVS Forum Special Member
 
Viper32's Avatar
 
Join Date: Mar 2003
Posts: 2,211
Mentioned: 10 Post(s)
Tagged: 1 Thread(s)
Quoted: 1341 Post(s)
Liked: 1029
Quote:
Originally Posted by drock0221 View Post
Well my 940C just broke today. Not very happy. Never had a TV break and only had this one for one month. Now I get to deal with Sony. I hope the warranty is covered even though I bought from Cleveland Plasma.
What happened to it?

Viper32

Current Sets: Sony XBR65A9F Master Series, Sony XBR75X940C, Sony XBR75X940D, Samsung UN65KS9800, TCL 65R617
Previous Sets: Samsung Q9FN, Sony XBR65X930D, XBR65X900B, XBR49X830C, Samsung KS8000, KU6500, UN55KS8500, UN49JS8500, JS9000, JU7090, JU6500, JU6400, HU9000, HU7250, PN64F8500, Vizio P65, LG 65EF9500, LG 55EC9300, Hisense 55H8C, TCL P-Series (55P607)
Viper32 is offline  
post #309 of 342 Old 05-13-2016, 06:19 AM
Senior Member
 
drock0221's Avatar
 
Join Date: Mar 2016
Location: Charlotte, NC
Posts: 267
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 197 Post(s)
Liked: 41
Quote:
Originally Posted by Viper32 View Post
Quote:
Originally Posted by drock0221 View Post
Well my 940C just broke today. Not very happy. Never had a TV break and only had this one for one month. Now I get to deal with Sony. I hope the warranty is covered even though I bought from Cleveland Plasma.
What happened to it?

Viper32
Was playing video games on it and then all of a sudden black screen and blinking red light. I'm good with electronics so knew that wasn't a good sign. I did all the steps I thought and still blank screen with a red light. Called Sony and they said the LED driver is bad and ordering a part. I'm not a big fan of having electronics that break early on and need repairs. Usually means everything else will just keep going bad so my only wish is that it happens enough within one year that Sony will eventually just replace the tv. In my opinion, they should be doing that anyways when you buy a once price tv of $8,000.
drock0221 is offline  
post #310 of 342 Old 05-13-2016, 06:35 AM
AVS Forum Special Member
 
jbug's Avatar
 
Join Date: Feb 2004
Location: Chicago
Posts: 4,037
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 275 Post(s)
Liked: 134
Quote:
Originally Posted by drock0221 View Post
Was playing video games on it and then all of a sudden black screen and blinking red light. I'm good with electronics so knew that wasn't a good sign. I did all the steps I thought and still blank screen with a red light. Called Sony and they said the LED driver is bad and ordering a part. I'm not a big fan of having electronics that break early on and need repairs. Usually means everything else will just keep going bad so my only wish is that it happens enough within one year that Sony will eventually just replace the tv. In my opinion, they should be doing that anyways when you buy a once price tv of $8,000.
Like Consumer Report always says, "If a product breaks it will normally do so sooner than later." On the bright side your set clunked during the warranty period. Even if you had purchased it elsewhere your 30 days would have been up and you would have to deal direct with Sony is that correct?
jbug is offline  
post #311 of 342 Old 05-13-2016, 01:23 PM
AVS Forum Special Member
 
Join Date: Jan 2015
Posts: 2,788
Mentioned: 13 Post(s)
Tagged: 0 Thread(s)
Quoted: 1782 Post(s)
Liked: 1476
I'm not sure if there's any evidence showing that one problem early on means something is more likely to develop more problems later. My last truck came from the factory with a bad fuel level sender that I had to have replaced the first week, but it was perfect after that. Sometimes a bad part just makes its way through QC at the manufacturer or a supplier.

That being said, with a TV this pricey, and the SquareTrade warranty at Costco so cheap, it seems like a no-brainier to buy it. I plan on getting one once mine arrives.
TuteTibiImperes is offline  
post #312 of 342 Old 05-13-2016, 01:46 PM
Senior Member
 
drock0221's Avatar
 
Join Date: Mar 2016
Location: Charlotte, NC
Posts: 267
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 197 Post(s)
Liked: 41
Quote:
Originally Posted by TuteTibiImperes View Post
I'm not sure if there's any evidence showing that one problem early on means something is more likely to develop more problems later. My last truck came from the factory with a bad fuel level sender that I had to have replaced the first week, but it was perfect after that. Sometimes a bad part just makes its way through QC at the manufacturer or a supplier.

That being said, with a TV this pricey, and the SquareTrade warranty at Costco so cheap, it seems like a no-brainier to buy it. I plan on getting one once mine arrives.
Yeah I posted on here after it happened so I was pretty pissed off ha. I used to build computers and replace parts. I know one part can just be bad and the rest will be fine for a while. I guess I just don't like knowing how expensive this tv is and something already going bad this quick. I do have the 5 year square trade warranty. Sony was good about it. Ordered a part and 3-5 days for repair place to call me and schedule an appointment so hopefully they can get out here by end of next week.
drock0221 is offline  
post #313 of 342 Old 05-15-2016, 10:06 AM
Senior Member
 
Todeseng3l's Avatar
 
Join Date: Sep 2010
Posts: 334
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 299 Post(s)
Liked: 499
Quote:
Originally Posted by EricQ View Post
Ordered a 940C from Chris at CP. Will probably be here next week. What wall mounts are you guys using? I'm gonna have to mount it due to the bottom portion of the screen not clearing my center channel.
I used the Sanus VMPL3-B Tilt Wall Mount, it worked perfectly and is reasonably priced. Thing is solid as a rock, I weigh 220lbs and was hanging from it to test it before putting my 940c on it.
Todeseng3l is offline  
post #314 of 342 Old 05-15-2016, 10:17 AM
Senior Member
 
Todeseng3l's Avatar
 
Join Date: Sep 2010
Posts: 334
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 299 Post(s)
Liked: 499
Hey All,

I posted this in the 930/940c owners thread and figured I would try asking here as well to get as much input as possible, sorry if you saw it already.

Maybe I am being overly critical of my set, however, I feel like the blooming is a bit excessive on my x940c. I don't recall my HX929 being this bad. I am using the calibrated settings from the shootout for non HDR video so local dimming is set to medium and brightness is set to 8. I apologize for the image quality but this is the best my phone could capture in low-light.

The first image is of the pause screen from a game I was playing against a black background, the entire left side of the screen is illuminated that the menu is on.

Watching HDR movies makes it even worst as the brightness is set to 100. I was watching Sicario tonight and the blooming was so bad in the dark scenes I was paying more attention to it than the movie.

Do you see the same level of blooming on your 940c?

I appreciate your response,

Tony
Attached Thumbnails
Click image for larger version

Name:	20160514_230704.jpg
Views:	153
Size:	71.1 KB
ID:	1440266   Click image for larger version

Name:	20160514_231641.jpg
Views:	152
Size:	108.4 KB
ID:	1440282  
Todeseng3l is offline  
post #315 of 342 Old 05-15-2016, 12:07 PM
Member
 
EricQ's Avatar
 
Join Date: Sep 2003
Location: Portland, OR
Posts: 134
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 35 Post(s)
Liked: 22
Quote:
Originally Posted by Todeseng3l View Post
I used the Sanus VMPL3-B Tilt Wall Mount, it worked perfectly and is reasonably priced. Thing is solid as a rock, I weigh 220lbs and was hanging from it to test it before putting my 940c on it.
Thanks for the tip!

"Guns at dawn, swords at dusk."
EricQ is offline  
post #316 of 342 Old 05-18-2016, 03:22 AM
Member
 
Jimmyballpeen's Avatar
 
Join Date: Aug 2006
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 10
I just Ordered a 940C from Chris at Cleveland Plasma and it should be arriving next week. I plan on using the stand from my old Samsung 71 DLP and it measures 65" wide. Can someone tell me the width of the legs setup on the outside placement and the depth. If I have to use the inside placement can someone suggest a tip over or earthquake strap. Besides taking it out of the box and checking for cracks or damage and plugging it in, what was the first thing you did when you got your set?
Jimmyballpeen is offline  
post #317 of 342 Old 05-18-2016, 03:32 AM
Member
 
Jimmyballpeen's Avatar
 
Join Date: Aug 2006
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 10
I have 2 Labs that is another reason why I might want hold down straps. They get crazy sometimes when I don't take them out.
Attached Thumbnails
Click image for larger version

Name:	image_1463567317204.jpg
Views:	172
Size:	102.9 KB
ID:	1445266  
Jimmyballpeen is offline  
post #318 of 342 Old 05-23-2016, 11:13 AM
Member
 
Stephen Terry's Avatar
 
Join Date: Sep 2001
Location: Littleton, Co , USA
Posts: 132
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 74 Post(s)
Liked: 41
Is there a Fandango app for the 940C?
If so, how do I find t and access it.

Thanks
Stephen Terry is offline  
post #319 of 342 Old 05-28-2016, 04:43 AM
AVS Forum Special Member
 
mt14942's Avatar
 
Join Date: May 2007
Location: Pembroke Pines, Florida
Posts: 2,261
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 751 Post(s)
Liked: 225
Has anybody had a problem with the 2nd small touch screen remote that came with this TV? I can't seem to get it to work. I did originally successfully pair it and get it to work, but it has now stopped working I tried to pair it again and I also rebooted the TV and tried to pair it again still no luck. Obviously I also put in new batteries to make sure it wasn't the batteries.

Sony 75xZ9D
Sony UBP-X800 4K player
Oppo UDP-205 4k player
Classe SSP-800 pre/pro
Parasound Halo 5 channel Amp
mt14942 is offline  
post #320 of 342 Old 06-04-2016, 04:57 AM - Thread Starter
AVS Forum Special Member
 
Viper32's Avatar
 
Join Date: Mar 2003
Posts: 2,211
Mentioned: 10 Post(s)
Tagged: 1 Thread(s)
Quoted: 1341 Post(s)
Liked: 1029
Sorry, I never use mine. I will check it later.

Sent from my SM-N920V using Tapatalk
CCsoftball7 likes this.

Current Sets: Sony XBR65A9F Master Series, Sony XBR75X940C, Sony XBR75X940D, Samsung UN65KS9800, TCL 65R617
Previous Sets: Samsung Q9FN, Sony XBR65X930D, XBR65X900B, XBR49X830C, Samsung KS8000, KU6500, UN55KS8500, UN49JS8500, JS9000, JU7090, JU6500, JU6400, HU9000, HU7250, PN64F8500, Vizio P65, LG 65EF9500, LG 55EC9300, Hisense 55H8C, TCL P-Series (55P607)
Viper32 is offline  
post #321 of 342 Old 06-04-2016, 05:43 AM
AVS Forum Special Member
 
mt14942's Avatar
 
Join Date: May 2007
Location: Pembroke Pines, Florida
Posts: 2,261
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 751 Post(s)
Liked: 225
Quote:
Originally Posted by Viper32 View Post
Sorry, I never use mine. I will check it later.

Sent from my SM-N920V using Tapatalk
Thanks, not a big deal since I would much rather use the larger remote, which I also use to control most of the functions for the Samsung 4K player. I will probably call Sony Monday about it. I also wanted to ask them about Dynamic HDR vs. Static HDR to see if we would be getting a firmware update for that. I was also wondering if both the 4K player and the TV need it in order to get Dynamic HDR?

Sony 75xZ9D
Sony UBP-X800 4K player
Oppo UDP-205 4k player
Classe SSP-800 pre/pro
Parasound Halo 5 channel Amp

Last edited by mt14942; 06-04-2016 at 10:01 AM.
mt14942 is offline  
post #322 of 342 Old 06-04-2016, 07:47 AM
AVS Forum Special Member
 
CCsoftball7's Avatar
 
Join Date: Dec 2002
Location: Cary, NC
Posts: 3,695
Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 1693 Post(s)
Liked: 1286
Quote:
Originally Posted by mt14942 View Post
Has anybody had a problem with the 2nd small touch screen remote that came with this TV? I can't seem to get it to work. I did originally successfully pair it and get it to work, but it has now stopped working I tried to pair it again and I also rebooted the TV and tried to pair it again still no luck. Obviously I also put in new batteries to make sure it wasn't the batteries.
I just tried it and it works fine.

Quote:
Originally Posted by Viper32 View Post
Sorry, I never use mine. I will check it later.
^^^What @Viper32 said. I never use mine either.

Sony XBR75X940C & XBR65A1E Samsung UBD K8500
My Recommended Daytime Settings Apps(Video), My Recommended Daytime Settings Apps, My non-HDR and HDR Settings, Setting HDMI to show no overscan
Sony XBR75X940C, Samsung UBD K8500, Roku Ultra, DirecTV RVU and C61K, Chromecast Ultra
CCsoftball7 is offline  
post #323 of 342 Old 06-04-2016, 10:05 AM
AVS Forum Special Member
 
mt14942's Avatar
 
Join Date: May 2007
Location: Pembroke Pines, Florida
Posts: 2,261
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 751 Post(s)
Liked: 225
Quote:
Originally Posted by CCsoftball7 View Post
I just tried it and it works fine.



^^^What @Viper32 said. I never use mine either.

Thanks gents, sorry for all the spacing errors in my post. This is what happens when I use Word and than copy and paste. I imagine most people use a Universal remote which I really need to do.

Sony 75xZ9D
Sony UBP-X800 4K player
Oppo UDP-205 4k player
Classe SSP-800 pre/pro
Parasound Halo 5 channel Amp
mt14942 is offline  
post #324 of 342 Old 06-04-2016, 11:11 AM
AVS Forum Special Member
 
CCsoftball7's Avatar
 
Join Date: Dec 2002
Location: Cary, NC
Posts: 3,695
Mentioned: 18 Post(s)
Tagged: 0 Thread(s)
Quoted: 1693 Post(s)
Liked: 1286
Quote:
Originally Posted by mt14942 View Post
Thanks gents, sorry for all the spacing errors in my post. This is what happens when I use Word and than copy and paste. I imagine most people use a Universal remote which I really need to do.
I actually use the regular Sony remote for pretty much everything.
iatacs19 likes this.

Sony XBR75X940C & XBR65A1E Samsung UBD K8500
My Recommended Daytime Settings Apps(Video), My Recommended Daytime Settings Apps, My non-HDR and HDR Settings, Setting HDMI to show no overscan
Sony XBR75X940C, Samsung UBD K8500, Roku Ultra, DirecTV RVU and C61K, Chromecast Ultra
CCsoftball7 is offline  
post #325 of 342 Old 06-04-2016, 04:04 PM - Thread Starter
AVS Forum Special Member
 
Viper32's Avatar
 
Join Date: Mar 2003
Posts: 2,211
Mentioned: 10 Post(s)
Tagged: 1 Thread(s)
Quoted: 1341 Post(s)
Liked: 1029
Quote:
Originally Posted by CCsoftball7 View Post
I actually use the regular Sony remote for pretty much everything.
Yeah me also. That other remote is not for me. ...

Sent from my SM-N920V using Tapatalk

Current Sets: Sony XBR65A9F Master Series, Sony XBR75X940C, Sony XBR75X940D, Samsung UN65KS9800, TCL 65R617
Previous Sets: Samsung Q9FN, Sony XBR65X930D, XBR65X900B, XBR49X830C, Samsung KS8000, KU6500, UN55KS8500, UN49JS8500, JS9000, JU7090, JU6500, JU6400, HU9000, HU7250, PN64F8500, Vizio P65, LG 65EF9500, LG 55EC9300, Hisense 55H8C, TCL P-Series (55P607)
Viper32 is offline  
post #326 of 342 Old 06-05-2016, 10:34 AM
AVS Forum Addicted Member
Industry Insider
 
Cleveland Plasma's Avatar
 
Join Date: Jun 2005
Location: Cleveland, Ohio
Posts: 24,206
Mentioned: 80 Post(s)
Tagged: 1 Thread(s)
Quoted: 6510 Post(s)
Liked: 6482
Quote:
Originally Posted by Jimmyballpeen View Post
I have 2 Labs that is another reason why I might want hold down straps. They get crazy sometimes when I don't take them out.
Accidents happen, better to be safe then sorry that is for sure.....
Cleveland Plasma is offline  
post #327 of 342 Old 06-22-2016, 04:39 PM
Senior Member
 
ultrasilent's Avatar
 
Join Date: Aug 2010
Posts: 423
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 267 Post(s)
Liked: 20
Do anybody use UPS for 940C? My plan is to buy this item:
http://powerquality.eaton.com/EL800USBIEC.aspx?CX=6

Is it enough to have 500 W UPS?
ultrasilent is offline  
post #328 of 342 Old 06-22-2016, 07:22 PM
Advanced Member
 
loudog2's Avatar
 
Join Date: Mar 2006
Location: Suburbs of Chicago
Posts: 512
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 266 Post(s)
Liked: 199
Quote:
Originally Posted by ultrasilent View Post
Do anybody use UPS for 940C? My plan is to buy this item:
http://powerquality.eaton.com/EL800USBIEC.aspx?CX=6

Is it enough to have 500 W UPS?
I have an apc j25 and j35 in my system. Then a trip lite smart1500 for the bedroom and one for the computer/router/modem. Let's me watch tv and surf the web during power outages.

Sony 940C*Sony HX909*Samsung K8500*Yamaha 3050*klipsch front RP-280's*rear RF-3's*center RP-450C*Sides RP-280's*front heights RP-140's*overhead 5650cii's*SVS-PB2000x4*emotiva XPA-5*Yamaha YSP-1600 sound bar*Sony HT-CT370 sound bar

Last edited by loudog2; 06-22-2016 at 07:26 PM.
loudog2 is offline  
post #329 of 342 Old 06-23-2016, 02:07 AM
Senior Member
 
ultrasilent's Avatar
 
Join Date: Aug 2010
Posts: 423
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 267 Post(s)
Liked: 20
what is minimum power requirement for 940C regarding UPS rating?
500W is enough?
ultrasilent is offline  
post #330 of 342 Old 06-24-2016, 07:36 AM
Newbie
 
Join Date: Jun 2016
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 0
Has it been confirmed if the update to allow PC connection with 4:4:4 chroma at 4K60p is released? Does this mean that the X940C's HDMI port is indeed capable of full 18gbps speed?
htfreak70 is offline  
Sponsored Links
Advertisement
 
Reply LCD Flat Panel Displays

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off