2019 Sony XBR X950G Owners Thread (No Price Talk) - Page 188 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 2416Likes
Reply
 
Thread Tools
post #5611 of 6760 Old 05-19-2020, 06:36 PM
Member
 
Join Date: May 2020
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Liked: 10
Just did the 950h update on my 65 950g and I love it so far! Wasn’t really excited about Factory resetting for the Bluetooth issue but wasn’t a big deal. Just screenshotted all my settings lol. Def love the new settings interface. Very interactive. Plan to check my arc and other things. To be honest I have ember had a issue with my arc or Dolby Atmos. I have the Sl8YG LG soundbar with the two rear surrounds. 5.1.2 setup.
Techguy361 is offline  
Sponsored Links
Advertisement
 
post #5612 of 6760 Old 05-19-2020, 06:50 PM
Member
 
Join Date: May 2020
Posts: 69
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 56 Post(s)
Liked: 18
European update for the XG95 = 1.32GB

US update for the XG95 = 1.19GB

So i'm afraid that there is indeed a difference and us Europeans have to wait for the European update for the XH95..
Hoger Mohammad is offline  
post #5613 of 6760 Old 05-19-2020, 07:28 PM
Newbie
 
Mehul Trivedi's Avatar
 
Join Date: Nov 2008
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 10
Help!

Quote:
Originally Posted by Kai Winters View Post
I was using the TV's built in apps, Netflix, Amazon Prime and YouTube only.
I use eARC from the TV to my Marantz SR5014 which is also eARC via HDMI.
When using these apps the audio would come from the TV speakers only and when using the TV's remote to change to HT audio it would not. Sometimes if I unplugged the TV and started it up again I could get audio from my HT audio but if I shut the system off...at the end of the day...and turned it on again it would revert to TV audio only.
It became just a pain in the ass to use and I tried everything, shy of not using eARC/ARC, which is my preference.
Thus I bought a Roku Streaming Stick + which I connected to a HDMI port on my AVR. Now I get all my audio through my HT system's speakers without a problem.
It's not a big deal but a bit of a nuisance considering Sony adds the cost of this to the TV. I did call Sony several times and they weren't able to do anything even when taking remote control of the via and I got tired to trying.
Overall I'm very happy with the TV and love the image.

I've not yet decided to install the "H" firmware and I honestly may not bother unless there are dramatic image improvements.
But I do read, with great interest, of those that do and what their experiences are.



Good evening, I am so glad I stumbled across your post and hope you can take a moment to help me!
I have the 75x950g and just bought the marantz sr5014 over the weekend. I couldn't get ANY video or audio from the Earc on the receiver if i plugged it into the TV ARC.....so i returned the receiver thinking had a bad unit, swapped it for another new 5014.....and same thing. I get nothing out of it . I updated the marantz, turned on ARC, turned on enhanced 4k and still nothing. Any ideas????
Mehul Trivedi is offline  
Sponsored Links
Advertisement
 
post #5614 of 6760 Old 05-19-2020, 08:04 PM
Advanced Member
 
Kai Winters's Avatar
 
Join Date: May 2006
Location: Northern NY
Posts: 856
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 233 Post(s)
Liked: 316
Quote:
Originally Posted by Mehul Trivedi View Post
Good evening, I am so glad I stumbled across your post and hope you can take a moment to help me!
I have the 75x950g and just bought the marantz sr5014 over the weekend. I couldn't get ANY video or audio from the Earc on the receiver if i plugged it into the TV ARC.....so i returned the receiver thinking had a bad unit, swapped it for another new 5014.....and same thing. I get nothing out of it . I updated the marantz, turned on ARC, turned on enhanced 4k and still nothing. Any ideas????
Wow, that sucks !
My setup went easy, no problems at all.
You have a correct HDMI cable? I'd try another cable making sure it is the correct type.
If that's not the problem I'd check the connections...one more time just to be sure you have the TV and AVR connected to the correct ports.
Double check the settings on both TV and AVR just to be sure...use the owner's manuals as a check.
That's all I've got.
Good luck and keep us informed.

TV: Sony XBR 65X950G, AVR: Marantz SR5014, Speakers: front/Paradigm Prestige 15B bookshelf, center/Paradigm Prestige 45C, surround/Paradigm Atom, sub/SVS SB3000, DVD: Panasonic DP-UB820P-K Disk Player, Media Player: Zidoo Z9S & Roku Streaming Stick +, Remote: Logitech Harmony Ultimate Home
Kai Winters is offline  
post #5615 of 6760 Old 05-19-2020, 08:07 PM
Senior Member
 
reechings's Avatar
 
Join Date: Mar 2012
Location: Canada
Posts: 335
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 228 Post(s)
Liked: 44
Is there a setting somewhere to change the auto quality setting on YouTube app? Keeps defaulting to 720p instead of 2160p. Cheers

Sent from my Pixel 2 XL using Tapatalk
reechings is offline  
post #5616 of 6760 Old 05-19-2020, 08:14 PM
AVS Forum Special Member
 
sjm817's Avatar
 
Join Date: Apr 2007
Posts: 1,632
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 925 Post(s)
Liked: 409
Quote:
Originally Posted by Mehul Trivedi View Post
Good evening, I am so glad I stumbled across your post and hope you can take a moment to help me!
I have the 75x950g and just bought the marantz sr5014 over the weekend. I couldn't get ANY video or audio from the Earc on the receiver if i plugged it into the TV ARC.....so i returned the receiver thinking had a bad unit, swapped it for another new 5014.....and same thing. I get nothing out of it . I updated the marantz, turned on ARC, turned on enhanced 4k and still nothing. Any ideas????
Your post is a bit hard to understand. ARC/eARC is for audio only. It does not affect video on the TV. The TV video comes from internal apps. The audio from the TV app is sent to AVR via ARC on the HDMI cable. When you use an appp on the TV does the sound just come out of the TV speakers? No sound? Im using a 75 950G with a Denon 4500 and it works very well. Your setup should as well.
galonzo likes this.
sjm817 is offline  
post #5617 of 6760 Old 05-19-2020, 08:29 PM
Newbie
 
Join Date: Oct 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 0
Quote:
Originally Posted by Hoger Mohammad View Post
European update for the XG95 = 1.32GB

US update for the XG95 = 1.19GB

So i'm afraid that there is indeed a difference and us Europeans have to wait for the European update for the XH95..

Similarly for Asia Pacific model, waiting for the x9500h update
Kyle Wong is offline  
post #5618 of 6760 Old 05-19-2020, 09:05 PM
 
DannyW75's Avatar
 
Join Date: Jul 2011
Posts: 308
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 209 Post(s)
Liked: 177
I am getting regular PMs from people still asking me about installing this on other models, such as the X900F, Z9F, Z9G, or the A9G. Again, no, do not install this firmware on any TV, other than the X950G or X950H. It is a hardware specific firmware, meant to only be installed on the X950G/X950H. If you try to install this firmware on a different TV, it may install. However, your TV will then be identified in the future by auto update as an X950H. Why would anyone want to do this ? This is just a disaster waiting to happen. Anyone who installs this firmware on any other TV than the X950G/X950H will experience major future firmware update issues, or even totally brick their TV. Do not install it on any other TV besides these two. I am not responsible for any damage that anyone does by installing it on any other TV.
sshuttari likes this.
DannyW75 is offline  
post #5619 of 6760 Old 05-19-2020, 10:54 PM
Member
 
Join Date: Jan 2020
Posts: 45
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 33 Post(s)
Liked: 3
An extraordinary discovery #DannyW75 .... I wonder, is there no legal opportunity to combat these perverse practices of producers? Especially in the USA where the legislative system is a special one. Did any of you talk to a lawyer? On the subject, I think they will find extremely quick an way to stop these "unauthorized" updates. Certainly the update for Europe will suffer the necessary changes to make this and future improvements no longer available for free.
In my case, if the software for the 2 products XH and XG does not align (after this unmasking), I will do the following: I will never buy Sony, meaning nothing from Sony and I will recommend to all my acquaintances to never buy Sony products - I suggest you all do the same. I think it hurts Sony the most, after a trial, to have a negative advertisement.
diaconusm is offline  
post #5620 of 6760 Old 05-20-2020, 12:08 AM
wmn
Member
 
wmn's Avatar
 
Join Date: Aug 2004
Location: Canada
Posts: 27
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Liked: 21
Quote:
Originally Posted by DannyW75 View Post
I am getting regular PMs from people still asking me about installing this on other models, such as the X900F, Z9F, Z9G, or the A9G. Again, no, do not install this firmware on any TV, other than the X950G or X950H. It is a hardware specific firmware, meant to only be installed on the X950G/X950H. If you try to install this firmware on a different TV, it may install. However, your TV will then be identified in the future by auto update as an X950H. Why would anyone want to do this ? This is just a disaster waiting to happen. Anyone who installs this firmware on any other TV than the X950G/X950H will experience major future firmware update issues, or even totally brick their TV. Do not install it on any other TV besides these two. I am not responsible for any damage that anyone does by installing it on any other TV.

Latest firmware filename for Z series (late 2018) OLED and LCD and G series (2019) OLED and LCD:
sony_atvotafull_2018_1603626100_naa_auth.zip


From Sony website: (F-series)

This information is for the following models:
  • XBR-65A9F
  • XBR-75Z9F
  • XBR-65Z9F
  • XBR-55A9F

Since Latest G-series firmware (v6.3626) is identical to the Z-series:

From Sony website: (G-series)

This information is for the following models:
  • XBR-75X850G
  • XBR-75X950G
  • XBR-65X850G
  • XBR-65X950G
  • XBR-55X950G
  • XBR-55X850G
  • XBR-77A9G
  • XBR-65A9G
  • XBR-85Z9G
  • XBR-85X850G
  • XBR-85X950G
  • XBR-98Z9G

It is good for OLED, LCD all model, F-series and G-series (v6.3626) and since H-series version (v6.4738) work on G-series, then logically it will work on F-series.


Latest firmware filename for H series (2020) OLED and LCD:
sony_atvotafull_2018_1604738100_naa_auth.zip

Remark the 2018 into the file name...

I think that v6.4738 is just a more recent build of the firmware, and it work on all F-G-H model.


So why SONY do not release a single firmware for Z+G+H series ?


H series is a 2020 product.



It is like the cars insustry, it must feel and look different from the last year model (even if it is still the same generation).


New menu user interface, new bezel, some added function etc.


___


This is just my opinion, and not a certitude...(It was installed on my XBR-65Z9F without any modification, no problem found yet, just do a full reset of the TV to fix the bluetooth problem as mentioned above in this thread).


My XBR-65Z9F is still identified as a XBR-65Z9F so....there is no warranty that H-series firmware (post v6.4738) will still work or be installable on my TV...
galonzo, sshuttari and vas82 like this.

Last edited by wmn; 05-20-2020 at 12:56 AM.
wmn is online now  
post #5621 of 6760 Old 05-20-2020, 03:06 AM
Newbie
 
Join Date: May 2020
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 3
I really don't know what to do for the best. I'm in UK and am going to buy a XH or XG but don't want to get XG and then find I've missed the boat and can't upgrade firmware to XH. Getting an XG would save me £500.

Incidentally Currys the UK biggest electrical retailer are advertising XH (not XG) as 3x2.0b and 1x2.1 so this is either a mistake or they know something we don't.
ratinthekitchen is offline  
post #5622 of 6760 Old 05-20-2020, 03:59 AM
wmn
Member
 
wmn's Avatar
 
Join Date: Aug 2004
Location: Canada
Posts: 27
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Liked: 21
Quote:
Originally Posted by ratinthekitchen View Post
I really don't know what to do for the best. I'm in UK and am going to buy a XH or XG but don't want to get XG and then find I've missed the boat and can't upgrade firmware to XH. Getting an XG would save me £500.

Incidentally Currys the UK biggest electrical retailer are advertising XH (not XG) as 3x2.0b and 1x2.1 so this is either a mistake or they know something we don't.
Depends of the screen size, wide angle feature or not.


According to Vince *HDTVTEST on Youtube* the x950H Wide Angle feature have better contrast ratio than previous series.


galonzo and Dellamorte13 like this.
wmn is online now  
post #5623 of 6760 Old 05-20-2020, 05:01 AM
Newbie
 
Mehul Trivedi's Avatar
 
Join Date: Nov 2008
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Liked: 10
Quote:
Originally Posted by sjm817 View Post
Your post is a bit hard to understand. ARC/eARC is for audio only. It does not affect video on the TV. The TV video comes from internal apps. The audio from the TV app is sent to AVR via ARC on the HDMI cable. When you use an appp on the TV does the sound just come out of the TV speakers? No sound? Im using a 75 950G with a Denon 4500 and it works very well. Your setup should as well.

Sorry for the confusion, I understand the Earc for Audio only. However when I plug the HDMI into the arc port on my receiver and TV I don't even get a picture. The TV says there is no input connected. I've tried different HDMI cords to no effect. I'll try a factory reset when I get home tonight see if that clears up any gremlins.
Mehul Trivedi is offline  
post #5624 of 6760 Old 05-20-2020, 05:07 AM
Member
 
Join Date: May 2020
Posts: 70
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 51 Post(s)
Liked: 1
Quote:
Originally Posted by jowo View Post
So...we still have nobody running the new X950H firmware that can confirm whether the eARC audio dropout issues are fixed?
for me after the upgrade to the new version of the software 6326 on XG9505 the sound on netflix has disappeared. so not fully eARC has been repaired
mikoko1966 is online now  
post #5625 of 6760 Old 05-20-2020, 05:17 AM
AVS Forum Special Member
 
sjm817's Avatar
 
Join Date: Apr 2007
Posts: 1,632
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 925 Post(s)
Liked: 409
Quote:
Originally Posted by Mehul Trivedi View Post
Sorry for the confusion, I understand the Earc for Audio only. However when I plug the HDMI into the arc port on my receiver and TV I don't even get a picture. The TV says there is no input connected. I've tried different HDMI cords to no effect. I'll try a factory reset when I get home tonight see if that clears up any gremlins.
Wow something is really wrong then. Factory reset everything, try a different HDMI cable.
sjm817 is offline  
post #5626 of 6760 Old 05-20-2020, 05:32 AM
AVS Forum Special Member
 
Join Date: May 2017
Posts: 2,035
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 1340 Post(s)
Liked: 378
Quote:
Originally Posted by diaconusm View Post
An extraordinary discovery #DannyW75 .... I wonder, is there no legal opportunity to combat these perverse practices of producers? Especially in the USA where the legislative system is a special one. Did any of you talk to a lawyer? On the subject, I think they will find extremely quick an way to stop these "unauthorized" updates. Certainly the update for Europe will suffer the necessary changes to make this and future improvements no longer available for free.

In my case, if the software for the 2 products XH and XG does not align (after this unmasking), I will do the following: I will never buy Sony, meaning nothing from Sony and I will recommend to all my acquaintances to never buy Sony products - I suggest you all do the same. I think it hurts Sony the most, after a trial, to have a negative advertisement.
I'll never buy Sony again. Here we are 2020. They make the greatest console of all time, the PlayStation. Only the 900h (I think maybe their high end 8k sets have 2.1) is touted as being ps5 ready..... Looks like they are going to milk it one last year before they they give their own product the tv features it needs for next gen console gaming.

Sent from my GM1915 using Tapatalk
Brian_Barros is online now  
post #5627 of 6760 Old 05-20-2020, 06:22 AM
Senior Member
 
dr_gallup's Avatar
 
Join Date: Oct 2011
Posts: 277
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 78 Post(s)
Liked: 53
Quote:
Originally Posted by sjm817 View Post
Installed the H FW in my 75G last night. Went smooth. Did factory reset, re-paired my remote. Havent noticed it mentioned but there was an upgrade to the remote that I installed as well (no it did not enable backlight)

As always DID NOT allow Samba TV to be installed and also disabled the Samba services app.

So far so good and thank-you @DannyW75 for the effort you have put into this
So I downloaded the X950G and X950H updates but since my X950G prompts me to install it's update every time I turn it on, I thought I would go ahead and let it do it's own thing. The last time I did that everything went fine and I was able to skip over the Samba TV part. However, this time, shortly after I told it to go ahead with the install, my AVR turned itself on and the screen started showing some TV program from the cable input. I turned the AVR & cable box off but I never saw the install screen again. The install completed and it looks to me like Samba TV got installed automatically. How can I tell for sure that it got installed? What is the downside to this? Is there a way to remove it?
dr_gallup is offline  
post #5628 of 6760 Old 05-20-2020, 06:26 AM
AVS Forum Special Member
 
sjm817's Avatar
 
Join Date: Apr 2007
Posts: 1,632
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 925 Post(s)
Liked: 409
Quote:
Originally Posted by dr_gallup View Post
So I downloaded the X950G and X950H updates but since my X950G prompts me to install it's update every time I turn it on, I thought I would go ahead and let it do it's own thing. The last time I did that everything went fine and I was able to skip over the Samba TV part. However, this time, shortly after I told it to go ahead with the install, my AVR turned itself on and the screen started showing some TV program from the cable input. I turned the AVR & cable box off but I never saw the install screen again. The install completed and it looks to me like Samba TV got installed automatically. How can I tell for sure that it got installed? What is the downside to this? Is there a way to remove it?
Samba TV back since my Z9D days was always something to avoid since it runs in background and is responsible for people complaining how slow Android TV was. I always made sure it was not installed. Do a factory reset and you should get a prompt during setup to install it. You have to decline like twice.
sjm817 is offline  
post #5629 of 6760 Old 05-20-2020, 06:40 AM
Newbie
 
Join Date: May 2020
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 2
I created this account just so I could thank DannyW75. Got an X950G last weekend, and was really disappointed in it after a day of use or so. Everything was super-laggy, kept reporting issues with WiFi when no other device had problems, the sound issues, etc. I was like, "where is all this computer processing power I supposedly purchased?" I began searching the internet and found the Reddit post which lead me here. Changing to the X950H firmware solved all issues. My TV is so awesome now, and I don't feel like I got ripped off anymore.

THANK YOU DANNYW75!!!!!
David Kyle is offline  
post #5630 of 6760 Old 05-20-2020, 07:05 AM
Member
 
unifexx's Avatar
 
Join Date: Dec 2013
Location: Europe
Posts: 137
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 91 Post(s)
Liked: 45
Quote:
Originally Posted by mikoko1966 View Post
for me after the upgrade to the new version of the software 6326 on XG9505 the sound on netflix has disappeared. so not fully eARC has been repaired

I have installed the latest (v6.3626) software on XG9505 and have no sound problems.
unifexx is online now  
post #5631 of 6760 Old 05-20-2020, 07:11 AM
Member
 
unifexx's Avatar
 
Join Date: Dec 2013
Location: Europe
Posts: 137
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 91 Post(s)
Liked: 45
Quote:
Originally Posted by dr_gallup View Post
So I downloaded the X950G and X950H updates but since my X950G prompts me to install it's update every time I turn it on, I thought I would go ahead and let it do it's own thing. The last time I did that everything went fine and I was able to skip over the Samba TV part. However, this time, shortly after I told it to go ahead with the install, my AVR turned itself on and the screen started showing some TV program from the cable input. I turned the AVR & cable box off but I never saw the install screen again. The install completed and it looks to me like Samba TV got installed automatically. How can I tell for sure that it got installed? What is the downside to this? Is there a way to remove it?

Just disable the app. In that respect the Android TV is similar to the phones - some apps are built-in and cannot be removed, but can be disabled. I did it first day I was playing with settings since I did not know what it was and saw no use for it.
unifexx is online now  
post #5632 of 6760 Old 05-20-2020, 07:18 AM
AVS Forum Special Member
 
meburdick's Avatar
 
Join Date: Oct 2010
Posts: 1,581
Mentioned: 20 Post(s)
Tagged: 0 Thread(s)
Quoted: 1092 Post(s)
Liked: 450
Quote:
Originally Posted by unifexx View Post
Just disable the app. In that respect the Android TV is similar to the phones - some apps are built-in and cannot be removed, but can be disabled. I did it first day I was playing with settings since I did not know what it was and saw no use for it.
I know that Samba TV will be offered during the initial setup process (which you can re-run at any time) if Samba TV is currently disabled. It would be worth trying the initial setup process to see if it offers up the opportunity to disable it right there as it only takes a minute to run.
meburdick is offline  
post #5633 of 6760 Old 05-20-2020, 07:19 AM
Newbie
 
dixonmac's Avatar
 
Join Date: Jun 2007
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 12
My new x950g 55" is being delivered this afternoon by BestBuy!!

I plan to immediately turn off auto updates, run the G and H updates (one at a time) from a USB flash drive per the instructions here, then start messing with settings.

Does it matter how the flash drive is formatted? Mac, Fat32, etc.???

I've pored through many pages of this thread, hoping to find a generally-agreed-upon-best-starting-point settings list but I don't really see a consensus on that. I've got the link to the rtings settings and have made notes of other suggestions, especially related to things changed after the H update. Is there a better approach?

I'm really looking forward to this TV - it's replacing a 50" 2007 720p Panasonic Plasma
galonzo and jlo8720 like this.
dixonmac is offline  
post #5634 of 6760 Old 05-20-2020, 07:59 AM
Newbie
 
Join Date: May 2020
Location: Germany
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 0
Quote:
Originally Posted by sshuttari View Post
I have the Sony HTX9000F connected to eARC HDMI Port. Atmos is working fine.

It sometimes glitches when I turn on regular TV or Bluetooth Headphones and I have to unplug soundbar and TV and it works fine after that. It's a little annoying

I can't speak on any other Atmos systems.
Also @ jowo
It depends on which source you use. The audio dropouts on my side are only by playing from the internal apps installed on tv like Disney+ etc. AVR (Yamaha Aventage) pluged over ARC on TV. When using a external HDMI-device as source, there are no issues.
Does anyone have the sound dropouts on the X950G using the new H-Firmware in this constellation?
Werty100 is offline  
post #5635 of 6760 Old 05-20-2020, 08:18 AM
Newbie
 
Join Date: May 2020
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 2
The USB flash drive must meet the following conditions:
The drive must be formatted in FAT16, FAT32, exFAT or NTFS
The drive will need to have sufficient free space to accommodate the update file
The update file must be saved in the root directory of the drive


Quote:
Originally Posted by dixonmac View Post

Does it matter how the flash drive is formatted? Mac, Fat32, etc.???
David Kyle is offline  
post #5636 of 6760 Old 05-20-2020, 08:27 AM
Member
 
Join Date: Feb 2020
Posts: 22
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Liked: 4
Hello everyone, im from Europe, someone asked about last firmware enhancements in European version of last XG update, so, have to do a disappointing statement that i cant see any improvements in motion clearance or in picture quality, it's still best with all motion settings put on AUTO, another way it's a stroboscopic nightmare! So all a
evidences for sony is pushing forward H and degrading G!((
Алексей Шарапов is offline  
post #5637 of 6760 Old 05-20-2020, 08:35 AM
Member
 
Join Date: May 2019
Location: Planet Earth
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 20 Post(s)
Liked: 2
Quote:
Originally Posted by diaconusm View Post
An extraordinary discovery #DannyW75 .... I wonder, is there no legal opportunity to combat these perverse practices of producers? Especially in the USA where the legislative system is a special one. Did any of you talk to a lawyer? On the subject, I think they will find extremely quick an way to stop these "unauthorized" updates. Certainly the update for Europe will suffer the necessary changes to make this and future improvements no longer available for free.
In my case, if the software for the 2 products XH and XG does not align (after this unmasking), I will do the following: I will never buy Sony, meaning nothing from Sony and I will recommend to all my acquaintances to never buy Sony products - I suggest you all do the same. I think it hurts Sony the most, after a trial, to have a negative advertisement.
My next HD TV will not be a Sony. I am done with them. Their software support sucks (but perhaps this partially is Google's fault?) I am not impressed at all with Android TV and with Sony's firmware updates.


D.Bailey is offline  
post #5638 of 6760 Old 05-20-2020, 09:04 AM
Senior Member
 
reechings's Avatar
 
Join Date: Mar 2012
Location: Canada
Posts: 335
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 228 Post(s)
Liked: 44
I've been pretty happy with my TV for the most part. Got a good open box deal at the time. Took a while to get past the cloudy mess on certain loading screens like Netflix and the occasional crash and reboot is still a little strange to me on a TV (used to it on my Android phones with custom ROMs etc). This is my first true smart TV and the wife does like using the voice control to launch her spa music on YouTube .

Sent from my Pixel 2 XL using Tapatalk
reechings is offline  
post #5639 of 6760 Old 05-20-2020, 09:10 AM
AVS Forum Special Member
 
Join Date: May 2017
Posts: 2,035
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 1340 Post(s)
Liked: 378
Quote:
Originally Posted by D.Bailey View Post
My next HD TV will not be a Sony. I am done with them. Their software support sucks (but perhaps this partially is Google's fault?) I am not impressed at all with Android TV and with Sony's firmware updates.


Not at all Google. 100% Sony. Use an Nvidia Shield and you'll change your mind about Android TV.

Sent from my GM1915 using Tapatalk
Brian_Barros is online now  
post #5640 of 6760 Old 05-20-2020, 09:15 AM
Member
 
Join Date: Nov 2014
Posts: 54
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 29 Post(s)
Liked: 6
Does anyone play their Nintendo Switch docked on a x950G? I’m using game mode obviously when playing my switch on it, but I noticed my switch looks grainy/has jaggies around it when in the system menu and playing games.

Was wondering if anyone can share their game mode settings for a switch. Also, I have the enhanced HDMI input on for all my inputs, but I’m not sure if Switch supports it?
omiexstrike is offline  
Sponsored Links
Advertisement
 
Reply LCD Flat Panel Displays

Tags
dolby atmos , sony 950g 85" , x95g

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off