2019 Samsung Q70R QLED Owner's Thread (No Price Talk) - Page 62 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 338Likes
Reply
 
Thread Tools
post #1831 of 2034 Old 05-24-2020, 03:20 AM
Advanced Member
 
powertoburn's Avatar
 
Join Date: Aug 2001
Location: Monterey Park, CA, USA
Posts: 835
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 295 Post(s)
Liked: 242
Quote:
Originally Posted by Spewdom View Post
The bottom and corner bezel of my TV looks different than that 55".
My Q7DR 85” also looks like how your 82” looks at the bottom. I don’t have the black strip
powertoburn is offline  
Sponsored Links
Advertisement
 
post #1832 of 2034 Old 05-24-2020, 09:08 AM
Member
 
Join Date: Apr 2020
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 1
Quote:
Originally Posted by extremist59 View Post
Well, have had my 65Q7DR plugged in and watching since Thursday 5/21/20 and have been experiencing several glitchy bugs and trying to troubleshoot what the issue is.

Equipment:
65Q7DR
Sony STRDH740 A/V Receiver
Sony UBPX700 4K UHD/BD Player
Channelmaster Stream+
Channelmaster CM7000PAL
AV2HDMI RCA-HDMI converter for old analog equipment

I have the HDMI4/ARC connection on the 65Q7DR connected to the Sony A/V receiver on it's HDMI/ARC(4) input
UBPX700 connected to BD/4K on Sony A/V
Channelmaster Stream+ connected to HDMI SAT/CATV/4K on Sony A/V
Channelmaster CM7000PAL on GAME/4K on Sony A/V
AV2HDMI RCA-HDMI convert on DVD/(not-4K capable) on Sony A/V

My issue with the TV is it keeps losing it's connection to the A/V receiver. Only way I've been able to get it to recognize it again is to unplug/replug the HDMI/ARC connection.
I've tried two different HDMI cables, same thing. Very flaky.

Also streaming issues with 65Q7DR and Google Play Movies. Redeemed the $50 credit and tried to watch "Bloodshot" tonight and it took forever to watch it. Having audio drop issues watching using the Google Play on 65Q7DR, so I switched to the Channelmaster Stream+ to watch it. Got about 30-40 min into the movie, paused it to do something else and when I came back to restart it the receiver lost the connection to the TV and I had to unplug/replug HDMI/ARC to get it back. No audio issues but about 60 min into movie, Google Play on the Stream+ stopped working, it wouldn't let me resume the movie. Tried restarting Stream+, clearing cache in Google Play Movies, logged out, logged into Google. Nada, still won't play any Google Movies. So I switched back to the 65Q7DR Google Play to resume the "Bloodshot" and it didn't let me choose resume (bug?), had to start from beginning and fast forward. Still have issues with audio dropout but finally made it through the rest of the movie.

Haven't seen as many issues so far with Netflix or Prime, except for the annoying loss of connection between A/V and TV.

Getting frustrated troubleshooting - anyone else had these kind of issues with their TV?

Thanks!
Last night we sat down to watch a google play movie on our 85q7dr. We generally watch a few trailers to decide on a movie. When we first tried to do this last night, the audio for the trailers had a static type distortion. I reloaded the google app on the tv and that cleared up the auio. We decided on Bloodshot and it played flawlessly.
jimkar is online now  
post #1833 of 2034 Old 05-24-2020, 12:03 PM
Member
 
Join Date: May 2020
Posts: 42
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Liked: 5
Quote:
Originally Posted by jimkar View Post
Last night we sat down to watch a google play movie on our 85q7dr. We generally watch a few trailers to decide on a movie. When we first tried to do this last night, the audio for the trailers had a static type distortion. I reloaded the google app on the tv and that cleared up the auio. We decided on Bloodshot and it played flawlessly.
Tried reloading the app on the TV and it did not fix the problem.

Issues so far with 65Q7DR:

- Audio dropouts watching Netflix programming. This is with the HDMI/ARC connection to the Sony receiver and listening to Audio there.
- Audio dropouts watching Prime programming. This is with the HDMI/ARC connection to the Sony receiver and listening to Audio there.
- Cannot play Google Play Movies&TV programming. Error code 132.

I did resolve the issue on my ChannelMaster Stream+ by uninstalling the updates to the Google Play Movies&TV application. This is not an option on the 65Q7DR.

I need to watch some programming on Netflix/Prime with the built in audio/speakers and see if I get dropouts there too. That would eliminate the receiver as an issue.
extremist59 is offline  
Sponsored Links
Advertisement
 
post #1834 of 2034 Old 05-24-2020, 12:10 PM
Member
 
Join Date: Apr 2020
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 1
Quote:
Originally Posted by extremist59 View Post
Tried reloading the app on the TV and it did not fix the problem.

Issues so far with 65Q7DR:

- Audio dropouts watching Netflix programming. This is with the HDMI/ARC connection to the Sony receiver and listening to Audio there.
- Audio dropouts watching Prime programming. This is with the HDMI/ARC connection to the Sony receiver and listening to Audio there.
- Cannot play Google Play Movies&TV programming. Error code 132.

I did resolve the issue on my ChannelMaster Stream+ by uninstalling the updates to the Google Play Movies&TV application. This is not an option on the 65Q7DR.

I need to watch some programming on Netflix/Prime with the built in audio/speakers and see if I get dropouts there too. That would eliminate the receiver as an issue.
What version firmware are you running, I am on 1356. Only other suggestion for the Google movie issue would be a factory reset on the tv.
jimkar is online now  
post #1835 of 2034 Old 05-24-2020, 12:30 PM
Member
 
Join Date: May 2020
Posts: 42
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Liked: 5
Quote:
Originally Posted by jimkar View Post
What version firmware are you running, I am on 1356. Only other suggestion for the Google movie issue would be a factory reset on the tv.
Looks like I'm on 1356.2

Well I watched some programming on the TV without it hooked to my receiver and didn't notice any audio dropouts on Netflix or Prime.

So it's something in the link to my receiver.

I've tried different HDMI cables, same results.

This is the one I bought to connect TV to Receiver: K HDR HDMI Cable 10FT
iVanky High Speed HDMI Cable supports [email protected](3840 X [email protected]), 1440P, 1080P, 720P, HDR, HDMI 2.0b.

I've tried Amazon's "generic" HDMI high speed with ethernet cables. Same results.

So now I've got to decide: is it the TV HDMI/ARC connection that's bad, is it the Sony Receiver STR-DH740 HDMI/ARC connection? Is that receiver too old? It says it supports 4K?

Hate to drop 300-400 on a new Receiver and it not fix the problem. Hate to return the TV if it's not the TV. Any other tips on troubleshooting?
extremist59 is offline  
post #1836 of 2034 Old 05-24-2020, 12:42 PM
Member
 
Join Date: Apr 2020
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 1
I doubt the receiver is too old, can you borrow a sound bar from someone to check the TV HDMI/arc port?
jimkar is online now  
post #1837 of 2034 Old 05-24-2020, 01:40 PM
Advanced Member
 
powertoburn's Avatar
 
Join Date: Aug 2001
Location: Monterey Park, CA, USA
Posts: 835
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 295 Post(s)
Liked: 242
Quote:
Originally Posted by extremist59 View Post
Looks like I'm on 1356.2

So now I've got to decide: is it the TV HDMI/ARC connection that's bad, is it the Sony Receiver STR-DH740 HDMI/ARC connection? Is that receiver too old? It says it supports 4K?

Hate to drop 300-400 on a new Receiver and it not fix the problem. Hate to return the TV if it's not the TV. Any other tips on troubleshooting?
Does your receiver support HDMI 2.0 and HDCP 2.2? I think you are experiencing handshake issue between receiver & TV. Have you tried hooking up Optical cable between TV and Receiver?
powertoburn is offline  
post #1838 of 2034 Old 05-24-2020, 01:46 PM
Advanced Member
 
powertoburn's Avatar
 
Join Date: Aug 2001
Location: Monterey Park, CA, USA
Posts: 835
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 295 Post(s)
Liked: 242
Quote:
Originally Posted by extremist59 View Post

Also streaming issues with 65Q7DR and Google Play Movies. Redeemed the $50 credit and tried to watch "Bloodshot" tonight and it took forever to watch it.
How did you redeem the $50 credit? I bought my 85" Q7DR from Costco and the box mentioned about the $50 credit but there was nothing in the box.

I am not experiencing any ARC issues with my TV and Denon AVR-X4400. There initially was an issue with my Xbox One S causing ARC to not work.
powertoburn is offline  
post #1839 of 2034 Old 05-24-2020, 03:39 PM
Member
 
Join Date: May 2020
Posts: 42
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Liked: 5
Quote:
Originally Posted by powertoburn View Post
How did you redeem the $50 credit? I bought my 85" Q7DR from Costco and the box mentioned about the $50 credit but there was nothing in the box.

I am not experiencing any ARC issues with my TV and Denon AVR-X4400. There initially was an issue with my Xbox One S causing ARC to not work.
Here: https://promos.samsungpromotions.com/membervalue

Got my new HDMI Cable 3' for the Sony UPB-X700 this afternoon.

Plugged it into the BD HDMI connector on the receiver.

Started watching Netflix to see if any audio drops. None.
But then the TV, blanked out, saying nothing was connected (the receiver).
To fix this I have to unplug the cable from TV to Receiver so TV will recognize device on HDMI4/ARC.

Watched Prime for a bit, no audio drops. None.

So where do I point the finger? Flummoxed.
extremist59 is offline  
post #1840 of 2034 Old 05-24-2020, 08:20 PM
Advanced Member
 
powertoburn's Avatar
 
Join Date: Aug 2001
Location: Monterey Park, CA, USA
Posts: 835
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 295 Post(s)
Liked: 242
Quote:
Originally Posted by extremist59 View Post
Thanks for the link! I was able to submit the information, now a waiting period of 2 weeks while Samsung verifies the submission
powertoburn is offline  
post #1841 of 2034 Old 05-24-2020, 09:31 PM
Member
 
Join Date: May 2020
Posts: 42
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Liked: 5
Quote:
Originally Posted by powertoburn View Post
Thanks for the link! I was able to submit the information, now a waiting period of 2 weeks while Samsung verifies the submission
Only took a day for mine, but with the holiday, may take until Tuesday, they are quick.
extremist59 is offline  
post #1842 of 2034 Old 05-24-2020, 09:51 PM
AVS Forum Special Member
 
andy sullivan's Avatar
 
Join Date: Mar 2005
Location: sun city west AZ
Posts: 4,425
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 994 Post(s)
Liked: 458
Quote:
Originally Posted by dcx4610 View Post
I had a Q60 and returned it because I found out it had Global Dimming. Q70 was more than I wanted to pay at the time but it was worth it for the FALD. The entire picture would noticeably dim and brighten on the Q60 with HDR. On the Q70, it's very uniform since it has the FALD. I would never get another TV without FALD going forward.
I had a Q85 and replaced it with the 82Q. Both have a problem with dimming and brightening during scenes. On Netflix, Amazon, and regular broadcast channels. I have tried every setting combination imaginable. ECO is turned of as is pretty much every enhancing feature. Someone told me the problem is Samsungs algorithm and had been a complaint for some time. I had no such problem with the 82RU8000.
andy sullivan is offline  
post #1843 of 2034 Old 05-24-2020, 09:56 PM
AVS Forum Special Member
 
Cam1977's Avatar
 
Join Date: Apr 2016
Location: El paso
Posts: 5,914
Mentioned: 36 Post(s)
Tagged: 0 Thread(s)
Quoted: 3365 Post(s)
Liked: 4150
^dimming unfortunately is aggressive on these...happens as well on my 82.
Cam1977 is offline  
post #1844 of 2034 Old 05-25-2020, 12:17 AM
Advanced Member
 
Spewdom's Avatar
 
Join Date: May 2009
Posts: 688
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 397 Post(s)
Liked: 317
I haven't seen any random dimming on any content I've watched or games I've played. Is it always random or are there certain movies or scenes where it does it every time?
Spewdom is online now  
post #1845 of 2034 Old 05-25-2020, 12:22 AM
AVS Forum Special Member
 
Cam1977's Avatar
 
Join Date: Apr 2016
Location: El paso
Posts: 5,914
Mentioned: 36 Post(s)
Tagged: 0 Thread(s)
Quoted: 3365 Post(s)
Liked: 4150
^it mostly happens in dark or space scenes. If you have the movie "First Man" towards the end you'll see what I mean.
Cam1977 is offline  
post #1846 of 2034 Old 05-25-2020, 04:11 AM
Advanced Member
 
Spewdom's Avatar
 
Join Date: May 2009
Posts: 688
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 397 Post(s)
Liked: 317
Quote:
Originally Posted by Cam1977 View Post
^it mostly happens in dark or space scenes. If you have the movie "First Man" towards the end you'll see what I mean.
Don't own First Man and haven't seen. The only fluctuation I really see is blooming during end credits because the size of the text varies on how far out it extends so the TV is trying to brighten and dim. So really just blooming on some text. But during regular viewing I haven't noticed any dimming to where it stood out and made me question why it's dimming. Only thing that bothers is a bright loading icon in video games that is placed at the bottom corner of a black screen. Shows there just aren't enough dimming zones.
Spewdom is online now  
post #1847 of 2034 Old 05-25-2020, 08:29 AM
Member
 
Bill Millar's Avatar
 
Join Date: Oct 2001
Location: Iowa Park Texas, North of Wichita Falls, Tx.
Posts: 149
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 17
Quote:
Originally Posted by powertoburn View Post
Does your receiver support HDMI 2.0 and HDCP 2.2? I think you are experiencing handshake issue between receiver & TV. Have you tried hooking up Optical cable between TV and Receiver?
You are right the Sony STR-DH740 is not HDCP 2.2-complain and will not support copy-protected 4K video content.
NotShorty likes this.
Bill Millar is offline  
post #1848 of 2034 Old 05-25-2020, 09:26 AM
Senior Member
 
pixelman's Avatar
 
Join Date: Dec 2002
Location: GSP
Posts: 279
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Liked: 10
Quote:
Originally Posted by Cam1977 View Post
^it mostly happens in dark or space scenes. If you have the movie "First Man" towards the end you'll see what I mean.

First Man — 2017 documentary or the 2018 space drama?


Sent from my iPhone using Tapatalk
pixelman is offline  
post #1849 of 2034 Old 05-25-2020, 11:49 AM - Thread Starter
Member
 
dcx4610's Avatar
 
Join Date: Jul 2012
Posts: 76
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 55 Post(s)
Liked: 53
Quote:
Originally Posted by andy sullivan View Post
I had a Q85 and replaced it with the 82Q. Both have a problem with dimming and brightening during scenes. On Netflix, Amazon, and regular broadcast channels. I have tried every setting combination imaginable. ECO is turned of as is pretty much every enhancing feature. Someone told me the problem is Samsungs algorithm and had been a complaint for some time. I had no such problem with the 82RU8000.

I'll notice it in dark scenes sometimes where if you have a dark scene and things keep popping in and out of frame. That will "confuse" the backlight. Any TV with any kind of dimming function will have this problem but the dimming is required for proper HDR. It's going to depend on the processor and the number of dimmable areas the screen can support whether how noticeable it's going to be.


Honestly, I rarely see it on my Q70. The most important settings that need to be turned off are ECO mode and any kind of dynamic option. Dynamic Contrast being the big one. Having a max backlight also helps.


What size 82Q do you have? I'm not familiar with that model and wonder if it may have global dimming.

Last edited by dcx4610; 05-25-2020 at 11:58 AM.
dcx4610 is offline  
post #1850 of 2034 Old 05-25-2020, 12:08 PM
Member
 
Join Date: May 2020
Posts: 42
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Liked: 5
Red face

Quote:
Originally Posted by Bill Millar View Post
You are right the Sony STR-DH740 is not HDCP 2.2-complain and will not support copy-protected 4K video content.
Interesting. Well, I connected an optical cable between TV and STR-DH740 and now it works perfectly, no dropouts.

So now only remaining issue with the TV is Google Play Movies & TV doesn't work.

I can live with that since that works perfectly on my ChannelMaster Stream+.

Thanks guys.
extremist59 is offline  
post #1851 of 2034 Old 05-25-2020, 12:09 PM
AVS Forum Special Member
 
andy sullivan's Avatar
 
Join Date: Mar 2005
Location: sun city west AZ
Posts: 4,425
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 994 Post(s)
Liked: 458
Quote:
Originally Posted by dcx4610 View Post
I'll notice it in dark scenes sometimes where if you have a dark scene and things keep popping in and out of frame. That will "confuse" the backlight. Any TV with any kind of dimming function will have this problem but the dimming is required for proper HDR. It's going to depend on the processor and the number of dimmable areas the screen can support whether how noticeable it's going to be.


Honestly, I rarely see it on my Q70. The most important settings that need to be turned off are ECO mode and any kind of dynamic option. Dynamic Contrast being the big one. Having a max backlight also helps.


What size 82Q do you have? I'm not familiar with that model and wonder if it may have global dimming.
I have had the Costco version of both the 85 and 82 Q7 series. Sometimes when showing a medium bright scene, especially a face, the screen will darken and brighten back and forth every few seconds the scene is on. Not just in HDR. Both sets did exactly the same thing. I do have the backlight maxed and all Dynamic settings to off. Picture mode is Standard but I have tried them all. Eco is off.
andy sullivan is offline  
post #1852 of 2034 Old 05-25-2020, 12:15 PM
Member
 
Join Date: May 2020
Posts: 42
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Liked: 5
Red face

Quote:
Originally Posted by Bill Millar View Post
You are right the Sony STR-DH740 is not HDCP 2.2-complain and will not support copy-protected 4K video content.
Just to be clear though, I'm not getting dropouts when playing Netflix/Prime programs and listening to Sound on my STR-DH740 via Optical link.

But when I'm playing UHD BD 4K disks or Netflix/Prime UHD/4K programs on my Sony UBX-700 I'm getting full audio support right out of my STR-DH740? I'm not experiencing any dropouts or lack of 5.1 or 7.1 right.

Thanks.
extremist59 is offline  
post #1853 of 2034 Old 05-25-2020, 01:30 PM - Thread Starter
Member
 
dcx4610's Avatar
 
Join Date: Jul 2012
Posts: 76
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 55 Post(s)
Liked: 53
Quote:
Originally Posted by andy sullivan View Post
I have had the Costco version of both the 85 and 82 Q7 series. Sometimes when showing a medium bright scene, especially a face, the screen will darken and brighten back and forth every few seconds the scene is on. Not just in HDR. Both sets did exactly the same thing. I do have the backlight maxed and all Dynamic settings to off. Picture mode is Standard but I have tried them all. Eco is off.

That really sounds like global dimming to me. The only way to know for sure is to enter diagnostic mode to see the dimming type of the TV. I believe this breaks your warranty though as it keeps track of how many times it has been entered. If it's global dimming, the entire backlight dims and brightens based on the scene type. My Q60 did this and I couldn't deal with it.

Do you have the exact model number? Perhaps I can dig something up.

Here's someone entering the Service Menu -






If you look when he goes under Option, for Dimming, it says "GLOBAL". You can't change this. It's just what you have. Edge Lit, Global, Local or Micro. If it says Global....

Last edited by dcx4610; 05-25-2020 at 01:36 PM.
dcx4610 is offline  
post #1854 of 2034 Old 05-25-2020, 05:43 PM
Advanced Member
 
powertoburn's Avatar
 
Join Date: Aug 2001
Location: Monterey Park, CA, USA
Posts: 835
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 295 Post(s)
Liked: 242
Quote:
Originally Posted by extremist59 View Post
Only took a day for mine, but with the holiday, may take until Tuesday, they are quick.
My claim was rejected because there was no model number listed on the receipt. I ordered online. I resubmit my claim including the delivery email that lists the model number. Hopefully it works
powertoburn is offline  
post #1855 of 2034 Old 05-26-2020, 08:46 AM
Member
 
MakaKam's Avatar
 
Join Date: Aug 2010
Posts: 37
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
What settings would you guys recommend for day watching in bright conditions? I have it pretty much covered in a movie mode for watching in the evenings. I'd like to have it set on some other mode to change quickly between them.
MakaKam is offline  
post #1856 of 2034 Old 05-26-2020, 10:07 AM
Member
 
Join Date: May 2020
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Liked: 1
Hello to everyone.

My Samsung 75Q6F (2018) got faulty and could not be fixed anymore (under warranty), so I got a refund and with a small difference I gave, bought the 82Q70R(2019).
Hopefully it is a lot better than the Q6F.
Can't wait to receive it.
bonepeeler is offline  
post #1857 of 2034 Old 05-26-2020, 07:40 PM
Advanced Member
 
powertoburn's Avatar
 
Join Date: Aug 2001
Location: Monterey Park, CA, USA
Posts: 835
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 295 Post(s)
Liked: 242
Quote:
Originally Posted by powertoburn View Post
My claim was rejected because there was no model number listed on the receipt. I ordered online. I resubmit my claim including the delivery email that lists the model number. Hopefully it works
My claim was finally approved and now have redeemed $50 in Google Play. My Google Play Movies app on the TV opens and I am able to play the trailers. Do movies stream in 4K & HDR? Is the audio in Dolby Atmos?
powertoburn is offline  
post #1858 of 2034 Old 05-26-2020, 08:52 PM
Member
 
Join Date: May 2020
Posts: 42
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Liked: 5
Quote:
Originally Posted by powertoburn View Post
My claim was finally approved and now have redeemed $50 in Google Play. My Google Play Movies app on the TV opens and I am able to play the trailers. Do movies stream in 4K & HDR? Is the audio in Dolby Atmos?
My Google Play Movies started working again on my 65QDR tonight. We watched Ford vs Ferrari tonight, in 4K as advertised. Don't have a Dolby Atmos receiver, so it showed Dolby 5.2.1 on my STR-DH740. Looked and sounded great! I have 7 speakers hooked up, definitely had effects going to all of them. FL-C-FR-SurroundR-SurrountL-Rear-R-RearL-Sub.

Got a new Amazon Fire TV Cube Rev 2 coming tomorrow that I'm going to hook up.

I'm not going to get any more magic out of my system unless I upgrade my receiver, which I'm not going to do right now.

James
extremist59 is offline  
post #1859 of 2034 Old 05-27-2020, 11:50 AM
Member
 
straubse's Avatar
 
Join Date: Dec 2003
Location: Los Angeles, CA
Posts: 46
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 11
Quote:
Originally Posted by straubse View Post
Thanks for the input. I think you are right. I have a Samsung 55" MU6800 or something like that in another room. I never ran a pixel test on it so tried that. It has zero dead/stuck pixels and less DSE than the Q70R which was almost 4x the cost. Q70 is gong back.

Just wanted to followup and say Spewdom was right. Got a new Q70R and the screen is perfect.

Thanks again Spewdom.

/z
straubse is offline  
post #1860 of 2034 Old 05-27-2020, 03:28 PM
Member
 
Join Date: Mar 2020
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Liked: 0
Quote:
Originally Posted by powertoburn View Post
How did you redeem the $50 credit? I bought my 85" Q7DR from Costco and the box mentioned about the $50 credit but there was nothing in the box.
What types of things can you buy with the $50? If movies, is there an app on this TV to play Google movies? When we got our 65Q7DR back in Feb. I quickly overlooked the Google offer on the box, figuring it was only good for android apps.

EDIT: Looks like the qualifying dates have changed since we purchased. I'm still going to apply. Nothing to lose.

Last edited by Seeley; 05-27-2020 at 03:45 PM.
Seeley is offline  
Sponsored Links
Advertisement
 
Reply LCD Flat Panel Displays

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off