2019 TCL 6-Series QLED R625 (55" & 65") Owners Thread (No Price Talk) - Page 14 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 518Likes
Reply
 
Thread Tools
post #391 of 1302 Old 10-15-2019, 12:53 PM
Newbie
 
Join Date: Oct 2019
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Liked: 4
Quote:
Originally Posted by whiteboy714 View Post
I ran through some slides of all the primary colors and black and white from my main seating position and didn't see anything. I am not going to sit up against the screen to find any little flaw because I know once I see it I can't unsee it.

Which is understandable, my problem is I can still see several of those dead pixel spots 10 feet away.
Trueweltall is offline  
Sponsored Links
Advertisement
 
post #392 of 1302 Old 10-15-2019, 12:55 PM
AVS Forum Special Member
 
whiteboy714's Avatar
 
Join Date: Feb 2009
Posts: 6,925
Mentioned: 14 Post(s)
Tagged: 0 Thread(s)
Quoted: 1512 Post(s)
Liked: 636
Quote:
Originally Posted by Trueweltall View Post
Which is understandable, my problem is I can still see several of those dead pixel spots 10 feet away.

Yeah that's an issue I'd have to deal with. Sounds like a return candidate.

TCL 65R625 -- Denon X1400h -- Klipsch RP600m -- RP450C -- Micca M-6S 6.5 -- Dual Klipsch RW-10
whiteboy714 is offline  
post #393 of 1302 Old 10-15-2019, 02:25 PM
AVS Forum Special Member
 
SteroMAdMAn's Avatar
 
Join Date: Nov 2002
Location: MN
Posts: 1,059
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 88 Post(s)
Liked: 98
Quote:
Originally Posted by whiteboy714 View Post
Yeah that’s the best setting for me as well. I'm still trying to figure this thing out. Sometimes I watch something and it looks great as it should. And then something else is glitchy. But I know the source is usually solid so it's hard to figure out what's really going on.

I am seeing the same as well with Spectrum cable, direct HDMI connection to HDMI input 1. Sometimes it looks fine and then sometimes it stutters. The 4k movie we watched on HDMI 2 did not exhibit any of this behavior. I haven't watched much streaming other than a few Dolby channel videos. No stuttering on them either, but that was literally 7 minutes of viewing time. Hard to make a definitive call if it is how the TV handles different sources. But that seems to be the case in my limited experience. It's not something that is easy to miss.


I have everything set to the CNET settings(everything off but Cinema motion or whatever it is called), went into the app and turned off the noise reduction on this input. But that didn't make much of a difference. Also strange; commercials don't appear to be affected or at least not nearly as bad as the show that is on. I can get over motion blur during sports, but this is much more pronounced and annoying.

If this isn't a simple setting, I'm certainly hoping a firmware update resolves it.

It is better to ask for forgiveness, than it is to ask for permissision - the WAF factor
SteroMAdMAn is offline  
Sponsored Links
Advertisement
 
post #394 of 1302 Old 10-15-2019, 02:27 PM
Member
 
Kizzer's Avatar
 
Join Date: Sep 2013
Posts: 171
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 112 Post(s)
Liked: 114
Quote:
Originally Posted by jjoel View Post
I got the audio dropping out fixed by using the optical cable. I must have not had it set up right before. I still have volume control using ARC thankfully. Other than that, I'm pretty happy with this TV and think I ended up getting a pretty good panel.
Does optical override ARC for sound? And you can still use your TCL remote to control the sound? I am using a soundbar, would that apply here?
Kizzer is offline  
post #395 of 1302 Old 10-15-2019, 02:46 PM
AVS Forum Special Member
 
whiteboy714's Avatar
 
Join Date: Feb 2009
Posts: 6,925
Mentioned: 14 Post(s)
Tagged: 0 Thread(s)
Quoted: 1512 Post(s)
Liked: 636
Quote:
Originally Posted by SteroMAdMAn View Post
I am seeing the same as well with Spectrum cable, direct HDMI connection to HDMI input 1. Sometimes it looks fine and then sometimes it stutters. The 4k movie we watched on HDMI 2 did not exhibit any of this behavior. I haven't watched much streaming other than a few Dolby channel videos. No stuttering on them either, but that was literally 7 minutes of viewing time. Hard to make a definitive call if it is how the TV handles different sources. But that seems to be the case in my limited experience. It's not something that is easy to miss.


I have everything set to the CNET settings(everything off but Cinema motion or whatever it is called), went into the app and turned off the noise reduction on this input. But that didn't make much of a difference. Also strange; commercials don't appear to be affected or at least not nearly as bad as the show that is on. I can get over motion blur during sports, but this is much more pronounced and annoying.

If this isn't a simple setting, I'm certainly hoping a firmware update resolves it.
I have not been seeing the issue lately. But I don't watch much cable. I also do not have a Spectrum STB, I use a cable card and view spectrum through the Nvidia Shield. I am not sure what causes it, but I have went back to a source where it was prevalent and this time did not see it. Which is odd but I am not complaining.

TCL 65R625 -- Denon X1400h -- Klipsch RP600m -- RP450C -- Micca M-6S 6.5 -- Dual Klipsch RW-10
whiteboy714 is offline  
post #396 of 1302 Old 10-15-2019, 02:53 PM
AVS Forum Special Member
 
rockaway1836's Avatar
 
Join Date: Jun 2005
Location: Myrtle Beach SC
Posts: 1,020
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 281 Post(s)
Liked: 281
Quote:
Originally Posted by Scottt1174 View Post
It looks like they took the app down in play store cause I can't find it.
That could be the case, because I don't see it anymore. I know they have a rep watching these threads. He may have let them know that we stumbled on to it before it was ready for prime time.
Kizzer likes this.

Last edited by rockaway1836; 10-15-2019 at 03:42 PM.
rockaway1836 is offline  
post #397 of 1302 Old 10-15-2019, 03:10 PM
Senior Member
 
vlad335's Avatar
 
Join Date: Sep 2002
Location: Latrobe, PA
Posts: 234
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 112 Post(s)
Liked: 61
Just picked up this set at BB. The box is perfect. I will have to wait till tomorrow to unbox it though as I have to go to work.


I think my Brother in law is more excited than me as I am gifting him my Samsung KS8000. He rents to own from RentaCenter and would end up paying over 3 grand for a cheapo Samsung.



Hope this works out. Some of the posts on this thread are scaring me. Oh well, if it's glitchy it will go back and I will pick up a Sony.
Attached Thumbnails
Click image for larger version

Name:	20191015_165010_resized.jpg
Views:	59
Size:	258.6 KB
ID:	2628154  
Kizzer likes this.
vlad335 is offline  
post #398 of 1302 Old 10-15-2019, 03:15 PM
AVS Forum Special Member
 
SteroMAdMAn's Avatar
 
Join Date: Nov 2002
Location: MN
Posts: 1,059
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 88 Post(s)
Liked: 98
Quote:
Originally Posted by whiteboy714 View Post
I have not been seeing the issue lately. But I don't watch much cable. I also do not have a Spectrum STB, I use a cable card and view spectrum through the Nvidia Shield. I am not sure what causes it, but I have went back to a source where it was prevalent and this time did not see it. Which is odd but I am not complaining.
Lucky you! The only problem with things that go away on their own, seem to come back on their own. But here's to hoping mine go away as well.

It is better to ask for forgiveness, than it is to ask for permissision - the WAF factor
SteroMAdMAn is offline  
post #399 of 1302 Old 10-15-2019, 03:26 PM
AVS Forum Special Member
 
whiteboy714's Avatar
 
Join Date: Feb 2009
Posts: 6,925
Mentioned: 14 Post(s)
Tagged: 0 Thread(s)
Quoted: 1512 Post(s)
Liked: 636
Quote:
Originally Posted by SteroMAdMAn View Post
Lucky you! The only problem with things that go away on their own, seem to come back on their own. But here's to hoping mine go away as well.
I know thats true. Hoping a setting helped it. I have some football games recorded, I might check them out and see how things look.

TCL 65R625 -- Denon X1400h -- Klipsch RP600m -- RP450C -- Micca M-6S 6.5 -- Dual Klipsch RW-10
whiteboy714 is offline  
post #400 of 1302 Old 10-15-2019, 05:24 PM
Member
 
Kizzer's Avatar
 
Join Date: Sep 2013
Posts: 171
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 112 Post(s)
Liked: 114
Quote:
Originally Posted by Kizzer View Post
Odd.

I lost sound on the TV with the soundbar. So I switched it over to the TV speakers and they didn't work either. I messed around and couldn't find what the issue was. Finally I just unplugged everything, waited a few minutes and once it came back to life the sound was working fine.

Hmmmm....
Still not sure why this happened. First thing this morning I turned it on just to check and it was fine.
Kizzer is offline  
post #401 of 1302 Old 10-15-2019, 05:25 PM
Newbie
 
Join Date: Oct 2019
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Liked: 4
Exclamation

Quote:
Originally Posted by whiteboy714 View Post
Yeah that's an issue I'd have to deal with. Sounds like a return candidate.

I did some back and forth with TCL via email today and they will be sending a replacement to a local technician who will inspect it for damage and then come by to swap it out with the one I have now. So in about two weeks hopefully I will have a 65R625 that doesn't have any screen issues.



It was determined that the one I received has debris between the screen and the diffuser.
rockaway1836 and Kizzer like this.
Trueweltall is offline  
post #402 of 1302 Old 10-15-2019, 05:26 PM
Member
 
Kizzer's Avatar
 
Join Date: Sep 2013
Posts: 171
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 112 Post(s)
Liked: 114
Quote:
Originally Posted by vlad335 View Post
Just picked up this set at BB. The box is perfect. I will have to wait till tomorrow to unbox it though as I have to go to work.


I think my Brother in law is more excited than me as I am gifting him my Samsung KS8000. He rents to own from RentaCenter and would end up paying over 3 grand for a cheapo Samsung.



Hope this works out. Some of the posts on this thread are scaring me. Oh well, if it's glitchy it will go back and I will pick up a Sony.
Thruth be told, most TV's released now have some kind of issue or another. I think it's just a crap shoot.
theboomr likes this.
Kizzer is offline  
post #403 of 1302 Old 10-15-2019, 06:26 PM
Member
 
Join Date: Aug 2018
Posts: 115
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 69 Post(s)
Liked: 54
What do you guys think of the color blue on this tv? On mine there seems to be this weird "water color" effect happening, specifically on blue skies.
samoth84 is offline  
post #404 of 1302 Old 10-15-2019, 07:27 PM
Member
 
Kizzer's Avatar
 
Join Date: Sep 2013
Posts: 171
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 112 Post(s)
Liked: 114
Quote:
Originally Posted by samoth84 View Post
What do you guys think of the color blue on this tv? On mine there seems to be this weird "water color" effect happening, specifically on blue skies.
Have you adjusted it?
Kizzer is offline  
post #405 of 1302 Old 10-15-2019, 07:39 PM
Member
 
Join Date: Aug 2018
Posts: 115
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 69 Post(s)
Liked: 54
Quote:
Originally Posted by Kizzer View Post
Have you adjusted it?
Only basic adjustments to brightness and picture setting.
samoth84 is offline  
post #406 of 1302 Old 10-15-2019, 07:53 PM
Member
 
Kizzer's Avatar
 
Join Date: Sep 2013
Posts: 171
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 112 Post(s)
Liked: 114
Quote:
Originally Posted by samoth84 View Post
Only basic adjustments to brightness and picture setting.

I don't have the color problem you are talking about and I am not near my TV to check but I think with the app you can adjust colors... I could be wrong.
Kizzer is offline  
post #407 of 1302 Old 10-16-2019, 07:07 AM
Member
 
wavsine's Avatar
 
Join Date: Jul 2010
Posts: 143
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 113 Post(s)
Liked: 87
wavsine is offline  
post #408 of 1302 Old 10-16-2019, 07:16 AM
Member
 
Capt. Hot Sauce's Avatar
 
Join Date: Nov 2006
Posts: 84
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Liked: 10
From Rtings

8.4 Movies
7.5 TV Shows
7.4 Sports
8.8 Video Games
8.5 HDR Movies
8.6 HDR Gaming
8.1 PC Monitor
Capt. Hot Sauce is offline  
post #409 of 1302 Old 10-16-2019, 07:48 AM
Member
 
mjconnor10's Avatar
 
Join Date: Oct 2006
Posts: 151
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 41 Post(s)
Liked: 30
So Apple TV released their Roku app yesterday, and it seems to be limited to certain devices at the moment. My Express has it, but my 625 does not. I have heard that it's on the 615, so I assume it's going to be a slow rollout until their streaming programming begins in November. Has anyone else been able to download the channel on their 625?

It's a nice feature (once it's fully live), because there are a lot of movies on the iTunes platform that don't port via Movies Anywhere to Vudu, which is what I primarily watch movie content on. Digging into my cabinet to turn on my Apple TV, praying to St. Francis to find that ridiculous little remote, and hoping that there isn't a system update has proven to be an impossible series of events to overcome in my house, just so my kid can watch "Ugly Dolls".
mjconnor10 is offline  
post #410 of 1302 Old 10-16-2019, 08:01 AM
AVS Forum Special Member
 
whiteboy714's Avatar
 
Join Date: Feb 2009
Posts: 6,925
Mentioned: 14 Post(s)
Tagged: 0 Thread(s)
Quoted: 1512 Post(s)
Liked: 636
Man doesn't seem like that review is all that good. Has some pretty decent flaws.

I'm tempted to try something else but you really have to jump in price besides the Hisense to get anything else similar.

TCL 65R625 -- Denon X1400h -- Klipsch RP600m -- RP450C -- Micca M-6S 6.5 -- Dual Klipsch RW-10
whiteboy714 is offline  
post #411 of 1302 Old 10-16-2019, 08:03 AM
AVS Forum Special Member
 
Dave in Green's Avatar
 
Join Date: Jan 2014
Location: USA
Posts: 8,513
Mentioned: 153 Post(s)
Tagged: 0 Thread(s)
Quoted: 3881 Post(s)
Liked: 3066
Quote:
Originally Posted by Capt. Hot Sauce View Post
From Rtings

8.4 Movies
7.5 TV Shows
7.4 Sports
8.8 Video Games
8.5 HDR Movies
8.6 HDR Gaming
8.1 PC Monitor
Most telling is the mixed review of the R625 compared with the R617. Rtings.com rates the R625 better in some performance areas and the R617 better in others. So it really depends on which balance of pros and cons is most relevant to those trying to decide between the two. Obviously current pricing favors the older model.

Quote:
The TCL 6 Series/R625 2019 is very similar to the TCL 6 Series/R617 2018. The R625 has a more premium design and a much better local dimming feature, but the R617 is brighter and has better reflection handling. The R625 has a higher backlight flicker frequency, but a slower response time, and motion doesn't look as good.
Dave in Green is offline  
post #412 of 1302 Old 10-16-2019, 08:04 AM
Member
 
Join Date: Jul 2018
Location: Tulsa, OK
Posts: 112
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 85 Post(s)
Liked: 43
I wonder if the motion issues that Rtings indicated (and have been anecdotally reported here by several members) can be resolved via firmware update?
Harbinger27 is offline  
post #413 of 1302 Old 10-16-2019, 08:17 AM
AVS Forum Special Member
 
SteroMAdMAn's Avatar
 
Join Date: Nov 2002
Location: MN
Posts: 1,059
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 88 Post(s)
Liked: 98
I dunno, the recommended settings aren't all that different from CNET, but it's not like there is a whole lot more that can be done with them to improve motion.


Personally, this set is bright enough so I don't know that I would need the "extra" brightness of the 615 if it has the same motion issues. Better reflection handing would be nice.. But maybe not at the cost of local dimming..


Although ironically, my stuttering seems to have stopped as well. Now I'm just dealing with the normal LCD motion issues I would expect.


Keep this set and live with the cons, or get a PX65 or 65 x900f and spend quite a bit more.. I'd really like the Sony, but it is quite a bump in cost and the warranty is quite a bit more over the TCL as well. So you take a hit 2x. If they sold the 900f at Costco I don't think it would be a debate for me. But then I'd miss out on the Roku OS as well.. and this thing rocks. As someone about to cut the cord, I don't know that I want to live without it.

It is better to ask for forgiveness, than it is to ask for permissision - the WAF factor
SteroMAdMAn is offline  
post #414 of 1302 Old 10-16-2019, 08:42 AM
AVS Forum Special Member
 
whiteboy714's Avatar
 
Join Date: Feb 2009
Posts: 6,925
Mentioned: 14 Post(s)
Tagged: 0 Thread(s)
Quoted: 1512 Post(s)
Liked: 636
Quote:
Originally Posted by SteroMAdMAn View Post
Personally, this set is bright enough so I don't know that I would need the "extra" brightness of the 615 if it has the same motion issues. Better reflection handing would be nice.. But maybe not at the cost of local dimming..


Although ironically, my stuttering seems to have stopped as well. Now I'm just dealing with the normal LCD motion issues I would expect.


Keep this set and live with the cons, or get a PX65 or 65 x900f and spend quite a bit more.. I'd really like the Sony, but it is quite a bump in cost and the warranty is quite a bit more over the TCL as well. So you take a hit 2x. If they sold the 900f at Costco I don't think it would be a debate for me. But then I'd miss out on the Roku OS as well.. and this thing rocks. As someone about to cut the cord, I don't know that I want to live without it.
I feel exactly the same way. Brightness has not been a concern mine feels plenty bright, haven't felt a need there for more brightness.

My stuttering also seems much improved. Haven't noticed the bad "hitching" I was seeing, just normal motion issues.

I have also considered the TV's you mentioned but its a 50% price increase, not a small bump. Not sure it would be worth it. And losing the Roku OS would suck, thats what keeps me from really considering the Hisense, I have an Nvidia Shield so its the best of
both worlds.

TCL 65R625 -- Denon X1400h -- Klipsch RP600m -- RP450C -- Micca M-6S 6.5 -- Dual Klipsch RW-10
whiteboy714 is offline  
post #415 of 1302 Old 10-16-2019, 09:01 AM
AVS Forum Special Member
 
SteroMAdMAn's Avatar
 
Join Date: Nov 2002
Location: MN
Posts: 1,059
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 88 Post(s)
Liked: 98
Yeah, the Sony after tax and warranty is an additional $700. That's a bitter pill to swallow.. If it was at Costco I could avoid the additional warranty costs. Although maybe I could go with 2 year over 5 since it is a Sony.. It would save me $170. But not sure.

It is better to ask for forgiveness, than it is to ask for permissision - the WAF factor
SteroMAdMAn is offline  
post #416 of 1302 Old 10-16-2019, 09:34 AM
Member
 
Join Date: Oct 2019
Posts: 27
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Liked: 15
Quote:
Originally Posted by Kizzer View Post
Yes, Plus I would recommend turning everything off except “natural cinema”.
I tried watching with LED Clarity on (i think it's on by default for the Sports setting, if I'm not mistaken). I started seeing kind of a "flicker" (for lack of better word), almost as if you are viewing a low refresh panel. Is that how it looks for others?

Anyway, turned it off, and picture looked better, even watching sports.Weird that a setting that's supposed to help with "motion" made it look worse.

I mentioned some "judder" (again, not 100% sure that's what I'm seeing) when I watched Jessica Jones on Netflix (only on certain scenes, like when a camera was panning from left to right) on the TV's Roku. However, watching both 1080p BD and 4k BD, I didn't see any issues.

Question: does the TV only display one "notification"? What I mean is that, I watched Infinity War and got the box for "Dolby Atmos" but didn't say anything if it was detecting "Dolby Vision". However, I watched an older 1080p BD and it displayed "Dolby Vision", but not Atmos (which is fine, because i don't think it supported Atmos).
Jay Gunz is offline  
post #417 of 1302 Old 10-16-2019, 09:39 AM
AVS Forum Special Member
 
SteroMAdMAn's Avatar
 
Join Date: Nov 2002
Location: MN
Posts: 1,059
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 88 Post(s)
Liked: 98
Quote:
Originally Posted by Jay Gunz View Post
Question: does the TV only display one "notification"? What I mean is that, I watched Infinity War and got the box for "Dolby Atmos" but didn't say anything if it was detecting "Dolby Vision". However, I watched an older 1080p BD and it displayed "Dolby Vision", but not Atmos (which is fine, because i don't think it supported Atmos).
I've found if you click the OK button during movie playback it will tell you the current sound/audio, i.e. 4k HDR 10, Dolby Atmos, etc. As I was wondering the same after going through the same thing you did.
LongRufus likes this.

It is better to ask for forgiveness, than it is to ask for permissision - the WAF factor
SteroMAdMAn is offline  
post #418 of 1302 Old 10-16-2019, 09:44 AM
AVS Forum Special Member
 
whiteboy714's Avatar
 
Join Date: Feb 2009
Posts: 6,925
Mentioned: 14 Post(s)
Tagged: 0 Thread(s)
Quoted: 1512 Post(s)
Liked: 636
Quote:
Originally Posted by Jay Gunz View Post

Question: does the TV only display one "notification"? What I mean is that, I watched Infinity War and got the box for "Dolby Atmos" but didn't say anything if it was detecting "Dolby Vision". However, I watched an older 1080p BD and it displayed "Dolby Vision", but not Atmos (which is fine, because i don't think it supported Atmos).
It should do both (at least I saw it on a review do both) but can be a little screwy. Yesterday on mine the HDR logo popped up like 5 times in a row. First time I saw that. If you are getting "DV" with a 1080p BD something is wrong there. Probably just a false flag.

If your talking about infinity war through the netflix app I don't believe the marvel movies are HDR or even 4k on netflix.

TCL 65R625 -- Denon X1400h -- Klipsch RP600m -- RP450C -- Micca M-6S 6.5 -- Dual Klipsch RW-10
whiteboy714 is offline  
post #419 of 1302 Old 10-16-2019, 10:29 AM
Newbie
 
Join Date: Oct 2019
Posts: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Liked: 2
Quote:
Originally Posted by Kizzer View Post
Does optical override ARC for sound? And you can still use your TCL remote to control the sound? I am using a soundbar, would that apply here?
Kind of...

I have the HDMI Out on my receiver going to HDMI-1 on the TV (which is a non-arc HDMI port). And I have the optical cable hooked up between the TV and the receiver. This allows me to run HDMI from an external 4k blu-ray player to my receiver and play video using the HDMI 1 port on the TV.

Strangely enough I still have full ARC audio control of the receiver using my TCL remote (even though I'm not longer connected to the ARC hdmi port on the TV).
jjoel is offline  
post #420 of 1302 Old 10-16-2019, 12:16 PM
Member
 
Join Date: Aug 2018
Posts: 115
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 69 Post(s)
Liked: 54
Quote:
Originally Posted by SteroMAdMAn View Post

Personally, this set is bright enough so I don't know that I would need the "extra" brightness of the 615 if it has the same motion issues. Better reflection handing would be nice.. But maybe not at the cost of local dimming..

My eyes were not lying to me. The 615 is brighter and it does make a difference in HDR highlights for sure. I am keeping my set as it does so many things better than my 615 but I sure do wish it was just as bright :/
samoth84 is offline  
Sponsored Links
Advertisement
 
Reply LCD Flat Panel Displays

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off