The Official LG PX950 3DTV Owner's Discussion Thread - Page 72 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 4Likes
Reply
 
Thread Tools
post #2131 of 2131 Old 11-17-2019, 02:01 PM
Member
 
nobb1's Avatar
 
Join Date: Apr 2007
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 10
Just fixed my 60PX950 which had a no picture problem. Power supply tested ok, so I ran the self test by disconnecting the main board from the ASIC/3DF board and jumpering two terminals. Self test ran ok, so it was a bad main board.

All the instructions I've seen online suggest baking the entire board at 385F for 10 min but that seemed like overkill to me. There's only one chip on the mainboard that is BGA soldered and that is the main processor beneath the heatsink. Took off the heatsink, applied some flux to the processor, then heated it up with a heat gun to 200C for a few seconds. Voila, that worked! For extra safety I also decided to make a cutout on the rear panel to install a small fan which I am powering off the 5V from the power supply. Hope this fix holds!
nobb1 is offline  
Sponsored Links
Advertisement
 
Reply Plasma Flat Panel Displays

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off