One lens of 3D glasses is not working - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 
Thread Tools
post #1 of 1 Old 11-07-2019, 04:50 PM - Thread Starter
Newbie
 
Join Date: May 2019
Posts: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 9 Post(s)
Liked: 0
One lens of 3D glasses is not working

I have 5 Hi-SHOCK glasses and one of them is not working properly, for which I received a new one (I was buying 4). The right lens is not lightning properly and I would like to try fixing it. So I am asking for your suggestion what can I try to do or what could be wrong with it. Is it the connections, battery or is the lens itself?

I've attached photos, so that you can see what is the problem and what's inside of the glasses.

The first two ones are showing what's the problem, but not sure why non-working lens (right one) in the second picture looks more pinky, that's why I've put the firs picture as well, which I think is a better representation.
Third picture is glasses turned off, forth picture is normal working glasses, how it supposed to look.
And the last ones are inside of the glasses, non-working lens on those pictures is left, since the picture is taken in-front.
Attached Thumbnails
Click image for larger version

Name:	20190115_222155.jpg
Views:	16
Size:	610.1 KB
ID:	2637882   Click image for larger version

Name:	IMG_20191106_160153.jpg
Views:	15
Size:	814.7 KB
ID:	2637884   Click image for larger version

Name:	IMG_20191106_160212.jpg
Views:	13
Size:	1.00 MB
ID:	2637886   Click image for larger version

Name:	IMG_20191106_160345.jpg
Views:	12
Size:	946.7 KB
ID:	2637888   Click image for larger version

Name:	IMG_20191108_001904.jpg
Views:	13
Size:	771.8 KB
ID:	2637890  

Click image for larger version

Name:	IMG_20191108_001958.jpg
Views:	17
Size:	1.34 MB
ID:	2637892  

Last edited by teidybugi; 11-07-2019 at 05:23 PM.
teidybugi is offline  
Sponsored Links
Advertisement
 
Reply 3D Tech Talk

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off