Samsung T650 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 
Thread Tools
post #1 of 2 Old 06-21-2020, 11:22 AM - Thread Starter
Senior Member
 
elwood58's Avatar
 
Join Date: Jun 2005
Location: Phoenix Arizona
Posts: 369
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 11
Samsung T650

Installed the T650 along with the SWA-8500S Rear Speakers yesterday. Very pleased with how the system sounds. I did have to boost the rear speaker output +5.
elwood58 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 07-10-2020, 01:22 PM - Thread Starter
Senior Member
 
elwood58's Avatar
 
Join Date: Jun 2005
Location: Phoenix Arizona
Posts: 369
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 11
Almost three weeks into using the new Soundbar. Very pleased with all types of media, including streaming and music. We initially experienced minor drop outs when using Optical as the main audio connection to the soundbar. After switching to HDMI-ARC there have been nearly zero issues regardless of source.

We moved our old Visio 2.1 Soundbar setup to our dining room where we have a 60" Sharp TV on the wall. We decided to feed the audio using Bluetooth, and have been very pleased with the results.
elwood58 is offline  
Sponsored Links
Advertisement
 
Reply Soundbars

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off