Refurbished Epson 5040UB - $1,151.00 - Page 16 - AVS Forum | Home Theater Discussions And Reviews
Forum Jump: 
 131Likes
Reply
 
Thread Tools
post #451 of 595 Old 06-14-2019, 08:16 PM
Member
 
Steve Sleeve's Avatar
 
Join Date: Nov 2018
Posts: 165
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 82 Post(s)
Liked: 32
Quote:
Originally Posted by mskim View Post
Received mine today. First opened the service menu, check lamp hour and total operation time, both showed 0 hour.
Connected to denon 4300 receiver with a Nvidia shield as an input device, saw the screen from the shield briefly
but the lense cover is closed and the lamp (orange) and the power (blue) lights are blinking and fan is running. Changed to hdmi2 but same problem.
Anyone know what's the problem? It works okay when there is no connection, I can open the menu, change settings.
But as soon as input is on, the issue is happening.
hopefully you figured it out but just pull the plug if totally lost, maybe you hit the standby button. Mine had 0 hours and the lens shift seemed all the way up on the veritcal.

Note: With Direct Power On turned on, the projector turns on as soon as you plug it in.
The projector's power light turns blue. This indicates that the projector is receiving power.
3. Press the power button on the projector or the On button on the remote control to turn on the
projector.
The shutter opens and the status light flashes blue as the projector warms up. Once the projector is
warmed up, the status light stops flashing and turns blue.
Warning: Never look into the projector lens when the lamp is on. This can damage your eyes and is
especially dangerous for children.
If you do not see a projected image right away, try the following:
• Turn on the connected computer or video device.
• Insert a DVD or other video media and press the play button, if necessary.
• Press the source button on the projector to detect the video source, or press a source button on the
remote control.
• If the Home screen is displayed, select the source you want to project

Denon AVR-X6500h Klipsch RP-8000f RP-440C (4) RP-150MS sides in parallel RB-51 rears, 4 JBL C67P pendants for atmos, 2 monolith 12" subs
Epson 5040UB, Sony Ubp-X700, AC infintiy T9, Nvidia Shield, 142" 2.35 silver ticket screen

Last edited by Steve Sleeve; 06-14-2019 at 08:25 PM.
Steve Sleeve is offline  
Sponsored Links
Advertisement
 
post #452 of 595 Old 06-14-2019, 08:30 PM
Member
 
filipp2442's Avatar
 
Join Date: Dec 2007
Posts: 126
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 29 Post(s)
Liked: 14
Got my free rebate lamp today, glad it worked out.
Archaea likes this.
filipp2442 is offline  
post #453 of 595 Old 06-14-2019, 09:39 PM
Member
 
YoMaMa84's Avatar
 
Join Date: Jan 2007
Location: Maryland
Posts: 131
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 12
I posted this in the original 5040/6040 thread, but I bought a refurbished unit on Tuesday and received it today. My tests show no issues so far and the lamp life was at zero. The entire unit looks brand new tbh. Hopefully no issues pop up in the future.
YoMaMa84 is offline  
Sponsored Links
Advertisement
 
post #454 of 595 Old 06-15-2019, 04:35 AM
Senior Member
 
xbladr's Avatar
 
Join Date: Apr 2008
Posts: 293
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 148 Post(s)
Liked: 60
Quote:
Originally Posted by bernito View Post
How are you getting these for $900ish with a free bulb? The price on their website is $1,151 and says nothing about a free bulb?
There was a 15 percent off coupon for a while now expired and a rebate going on for a free bulb

Sent from my SM-N950U1 using Tapatalk
xbladr is offline  
post #455 of 595 Old 06-15-2019, 06:16 AM
Member
 
Steve Sleeve's Avatar
 
Join Date: Nov 2018
Posts: 165
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 82 Post(s)
Liked: 32
Quote:
Originally Posted by YoMaMa84 View Post
I posted this in the original 5040/6040 thread, but I bought a refurbished unit on Tuesday and received it today. My tests show no issues so far and the lamp life was at zero. The entire unit looks brand new tbh. Hopefully no issues pop up in the future.
Nice! my exterior was flawless too, When I shine a light on the lens I had no scratches but could see some dust that is typical with any PJ. I think they put new bulbs in all of them, everyone seems to be a 0 hours.

Denon AVR-X6500h Klipsch RP-8000f RP-440C (4) RP-150MS sides in parallel RB-51 rears, 4 JBL C67P pendants for atmos, 2 monolith 12" subs
Epson 5040UB, Sony Ubp-X700, AC infintiy T9, Nvidia Shield, 142" 2.35 silver ticket screen
Steve Sleeve is offline  
post #456 of 595 Old 06-15-2019, 06:35 AM
Member
 
mskim's Avatar
 
Join Date: May 2004
Location: Redmond,WA
Posts: 19
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 10
Quote:
Originally Posted by Steve Sleeve View Post
hopefully you figured it out but just pull the plug if totally lost, maybe you hit the standby button. Mine had 0 hours and the lens shift seemed all the way up on the veritcal.

Note: With Direct Power On turned on, the projector turns on as soon as you plug it in.
The projector's power light turns blue. This indicates that the projector is receiving power.
3. Press the power button on the projector or the On button on the remote control to turn on the
projector.
The shutter opens and the status light flashes blue as the projector warms up. Once the projector is
warmed up, the status light stops flashing and turns blue.
Warning: Never look into the projector lens when the lamp is on. This can damage your eyes and is
especially dangerous for children.
If you do not see a projected image right away, try the following:
• Turn on the connected computer or video device.
• Insert a DVD or other video media and press the play button, if necessary.
• Press the source button on the projector to detect the video source, or press a source button on the
remote control.
• If the Home screen is displayed, select the source you want to project
I contacted Epson and after little trouble shooting they said it is a hardware error. The replacement unit will be sent out overnight, so I will get on Tuesday.
mskim is offline  
post #457 of 595 Old 06-15-2019, 06:36 AM
Member
 
Join Date: May 2019
Location: WI
Posts: 45
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 33 Post(s)
Liked: 7
Quote:
Originally Posted by YoMaMa84 View Post
I posted this in the original 5040/6040 thread, but I bought a refurbished unit on Tuesday and received it today. My tests show no issues so far and the lamp life was at zero. The entire unit looks brand new tbh. Hopefully no issues pop up in the future.


How do we do the tests?
Any useful link that I could follow?


Sent from my iPhone using Tapatalk
vizag is online now  
post #458 of 595 Old 06-15-2019, 08:06 AM
Member
 
Steve Sleeve's Avatar
 
Join Date: Nov 2018
Posts: 165
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 82 Post(s)
Liked: 32
Quote:
Originally Posted by vizag View Post
How do we do the tests?
Any useful link that I could follow?


Sent from my iPhone using Tapatalk
The first thing I looked for is on a blank screen or your empty blu ray player welcome screen are any colored or strangle blobs or pixel looking abnormalities that others reported. Next open you tube and search projector calibration 4k and find some that and run the test to calibrate. I did a couple to compare. When doing the calibrations look for any strange tints in the whites or dark area in the colors. Often bad PJ's will have some pink or color tinting transitions happening out to the corners. You want even whites and colors.

try this one
vizag likes this.

Denon AVR-X6500h Klipsch RP-8000f RP-440C (4) RP-150MS sides in parallel RB-51 rears, 4 JBL C67P pendants for atmos, 2 monolith 12" subs
Epson 5040UB, Sony Ubp-X700, AC infintiy T9, Nvidia Shield, 142" 2.35 silver ticket screen
Steve Sleeve is offline  
post #459 of 595 Old 06-15-2019, 08:15 AM
Member
 
Join Date: May 2019
Location: WI
Posts: 45
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 33 Post(s)
Liked: 7
Quote:
Originally Posted by Steve Sleeve View Post
The first thing I looked for is on a blank screen or your empty blu ray player welcome screen are any colored or strangle blobs or pixel looking abnormalities that others reported. Next open you tube and search projector calibration 4k and find some that and run the test to calibrate. I did a couple to compare. When doing the calibrations look for any strange tints in the whites or dark area in the colors. Often bad PJ's will have some pink or color tinting transitions happening out to the corners. You want even whites and colors.



try this one https://www.youtube.com/watch?v=rjxd4btnuLU


Thanks much!


Sent from my iPhone using Tapatalk
vizag is online now  
post #460 of 595 Old 06-15-2019, 05:43 PM
Member
 
jblade44's Avatar
 
Join Date: Oct 2004
Location: Canada
Posts: 80
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 40 Post(s)
Liked: 17
Quote:
Originally Posted by donetodeath View Post
Please keep me posted on this, I've been in the same situation. They cancelled two of my orders on different cards due to their verification process (one visa, one mastercard). I now have $2400 tied up between the two orders, and i'm sure it won't be credited back until next week. Very frustrating, and Epson wasn't really helpful at all to my situation.

I'm curious to hear what happens with your third order, I'm crossing my fingers for you.
Visa failed first time.. my error..wrong primary ph# ... 2nd Costco mastercard...failed....3rd... Visa with correct ph#... Wolla... showing as shipped Friday....
jblade44 is offline  
post #461 of 595 Old 06-16-2019, 06:16 PM
Senior Member
 
Kriilin's Avatar
 
Join Date: Apr 2002
Posts: 470
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 65 Post(s)
Liked: 26
Quote:
Originally Posted by jblade44 View Post
Visa failed first time.. my error..wrong primary ph# ... 2nd Costco mastercard...failed....3rd... Visa with correct ph#... Wolla... showing as shipped Friday....
I had an issue the first time as well. Epson (Canada at least), has a third party that manually phones in the info to the credit card co. There's no or minimal error checking or verification on the web site itself.

I see dead pixels.......
Kriilin is offline  
post #462 of 595 Old 06-17-2019, 09:40 AM
Newbie
 
donetodeath's Avatar
 
Join Date: Jan 2007
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Liked: 12
Well I just tried for my third time. I called chase/visa and made sure all my details matched beforehand, so hopefully third time is the charm.

I'm shocked at how many they've had for sale over the last few days.
donetodeath is offline  
post #463 of 595 Old 06-17-2019, 10:38 AM
Senior Member
 
Kriilin's Avatar
 
Join Date: Apr 2002
Posts: 470
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 65 Post(s)
Liked: 26
Just got my refurb. This unit is cherry, no scratches, no image artifacts, and zero hours on bulb. I'm a happy camper!
Steve Sleeve likes this.

I see dead pixels.......
Kriilin is offline  
post #464 of 595 Old 06-17-2019, 12:07 PM
Member
 
croak's Avatar
 
Join Date: Sep 2001
Location: Seattle, WA, USA
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Liked: 12
Has anyone ordered one of these recently? I ordered Friday night and it's still "processing". Looks like they are now sold out so I wonder if I'll get it.
croak is offline  
post #465 of 595 Old 06-17-2019, 01:26 PM
Newbie
 
Join Date: Jun 2019
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 0
Just received mine fedex, about to unbox etc. I'll also check the serial number to see if it matches any from the previous posters.
Garrettn67 is offline  
post #466 of 595 Old 06-17-2019, 02:22 PM
Newbie
 
Join Date: Jun 2019
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 0
Ok, so far so good for the most part. Case looks perfect, lens has no scratches, doesn't appear to have ever been used honestly, although the black front pads appear to have been used. Serial number X334721440L. Total operation time zero hours, lamp operation time zero hours. Lamp replacement one time. Lamp on two times, lamp off one time (I only turned it on 10 min ago for the first time, still on. I never turned it off.)

One question: Although I see no dust blobs and no dead pixels on the blue pattern screen, upon inspecting the lens I see an outer clear glass then an inner clear glass about one inch behind it. With the lamp off, they both look clean and clear. However, with the lamp on, both appear to have a fair amount of very fine dust covering them, especially the inner one. Looks like the milky way galaxy covering the inner one! Is this normal? Can both glass areas be cleaned? My 2150 doesn't look like this at all when I peer into the lens from an angle when it's powered up. It looks totally clean and clear looking into the housing.
Garrettn67 is offline  
post #467 of 595 Old 06-17-2019, 02:41 PM
AVS Forum Addicted Member
 
Archaea's Avatar
 
Join Date: Apr 2004
Location: Kansas City, MO
Posts: 11,041
Mentioned: 603 Post(s)
Tagged: 2 Thread(s)
Quoted: 3769 Post(s)
Liked: 3552
Quote:
Originally Posted by Garrettn67 View Post
Ok, so far so good for the most part. Case looks perfect, lens has no scratches, doesn't appear to have ever been used honestly, although the black front pads appear to have been used. Serial number X334721440L. Total operation time zero hours, lamp operation time zero hours. Lamp replacement one time. Lamp on two times, lamp off one time (I only turned it on 10 min ago for the first time, still on. I never turned it off.)

One question: Although I see no dust blobs and no dead pixels on the blue pattern screen, upon inspecting the lens I see an outer clear glass then an inner clear glass about one inch behind it. With the lamp off, they both look clean and clear. However, with the lamp on, both appear to have a fair amount of very fine dust covering them, especially the inner one. Looks like the milky way galaxy covering the inner one! Is this normal? Can both glass areas be cleaned? My 2150 doesn't look like this at all when I peer into the lens from an angle when it's powered up. It looks totally clean and clear looking into the housing.

The consumer can only clean the outside lens. IF you can't see it on screen, then don't worry about it - cause they all will have that unless you buy brand new - and then it won't stay that way for long.

Archaea's 9.8.4 Home Theater Room
(13) JBL CBT 70j-1 | Denon x7200wa | Sherbourn PA 7-350 amplifier | (8) Ultimax 18" sealed subwoofers | (4) iNuke DSP 6000 amplifiers | (4) MB Quart 12" subwoofers mounted direct mounted to Berkline theater chairs BOSS style | Epson 5040UB Projector | Jamestown 144" acoustic transparent 2.35:1 screen w/ Seymour XD fabric
Archaea is offline  
post #468 of 595 Old 06-17-2019, 02:53 PM
Newbie
 
Join Date: Jun 2019
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 0
Quote:
Originally Posted by Archaea View Post
The consumer can only clean the outside lens. IF you can't see it on screen, then don't worry about it - cause they all will have that unless you buy brand new - and then it won't stay that way for long.
My HC2150 doesn't have that, and it has 2700 hours. Both the inner and outer lenses are clear as a bell. Although I may not see any obvious blobs on the projection screen, is it possible the dust is reducing the light output or otherwise affecting the image in such a way that I may not notice without a new projector for direct comparison?
Garrettn67 is offline  
post #469 of 595 Old 06-17-2019, 02:56 PM
AVS Forum Addicted Member
 
Archaea's Avatar
 
Join Date: Apr 2004
Location: Kansas City, MO
Posts: 11,041
Mentioned: 603 Post(s)
Tagged: 2 Thread(s)
Quoted: 3769 Post(s)
Liked: 3552
Quote:
Originally Posted by Garrettn67 View Post
My HC2150 doesn't have that, and it has 2700 hours. Both the inner and outer lenses are clear as a bell. Although I may not see any obvious blobs on the projection screen, is it possible the dust is reducing the light output or otherwise affecting the image in such a way that I may not notice without a new projector for direct comparison?
Take a picture and toss it up here on the forums for us to see how bad it is.

Archaea's 9.8.4 Home Theater Room
(13) JBL CBT 70j-1 | Denon x7200wa | Sherbourn PA 7-350 amplifier | (8) Ultimax 18" sealed subwoofers | (4) iNuke DSP 6000 amplifiers | (4) MB Quart 12" subwoofers mounted direct mounted to Berkline theater chairs BOSS style | Epson 5040UB Projector | Jamestown 144" acoustic transparent 2.35:1 screen w/ Seymour XD fabric
Archaea is offline  
post #470 of 595 Old 06-17-2019, 03:05 PM
AVS Forum Addicted Member
 
Archaea's Avatar
 
Join Date: Apr 2004
Location: Kansas City, MO
Posts: 11,041
Mentioned: 603 Post(s)
Tagged: 2 Thread(s)
Quoted: 3769 Post(s)
Liked: 3552
Refurbished Epson 5040UB - $1,151.00

Quote:
Originally Posted by Archaea View Post
Take a picture and toss it up here on the forums for us to see how bad it is.


Mine is fine and it looks like this





You aren’t going to get one without that look.

These Epsons don’t have sealed light paths like premium LCOS or even DLP.
Just clean it off on the outside every six months or what not, and try not to think about it.

Archaea's 9.8.4 Home Theater Room
(13) JBL CBT 70j-1 | Denon x7200wa | Sherbourn PA 7-350 amplifier | (8) Ultimax 18" sealed subwoofers | (4) iNuke DSP 6000 amplifiers | (4) MB Quart 12" subwoofers mounted direct mounted to Berkline theater chairs BOSS style | Epson 5040UB Projector | Jamestown 144" acoustic transparent 2.35:1 screen w/ Seymour XD fabric
Archaea is offline  
post #471 of 595 Old 06-17-2019, 03:31 PM
Newbie
 
Join Date: Jun 2019
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 0
Pic
Attached Thumbnails
Click image for larger version

Name:	20190617_165943_1560810641340.jpg
Views:	124
Size:	2.18 MB
ID:	2581218  
Garrettn67 is offline  
post #472 of 595 Old 06-17-2019, 04:10 PM
Newbie
 
Join Date: Jun 2019
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 0
Refurb 5040UB on left, my HC2150 with 2700 hrs on right.
Attached Thumbnails
Click image for larger version

Name:	20190617_165943.jpg
Views:	56
Size:	557.7 KB
ID:	2581226   Click image for larger version

Name:	20190617_184925.jpg
Views:	53
Size:	596.7 KB
ID:	2581228  
Garrettn67 is offline  
post #473 of 595 Old 06-17-2019, 08:28 PM
Member
 
croak's Avatar
 
Join Date: Sep 2001
Location: Seattle, WA, USA
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Liked: 12
Quote:
Originally Posted by croak View Post
Has anyone ordered one of these recently? I ordered Friday night and it's still "processing". Looks like they are now sold out so I wonder if I'll get it.

Got my tracking number!
croak is offline  
post #474 of 595 Old 06-18-2019, 08:33 AM
Member
 
ultracitrus's Avatar
 
Join Date: Jan 2008
Posts: 20
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Liked: 5
Quote:
Originally Posted by Archaea View Post
I’d be surprised if that green isn’t your HDMI cord.

Look at the built in GUI uniformity checks for issues. Then unhook your Blu-ray player, drag it over to the back of the projector and hook it into the projector with < 6’ HDMI cord. That’ll confirm if the green discoloration is your cord or not.

Thanks for the tip Archaea. Turns out is was the dedicated graphics card on my laptop, not the PJ (same laptop/cable i use on my current 5030ub with no issues). I used a different source (Chromecast & different laptop) and no issues.


But that scratch, oh man, that one is killing me, we'll see how Epson handles it later today with a call to them.
ultracitrus is offline  
post #475 of 595 Old 06-18-2019, 08:43 AM
Senior Member
 
PDXscreen's Avatar
 
Join Date: May 2010
Location: Portland, OR
Posts: 326
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 10
Hi,

I ordered last Tuesday and they delivered on Friday. I was out of town so only had a chance to open it up last night. The projector looks like it is in good shape. The only abnormality was a fine black dust under the plastic wrap. The lens itself looks clean. I tested it on a tabletop and ran test patterns and it looks pretty great without color distortions. Honestly, it was such an improvement in black levels and distortion compared to my Sony. I have an OLED in my living room so I am kind of spoiled when it comes to black levels.

A couple of quick notes:

The memory settings are not super intuitive. I think I understand how to set a memory, but it seems like I am writing over one of their preset modes.

The motorized lens shift is fantastic and it would be kind of hard to set this up without.

The Cinema mode looks great out of the box. I played some dark scene torture tests from LOTR and Skyfall. It did great.

I noticed that I don't have the correct screws for my chief mount. Why don't manufacturers standardize the sizing??
PDXscreen is offline  
post #476 of 595 Old 06-18-2019, 02:58 PM
Member
 
Join Date: May 2019
Location: WI
Posts: 45
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 33 Post(s)
Liked: 7
what's the best mount for the 5040UB?
vizag is online now  
post #477 of 595 Old 06-18-2019, 03:17 PM
DIY Granddad (w/help)
 
MississippiMan's Avatar
 
Join Date: Nov 2002
Location: Byhalia, Mississippi. Waaaay down in the Bottoms
Posts: 21,630
Mentioned: 214 Post(s)
Tagged: 6 Thread(s)
Quoted: 3458 Post(s)
Liked: 1618
Send a message via Skype™ to MississippiMan
Quote:
Originally Posted by vizag View Post
what's the best mount for the 5040UB?



Chief RPA-357


........hands down.


Chief makes a deluxe model called the "Elite" with a SLB-357 plate, which has easier to use Adjustment Knobs and a quick-release Lever Mount, but it is premium priced at least $40-60.00 more.
Archaea likes this.

"They said it couldn't be done. Well, we sure showed 'em otherwise!"
HAS Advanced Audio and Imaging Solutions...Audio Transducers & Projection Screen Coatings
MississippiMan is online now  
post #478 of 595 Old 06-18-2019, 04:57 PM
AVS Forum Addicted Member
 
Archaea's Avatar
 
Join Date: Apr 2004
Location: Kansas City, MO
Posts: 11,041
Mentioned: 603 Post(s)
Tagged: 2 Thread(s)
Quoted: 3769 Post(s)
Liked: 3552
Refurbished Epson 5040UB - $1,151.00

Quote:
Originally Posted by vizag View Post
what's the best mount for the 5040UB?
CHF2500 and CHF4500 are the combo packs (include all necessary parts) for the 5040UB on that Chief mount that missippiman recommended. They are cheap on eBay.

I second his recommendation. Fantastic custom mounts you could hang on. Nearly everything else I’ve tried over the last 20 years is pure junk by comparison.

Archaea's 9.8.4 Home Theater Room
(13) JBL CBT 70j-1 | Denon x7200wa | Sherbourn PA 7-350 amplifier | (8) Ultimax 18" sealed subwoofers | (4) iNuke DSP 6000 amplifiers | (4) MB Quart 12" subwoofers mounted direct mounted to Berkline theater chairs BOSS style | Epson 5040UB Projector | Jamestown 144" acoustic transparent 2.35:1 screen w/ Seymour XD fabric

Last edited by Archaea; 06-18-2019 at 06:58 PM.
Archaea is offline  
post #479 of 595 Old 06-18-2019, 05:51 PM
Senior Member
 
xbladr's Avatar
 
Join Date: Apr 2008
Posts: 293
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 148 Post(s)
Liked: 60
I actually picked up a peerless-av prgs-unv. I can't from any 4 different universal mounts and this one is amazing all the other stuff was junk. No idea how it compares to the chief but the adjustable knobs and the easy slide in and out is sweet.

Sent from my SM-N950U1 using Tapatalk
Archaea likes this.
xbladr is offline  
post #480 of 595 Old 06-18-2019, 06:06 PM
Member
 
Join Date: Oct 2018
Posts: 154
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 71 Post(s)
Liked: 24
Got my refurb 5040ub from epson CANADA today. Not impressed!!!

Scratch on lens and boxing was horrible.

Anyone know if the scratch will affect the projected image or should I send back? I’m going to do a test tonight.

S/N: X334810969L
Attached Thumbnails
Click image for larger version

Name:	AEA2CD64-1232-46E5-96E2-E2BF7B8C45DE_1560906320028.jpg
Views:	47
Size:	56.3 KB
ID:	2581782   Click image for larger version

Name:	EFAED450-342C-413F-AF19-D3E4C12D7F49_1560906356022.jpg
Views:	38
Size:	61.7 KB
ID:	2581784  

Build Thread:https://www.avsforum.com/forum/19-de...m-wet-bar.html
Theatre Room: Samsung UN55KU7000F | Pioneer SP-FS52 x 2 | Polk MC80 x 2
Epson 5040UB | 120" Elunevision 4K Reference Tab 2.35:1 | Philharmonic Audio Affordable Accuracy Center Channel

Last edited by phanttom; 06-18-2019 at 06:55 PM.
phanttom is offline  
Sponsored Links
Advertisement
 
Reply Front Projectors Great Found Deals!

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off